Peaceful world?

Discussion in 'Bukkit Help' started by Shining_KoW210, Oct 24, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Shining_KoW210

    I've just got back into Minecraft and Bukkit.

    I just set up a server and for some reason the mobs are peaceful and don't attack.

    I'm using MCMyAdmin and I have set up everything to survival. Even in the property files and yet, none of the monsters are aggressive.

    Does anyone have any ideas on what I can try?
     
  2. Offline

    Shining_KoW210

    So does anybody have any ideas?
     
  3. Offline

    BlockCat

    Are you creative?
     
  4. Offline

    GRPGamer

    1. Are you in Creative?
    2. Your not vanished or anything are you?
    3. Your server difficulty is correct?
    4. Try attacking them?
    5. You could be lagging, try relog?
     
  5. Offline

    Shining_KoW210


    No I am not in creative.

    No I am not vanished, I don't have any plugins installed that do that.

    Yes the server difficulty is set to "2" aka "normal"

    Yes you can attack them but they won't attack back.

    I'm running this server on my very powerful computer, there is absolutely no lag.
     
  6. Offline

    j0ez

    Do you have any Plugins running, because a few plugins do so its kinda fucked.
     
  7. Offline

    Shining_KoW210

    The plugins I am running:

    Dynmap
    Essentials
    Multiverse-Core
    NoCheatPlus
    PermissionsEx
    WorldEdit
    WorldGuard
     
  8. Offline

    MyPictures

    I suspect Multiverse-Core then, you should take a look at this plugin and its config.
     
  9. Offline

    j0ez

    Its not Multiverse-Core thats only for more Worlds im ussing that aswell, could be a Permission Thing or Essentials, but do you have all the Essentials Plugins?
     
  10. Offline

    Shining_KoW210

    I did check out the multiverse settings and they were all set correctly.

    I only have Essentials and Essential Spawn, none of the others.

    At first I did think it was a permissions problem, and I checked over my permissions file over and over.

    It doesn't make sense that PermissionsEx would cause the mobs to not attack back.


    Here's a copy of my Multiverse settings, I could have overlooked something.

    Code:
    worlds:
      world:
        seed: 1479709459070001322
        environment: NORMAL
        type: NORMAL
        hidden: false
        alias:
          name: ''
          color: WHITE
        pvp: true
        scale: 1.0
        respawnworld: ''
        allowweather: true
        difficulty: NORMAL
        animals:
          spawn: true
        monsters:
          spawn: true
        entryfee:
          currency: -1
          price: 0.0
        hunger: true
        autoheal: true
        adjustspawn: true
        portalform: ALL
        gamemode: SURVIVAL
        keepspawninmemory: true
        spawn:
          x: -232.5
          y: 64.0
          z: -91.5
          pitch: 0.0
          yaw: 0.0
          world: world
        autoload: true
        bedrespawn: true
      world_nether:
        seed: 1479709459070001322
        environment: NETHER
        type: NORMAL
        hidden: false
        alias:
          name: ''
          color: WHITE
        pvp: true
        scale: 8.0
        respawnworld: ''
        allowweather: true
        difficulty: NORMAL
        animals:
          spawn: true
        monsters:
          spawn: true
        entryfee:
          currency: -1
          price: 0.0
        hunger: true
        autoheal: true
        adjustspawn: true
        portalform: ALL
        gamemode: SURVIVAL
        keepspawninmemory: true
        spawn:
          x: -2.5
          y: 65.0
          z: 4.5
          pitch: 0.0
          yaw: 0.0
          world: world_nether
        autoload: true
        bedrespawn: true
      world_the_end:
        seed: 1479709459070001322
        environment: THE_END
        type: NORMAL
        hidden: false
        alias:
          name: ''
          color: WHITE
        pvp: true
        scale: 1.0
        respawnworld: ''
        allowweather: true
        difficulty: NORMAL
        animals:
          spawn: true
        monsters:
          spawn: true
        entryfee:
          currency: -1
          price: 0.0
        hunger: true
        autoheal: true
        adjustspawn: true
        portalform: ALL
        gamemode: SURVIVAL
        keepspawninmemory: true
        spawn:
          x: 0.0
          y: 90.0
          z: 0.0
          pitch: 0.0
          yaw: 0.0
          world: world_the_end
        autoload: true
        bedrespawn: true
    

    and while we're at it, here's my PermissionsEx config,

    Code:
    groups:
        Guildie:
            default: true
            options:
                rank: '1000'
            prefix: '&0(&8M&7ember&0)&7 '
            permissions:
            - modifyworld.*
        Member:
            prefix: '&0(&8M&7ember&0)&7 '
            permissions:
            - modifyworld.*
            options:
                rank: '900'
        VIP:
            prefix: '&0(&eVIP&0)&7 '
            inheritance:
            - Member
            permissions:
            - -modifyworld.mobtarget.monster.creeper
            options:
                rank: '800'
        Moderator:
            prefix: '&0(&1Moderator&0)&7 '
            inheritance:
            - VIP
            permissions:
            - -modifyworld.mobtarget.*
            options:
                rank: '100'
        Admins:
            prefix: '&0(&4Admins&0)&7 '
            permissions:
            - -modifyworld.mobtarget.*
            - modifyworld.*
            - permissions.*
            - '*'
            options:
                rank: '1'
    users:
        AnotherPlayer:
            group:
            - default
        Shining_KoW210:
            group:
            - Admins
    I wiped my hand written permissions config and used a slightly tweaked default one.
     
  11. Offline

    minecrafterwork I steal plugins as my own

    Mob Damage might be disabled in your World Guard config check that
     
  12. Offline

    Shining_KoW210

    I checked and that's not the problem.
     
Thread Status:
Not open for further replies.

Share This Page