OH NO, a Minecraft update has broken Bukkit! What do I do!?

Discussion in 'Bukkit News' started by EvilSeph, Mar 31, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    First off, relax.

    If you're using the new Minecraft launcher, you have a choice on whether or not you want to update to the latest Minecraft release - simply choose "Not now" when it asks if you want to update and you can continue to play on your pre-update Minecraft server.

    If you're not using the new Minecraft launcher, backup your old launcher and update it by downloading it from http://minecraft.net, then follow the steps above.

    It usually takes us a few hours AT LEAST to get Bukkit working with the latest Minecraft update, so you're better off playing a different game or staying on the previous version of Minecraft, instead. If you have a special server that requires lots of mods, like a class-based server, consider backing up your world, running the new Minecraft update and calling it a grief/fun/fool-around period OR stay on your current version and just keep playing.

    Just remember, always backup so you can switch between versions. You're no longer forced to go weeks without a Bukkit powered server.

    Once we have a new Bukkit build that is compatible with the newest Minecraft update, we'll put it under rigorous testing and then promote it as a Recommended Build. Usually, due to the way Bukkit and CraftBukkit are designed, plugins should work just fine but there's no guarantee that this is always the case so be sure to test everything on a test server before you go live.

    Lastly, we're fully aware that a new update is out - usually before anyone else. Don't spam the forums with threads or IRC with messages informing us that there's a new Minecraft update out. We know. And we're working on updating Bukkit to work with it. The more you bother us, the longer it'll take.

    Have fun!
     
  2. Offline

    KoryuObihiro

    @Fekillix Top of the page, click "Get CraftBukkit..."
     
  3. Offline

    Fekillix

    Its a new version even tho it got the same name as the old one?
     
  4. Offline

    Shadowlordz

    Hi, I just have a query for all the mac users here. I have downloaded the latest version of minecraft, but it doesn't work, is anyone else getting the same problem?
     
  5. Offline

    KoryuObihiro

    @Fekillix o_o Yes. They're all named "craftbukkit-0.0.1-snapshot.jar", for technical reasons.
     
  6. Offline

    Fekillix

    I pasted the file in my minecraft server folder without replasing enything, what am i suppost to do to uppdate the server? I dont want to lose my plugins
     
  7. Offline

    KoryuObihiro

    You won't lose your plugins. What's your setup? How are you running CraftBukkit as a server?
     
  8. Offline

    ScorchRaserik

    Hi. New guy here. Go easy on me :p

    Why is it that the op functions keep changing?
    When I first started, the /give function needed the exact player name (even if you were giving to yourself, the exact item number, and the amount. And it tossed the item out in front of you.

    Then I upgraded to 556 after a day of realizing my version was outdated, and the /give function seemed to be improved. Instead of throwing the item out, it put it in the inventory, you could type in the item name if you didn't know the number, and if you wanted to give an item to yourself, you didn't need to specify a player.

    Now I've upgraded to 617, and the /give function is back to its old self. Am I doing something wrong? Or was the function downgraded for stability or something?
     
  9. Offline

    Touco

    Hello,

    Is the last release compatible with 1.4 or not yet ?
     
  10. Offline

    BjarkeBS

    Ohh god :/
     
  11. Offline

    Mohammad

    ITS Out :D
     
  12. Offline

    Bronski

     
  13. Offline

    racecar56

    Yep, I'm getting those like crazy too.

    EDIT: I think they fixed it now.
     
  14. Offline

    AKWintermute

    People would stop asking if its out, if there was some indication on the front page/download page/announcements threads that there has been an update. The only way to know that there has been and update is to read through this thread. Why not create an announcement that its out and sticky it to the front page like they did this thread?
     
    Troopah and Skadar like this.
  15. Offline

    KoryuObihiro

    @Bronski The entire website was like that for a while, seems to be fine now. :x
     
  16. Offline

    PatrickFreed

    is b612 1.4?
     
  17. Offline

    KoryuObihiro

    Yup. But 617's been promoted as the latest RB.
     
  18. Offline

    ZerG

    so were looking to run 617 as RB now ? ... LAPZOO where are you with your test list O.O .
    lol anybody get word from sk89q today ?

    PLUGIN MAKERS :
    http://KLoNDiKeCRaFT.CoM needs some worldgaurd, worldedit , mcmmo , and essentials plugins that work :)
     
  19. Offline

    KoryuObihiro

    @ZerG Patience might be the best option there. High-demand plugins have a lot of pressure to update quickly.
     
  20. Offline

    rybird

    thanks guys, i finnaly got my server running and was flipping out at first, but u guys got it.
     
  21. Offline

    wristdirect

    Oh, and just in case, I'd like to divulge a little problem I ran into and clarify something in case anyone else is having this issue and came here to figure it out. The main page of the wiki is still out of date and has the wrong versions listed for the recommended and dev builds. And for some reason no one seemed to think it would be a good idea to put an indicator on the recommended build page to let you know exactly what version it is you are downloading. This caused me a good hour of grief searching for the correct build just to find I had downloaded it already.

    Silly Bukkit team. Thanks for the update! Despite your confusing wiki lol...update that thing!
     
  22. Offline

    Troopah

    Whenever I try to start a server with any of the RB's compatible with MC 1.4, there are no errors when starting it up in terminal but when I put my ip in the server.properties and try to log into it on minecraft im stuck at a screen that say "Connecting to the server...". Can anyone help me?
     
  23. Offline

    KoryuObihiro

    @Troopah What's your setup? Are you trying to access another computer hosting your server internally/externally, or are you just running it alongside your client?
     
    fyermen8 likes this.
  24. Offline

    Troopah

    @KoryuObihiro I am hosting my server on my computer and trying to access it on my computer,
     
    fyermen8 likes this.
  25. Offline

    EthernetHub

    You don't need to put your IP in the server.properties file, and which IP are you using to connect to your server? I was having trouble using my own external IP, but when I switched to the internal IP I never have that problem any more.

    Find out your internal IP and try that (probably 192.168.x.x) or use localhost 127.0.0.1
     
    fyermen8 likes this.
  26. Offline

    KoryuObihiro

    @Troopah Rawr, EthernetHub beat me to it. :p

    Anyway, when you configure the IP setting on the server you're only using a single integer to define which port to use. When you're running it on the same machine client, it's best to just not bother and use "localhost" when you want to join that server. So, try it out, let me know how it works. :)
     
    fyermen8 likes this.
  27. Offline

    Centribo

    Hey guys I just got the new build, and some of my plugins like worldguard are not working. Help?

    Actually to be more indepth about it, any mod that worked with tools (like teleplus, using item 288/feather to quick jump) isn't working. World edit and world guard re working, but things like super pick axe, region defining, region checking arn't wokring.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 13, 2016
    fyermen8 likes this.
  28. Offline

    Aspernatio

    Is bukkit updated to Beta 1.4? I can't seem to find any article that answers this query. Also - how does one check one's bukkit version?
     
    fyermen8 likes this.
  29. Offline

    Centribo

    Also, the concolse spits out "BLOCK DAMAGED" for all the plugins when attempting to load them, and some random stuff and some message "Is it updated?" But the plugins do load.
     
    fyermen8 likes this.
  30. Offline

    Troopah

    @EthernetHub @KoryuObihiro Whenever i put my internal ip in my server.properties, I get the error
    Maybe If I explain what happened since my first server It will help you, I used LogMeIn Hamachi to get my server ip (which is 5.187.227.234:25565) and I put it in server.properties and everything worked fine. I had all my plugins installed and I just got my first server running. Then the next day MC was updated to 1.4 so I had to update. I put my old server on a flash drive, I started a new one with I think RB 612. I used the same ip as before and everything worked. So I waited for plugins to be updated, but then I heard Rb 617 was out so I deleted the 612 server and tried to update to 617 on the same ip and that when I got stuck at "Connecting to the server...". So I tried to go back to 612 and 605 and the same thing happened again.
     
    fyermen8 likes this.
  31. Offline

    EthernetHub

    I'm not familiar with LogMeIn, what benefits does it provide for a Minecraft server? I might want to check it out :)

    Have you tried connecting to your server using your internal IP in the game client and leaving the server.properties IP field blank? (just to see what happens, to help the troubleshooting process)

    Also, can other people connect to your server? Or are you the only one having these issues?
     
    fyermen8 likes this.
Thread Status:
Not open for further replies.

Share This Page