OH NO, a Minecraft update has broken Bukkit! What do I do!?

Discussion in 'Bukkit News' started by EvilSeph, Mar 31, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    First off, relax.

    If you're using the new Minecraft launcher, you have a choice on whether or not you want to update to the latest Minecraft release - simply choose "Not now" when it asks if you want to update and you can continue to play on your pre-update Minecraft server.

    If you're not using the new Minecraft launcher, backup your old launcher and update it by downloading it from http://minecraft.net, then follow the steps above.

    It usually takes us a few hours AT LEAST to get Bukkit working with the latest Minecraft update, so you're better off playing a different game or staying on the previous version of Minecraft, instead. If you have a special server that requires lots of mods, like a class-based server, consider backing up your world, running the new Minecraft update and calling it a grief/fun/fool-around period OR stay on your current version and just keep playing.

    Just remember, always backup so you can switch between versions. You're no longer forced to go weeks without a Bukkit powered server.

    Once we have a new Bukkit build that is compatible with the newest Minecraft update, we'll put it under rigorous testing and then promote it as a Recommended Build. Usually, due to the way Bukkit and CraftBukkit are designed, plugins should work just fine but there's no guarantee that this is always the case so be sure to test everything on a test server before you go live.

    Lastly, we're fully aware that a new update is out - usually before anyone else. Don't spam the forums with threads or IRC with messages informing us that there's a new Minecraft update out. We know. And we're working on updating Bukkit to work with it. The more you bother us, the longer it'll take.

    Have fun!
     
  2. Offline

    Brettflan

  3. Offline

    Windwaker

    Okay.... updated....

    Now the plugins
     
  4. Offline

    Criixx

    All the Plugins are broken -.-
     
  5. Offline

    KidCanada

    iconomy permission, worldedit all the important plugins are broken.

    Murder, FakeMessage, nether all work
     
  6. Offline

    Taxick

    Any have a link to the "new Minecraft launcher"??????

    Thanks
     
  7. Offline

    yamashi

    Build 608 still says Outdated server !
     
  8. Offline

    Liger_XT5

  9. Offline

    Opie95

    are plugins seriously not working
     
  10. Offline

    Liger_XT5

    Most plugins are still running on 556, very few, last I knew, were set for 600+.
    I wouldn't be surprised if there was enough changes to cause bugs.
     
  11. Offline

    Opie95

    im running 556 and my plugins r fine (for now)
     
  12. Offline

    lapzoo

    I do this too :)
    But my post a few minutes ago, I meant, I DON'T get this :)
    can't edit! website's buggy.
     
  13. ItvSuckThat MC Updated.I just Got My Last Plug-in And My Server Started Lookin Good:(
    Guess I Just Got To Run MCAdmin For A Bit.Unless That Has To Be Updated ....
     
  14. Offline

    SeanMalloy

    Is the only way to update doing the terminal copy paste coding? I do not understand how to update :/. What do i do with the craftbukkit snapshot.jar thingy?Website is barely working for me aswell "502 Error"
     
  15. Offline

    Ben1002

    Ok, Just updated, Now im getting
    Disconected By Server
    Internal Server Error

    Any ideas guys?
     
  16. Offline

    Mukrakiish

    No reason for anyone to update right now. There is no stable RB of the 1.4 compatible bukkit no less plugins that will support it. Just relax...go play something else for a while or stick with 556 & 1.3_1 like all my (and mostly likely 95% of all other servers) are doing right now.
     
    Spazmic likes this.
  17. Offline

    overlord79003

    So does up new minecraft server up top not work for owrld edit i watned meh plugins:(
     
  18. Offline

    LordAndrew

    I hope that bukkit will be up and running within the next few days, I am going to have nothing to do but play minecraft(and being a dumb-ass like a few other people, i didnt backup my launcher before updating.):mad:
     
  19. Offline

    fifth

    So much impatience.
     
  20. Offline

    overlord79003

    Yeah they said a couple hours at the least so i mean it couldnt be to long probably up in 2hours maybey
     
  21. Offline

    nIkbot

    Rable Rable Rable Rable Rable Rable! :mad:








    Couldn't help it
     
  22. Offline

    lapzoo

    Build 605 works for me! (Permissions and WorldEdit WORKS 100%!!!)
     
    nIkbot likes this.
  23. Offline

    hofec

    Thank you so much BukKit Team :cool: Rocks every day ! Keep it up ! [diamond]
     
  24. Offline

    lapzoo

    [​IMG]

    I don't know why it tells me the marked error, but I just ignored and everything works fine :)
     
  25. Offline

    who885

    lol i hope it updates soon thing is i just started playing with a good buddy of mine sorry for my bad English btw[diamond]
     
  26. Offline

    Opie95

    wait 60
    605 1.4 work and plugins wat others r u using
     
  27. Offline

    lapzoo

  28. Offline

    Opie95

    sweet personaly i would like to know elevators worldedit worldguard region market iconomy and the essentials stuff oh command book
     
  29. Offline

    lapzoo

    KK Now using 612 because iConomy is not compatible with lower versions how it seems.
    WorldEdit (-> so WorldGuard doesn't too) doesn't work for 612.

    I will edit this after checking for other plugins which got updated.
    (01.04.11 - 00:47 testing with CB612)

    YES:
    • iConomy,
    • Permissions (works but somehow I have an invalid config file :S)
    • Elevators
    • Essentials (GroupManager doesn't work perfectly but I think I did something wrong in the config files :>)
    • Minecart Mania (every single plugin of Minecart Mania does work)
    + and I think EssentialsProtect does not work correctly but I don't know much about Essentials,
    I just saw a this fail: Could not pass event PLAYER_INTERACT to EssentialsProtect...
    and then comes much text.

    defenetly NO:
    • WorldEdit,
    • WorldGuard,
    • RegionMarket,
    For all of sk89q's plugins:

    If there are plugins you want me to check just write me and I will update
    my list here ;)
     
    Invididom likes this.
  30. Offline

    Troopah

    Can you tell me if there is a way to update my bukkit server without having to start over. I just made my first server yesterday, and then I hear that minecraft's updated. Thanks
     
  31. Offline

    lapzoo

    What do you mean -> starting over?
    I think first, you should leave your server how it is currently and just
    join with version 1.3 and wait until all your plugins are updated ;)
     
Thread Status:
Not open for further replies.

Share This Page