<NULL> in chat - no player names :(

Discussion in 'Bukkit Help' started by woody_matt, Mar 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    hello there,
    i was wondering if anybody would be able to assist me. i have a dedicated server running windows server 2008 x86. i believe the java version is the latest but my server company dont state the version so i am unable to tell you. the plugins i have installed are; Dynmap 0.13,Essentials plugin (all of the addons appart from the economy ones),General 2.0,ichat 1.6 (rebirth),permissions 2.1,whitelist,worldedit 4 beta

    my problem is this; i restarted my server (i had just added someone to the whitelist) and the chat no longer works. i have changed nothing, no extra plugins etc. whenever anyone, be it random people, ops and admins, types anything in the chat, their name no longer shows up. all that is displayed is <null> whereas it used to be <Playername>. the error code from the server log is as follows

    18:38:32 [SEVERE] Could not pass event PLAYER_CHAT to iChat
    mapping values are not allowed here in "<reader>", line 38, column 13:

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:745)
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:307)
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:564)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:228)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at org.bukkit.util.config.Configuration.load(Configuration.java:73)
    at com.nijiko.permissions.Control.load(Control.java:147)
    at com.nijiko.permissions.Control.loadWorld(Control.java:111)
    at com.nijiko.permissions.Control.getGroup(Control.java:532)
    at net.theyeticave.theyeti.iChat.Listener.onPlayerChat(Listener.java:50)
    at org.bukkit.plugin.java.JavaPluginLoader$6.execute(JavaPluginLoader.java:150)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:588)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-01 18:38:32 [INFO] <null> help

    please help me - i have lots of unhappy players
  2. Offline


    are iChat and EssentialsChat conflicting? Try disabling one of them and see if the problem stops.
  3. Offline


    its not :(
    i disabled ichat and the same problem occured and the same with essentialschat disabled.
    also,only just noticed, all of the essentials plugins seem to be disabled
  4. Offline


    Have you updated the Essentials config.yml? They recently changed how that config file is written, and if you only updated the .jars and not the config.yml, you will have errors. And lots of them.

    Also, are you using the Essentials.GroupManager plugin as well? Essentials has recently implemented their own permissions file, and it may be clashing with Permissions.

    Also-also are you using the updated permissions plugin by Phoenix, or are you still using Ninjokun's?
  5. Offline


    the config.yml could be the problem, ill give it a try. also i will disable the groupmanager, i am using ninjokuns last permissions release (2.1 i think?)
  6. Offline


    You need to update to Phoenix's. Ninjokun is no longer supporting the old permissions plugin. It may not be the source of your problem, but I'd still recommend it regardless: http://forums.bukkit.org/threads/ad...5-1-phoenix-now-with-more-antibuild-440.5974/

    Once you've done that, disabled the groupmanager, and updated the config.yml, let us know how it's going. Might solve a lot of problems just doing those things ;)
  7. Offline


    thanks for the help. reinstalling essentials and all its "addons" and updating to the latest config.yml file has fixed all of the essentials plugins. however the players are still displayed as null (interestingly, ops and admins <null> is in red like their names should be)

    ill try the new permissions plugin and let you know if it solves the problem

    thanks for your help :D
  8. Offline


    Not a problem! Glad to hear things are getting fixed :)
    Keep us posted.

    Make sure that GroupManager is disabled too! And whatever the other group plugin is. There are two of them, I forget what they're both called. But if you're using Permissions, both of those Essentials.Group* files need to be deleted.
    --- merged: Mar 1, 2011 7:29 PM ---
    Oh. One MORE thing:

    When you added the person to the whitelist, did you use the TAB key to create spaces in the whitelist file? Or did you use the spacebar?

    Using the tab key in configuration files seems to break them. Might check that too.
  9. Offline


    hmm, the new permissions plugin has the same problem, names still show up as <null>

    i did spot this in the log

    [INFO] woody_matt has logged in for the first time.
    2011-03-01 19:23:01 [INFO] Loaded world: world_private
    2011-03-01 19:23:01 [WARNING] Missing a prefix or suffix for null

    well it deffinately isnt the first time, or is this because i restarted it?
    i was wondering if i deleted the prefixes in my permissions config if that would make any difference?

  10. Offline


    Also, for good measure, I'd recommend that you remove General plugin. Essentials has many new features that cover everything General used to. You might be getting some sort of overlap there.

    The prefix/suffi...x.... That's weird. It looks like you...

    Go into your Permissions config file, and make sure you used space bar and not tab to create spaces in your file. It looks like it's having an error reading your user groups.
    --- merged: Mar 1, 2011 7:35 PM ---
    Also, try deleting the prefixes and suffixes just for good measure. It's worth a shot.

    But I don't think that's the problem. The problem appears to be that it's reading everyone's group as "null" isntead of "Default", "Moderator", or "Admin".
  11. Offline


    im using an older plugin that is just called whitelist, i am affraid i cant remember what it was called here - ill look for it in the plugins list. do you think it would be worth switching to the default minecraft one that was added in the last update?
  12. Offline


    Eh. I mean, yes, updating to new versions is always good, but if your server was running fine before you added the new person, you shouldn't have to change anything. It just sounds like you messed something up accidentally when you added the new person.

    Go back to the whitelist, make sure you didn't use the tab key. And make sure you didn't accidentally remove a # or add a # or something weird. Just check the integrity of the whitelist file.
  13. Offline


    I'm having this same error on a server I set up for my brother, and he has _no_ plugins installed. Just the latest dev build as of a couple hours ago
  14. Offline


    the whitelist file is just a .txt file with a player name on each line. i think the reason the server ceased to funtion properly was the restart itself. if the problem ensues i may just backup my files and reinstall the server - i have tried using a blank permissions file and adding the usernames and plugin permissions to it but it still isnt working.

    ill keep you updated if i find any other fixes or problems
    --- merged: Mar 1, 2011 8:27 PM ---
    hmm, i found out something else, all player orientated commands work, eg /give {player} {item} {number} work if you use a playername and if you do this everyones names suddenly appear?!?!
    ill restart the server and try and do another test to see if it wasnt a fluke
    --- merged: Mar 1, 2011 8:48 PM ---
    i have tested this three times now. if you spawn something for yourself, eg using /i 1 1 to get one stone, everyones names appear but the fix isnt permanent it is only as long as you are online. i dont know whether if someone else is online and you disconnect and reconnect that it remembers i havent tested this far yet. i am using bukkit build 481
    --- merged: Mar 1, 2011 9:29 PM ---
    Ok bad news - my server log went from 150kb to 42.6mb in 20 minutes - there is deffinately a problem. i have installed the lates compatible versions of all of my plugins and ditched the old whitelist plugin to use the buitl in one - this problem still ensues!
    that weird fix still works though, if you spawn something using /i then everyones names appear
  15. Offline


    Here's a shot in the dark - try disabling Dynmap. I've heard it's caused problems for several plugins that have nothing to do with what Dynmap does. So I'm not sure if it'd help at all, but why not try haha.

    Also, try rolling back to build 440 if nothing works, and see if that solves the problem?
  16. Offline


    Hey, i just gotten myself into the minecraft server as my friends demanded it ( due to having a 120mbit connection lol )
    Everything is running fine as it is and i'm enjoying the plugin abilities Bukkit is able to give me!
    Now after i installed 2 plugins , i get this exact problem , where player names are showed as <null> , hence why some searching i found this thread.

    The plugins i currently use are the latest versions of Permissions and MagicCarpet.
    I plan to add more at a later date but i want this problem out of the way first

    Currently running this server on my main system which is running on W7 x64
  17. Offline


    You have Permissions, MagicCarpet, AND iChat - correct? What about Essentials?

    Go and check your config.yml for Permissions and ensure you have not used the Tab key to create spaces - only use the Space Bar. When Tab is used, it causes the plugin to stop reading the config file and crash.
  18. Offline


    Nope , Just MagicCarpet and Permissions.
    Is iChat viable for this to work ?
    I have checked the config file for any tabbing and i just did it again to confirm it wasn't the mistake.
  19. Offline


  20. Offline


    I'm sorry , i will update This post with the information needed.

    Windows 7 x64
    java version "1.6.0_24"
    Java(TM) SE Runtime Environment (build 1.6.0_24-b07)

    No wrappers.

    Implementation-Version: git-Bukkit-0.0.0-484-g36a33aa-b481jnks

    I run my server through the made batch file

    Plugins running are Permissions and MagicCarpet

    I have tried using an older version of MagicCarpet and the earlier given options, as in checking for tabs.
    I have also tried just making myself the only user with rights

    And yes , if i use /give player x x i can see the name
    Also if i type /list i can see player names.
  21. Offline


    Did you rename the Permissions config.yml to the name of your world folder? This is a new requirement.
  22. Offline


    #Minecraft server properties
    #Wed Mar 02 01:08:12 CET 2011

    File name: World1.yml
  23. Offline


    Yes, like that. Does the problem persist?
  24. Offline


    It was one of the first things i did when i set-up the server as told in the given tutorial, so this was done before i even installed any plugins
  25. Offline


    Have you tried rolling back to build 440?
  26. Offline


    I have just tried installing iChat with the default iChat config file
    Saying something in-game now shows as "[Default] null"
    If it helps anyone..

    I will try rolling back to 440 right now, thanks for the help sofar
  27. Offline


    Afraid I've not been much help ;)

    Just taking shots in the dark! Figure it's better than being ignored.
    --- merged: Mar 2, 2011 8:47 AM ---
    Two more things for you guys to try.​
    Try reverting iChat's message format to the default:​

    message-format: '[+prefix+group+suffix&f] +name: +message'
    And try rolling back Permissions to 2.0 or 2.1 with a fresh config.yml. See if that works. If it does (and if none of the other fixes work) then I am going to say iChat is outdated, because it appears to only support Permissions 2.0/2.1 in this case.​
  28. Offline


    I have to correct you there!
    I just installed build 440 and the chat output for me (unmodded config for iChat ) is showing as "[Default] Gekkeloko"
    Without iChat it's showing as Gekkeloko

    I don't think it had anything to do with iChat, i will give it a shot with an older Permissions as well just to know where the problem is hiding tho.
  29. Offline


    Whooooo! Glad to hear it's working. Keep us posted!

    It looks like, then, iChat is just not ready for one of the new builds.

    If it is working properly now, just rolling back the bukkit build, then update your bukkit build again and roll back Permissions - don't try them both rolled back unless rolling back bukkit alone doesn't fix it.
  30. Offline


    Yeah that's what i ment, it's the perfect way to close out a problem ( Just like with my IT job ) ^^
Thread Status:
Not open for further replies.

Share This Page