Nether lags heavily on 1.2.3-R0.2-SNAPSHOT

Discussion in 'Bukkit Help' started by Archa, Mar 8, 2012.

Thread Status:
Not open for further replies.
  1. Offline



    I went from 1.1-R4 straight to 1.2.3-R0.1 as an upgrade. Everything worked really smoothly - thanks to the Bukkit team for that!

    But the problem is that Nether is unusable any more. I get really heavy lag upon entering it, then it continues to work fine for a few seconds and I keep getting a huge lag again. This repeats endlessly. The lag affects all my servers players, so I guess it's not a client side issue. When the lag occurs, I get a huge frame rate drop.

    No errors on Bukkit console, running top command whilst in Nether shows no significant increase in CPU utilisation, load average stays on an approx. 1.49-1.52 (2 CPUs allocated). Running /mem in bukkit console shows that I still have plenty of RAM left.

    Can anybody please point me out to where I should start looking? I have reset the Nether, I have added more RAM(from 3Gb to 4Gb), nothing helps. This occurs only in Nether, End seems to be unaffected.
  2. Offline


    Same on my server. The world was generated in 1.2, so it's not a map conversion issue.
  3. Offline


    Made an upgrade from Oracle JDK 1.6 to Oracle JDK 1.7 - no change.

    OS is Ubuntu 11.10 virtual flavor, 64bit machine, 64bit Java 7
  4. Offline


    same thing
  5. Offline


    It also heavily lags in 1.2.3-R0.1-SNAPSHOT. I too made a new map generate for 1.2.3 and im running my server on Ubuntu 11.04.
  6. Offline


    This appears to be an issue in the vanilla client or server and I doubt it specifically has anything to do with Bukkit. I'm running a vanilla server and client, the server is on a dedicated host so there's no lack of hardware or bandwidth, and the client is ran on a pretty high end desktop, and the Nether lags sporadically, so bad that the entire client locks up. If Jeb/Mojang has a bug report forum or something like that, I'd report the issue there.
  7. Offline


    After reading commits in Github, found out about a fix which restricts Nether build height to 128. Updated to CraftBukkit version git-Bukkit-1.2.3-R0.2-3-g7acc04c-b2063jnks (MC: 1.2.3) (Implementing API version 1.2.3-R0.3-SNAPSHOT), regenerated Nether and it lags quite less. Still an awful lot of lag, but it is now possible to play in Nether. Anyone else experiencing this after an upgrade?
  8. Offline


    I'm seeing this on the surface of the world with 1.2.3-R0.2. Server chat lag, sometimes measured in MINUTES.... smack an animal and it reacts 30 seconds later etc etc. All plugins disabled and still the lag persists. Might try going back to 1.2.3-R0.1 tonight to see if that helps any.
  9. Offline


    Yes, brutal amounts of lag in nether on R.02 - Just updgraded to 2083 dev build and still terrible lag.. i have not however, regenerated my nether world.. I will try this out later and see if a fresh nether from R03's fix the issues.
  10. Offline


    I've noticed, on the newer craftbukkit builds(2083), that the lag occurs when chunks are being loaded or re-loaded. when you are looking towards and walking in a generated chunk it's like playing in the over-world, no lag. But if you begin to load chunks, then BAM, instant lag spike.

    Lag is definitely better on the newer builds(2083) than the previous ones.

    Deleting your nether world does NOT fix the issue.
  11. Offline


    Damm There goes my Kingdom in the Nether... The Map is playble for me, but when I go over to a new chunk, it would lag for like 3 seconds... Which is enough to annoy the shit outta me.
  12. Offline


    Very latest dev builds, nether still lags horribly... Gotta wait for Mojang to release a fix i assume.
  13. Offline


    My server is running on the latest dev builds all the time. I do an update once in a week or so. Also I regenerate the Nether every time, so I have gained a hate from my players but it doesn't help :( Lag exists and I cannot even point out why.
  14. Offline


    Are people still having this issue? I am running 1.2.5 and having this exact issue .. the lag is very different from the lag I usually experience (delay), as it feels like an fps drop. My users are also experiencing the lag.
  15. Offline


    im still having the same issue on 1.2.5 RB
    vat21s likes this.
  16. Offline


    Hi,we havethis problemallaround.Helped mea lot ofthis plugin. PTweaks.
  17. Offline


    My 1.2.5 server had been suffering from Nether lag for a while as well and I was stumped, so I looked through my plugins to see if one of them might be the issue. I saw I had NoLaggLighting, remembered that it was for the 1.2.4 version of bukkit, and that I thought 1.2.5 had fixed some of the lighting bugs. I figured NoLaggLighting *might* be conflicting somehow, so I disabled it and restarted my server. And what do you know? No lag spikes in the nether! I haven't had a chance to thoroughly test the results yet, but for the 20 minutes I've been wandering around the nether, I haven't gotten a single lag spike. If you don't use NoLagg, I'm sorry, but I don't know what your issue is. :/
  18. Offline


    One way to combat this is to use the Spoutcraft client. Once you have it, in video settings uncheck "client lighting" (not sure what it is exactly, can't check now)

    That will fix your frame lag that you get in the Nether.
  19. Offline


    For a while I have the same problem.
    The Spoutcraft Client worked for me.

    Today for me it worked to reconnect to the server while I was in the Nether. Hope this helps some of you, too.
Thread Status:
Not open for further replies.

Share This Page