Need help with Permissions

Discussion in 'Bukkit Help' started by masteralvin, Jan 28, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    masteralvin

    I started making my groups with groupmanager and I always get a error and it says that commands are blocked due to an error

    Here is the error: http://pastebin.com/iptcEETp
    Here my groups,yml which I have pasted in the 2 world-folders I have in my servers groupmanger folder:
    http://pastebin.com/uwEttmpf
    And here the users.yml which is identical in both folders: http://pastebin.com/2fwkkXy8
    And here my config: http://pastebin.com/dezCGvQ5
    and my globalgroups: http://pastebin.com/vKntGJtp

    My bukkit is #2995. Also strange ist that if I (the player set as admin in the users.yml) log in I have all my OP-Rights but no rights from the set groups, like /help or /gm etc.

    I hope you may help me :). I am pretty new to servers.
     
  2. Offline

    Necrodoom

    Missing 'groups:' line behind line 11 in groups.yml.
     
  3. Offline

    masteralvin

  4. Offline

    JaguarJo Retired Staff

    masteralvin Since you didn't link the redone groups file, I can't see how you added in the groups: line like Necrodoom said you needed. So just in case your spacing is still off, which the error makes it look like it is, it should look like this:
    Code:
    groups:
      Default:
        default: true
        permissions:
        - essentials.sethome
    In the file you linked above, the default: true line wasn't lined up with the other lines and your Default: groupname wasn't indented at all.

    There are also spacing problems once you reach your VIP group and the groups after that. You have your build: true and info: lines out too far; they need to be spaced in 4 spaces, like the permission nodes are. And then remember that when you bump the info section in, you also need to bump the inheritance, prefix, and suffix lines in, because they should be in 6 spaces.

    P.S. Your moderator group doesn't have any info lines added, you just left the line blank. You can't have a blank line there; either add something or take the line out.
     
  5. Offline

    masteralvin

  6. Offline

    Necrodoom

    masteralvin Missing one space behind line 11, also, your VIP and below groups are butchered:
    Replace ‘*’ with '*'
    Move build line into info section, and inhertiance line out of it.
    'inheritance: group' should be 'inhertiance (newline here) - group'
     
  7. Offline

    masteralvin

    Thanks I don't know much about the form of the groups that is needed
     
  8. Offline

    tweker

    masteralvin try using PermissionsEx, i find its much more simpler with a bunch of options, I can help you setup some part of it, you will be able to catch up on it.
     
  9. Offline

    Necrodoom

    There is already a working permissions setup, i dont see the reason in converting.
     
  10. Offline

    tweker

    Necrodoom I prefer PEX over GM because I'm more used to it, plus it was just a suggestion, I wasn't telling him what to do.
     
  11. Offline

    masteralvin

    Why use PEX? I heard it supports way less plugins....
     
  12. Offline

    JaguarJo Retired Staff

Thread Status:
Not open for further replies.

Share This Page