Modloader MP Problems

Discussion in 'Bukkit Help' started by Negrotron, Aug 15, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I really need help! I got so far as to get a server running and I was able to get in and see that my plugins and Itemcraft was working.
    But now i cant login because
    " Bad Packet id: 230 "
    I know this is because it thinks I am missing mods, but I'm not. I've done many reinstalls of my .minecraft/bin and of Modloader, modloadermp, and the 16bit enitity patch.
    I think the problem is my ModloaderMP isnt initializing and i cant find out how to fix it.
    Any help would be really appreciated.

    Heres some information:
    Running Windows 7 x64
    Java 1.6.0_26 64 bit
    dont see a server.log file..

    Using this command:
    echo off
    if exist "C:\Program Files\Java\jre6\bin"\java.exe "C:\Program Files\Java\jre6\bin\"java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    craftbukkit is build 1060
    Im running slopes, fancy pack, better stained glass, and Essestials.
    I can connect to clean servers, not my Itemcraft server.
    And im running Hamachi, but i go offline and it still doesnt work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  2. Offline


    @Negrotron You're unlikely to get help here as you're modding your craftbukkit.jar, but try running the server with JUST ModloaderMP, then mod it again to include the other mods. If your CLIENT is saying you got disconnected with Bad Packet 230, that means you don't have Modloader and ModloaderMP installed client side.
  3. Offline


    He doesn't Mod the craftbukkit.jar, but the minecraft.jar (afaik.)
  4. Offline


    ItemCraft requires modding the craftbukkit.jar file. @Negrotron You're using an incompatible build. Only use the listed builds in the ItemCraft thread as it's modifying a specific version. Rollback to CB1000 or wait for ItemCraft to be updated to CB 1060.
  5. Offline


    Oh right, didn't see that :p
  6. Offline


    Ok, I'll try again and see what happens. Thanks a lot for your help!

    So i tried running with all the Itemcraft mods commented out (#) and i rolled back to craftbukkit1000 and I get the same error. I'm convinced my client-side ModloaderMP is not initiliazing , I read that it doesnt load when you have no MP Mods, which i do. I saw it randomlly work one time in my Minecraft.jar console after it screwed up trying to connect to my server. I thought all i had to do was Try to connect, let it fail once, then try again. But it only did it once, now it doesnt load.

    I downloaded a fresh test Server instead of using the Noob craftbukkit installer and everything works now. :S

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  7. Offline


    hey u dont have to install it on your minecraft jar. if u install it on your server does anyone ever think that all u have to do is put the modloader files in the craftbukkit jar. and i am not sure about the mods but u DONT HAVE TO put anything in your minecraft jar
Thread Status:
Not open for further replies.

Share This Page