[MISC] Sleep v7.0.0 - Multi-Player Sleep Management (Idle, Notifications, Force) [1.5.1]

Discussion in 'Archived: Plugin Releases' started by EdGruberman, Apr 26, 2011.

  1. Offline

    EdGruberman Retired Staff

    harakiwi, Glaze, Frogging101 and 2 others like this.
  2. Offline

    xorvious

    Your Ti Kwan Leep is strong with this post! ;)
     
  3. Offline

    MineralMC

    2011-05-11 08:32:07 [INFO] [ALL] UnimportantHero » Can you go to sleep
    2011-05-11 08:32:11 [FINE] [SimpleAwaySleep] Pricella entered bed in "fh-core".
    2011-05-11 08:32:11 [FINEST] [SimpleAwaySleep] Ignoring UnimportantHero in "fh-core"; Always ignores sleep.
    2011-05-11 08:32:11 [FINE] [SimpleAwaySleep] Setting UnimportantHero in "fh-core" to asleep.
    2011-05-11 08:32:12 [INFO] [ALL] UnimportantHero » Need to test something for a dev
    2011-05-11 08:32:16 [FINE] [SimpleAwaySleep] Pricella left bed in "fh-core".
    2011-05-11 08:32:16 [FINE] [SimpleAwaySleep] Setting UnimportantHero in "fh-core" to awake.
     
  4. Offline

    EdGruberman Retired Staff

    Thank you MineralMC! Unfortunately that doesn' t show anything that would indicate the problem you had earlier with the NPE. If that still existed it would have said "Ignoring <Player> in "<World>"; No activity recorded yet."
    Well, I'll just assume it can happen under odd circumstances and push out a release. I've been using 1.1.1b2 on my server and it's been working just fine. Thank you again for your help, MineralMC!
     
  5. Offline

    EdGruberman Retired Staff

    I just verified this still works as expected with Build #794.
     
  6. Offline

    rodey

    First I want to say really nice plugin.

    I have a request for the plugin that would be really awsome if it gets implemented.
    Maybe you could add a feature that sleeping is forced when for example 2/3 of the people is sleeping in the server.
    This would be kinds like a votesystem but without the command stuff that takes the fun out of minecraft.

    If you could pull this of it would be really awsome :)

    Thx for your effort in advance.
     
  7. Offline

    EdGruberman Retired Staff

    @rodey - It's an interesting concept I've thought about. My goal with any of my plugins has always been to stay as true as possible to the "official" implementation by Mojang/notch. That said, I've also always felt notch focuses way too much on single player for his solutions and sleep in particular has been highly neglected on how it interacts with multiplayer reality.
    To be honest, I'm overloaded in my schedule right now. IF I were to do this it might take me a few weeks to dedicated a few hours to focus to make this change.
    Off the cuff, I'd imagine two attributes that defined a minimum number of players and a minimum percentage. By default everyone would either have to be in bed or away. But if you set those attributes in the configuration file with values then it would force anyone above and beyond the minimums that wasn't in bed to be treated as if they were in bed.
    I believe this approach would be fairly simple additional logic to add in only a few places. Though it then makes me think of renaming the plugin to something more appropriate. SimpleSleep ? MultiplayerSleep? Not sure. Well give me a few weeks to think on it all, I have vacation coming up and I might play a bit more with all this. (The source is available also, so as always, if you want to try and edit it yourself, nothing is stopping you! :) )
     
  8. Offline

    EdGruberman Retired Staff

    I've added the minimum percentage and minimum number of players options now. I've tested it very minimally though, so here is a link to the Release Candidate 1.2.0rc2.

    Minimum Percentage/Number of Players

    In order to configure the minimum percentage and/or number of players feature, you must manually edit the "plugins/SimpleAwaySleep/config.yml" file. You can put one or both of the following values in that file.

    Code:
    minimumSleepers: 2
    minimumPercentage: 50
    You can change the numbers to whatever you want (as long as they are whole numbers/integers). If you set them to -1 they will be disabled as they are by default. e.g. If you only want to set a minimum number of players that forces sleep (even just 1) you can set minimumPercentage to -1 and it will not check the percentage.

    If someone can confirm the new feature works as expected or after I get a chance to test it more thoroughly I'll officially release it.

    Another important change to note is that this plugin now depends on another plugin, MessageManager, to be installed also. MessageManager will not change anything with how your server works and is only an API for managing the output of plugins that specifically use it.

    Please note that utilizing this feature could have outcomes that are not intuitive. For instance, say you have it set as minimumSleepers: 2 and minimumPercentage: 50, and there are 3 players. If two players enter bed and the third is moving towards their bed, the sleep cycle could be forced before that third player reaches their bed. Nothing bad will happen to that third player as they will be protected from nightmares by being placed in an ignored sleep status, but it should be noted that this might be considered unexpected by most players if they are not properly trained on how your server operates with this custom feature.
     
  9. Offline

    rodey

    Very cool man!!! much appreciated.

    I shall take a look at the source.
    I'm very interested in programming Java and I know a other few programming languages so shouldn't be too hard.
     
  10. Offline

    EdGruberman Retired Staff

    Okay I finally had a chance to test this out more and I'm comfortable it does what it promises. I just released 1.2.0 officially.
     
  11. Offline

    Poeschl

    Works it with the #953 build?
     
  12. Offline

    EdGruberman Retired Staff

    Yes. Although, I've been testing with 1.3.0 (just released).
    I found a bug where people in the nether were preventing the sleep cycle from occuring.
    Also, I had to make a change to support multiple worlds and the minimum players/percentage feature added last update. Though, it shouldn't impact any configurations, itself is almost more of a fix.
    Please let me know if anyone has any problems!
     
  13. Offline

    SulimirCular

    Nice plugin... maybe u could sent a message to the server like:
    "{Player} is laying in bed and waits for dawn"
    so that other players know that another player want to have it day
     
  14. Offline

    DiscoBiscuit

    Great plugin! Very useful. However, I think it conflicts with MyHome. After going to bed, you can no longer teleport home.
     
  15. Offline

    EdGruberman Retired Staff

    @DiscoBiscuit - Ah good to know. Thanks for the feedback, I'll download MyHome and test. I'm doing a lot of testing for the next version actually over the next couple of days/weekend.

    @SulimirCular - I'm working on adding a message option for the next version.
     
  16. Offline

    EdGruberman Retired Staff

    Okay, big change put out. Plugin has been renamed to just Sleep to indicate it's general purpose nature now. By default it still gives you Inactive Player sleep management. But now with more configuration options (check the first post for details under the Instructions and Changelog sections.)

    I just reazlied I forgot to test with the MyHome plugin to see if this new version works. I'll try and test that today/tomorrow to see.

    Please note that the name change will require you to delete any existing SimpleAwaySleep.jar so it doesn't try to run at the same time the new Sleep.jar does.

    Also, please note you will need to update MessageManager to 3.0.0 if you already have it. That is a simple file copy to replace the original.
     
  17. Offline

    EdGruberman Retired Staff

    I just released 2.1.0. It's a small change which only impacts Server Operators if permissions have been assigned individually. I've renamed permissions slightly to simplify things a bit. If you've only assigned the info permission as I suspect, then this shouldn't cause you to redo any permission configuration. Check the Instructions section in the first post for details on how it works now.

    @DiscoBiscuit - I finally did more MyHome testing. It seems to work now with the latest version (2.1.0).

    In the version you mentioned the problem (1.2.0) I was only doing a very simple check if the player was set to ignore sleep, then cancel the teleport.

    Since version 2.0.0, I changed it to record a list of players who have left bed and are set to ignore sleep. The very next teleport they experience is then cancelled. So if for some reason this logic still screws up somehow, theoretically if you just call the /home command a second time it will then work. But my hunch is the more advanced logic/tracking should make things work as expected the first go around.

    https://github.com/EdGruberman/Slee...ruberman/bukkit/sleep/PlayerListener.java#L82

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  18. Offline

    Sinazok

    The percent system doesn't appear to be working properly. I have it set to allow sleep when 50% of players are sleeping and tested with 4 players online. If 1 of them gets into a bed, it announces that it needs +0 more for sleep and jumps to day. I only need this for the percent system and would really love if 50% could work (and round up if there is an odd number online).
     
  19. Offline

    EdGruberman Retired Staff

    @Sinazok - Can you paste your configuration file(s) here or somewhere?

    We need to make absolute sure there are no tabs and that the spacing is exact.

    Code:
    force:
        percent: 50
    You should not have a count setting. You can try setting count to -1 and null also if you'd like.

    Do you get any errors?

    Lastly, try creating a file "plugins/Sleep/MessageManager.yml" and copy the following in to it:
    Code:
    send:
        PLAYER:
            level: ALL
        SERVER:
            level: ALL
        WORLD:
            level: ALL
        LOG:
            level: ALL
    Then try restarting your server to see if you get any further error information in your logs that might help us understand better. (This will also give you CONFIG log entries on server startup that will confirm your configuration.)

    The percent setting should round up if you have an odd number. percent: 50 will require 3 with 5 players.
     
  20. Offline

    Sinazok

    I discovered that setting "inactivityLimit: -1" treats everyone as inactive and begins sleep when 1 out of 0 possible are in bed. After changing it to 86400, it counts the proper number of players for possible but doesn't initiate sleep when the percentage is met. It'll say "Sleep needs +2; 2 in bed out of 4 possible = 50% (need 50%)" but it doesn't jump to day until all 4 are in bed. Here is my current config http://pastebin.com/H32LRWg5 and I use your MessageManager.yml as suggested.
     
  21. Offline

    EdGruberman Retired Staff

    Thank you for the feedback. You'd think I'd have tested this better... I will check this out more tonight and let you know. Again, Thank you!
     
  22. Offline

    Sawn

    Nice plugin here.

    But I get an error on restarting the server with it é_è :

    Code:
    2011-07-30 14:14:49§f[MessageManager] Plugin Enabled
    2011-07-30 14:14:49 [SEVERE] Error occurred while enabling Sleep v2.1.0 (Is it up to date?): null
    java.lang.NullPointerException
            at edgruberman.bukkit.sleep.Main.loadConfiguration(Unknown Source)
            at edgruberman.bukkit.sleep.Main.onEnable(Unknown Source)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Here is my conf file :

    Code:
    inactivityLimit: 1200
    safeRadius: 3
    force:
        count: null
        percent: null
    message:
        enterBed: '%1$s est dans son lit, il manque encore +%2$d pour dormir'
        maxFrequency: 10
        timestamp: false
    activity:
        - PLAYER_MOVE
        - PLAYER_CHAT
        - PLAYER_INTERACT
        - PLAYER_DROP_ITEM
        - PLAYER_TOGGLE_SNEAK
        - PLAYER_ITEM_HELD
        - PLAYER_JOIN
    ignoredAlways:
        - testuser1
        - testuser2
        - Wiegraf
    event:
        PLAYER_TELEPORT:
            priority: Normal
        CREATURE_SPAWN:
            priority: Normal

    I'm running RB #1000.

    Any idea ? Maybe I just misunderstood something (but the error also occurs with default config file).

    Thanks.
     
  23. Offline

    EdGruberman Retired Staff

    @Sinazok - I think I was trying to be "too smart" in my calculations originally and I ended up looking stupid as a result :( I've made the formulas more straight-forward now. I haven't tested thoroughly, but if you'd like to try it out now, you can grab the beta (link below).

    If you specify -1 for count or percent now, it should work as expected. Also, -1 inactivityLimit should also work as expected now and never treat anyone as inactive.

    @Sawn - Looks like I overlooked disabled nether configurations. I've put a fix in for your issue also, if you'd like to give it a try before I fully confirm/test you can download the beta also.




    Download Beta 2.2.0b1 for testing
    Of note: I changed the permissions once again. Still trying to understand permissions fully. I just renamed them basically to simplify again. If you haven't configured permissions specifically for this plugin, it shouldn't affect you in any way.


    Changelog for 2.2.0b1:
    CHG: Renamed permissions to simplify
    CHG: Configure code defaults to mimic native sleep behavior
    CHG: Players in bed no longer ignored if inactive or always ignored
    FIX: Setting inactivityLimit to -1 would not disable inactive player check
    FIX: Forced sleep with count or percent not working as expected
    FIX: NPE when nether disabled/default nether not found
     
  24. Offline

    Sawn

    Thanks for the reactivity, no more error at launch it seems, we'll test for the evening and give you feedback if anything odd occurs. :)
     
  25. Offline

    Sinazok

    Your update made it work well enough for me ^_^ thanks a lot. However, you might like to know the following.

    The percentage works as expected unless I set inactivityLimit to -1. In which case, it behaves strangely. When 1 of 4 people got into bed, it said +0 more needed and didn't become day. When 2 of 4 got into bed, it said +1 more needed and didn't become day. When 3 of 4 got into bed, it said +1 more needed again and didn't become day. At this point I changed the config to use 86400 instead of -1 and we all tried again. The percentage worked perfectly after that.
     
  26. Offline

    EdGruberman Retired Staff

    @Sawn - Thank you for your assistance! I can only find time to test so much and feedback like yours is invaluable.

    @Sinazok - Your dedication to testing and providing details is very much appreciated also. I was able to test inactivityLimit: -1 more just now and I got exactly what I expected now. I tried with your same setup of 4 players and percent: 50

    I altered a few more minor things unrelated to inactivityLimit (a few more permissions related stuff cleaned up), but who knows, maybe try this second beta build to see if any more luck? Also, I'd love the log file section from your testing with the logging turned to ALL and the CONFIG entries from the log that show what it recognizes for your Sleep configuration. That would help me tons if you could.

    Download beta 2.2.0b2 for testing
    Changelog for 2.2.0b2:
    CHG: sleep.sleep.ignore permission renamed to sleep.ignore permission
    FIX: Removed event priorities from config file to simplify config file


    My Testing Logs (open)
    Code:
    2011-07-30 23:54:25 [INFO] EdGruberman issued server command: sleep reload
    2011-07-30 23:54:25 [FINE] º0[Sleep] EdGruberman issued command: sleep reload
    2011-07-30 23:54:25 [FINEST] º0[Sleep] Command Context for sleep; Action: reload; Arguments: [reload]
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Default Nether: Worlds/World1_nether
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Excluded Worlds: []
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Inactivity Limit (seconds): -1
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Safe Radius (blocks): 3
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Always Ignored Players (Configuration File Defined): []
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Forced Sleep Minimum Count: -1
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Forced Sleep Minimum Percent: 50
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Enter Bed Message: %1$s is in bed (Need +%2$d to sleep)
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Maximum Message Frequency: 10
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Message Timestamp: false
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1] Monitored Activity: [PLAYER_DROP_ITEM, PLAYER_CHAT, PLAYER_INTERACT, PLAYER_TOGGLE_SNEAK, PLAYER_JOIN, PLAYER_ITEM_HELD, PLAYER_MOVE]
    2011-07-30 23:54:25 [CONFIG] º3[Sleep] Sleep state for [Worlds/World1_nether] will not be tracked.
    2011-07-30 23:54:25 [STATUS] º2[Sleep] [PLAYER] [EdGruberman] ºa-> Configuration reloaded.
    2011-07-30 23:54:41 [FINE] º0[Sleep] EdGruberman issued command: sleep detail
    2011-07-30 23:54:41 [FINEST] º0[Sleep] Command Context for sleep; Action: detail; Arguments: [detail]
    2011-07-30 23:54:41 [STATUS] º2[Sleep] [PLAYER] [EdGruberman] ºa-> Sleep needs +2; 0 in bed out of 4 possible = 0% (need 50%)
    2011-07-30 23:54:41 [FINE] º0[Sleep] [Worlds/World1] Sleep needs +2; 0 in bed out of 4 possible = 0% (need 50%)
    2011-07-30 23:54:47 [FINE] º0[Sleep] EdGruberman entered bed in [Worlds/World1]
    2011-07-30 23:54:47 [EVENT] º8[Sleep] [WORLD] º8[Worlds/World1] EdGruberman is in bed (Need +1 to sleep)
    2011-07-30 23:54:47 [FINE] º0[Sleep] [Worlds/World1] Sleep needs +1; 1 in bed out of 4 possible = 25% (need 50%)
    2011-07-30 23:54:57 [FINE] º0[Sleep] Player entered bed in [Worlds/World1]
    2011-07-30 23:54:57 [EVENT] º8[Sleep] [WORLD] º8[Worlds/World1] Player is in bed (Need +0 to sleep)
    2011-07-30 23:54:57 [FINE] º0[Sleep] [Worlds/World1] Sleep needs no more; 2 in bed out of 4 possible = 50% (need 50%)
    2011-07-30 23:54:57 [FINE] º0[Sleep] Setting Another in [Worlds/World1] to ignore sleep. (Forcing Sleep)
    2011-07-30 23:54:57 [FINE] º0[Sleep] Setting Another2 in [Worlds/World1] to ignore sleep. (Forcing Sleep)
    2011-07-30 23:55:02 [FINER] º0[Sleep] Cancelling ignored sleep related spawn of SKELETON in [Worlds/World1] at x: -362 y: 66 z: 604
    2011-07-30 23:55:02 [FINE] º0[Sleep] Cancelling wakeup bed return teleport for Another who is ignoring sleep.
    2011-07-30 23:55:02 [FINER] º0[Sleep] Cancelling ignored sleep related spawn of ZOMBIE in [Worlds/World1] at x: -362 y: 66 z: 604
    2011-07-30 23:55:02 [FINE] º0[Sleep] Cancelling wakeup bed return teleport for Another who is ignoring sleep.
    2011-07-30 23:55:02 [FINE] º0[Sleep] EdGruberman left bed in [Worlds/World1]
    2011-07-30 23:55:02 [FINE] º0[Sleep] Player left bed in [Worlds/World1]
    2011-07-30 23:55:02 [FINE] º0[Sleep] Setting Another in [Worlds/World1] to not ignore sleep. (Awakening World)
    2011-07-30 23:55:02 [FINE] º0[Sleep] Setting Another2 in [Worlds/World1] to not ignore sleep. (Awakening World)


    I just officially released 2.2.0. This update adds more events you can control to determine inactive players if you wish.

    This update also includes the permissions renaming I mentioned a bit ago. Again, this shouldn't really affect anything unless you've really customised permissions for this plugin, but my assumption is most people will use the defaults.

    Everything else in the update is basically fixes for logic/formulas. I'm hoping I did better testing this time around, but as always, please let me know if you encounter any problems/errors. I'll be happy to try and address them as I can!

    Changelog for 2.2.0:
    •CHG: Configure code defaults to mimic native sleep behavior
    •CHG: Added more event choices to monitor for activity
    •CHG: Renamed permissions to simplify
    •CHG: sleep.sleep.ignore permission renamed to sleep.ignore permission
    •CHG: Players in bed no longer ignored if inactive or always ignored
    •FIX: Forced sleep with count or percent not working as expected
    •FIX: Setting inactivityLimit to -1 would not disable inactive player check
    •FIX: NPE when nether disabled/default nether not found
    •FIX: Unable to configure force.count in configuration file
    •FIX: /sleep commands would still return +1 needed when requirements were met
    •FIX: Removed event priorities from config file to simplify config file
    •FIX: General code organization

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  27. Offline

    EdGruberman Retired Staff

    There is a bug with this I finally pinpointed.

    When a player has used a bed in their current gaming session and is later set to then ignore sleep, they will still be returned to their bed at the end of the sleep cycle and it's unpreventable in the current state of CraftBukkit. I'm working on getting a pull request for CraftBukkit in place to fix this, but I'm out on vacation most of next week and it will probably have to wait until after that.
     
  28. Offline

    EdGruberman Retired Staff

  29. Offline

    Brocodo

    I'm getting this error, but i have no problems or something...
    INFO: bukkit build b1000
    Maybe ichat has to do with it?
    I have essentials also with the Myspawn plugin in it...
    Code:
    07:11:36 [SEVERE] Could not pass event PLAYER_BED_LEAVE to Sleep
    java.lang.NullPointerException
            at edgruberman.bukkit.sleep.State.awaken(Unknown Source)
            at edgruberman.bukkit.sleep.PlayerListener.onPlayerBedLeave(Unknown Sour
    ce)
            at org.bukkit.plugin.java.JavaPluginLoader$24.execute(JavaPluginLoader.j
    ava:405)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    a:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    ava:332)
            at net.minecraft.server.EntityHuman.a(EntityHuman.java:730)
            at net.minecraft.server.EntityPlayer.a(EntityPlayer.java:334)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:813)
            at net.minecraft.server.Packet19EntityAction.a(SourceFile:34)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    
     
  30. Offline

    EdGruberman Retired Staff

    @Brocodo - Looks like I still overlooked a problem with a disabled nether configuration. I've fixed it for the next version, but I need to test more still. If you feel adventurous, you can try the beta: https://github.com/EdGruberman/Sleep/raw/master/dist/Sleep.jar

    Biggest change is more optional notifications (LEAVE_BED, NIGHTMARE, and FORCE_SLEEP). You'll have to edit your config.yml if you've previously added a message for ENTER_BED (message.enterBed).

    Notifications
    By default this plugin will not broadcast if someone has performed any actions related to sleep, other than a Server Operator forcing sleep from in-game. However, if you want to enable other notifications, Server Operators can edit the configuration file to change the following settings as desired.
    Code:
    notifications:
        ENTER_BED:
            format: '%1$s is in bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
        LEAVE_BED:
            format: '%1$s has left bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
        NIGHTMARE:
            format: '%1$s is having a nightmare (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
        FORCE_SLEEP:
            format: '%1$s has forced sleep.'
            maxFrequency: -1
            timestamp: false
    The format setting is a string that accepts two format parameters. "%1$s" will be replaced with the display name of the player entering bed. "%2$d" will be replaced with the number of players still needing to enter bed in order for a sleep cycle to commence. FORCE_SLEEP only recognizes the first parameter. (To remove the notification, use an empty string. e.g. format: '')
    The maxFrequency setting is an integer that specifies how many seconds a given player can cause that notification to appear. This will help avoid people entering and exiting bed causing a lot of spam. (Use -1 to remove the restriction and allow notification to appear as often as event occurs.)
    The timestamp setting allows you to enable the message to be prefixed with a timestamp. (This is actually managed by the MessageManager plugin where you can control more formatting options with that if you want. Otherwise you can just leave it set to false and no timestamp will display.)
    These notifications will only be sent to players in the world in which the related event occurs.

    Notifications are by default are generated by all players. To enable/disable a player from being able to generate a notification, grant/revoke the appropriate permissions.
    Code:
        sleep.notify:
            description: Messages will be broadcasted for sleep related activities.
            default: true
            children:
                sleep.notify.ENTER_BED: true
                sleep.notify.LEAVE_BED: true
                sleep.notify.NIGHTMARE: true
                sleep.notify.FORCE_SLEEP: true
        sleep.notify.ENTER_BED:
            description: Will notify local world in which player has entered bed.
            default: false
        sleep.notify.LEAVE_BED:
            description: Will notify local world in which player has left bed manually.
            default: false
        sleep.notify.NIGHTMARE:
            description: Will notify local world in which player has left bed because of a mob spawn.
            default: false
        sleep.notify.FORCE_SLEEP:
            description: Will notify target world that has been forced to sleep.
            default: false
     
  31. Offline

    Brocodo

    I don't understand everything you said but i wil try the beta.
     

Share This Page