Inactive [MECH] SignLift v1.22 - Elevators with signs [1.2.5 R1.0] (Permissions)

Discussion in 'Inactive/Unsupported Plugins' started by freman, Jan 30, 2011.

  1. Offline


    SignLift - Elevators with signs:
    Version: v1.22

    Based on CraftBook's elevator system, SignLift works very much the same way - with two small improvements:
    1. Before transporting you it checks to make sure that you won't warp into a wall
    2. Prevents accidental block placement on transport
    Create signs on top of each other with [Lift up]/[Lift down]/[Lift] on the second line to use.

    Create signs on top of each other with {Lift up}/{Lift down}/{Lift} on the second line to create a private lift

    Create a sign on ground level with the second line set to [Lift Down]
    Dig down under that sign (place a block in the top of the hole)
    Create a sign with the second line set to [Lift Up]

    Right click the sign to use

    • Customizable strings
    • Safety checks to prevent into wall "lifting"
    • Brick placement prevention
    • First line can be the floor name
    • Hide signs on the back of blocks and use buttons!
    • Private lifts
    • Permissions
    Download SignLift

    Configuration (config.yml)
    Show Spoiler

        lift: LIFT
            - String users will use when placing lifts that go neither up nore down
            lift: LIFT DOWN
            - String users will use when placing lifts that go down
            default: Going Down
            - What is messaged to the user when going down
            format: Going to %s
            - Message format for going down to a named floor (%s gets replaced with name)
            open: '['
            - Open for normal lifts
            close: ']'
            - Close for normal lifts
            open: '{'
            - Open for private lifts
            close: '}'
            - Close for private lifts
            lift: LIFT UP
            - String users will use when placing lifts that go up
            default: Going Up
            - What is messaged to the user when going up
            format: Going to %s
            - Message format for going up to a named floor (%s gets replaced with name)
                denied: You don't have permission to destroy that sign lift
                - Message to display when someone attempts to destroy a lift they don't have permission to
                denied: You don't have permission to use this lift
                - Message to display when someone attempts to use a lift they don't have permission to
                denied: You don't have permission to create that sign lift
                - Message to display when someone attempts to create a lift they don't have permission to
            paranoid: true
            - true: Uses original algorithm, gaurenteed not transport you into a block
            - false: Uses new one, may end up being partially in a block (never wholely)

    Permissions (PermissionsBukkit)
    Show Spoiler

    - Gives access to all SignLift privileges
    - Gives access to all SignLift create privileges
    - Permits the creation of a normal sign lifts for anyone to use
    - Permits the creation of private sign lifts with the PRIVATE tag
    - Permits the creation of private sign lifts for other users
    - Permits the use of any normal sign lift
    - Permits the use of any private sign lift made for this user
    - Permits the use of other users private lifts
    If no permissions manager is installed then the default's are that every player can do everything with exception to signlift.use.private.others which only ops can use.

    Version 1.22
    • Changed the whitespace checks
    • Fixed the parameters error.
    Version 1.21
    • Added more whitespace checks to pervent crashing on empty signs
    Show Spoiler

    Version 1.2
    • Updated for 1.2.3 R0.2
    • Added a whitespace check to pervent crashing on empty signs
    Version 1.1
    • Fixed block placing bug introduced in 1.0
    Version 1.0
    • Private signs are now done by encapsulating the "LIFT UP", "LIFT DOWN" and "LIFT" in {} instead of []
    • Saves owner to disk
    • Delete your configuration file
    Version 0.9
    • Permissions
    • Basic block protection
    • Might be a good idea to delete your config, it won't break but you'll have old unused values
    Version 0.8
    • Introduction of private lifts
    • Updated deprecated code
    Version 0.7
    • Updated build for latest bukkit - Will not work on older builds.
    • Re-factored the entire codebase, buttons will now respond to left clicks as well as right clicks.
    Version 0.6

    • Updated build for latest bukkit - might work on older builds but not too old...
    • Changed the sign seek code on the button will only look for wall signs on the opposite side of the block directly behind the button.
    Version 0.5

    • Made it so you can hide signs on the back of blocks and use buttons
    Version 0.4

    • Add configuration file
    • Make strings used customizable
    • Make it possible to switch to a less paranoid block detection algorithm
    • Cleaned up accidental block place prevention code.
    Version 0.3

    • Added ladders to the list of safe things
    • Fixed rounding issues
    Version 0.2

    • Bug fixes...
    Version 0.1

    • Releasing my awesome plugin

    Alcohol makes coding in Java more fun, Caffeine makes it possible to do after a day of coding in other languages at work - both of these habits are expensive - Want to help me feed my addictions and make more, better plugins faster? Consider hitting the button below.
  2. Offline


    freman really? Your going to fuck everyone over because someone took the time to update it to 1.2 for you temp to keep your current users happy and then your going to try to fuck over your current users. Might as well take the plugin down now for good since I'm not going to support such dick moves.
  3. Offline


    freman please update this plugin tyzoid 's update doesnt even work -.-
    plz update it u'll be my hero my server has thousands of lifts and they dont work :(
  4. Offline


    He was more upset that I put his closed-source code on github.

    I fully understand his actions, and I should have read a little more carefully that the license he chose doesn't permit such actions that I took.

    I am still working on fixing this plugin. If freman doesn't want me to release it, that is his decision, and I will honor it.

    Oh, and freman , Ordinals are now zero-indexed...
  5. Offline


    It was a dick move to modify and release code he had no right to, especially without contacting me, and especially right after I said there was an update coming that proved I wasn't dead - if he'd made even the slightest attempt at contacting me then I would have probably given him permission as his intentions were good, just his execution not so much.

    As for supporting, what support, if there was some of that the plugins would probably get more attention rather than getting updated when I finally feel the RB is stable enough to update my server.

    I've finished updating and testing, it will be released today (Australia time) some time
  6. Offline


    freman u are a god ! i thank u soo much !! my server really needs it :D
  7. Offline


    No god, just a cranky aussie
  8. Offline


    is the update on yet?
  9. Offline


    You can always go grab the falsebook (craftbook) version which this plugin came from as well as does exactly the same thing without the {Lift Up/Down} private signs which falsebook has hooked into LWC for that, any sign that is LWC privated can only be used by the owner.

    Also freman im sure many people have have tried for weeks to contact you for ANY word on updating but you failed to even lift a finger to type anything out letting anyone know you were still around. Also about bukkit being stable enough to update plugins thats a laughable joke right? Every other active plugin out there has dev builds that work just fine against 1.2.3 bukkit dev builds and imo there is and never will be a fully "stable" build of bukkit as everyone has seen in the past even the "recommended" builds get red skulled (Broke/UNstable).

    Anyways it is your plugin and you have every right to do as you wish with it. Just dont think you will ever get any support with that kind of attitude. Good luck to you.
  10. Offline


    I've previously mentioned that this forums email is spotty at the best of times (Hell, I didn't get any emails saying there were 4 alerts and a pm waiting for me) but my website is in the source of the plugin, comes up when you boot the plugin, it has a perfectly good contact form , and my problem that I have is that even after I told people when I was releasing the update someone posted infringing code.

    I suppose FuRiouSOne the question is, how would you feel if it happened to you.

    I'm not here writing plugins for *you* I'm here releasing plugins I wrote for *us*, when we upgrade our server then a new plugin will become available. Sometimes I have free time and will release one before hand. I work full time, I also freelance off time so playing minecraft and updating free plugins isn't high on my priority list.

    You can be sure however that before I vanish off the face of the earth that all my plugins will be open source.

    Plugin has been updated. Feel free to use it, or not, but don't be a hypocrite and say one and do the other.

    You can download it from here

    edit: Tag those who want it EdwardBerry Pawn3d, Buckethead, TheChinski
  11. Offline


  12. Offline


    Freman, when I try to use this, when this plugin starts up, it says, "Wrong method arguments used for event type registered," and it's a [SEVERE] error.
  13. Offline


    Does it give you a trace?
  14. Offline



    22:19:14 [INFO] [SignLift] Enabling SignLift v1.2
    22:19:14 [SEVERE] Wrong method arguments used for event type registered
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 7, 2016
  15. Offline


    freman awww mann it doesnt work :( plz fix it...
  16. Offline


    There's no dump of garbage after that?

    I'll have a look tonight when I get home, as you can see by the tutorial video I had no issues when I was testing it - how is it not working? What is the exact bukkit version you're using (I built it against the latest beta)?
  17. Offline


    im using recommended build
  18. Offline


    Isn't that 1.1pR6 - for minecraft 1.1?
    In which case that's probably why this isn't working for you...

    Ok, I've just uploaded 1.21 - this should fix the "java.lang.StringIndexOutOfBoundsException: String index out of range: -1"

    I suspect the other problems I'm seeing here are from people using 1.1 or older 1.2.3 builds, please try a build newer than 2060

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 7, 2016
  19. Offline


    hmm ooh wait im using 1.2.3 R0.1, i need 2 update to 1.2.3 R0.2 thats (2060) right?
  20. Offline


    That should probably resolve your issues
  21. Offline


    im using 2060 bukkit and no no garbage i can post my full starup log if u want
  22. Offline


    All I can suggest is try Version 1.21 and see if the problem has gone away otherwise post a list of plugins and a full startup log and I'll see what I can do.
  23. Thank you for updating your plugin to 1.2
  24. Offline


    14:30:55 [INFO] Starting minecraft server version 1.2.3
    14:30:55 [INFO] Loading properties
    14:30:55 [INFO] Starting Minecraft server on
    14:30:55 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    14:30:55 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    14:30:55 [WARNING] To change this, set "online-mode" to "true" in the file.
    14:30:55 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.3-R0.2-b2060jnks (MC: 1.2.3) (Implementing API version 1.2.3-R0.2)
    14:30:56 [INFO] [PermissionsEx] sql backend registered!
    14:30:56 [INFO] [PermissionsEx] file backend registered!
    14:30:56 [INFO] [PermissionsEx] PermissionEx plugin initialized.
    14:30:56 [INFO] [PermissionsEx] p2compat backend registered!
    14:30:56 [INFO] [PermissionsCompat] Compatibility Layer Initalized!
    14:30:56 [INFO] [obuShutTheHellUp] Loading obuShutTheHellUp v0.2
    14:30:56 [INFO] [CityGuard] Loading CityGuard v1.11
    14:30:56 [INFO] [Vault] Loading Vault v1.2.12-b136
    14:30:56 [INFO] [SignLift] Loading SignLift v1.2
    14:30:56 [INFO] [PermissionsEx] Loading PermissionsEx v1.19
    14:30:56 [INFO] [PermissionsEx] Initializing file backend
    14:30:56 [INFO] [Rakamak] Loading Rakamak v4.0.0
    14:30:56 [INFO] [RemoteToolkitPlugin] Loading RemoteToolkitPlugin v0.5
    14:30:56 [INFO] [LazyRoad] Loading LazyRoad v0.7.1
    14:30:56 [INFO] [AutoMessage] Loading AutoMessage v1.5
    14:30:56 [INFO] [MineBackup] Loading MineBackup v0.5.8
    14:30:56 [INFO] [SimpleJail] Loading SimpleJail v1.7.7
    14:30:56 [INFO] [iConomy] Loading iConomy v6.0.9b
    14:30:56 [INFO] [Permissions] Loading Permissions v2.7.7
    14:30:56 [INFO] [HeroicRebuke] Loading HeroicRebuke v1.2.6.86
    14:30:56 [INFO] [AcceptRules] Loading AcceptRules v1.7
    14:30:56 [INFO] [Lockette] Loading Lockette v1.5
    14:30:56 [INFO] [Modifyworld] Loading Modifyworld v1.2
    14:30:56 [INFO] [GriefPrevention] Loading GriefPrevention v2.0
    14:30:56 [INFO] [NoCheat] Loading NoCheat v3.4.3
    14:30:56 [INFO] [Zombes4Bukkit] Loading Zombes4Bukkit v0.2.1
    14:30:56 [INFO] [Essentials] Loading Essentials vDev2.9.45
    14:30:56 [INFO] [ChatManager] Loading ChatManager v1.19
    14:30:56 [INFO] [EssentialsProtect] Loading EssentialsProtect vDev2.9.45
    14:30:56 [INFO] MLog clients using java 1.4+ standard logging.
    14:30:56 [INFO] [EssentialsSpawn] Loading EssentialsSpawn vDev2.9.45
    14:30:56 [INFO] [SetRankPEX] Loading SetRankPEX v1.3.4
    14:30:56 [INFO] [Superpickaxe] Loading Superpickaxe v0.4f
    14:30:56 [INFO] [ChestShop] Loading ChestShop v3.38
    14:30:56 [INFO] [EssentialsChat] Loading EssentialsChat vDev2.9.45
    14:30:56 [INFO] [Vault] Enabling Vault v1.2.12-b136
    14:30:56 [INFO] [Vault][Economy] Essentials Economy found: Waiting
    14:30:56 [INFO] [Vault][Economy] iConomy 6 found: Waiting
    14:30:56 [INFO] [Vault][Permission] PermissionsEx found: Waiting
    14:30:56 [INFO] [Vault][Permission] SuperPermissions loaded as backup permission system.
    14:30:56 [INFO] [Vault][Chat] PermissionsEx found: Waiting
    14:30:56 [INFO] [Vault] Enabled Version 1.2.12-b136
    14:30:57 [INFO] Preparing level "Forza"
    14:30:57 [INFO] Default game type: 0
    14:30:57 [INFO] Preparing start region for level 0 (Seed: -7560764986418959355)
    14:30:58 [INFO] Preparing spawn area: 77%
    14:30:58 [INFO] Preparing start region for level 1 (Seed: -7560764986418959355)
    14:30:59 [INFO] Preparing spawn area: 89%
    14:30:59 [INFO] Preparing start region for level 2 (Seed: -7560764986418959355)
    14:30:59 [INFO] [obuShutTheHellUp] Enabling obuShutTheHellUp v0.2
    14:30:59 [INFO] [obuShutTheHellUp version 0.2] Settings file successfully loaded
    14:30:59 [INFO] [obuShutTheHellUp version 0.2] Enabled!
    14:30:59 [INFO] [CityGuard] Enabling CityGuard v1.11
    14:30:59 [INFO] [CityGuard] Succesfully loaded 0/0 guards.
    14:30:59 [INFO] [CityGuard] version 1.11 by Schwarzer Zylinder is enabled.
    14:30:59 [INFO] [SignLift] Enabling SignLift v1.2
    14:30:59 [SEVERE] Wrong method arguments used for event type registered
    14:30:59 [INFO] [SignLift] Version 1.2 - Copyright 2012 - Shannon Wynter ( is enabled
    14:30:59 [INFO] [SignLift] Note: This is not an open source program, decompilation and modification is strictly prohibited
    14:30:59 [INFO] [PermissionsEx] Enabling PermissionsEx v1.19
    14:30:59 [INFO] [PermissionsEx] Superperms support enabled.
    14:30:59 [INFO] [PermissionsEx] v1.19 enabled
    14:30:59 [INFO] [Vault][Permission] PermissionsEx hooked.
    14:30:59 [INFO] [Vault][Permission] PermissionsEx_Chat hooked.
    14:30:59 [INFO] [Rakamak] Enabling Rakamak v4.0.0
    14:30:59 [INFO] [Rakamak] Rakamak version 4.0.0 is enabled. Plugin provided by [alecgorge, Erwyn & Dorpaxio]
    14:30:59 [INFO] [RemoteToolkitPlugin] Enabling RemoteToolkitPlugin v0.5
    14:30:59 [INFO] Memory max: 1265041408 bytes
    14:30:59 [INFO] Memory total: 202768384 bytes
    14:30:59 [INFO] Remote Toolkit Plugin V0.5 enabled!
    14:30:59 [INFO] [LazyRoad] Enabling LazyRoad v0.7.1
    14:30:59 [INFO] [LazyRoad] : Version 0.7.1 is enabled!
    14:30:59 [INFO] [AutoMessage] Enabling AutoMessage v1.5
    14:30:59 [INFO] [AutoMessage] version [1.5] loaded
    14:30:59 [INFO] [MineBackup] Enabling MineBackup v0.5.8
    14:30:59 [INFO] [MineBackup] v0.5.8 enabled
    14:30:59 [INFO] [SimpleJail] Enabling SimpleJail v1.7.7
    14:30:59 [INFO] [SimpleJail] SimpleJail v1.7.7 enabled.
    14:30:59 [INFO] [iConomy] Enabling iConomy v6.0.9b
    14:30:59 [INFO] [iConomy - Celty] Enabled (35 ms)
    14:30:59 [INFO] [Vault][Economy] iConomy 6 hooked.
    14:30:59 [INFO] [Permissions] Enabling Permissions v2.7.7
    14:30:59 [INFO] [PermissionsCompat] Compatibility layer enabled.
    14:30:59 [INFO] [HeroicRebuke] Enabling HeroicRebuke v1.2.6.86
    14:31:00 [INFO] [iConomy - Celty] Purged accounts with default balance.
    14:31:00 [INFO] [HeroicRebuke] Permission system possibly not present.
    14:31:00 [INFO] [HeroicRebuke] Loaded 1 active warning.
    14:31:00 [INFO] [HeroicRebuke] enabled.
    14:31:00 [INFO] [AcceptRules] Enabling AcceptRules v1.7
    14:31:00 [INFO] [AcceptRules] AcceptRules plugin succesfully enabled!
    14:31:00 [INFO] [Lockette] Enabling Lockette v1.5
    14:31:00 [INFO] [Lockette] Version 1.5 is being enabled!  Yay!  (Core version 1.3.1)
    14:31:00 [INFO] [Lockette] Detected craftbukkit build [2060] ok.
    14:31:00 [INFO] [Lockette] Enabled link to plugin PermissionsEx for Groups/Permissions, version 1.19
    14:31:00 [INFO] [Lockette] Ignoring fake Permissions plugin version 2.7.7
    14:31:00 [INFO] [Lockette] Using linked plugin for admin permissions.
    14:31:00 [INFO] [Lockette] Ready to protect your containers.
    14:31:00 [INFO] [Modifyworld] Enabling Modifyworld v1.2
    14:31:00 [INFO] [Modifyworld] Modifyworld enabled!
    14:31:00 [INFO] [GriefPrevention] Enabling GriefPrevention v2.0
    14:31:00 [INFO] GriefPrevention: Grief Prevention enabled.
    14:31:00 [INFO] GriefPrevention: 630 total claims loaded.
    14:31:00 [INFO] GriefPrevention: 118 players have staked claims.
    14:31:00 [INFO] GriefPrevention: PopulationDensity: Unexpected exception saving data for player "jaap?": The filename, directory name, or volume label syntax is incorrect
    14:31:00 [INFO] [NoCheat] Enabling NoCheat v3.4.3
    14:31:00 [INFO] [NoCheat] version [3.4.3] is enabled.
    14:31:00 [INFO] [Zombes4Bukkit] Enabling Zombes4Bukkit v0.2.1
    14:31:00 [INFO] [Zombes4Bukkit] NoClipEnabled
    14:31:00 [INFO] [Essentials] Enabling Essentials vDev2.9.45
    14:31:01 [INFO] [Vault][Economy] Essentials Economy hooked.
    14:31:01 [INFO] Essentials: Using PermissionsEx based permissions.
    14:31:01 [INFO] [Essentials] Payment method found (Vault - Economy: iConomy 6 version: 1.2.12-b136)
    14:31:01 [INFO] [ChatManager] Enabling ChatManager v1.19
    14:31:01 [INFO] [ChatManager] ChatManager enabled!
    14:31:01 [INFO] [EssentialsProtect] Enabling EssentialsProtect vDev2.9.45
    14:31:01 [INFO] Initializing c3p0- [built 21-May-2007 15:04:56; debug? true; trace: 10]
    14:31:01 [INFO] [EssentialsSpawn] Enabling EssentialsSpawn vDev2.9.45
    14:31:01 [INFO] [SetRankPEX] Enabling SetRankPEX v1.3.4
    14:31:01 [INFO] [SRPEX] Found PermissionsEx v1.19 and is good to go
    14:31:01 [INFO] [SRPEX] SetRankPEX v1.3.4 is now enabled.
    14:31:01 [INFO] [Superpickaxe] Enabling Superpickaxe v0.4f
    14:31:01 [SEVERE] [Superpickaxe] [Superpickaxe] LogBlock not found
    14:31:01 [INFO] [Superpickaxe] Superpickaxe v0.4f by DiddiZ enabled
    14:31:01 [INFO] [ChestShop] Enabling ChestShop v3.38
    14:31:01 [INFO] [ChestShop] Lockette version 1.5 loaded.
    14:31:01 [INFO] [ChestShop] Vault loaded using economy plugin iConomy 6
    14:31:01 [SEVERE] [ChestShop] WARNING! Your spawn-radius in bukkit.yml isn't set to 0! You won't be able to sell to shops built near spawn!
    14:31:01 [INFO] [EssentialsChat] Enabling EssentialsChat vDev2.9.45
    14:31:01 [INFO] Server permissions file permissions.yml is empty, ignoring it
    14:31:01 [INFO] Done (5.017s)! For help, type "help" or "?"
    14:31:01 [INFO] Starting GS4 status listener
    14:31:01 [INFO] Query running on
    Plugins: obuShutTheHellUp, CityGuard, Vault, SignLift, PermissionsEx, Rakamak, RemoteToolkitPlugin, LazyRoad, AutoMessage, MineBackup, SimpleJail, iConomy, Permissions, HeroicRebuke, AcceptRules, Lockette, Modifyworld, GriefPrevention, NoCheat, Zombes4Bukkit, Essentials, ChatManager, EssentialsProtect, EssentialsSpawn, SetRankPEX, Superpickaxe, ChestShop, EssentialsChat
  25. Offline


    freman its works like a charm my users salut u !
  26. Offline


    Sorry but I don't know what the problem might be.

    Perhaps a conflict between one of the permissions plugins and mine?
    Only diagnostic I can suggest is remove all the plugins, start with signlift and just keep adding until you get the issue
  27. Offline


    I tried it by itself and same thing. still works though
  28. Offline


    Hey just wanted to say that I loved your plugin, haven't had any problems yet. :)

    Thought you might want to know, I'm currently running the most up to date dev build (at time of posting, I've downloaded several revisions in the past 12 hours lol) of 1.2.4, and everything is working fine (from what I can see). In the console on just after enabling it reports "[SEVERE] Wrong method arguments used for event type registered". But like I said, it's working fine for me and my members. Thanks again for all your work :)
  29. Offline


    Yeh not sure what causes that, it'll be fixed next release I'm sure :)
  30. Offline


    bukkit 2110 in midst of use w/ ur newest build

    23:36:04 [SEVERE] Could not pass event BlockCanBuildEvent to SignLift
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.World.mayPlace(
            at net.minecraft.server.ItemBlock.interactWith(
            at net.minecraft.server.ItemStack.placeItem(
            at net.minecraft.server.ItemInWorldManager.interact(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet15Place.handle(SourceFile:39)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(
            at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
            at java.lang.String.substring(Unknown Source)
            at sun.reflect.GeneratedMethodAccessor61.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            ... 14 more
  31. Offline


    I think its a bit too unrealistic...

Share This Page