Inactive [MECH] SignClock v1.8.2 - View the in game time on Signs [1060]

Discussion in 'Inactive/Unsupported Plugins' started by V10lator, Jul 7, 2011.

  1. Offline

    V10lator

    SignClock - View the in game time on Signs.

    Moved to http://dev.bukkit.org/server-mods/signclock/
    Licence
    GPLv3 or later (Sources includes in the jar)

    Changelog:
    Version 1.8.2
    • Updated for lib24time 0.7.
    Version 1.8.1
    Version 1.8
    • Updated for lib24time 0.6.
    • Removed a useless log message (Bug report from: Navigateur).
    • Hopefully fixed a few bugs in the marquee code.
    Version 1.7.2
    • Fixed a bug which prevents users not having the permissions to destroy SignClocks to destoy any blocks.
    Version 1.7.1
    • Fixed the lib24time detection to the right version.
    Version 1.7
    • Added better daytime scrolling (still not pefect!)
    • Added PermissionsBukkit support (not tested).
    Version 1.6
    • Removed MagicSign.
    • Added /SignClock as MagicSign replacement.
    • Removed daytime clock.
    • Added daytime theme tag.
    • Cleaned up code.
    • Changed save file fomat but save files since 1.3 should get converted to the new format.
    Version 1.5
    • Added daytime clock (you have to update lib24time, too! ) (request from Marcos Cosmos).
    • Reworked save file handling (you know it from some of my other plugins: reduced diskwites).
    • Added MagicSign.
    • Cleaned up code.
    • Rewoked code parts here and there.
    • Hopefully fixed the bug reported by chickenmove.
    • Made everything you write on the sign (exception: theme names) case insensitive.
    • Changed save file fomat but save files since 1.3 should get converted to the new format magically. ;)
    • Changed block power detection.
    Version 1.4.2
    • Updated plugin for lib24time 0.2
    • Changed craftbukkit includes/functions with bukkit ones (craftbukkit is no longer a building dependency).
    Version 1.4.1
    • Fixed a bug (self-triggered clocks won't reset after server reload).
    Version 1.4
    • Fixed a memory leak.
    • Changed display update timings (for self triggered clocks).
    • Added left-click support.
    • Cleaned up code.
    Version 1.3
    • Exported the themes to customizable theme files.
    • Added an option to use the Clock without redstone.
    Version 1.2
    • Splitted out lib24time
    Version 1.1
    • Fixed a Bug (the display won't update always)
    Version 1.0
    • First public release
    Older downloads:
    Download v1.8.1
    Download v1.8
    Download v1.7.2
    Download v1.7.1
    Download v1.7
    Download v1.6
    Download v1.5
    Download v1.4.2
    Download v1.4.1
    Download v1.4
    Download v1.3
    Download v1.2
    Download v1.1
    Download v1.0
     
    jon674, nandinho and Marcos Cosmos like this.
  2. Offline

    V10lator

    There's a link to the newest dev version on the spout thread. ;)

    For now I have absolutely no idea why this happens but spout seems to change a lot of default bukkit functions. So I tied to ask the devs of spout: http://forums.bukkit.org/threads/de...-possibilities-1000.29259/page-78#post-571826

    As I sayed there: I think spout changes something in bukkits threading code which triggers this error. If this is the case it shouldn't be and it's definitely a bug in spout.
    If I don't get a reply the next few days I will write to a spout dev directly.
     
  3. Offline

    Kepas Beleglorn

    Update:
    I use
    BUKKIT 1000
    lib24time 0.6
    SignClock 1.8.1
    Spout 1.0.1 /Edit: No new results with the current dev-version. (1.0.2.101)

    Redstone triggered clock:
    • only one line in SignClock.sav
    • clock doesn't work after restart
    • no error on start
    • Line in config after destruction of the sign still present (<world>,-181,73,-135,1,0)
    Self triggered clock:
    • no new config entry on creation
    • after /stop the config contains the following:
      Code:
      V1.1,0
        the world of Kepas Beleglorn,-179,73,-129,1,1
        the world of Kepas Beleglorn,-178,73,-130,1,1
        the world of Kepas Beleglorn,-181,73,-135,1,0
        
    • on server start again this error occurs
      Code:
      22:24:52 [WARNUNG] Task of 'SignClock' generated an exception
         java.lang.NullPointerException
                 at com.V10lator.SignClock.triggerTicker.run(triggerTicker.java:73)
                 at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
                 at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
                 at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
                 at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    • clock doesn't work after restart
     
  4. Offline

    V10lator

    The on-disk save won't get updated every time you create/destroy a clock. It should update every 15 minutes or when the server stops, if it updates at any other time it's a bug!
    To force a save a server /reload should be enough. ;)
     
  5. Offline

    Marcos Cosmos

    Uhm everyone, I'm pretty sure using spout 1.0.2 (at least, the RB edition) without using bukkit 1060 causes loading problems... or maybe 1060 came out after all these posts?
     
  6. Offline

    Madness

    Would it be possible to have a server time/milliseconds enabled version? I need to time how long it takes for a cart to travel between 2 points, and linking this to a pressure plate would work perfectly for my needs, if it had that kind of data.
     
  7. Offline

    V10lator

    Sorry for late answer... But no. This is for in-game time.
     
  8. Offline

    mrgreaper

    cant get it to work

    second line [SignClock]

    fourth line ST
    the text doesnt change

    CB1060
    signclock what ever the verson on the god awful bukkit dev is
     
  9. Offline

    SpiFioY

    Can it work whitout a redstone?
     
  10. Offline

    V10lator

    Are there any errors on the log/console when the plugin enables and/or you create the sign?
    Do you get a message that a SignClock was created?
    Does it work with redstone?
    Yes.
     
  11. Offline

    SpiFioY

    how? :oops:
     
  12. Offline

    V10lator

    Did you read http://dev.bukkit.org/server-mods/signclock/?
     
  13. Offline

    mrgreaper

    might be an idea to add that to the main post as well, many of us server admins dont like having to check a second site for details.

    i dont get any errors in the log, simply put nothing happens, i did howerver go and read the bukkit dev site and see that it requires a lib file (an important fact missing from the original post!) i added it before work and will get back to you once i have a chance to test
     
  14. Offline

    V10lator

    Well, you have to go to the dev side to get the newest download so... ;)
     
  15. Offline

    mrgreaper

    yeah but i didnt see the requirement there before, i litterly went over to dev to just download it (an annoying step in a fair few plugins now that could of just been linked in the first post of the plugins)
    i now need to get in the habbit of knowing i got to read the proper plugin thread and then the bukkit dev site :(
     
  16. Offline

    Svettnes

    This appeared in console (no server restart)

    18:19:47 [WARNING] Task of 'SignClock' generated an exception
    java.lang.NullPointerException
    at com.V10lator.SignClock.triggerTicker.run(triggerTicker.java:74)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbea
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:439)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)

    The clock was frozen, and when i tried setting up a new clock it didn't work at all
     
  17. Offline

    V10lator

    @Svettnes: Are there any other errors in the logs (when the plugin enables, for example)?
    Do you have files in the plugins/V10lator/themes folder?
    Do you use selfmade themes?
     
  18. Offline

    Toni1602

    its a error with the new bukkit version.. i think the last stable verison with signclock is bukkit 1298... all newer.. not working. :(
     
  19. Offline

    V10lator

  20. Offline

    Silvo

    Would it be possible to add a feature to update the clock just every 5 units instead of 1?
    Not that your plugin would drop server performance or anything, just asking.
     
  21. Offline

    Ozelo

    please update
     
  22. Offline

    MinopolisMc

    Can you please update your plugin to minecraft 1.2.5? I'd find it really awesome :)
     
  23. Offline

    V10lator

    MinopolisMc likes this.
  24. Offline

    R34CH

    Its not works :/
     
  25. Offline

    CraftMastaaaa

    Having some problems with the plugin i'm afraid :(
    On the first line it says org.bukkit.plugin.UnknownDependencyException: lib24time
    and then just spams a few other bukkit errors to do with loading the plugin, help pleeease? :(
    <3
     
  26. Offline

    V10lator

    Try it another way... :confused:

    Can't read?
     
  27. Offline

    hansahalim15

    Can you please make an update to CB 1.2.5 R4.0
    I really want this plugin
     
  28. Offline

    V10lator

    There's nothing broken, so why should I update? :confused:
     

Share This Page