[MECH] RedstoneChips 0.97 - Integrated circuits plugin [1.5.1-R0.2]

Discussion in 'Archived: Plugin Releases' started by eisental, Jan 19, 2011.

  1. Offline


    RedstoneChips 0.97 / BasicCircuits 0.97 / SensorLibrary 0.34
    (Last update on April 30th, 2013, cb 1.5.1-R0.2)


    • Build chips with any number of input and output pins, from compact 2 block chips up to whatever you can imagine.
    • Choose from over 50 different chip types and several 3rd party chip libraries.
    • Most chip types can work with a wide or infinte range of i/o configurations. Sign arguments allow you to customize chip behavior.
    • Chips can communicate through redstone, or directly by touching each other. Some chip types can also communicate over wireless channels.
    • Chips can be built in almost any imaginable structure allowing very compact circuits.
    • Debug and maintain large projects using various tools and commands.

    [cake] Help me spend more time working on RedstoneChips. Please donate

    Circuit libraries made by other people:
    Changelog (open)

    RedstoneChips 0.97 (Apr 30th, 2013)
    • Fixed the saving bug on cb 1.5.1.
    • Added an option to disable update checking.
    BasicCircuits 0.96 (Apr 30th, 2013)
    • pixel: Added a maximum distance value preference to prevent lags and server crashes. The max can be changed using/rcprefs pixel.maxDistance x and defaults to 7.
    • sram: Fixed a problem with anonymous memory.
    SensorLibrary 0.34 (Dec 1st, 2012)
    • daytime: Fixed daytime offset bug.

    Full changelogs and source code @ github.com:
    RedstoneChips [gunpowder] BasicCircuits [gunpowder] SensorLibrary
    DoomLord, Shamebot, Vecht and 6 others like this.
  2. Offline


    [fire] RedstoneChips 0.95 is officially released! [fire]

    See main post for more info and changelogs.
    Thanks everyone for testing, contributing and reporting/solving problems. I hope there's only a reasonable amount of bugs ;)
  3. Offline


    Hi eisental, been a huge while, but i am glad i can be the first (hopefully) to react. Thank you for this amazing plugin, its the only reason i play minecraft! and for a change i did bought the game.
    i am playing tekkit now, toghether with redstone chips, hmmm, really crazy! i am building an automatic nuclear reactor, with cooling system, failing errors, and alot counters! 2200 chips so far! but i stopped playing for to long, and i am stuck where i stopped playing.... the display chip :p i have a 7 segment display, for numbers, but i need a big one to display what the number is, but my brain fails me.
    anyway, its a big and good suprise for me to see that youre still supporting youre plugin. it was the best plugin ever made last year, and i think it still is. maybe my reactor will explode again, thanks to some bugs, but it i am happy to take that risk! if my project is done, you will be the first to see it!

    Loading RedstoneChips v0.95.
    2012-04-10 20:18:56 [SEVERE] Error occurred while enabling RedstoneChips v0.95 (Is it up to date?): org.tal.redstonechips.circuit.CircuitLibrary.getName()Ljava/lang/String;
    java.lang.NoSuchMethodError: org.tal.redstonechips.circuit.CircuitLibrary.getName()Ljava/lang/String;
        at org.tal.redstonechips.circuit.CircuitLibrary.getIndexName(CircuitLibrary.java:40)
        at org.tal.redstonechips.RedstoneChips.loadLibraries(RedstoneChips.java:256)
        at org.tal.redstonechips.RedstoneChips.onEnable(RedstoneChips.java:52)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:230)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:1057)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:380)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:200)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:183)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:142)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:151)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    i use tekkit 2.1.1, but that runs on 1.1, i guess i need to go back to 0.94 untill tekkit gets updated. to bad, cause i read you made changes on the display chip 0.95, lucky for me i didnt start building the display yet, but i want to start soon. i do not understand java, so i don't know what the problem is for sure

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  4. Offline


    can u make a new and working tutorial for a normal digital clock?
    it can realy help pepole :)
  5. Offline


    i´ve made some Videotutorials about this really nice plugin :)
    The language is german, cause my english isnt the best and i
    can not find some tutorials in german.

    Maybe not german people can watch these videos too to look how some functions of this plugin

    Here is the youtube channel:


    Greatings Schooko aka PedoFredo

    hey Leute,
    da ich so gut wie garkeine Tutorials zu diesem Plugin in Deutsch finden
    konnte habe ich mir gedacht, ich erarbeite mir die Funktionen selbst
    und mache einfach mal ein paar Deutsche Videos zu diesem Plugin.

    Ich hoffe sie helfen euch ein wenig weiter und ihr kritisiert mich schön ;)

    Hier mal mein Yotube-Channel:


    MfG Schooko aka PedoFredo
  6. Offline


  7. Offline


    I get an error when using redstonechips v0.95:

    2012-04-23 21:59:33 [INFO] [RedstoneChips] Loading chips for world 'world'...
    2012-04-23 21:59:33 [SEVERE] Could not pass event WorldLoadEvent to RedstoneChips
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:303)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:459)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:354)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.NullPointerException
            at org.bukkit.craftbukkit.block.CraftSign.<init>(CraftSign.java:17)
            at org.bukkit.craftbukkit.block.CraftBlock.getState(CraftBlock.java:227)
            at org.tal.redstonechips.circuit.Circuit.updateCircuitSign(Circuit.java:557)
            at org.tal.redstonechips.CircuitManager.activateCircuit(CircuitManager.java:247)
            at org.tal.redstonechips.CircuitPersistence.loadCircuitsFromFile(CircuitPersistence.java:165)
            at org.tal.redstonechips.CircuitPersistence.loadCircuits(CircuitPersistence.java:118)
            at org.tal.redstonechips.RCBukkitEventHandler.onWorldLoad(RCBukkitEventHandler.java:211)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:301)
            ... 6 more
    im using also
    BasicCircuits 0.95
    SensorLibrary 0.33

    When the server runs a while i get this error:
    2012-04-23 21:59:37 [WARNING] Task of 'RedstoneChips' generated an exception
            at org.bukkit.craftbukkit.block.CraftSign.<init>(CraftSign.java:17)
            at org.bukkit.craftbukkit.block.CraftBlock.getState(CraftBlock.java:227)
            at org.tal.redstonechips.circuit.Circuit.updateCircuitSign(Circuit.java:557)
            at org.tal.redstonechips.CircuitManager.activateCircuit(CircuitManager.java:247)
            at org.tal.redstonechips.CircuitPersistence.loadCircuitsFromFile(CircuitPersistence.java:165)
            at org.tal.redstonechips.CircuitPersistence.loadCircuits(CircuitPersistence.java:118)
            at org.tal.redstonechips.RedstoneChips.postStartup(RedstoneChips.java:78)
            at org.tal.redstonechips.RedstoneChips.access$000(RedstoneChips.java:25)
            at org.tal.redstonechips.RedstoneChips$1.run(RedstoneChips.java:67)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:126)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:517)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:449)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
  8. Offline


    Hi, Sorry for the delayed response. This looks like a Craftbukkit bug which is not caught by RC.
    The only solution I can offer is to find the chip that causes this error and rebuild it or at least replace its sign.
  9. Offline


    That doesn't help, i already replaced it several times, rebuild it somewhere else...the error occours again when i restart the server.

    Before restart every chip runs fine.
  10. Offline


    Very nice exept one bad thing that ruins everything... every time my server crashes all circuts gets disabled and have to manually be reactivated one by one again, and thats a pain in the ass when there are 226 circuts on the server =(
    Restoring a backup on the plugins directory from before the server crashed aint working either, all circuts are still dead
  11. Offline


    Is anything like "rescan", "reset", "reactivate" documented on http://eisental.github.com/RedstoneChips/howto.html helping in that process (try on your own risk!)?
  12. may be you should investigate why your server is crashing, you think not ?
    bukkit server are not supposed to crash, specially since many plugins saves their config on disabling during shutdown process.
  13. Offline


    Whenever chips are disabled a backup file is supposed to be created in /plugins/RedstoneChips/<world-name>.circuits.BACKUPxxx
    Do you see any such files? if so, just rename them and remove the .BACKUPxxx from the filename.
  14. Offline


    Nope, i don't even have a folder with the world name, just a "memory" folder, but no .BACKUP files to be found.
    But i got a new server now (hopefully more stable then the last one) so hopefully there will be no more bluescreens.
  15. Offline


    It appears that the offset argument for the daytime chip is not working properly. With an offset of 6 for gametime, hours goes from 6-23 correctly, then stays at 23 for the remaining 6 hours instead of wrapping to 1 - 5 like it should..
  16. Offline


    OK im new to this thing and im tring to make a clock chip XD so i can type clock 1s 0.9-0 and it will do what its supposed to do but i cant get it to do clock 1s 1.0 or clock 1m 1 and so on just 1.0 and 1 just don't work PLZ HELP
  17. Offline


    Any ETA on an update for 1.3?
  18. Offline


    Main change for 1.3 is frequent chunks save resulting in onWorldSave event which leads to just as frequent circuit resaving and console spamming.

    If you want to make for example 1m pulse and 20sec pause you do 'clock 80s 0.75' and that makes 80s*0.75=60sec pulse, plus 80s*(1-0.75)=80*0.25=20 sec pause in between.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    QQCucumber , AterIgnis , are there any other problems besides constant saving and lack of support for "roof" input levers?

    I don't have an ETA but hopefully it'll come...

    Thanks! :eek:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  20. Offline


  21. Offline


    is there any way of making a simple clock like with the outdated clockdisplay plugin?
    something to replace the dclock circuit?
  22. Offline


    It looks like eisental might be out for a while, and I don't want this wonderful plugin to die, so if there's no problem with it, I would be willing to help maintain it while he's out. I'm going to try to get ahold of him, but if I can't I'll just try to proceed with best intentions in mind.
  23. Offline


    I'm kind of bummed out I can't use this plugin in its present state. When updating to Craftbukkit 1.3.2 R1.0 my server keeps crashing and won't start up until I disable this plugin or remove it. I tried keeping my server at R0.2, but I had to update eventually.
  24. Offline


    Are you getting an exception in the server log? Problems like this are difficult to fix without an exception log.
  25. Offline


    [redflower] I released RC 0.96. See the main post for more details.[redflower]
    Thanks to jpfx1342 for his help.
  26. Offline


    Hi. I realy need some help with this one . Im designing a cube type game within minecraft and I downloaded this. I'm not a programmer but I do know this could help some how . Can it be used to make 2 and 4 out put randomizers. Mabey even keep a variable that could say keep a door closed unles somone reaches a certin point.
    Heres my you tube video and you can see how massive this thing is and I want it to be stable and not use minecard randomizers and such. the mechanicle stuff does work but I would like to compact it more . less cubes better server response and loading for players

    Specs of cube

    4 cross towers with 16 rooms each
    4 cross sections witch will have 4 doors that will open with a randomizer
    then you have the 8
    8 outside doors that lead around up down lef and right directions to another door in the cube
    each of the 16 rooms have Dispencers for Projecting what ever is in them (Arrows fire) stuff like that.
    The outer section or the halls that lead different direction are all random to (the pat witch they lead)
    Each have opsticles and some traps.

    This video wills how you how much this thing has.
    If anyone is interested in helping me figure this out let me know. I use Himachi atm for the connection My server wont brodcast otherwize
  27. Offline


    got some weired things when using a counter connected to sram (readonly mode).
    the sram seems to get wrong addresses from the counter. (5bit)

    f.e. while debuging the sram (5bit):

    "reading from address 1"
    "reading from address 0"
    "reading from address 2"
    "reading from address 3"
    "reading from address 2"
    "reading from address 0"
    "reading from address 4"
    "reading from address 5"

    the sram reads sometimes twice at only one clock tick to counter.

    the counter ist connected directly to sram with correct pin order. cant see what i did it wrong :) maybe it needs some clock synchronisation to sram, although sram doesn't have any clock input.
  28. Offline


    This behavior is normal. When the counter switches between 1 and 2, for example, it first turns off the 1st output, triggering the 0 debug message, and then turns the 2nd output on, triggering the 2 debug message. The same happens with the transition from 2 to 3 and from 3 to 4, etc.

    You need to synchronize the output of the sram to the chip that increments your counter. Build a pulse chip with a 0 pulse width argument and 2 outputs and connect its input to whatever triggers your counter. Connect the 1st output of the pulse chip to the counter clock input and its 2nd output to the clock input of the chip that's connected to the sram's outputs.

    The pulse chip pulses each of its outputs only after the output before that is done processing/propagating all the way through the counter and sram chips. That way, the last chip triggers only after the sram output is already stable.
    This technique is quite common. I hope what I wrote is clear enough...
  29. Offline


    thank you! works like a charm. the sram have still unnecessary states from the counter (like you said because of reseting bits to null when counting) but it doesn't matter when the synth chip connected to sram reads the data on the next pulse "round trip".
    ye, i'm using a synth chip to play notes from the memory. the sram is filled with note data from a file.
    now i got a little challange:
    synth chip is playing sequentially notes from the sram but there is no "synth value" for resting.
    i tried to use invalid value of 25 to hope the synth will ignore it and simulate pause but then the synth stops working completly. what can i do?
  30. Offline


    [redflower] Version 0.97 is released. See main post for details. [redflower]
    Thanks to everybody who told me about new problems and old bugs.

    [cake] If RedstoneChips is dear to you and you would like to increase my motivation for fixing bugs and releasing new versions, please donate. Thanks!

    EDIT: I forgot to update the link on the main post. It should point to the right direction now. I also added a preference for disabling the update checker as requested by the dev.bukkit moderators.

Share This Page