[MECH] RedstoneChips 0.97 - Integrated circuits plugin [1.5.1-R0.2]

Discussion in 'Archived: Plugin Releases' started by eisental, Jan 19, 2011.

  1. Offline


    RedstoneChips 0.97 / BasicCircuits 0.97 / SensorLibrary 0.34
    (Last update on April 30th, 2013, cb 1.5.1-R0.2)


    • Build chips with any number of input and output pins, from compact 2 block chips up to whatever you can imagine.
    • Choose from over 50 different chip types and several 3rd party chip libraries.
    • Most chip types can work with a wide or infinte range of i/o configurations. Sign arguments allow you to customize chip behavior.
    • Chips can communicate through redstone, or directly by touching each other. Some chip types can also communicate over wireless channels.
    • Chips can be built in almost any imaginable structure allowing very compact circuits.
    • Debug and maintain large projects using various tools and commands.

    [cake] Help me spend more time working on RedstoneChips. Please donate

    Circuit libraries made by other people:
    Changelog (open)

    RedstoneChips 0.97 (Apr 30th, 2013)
    • Fixed the saving bug on cb 1.5.1.
    • Added an option to disable update checking.
    BasicCircuits 0.96 (Apr 30th, 2013)
    • pixel: Added a maximum distance value preference to prevent lags and server crashes. The max can be changed using/rcprefs pixel.maxDistance x and defaults to 7.
    • sram: Fixed a problem with anonymous memory.
    SensorLibrary 0.34 (Dec 1st, 2012)
    • daytime: Fixed daytime offset bug.

    Full changelogs and source code @ github.com:
    RedstoneChips [gunpowder] BasicCircuits [gunpowder] SensorLibrary
    DoomLord, Shamebot, Vecht and 6 others like this.
  2. Offline


    seems to be fixed, thanks

    Edit:Well I thought everything was fixed anyways, I went onto my server directly after to work on some of my circuits, all of them seemed to be active but were unresponsive to anything. I can still use all of the /rc commands like rctype and get responses and such but it's like nothing is working correctly
  3. Offline


    If you updated from an old version (before 0.92 i think) than you have to reset all the circuits ("/rcreset all" should work)
  4. Offline


    thanks for the quick response, everything seems to be running smooth now.
  5. Offline


    I really love this Plugin! I'm currently building up a server and it's one of my basics using the wireless thing.
    But now i have one thing recognized, when i build one transmitter with multiple receiver, it might cause significant delays, at least it's a first impression, when checked more in detail, i found that the receiver is getting the signal, but somewhy the signal isn't continueing the path in normal time (look at images about the Redstone Torches) - about 10-25 seconds later, the final output is changing how it should. Only recognized this issue with multiple receiver and different distances.

    *Edit: forgot the images *lol*
    1. [​IMG]
    2. [​IMG]
  6. Offline


    Did you try using levers instead of torches? Some change in bukkit 1.1 caused redstone torches to start act funny which might be the reason for this.
  7. Offline


    Levers as Torches? Never got the idea to try this (in Pics i always thought of them as example of output signs, but in general having a hard time to fully understand the description of some circuits :/
    Will try this tomorrow (in fact the affect is reduced to the multiple receiver design (as i recognized it) other wireless seems OK).

    Edit: I tested some configuration, but all the same result, all the (about) 16 Auto:1 receivers seem to randomly timeshifting the signal through (the order of correcting signals is different every time and i have the impression, that times the circuit needs to correct itself, are also randomly from few seconds up to >1min).

    Here i tried it with a repeater, the problem also is vice versa (repeater has energie, nothing else):[​IMG]

    Then a try without repeater, same result (again, same vice versa):

    Another example, rsdust is coming directly from the lever on the receiver.

    I didn't wait serveral minutes to check if the 3 issues above are selfcorrecting over time.

    ... if it helps, when i pull the outputtrigger maually, it works perfecly.

    Edit: I found some mistakes i made by copy&paste and forgetting to redo the chips - maybe its all my fault, i'll keep reporting.

    Edit: I can now reproduce the described behavior. I put some receivers in one row (1 space between). With a transmitter near them, there are no problems. When the transmitter is about 30 blocks away and with fast triggering, i could get the effect. When one of the receivers (or better the block coming after the output) is updating, the others follow, but if i remove one of them and leave a gap (3 spaces) they build "2 groups" with different update times. Also it seems, when putting rsdust on 1 spot around the block with the problem, it updates (a short video is here: ).
    Hopefully you have any clue what's going on.

    Edit: Now i finally also tested with Bukkit-1.0.1-R1-b1597 and only Essentials (+chat) and Multiverse-Core. Same Problem :'(
  8. Offline


    _Alf : Sorry, I don't get notifications when you edit the post, so I managed to miss your reply until now. I'll check this out tomorrow.
  9. Offline


    No problem i edited until today, so you get the fulls story by now ;)
  10. Offline


    When you add the offset to the daytime chip for hours in the next release, please make it work for both gametime and earthtime, as well as 12 and 24 hour modes. This will replace a great deal of the extra circuitry that I currently need to support this. Thanks for a fantastic plugin! It makes working with redstone a pleasure instead of a chore. :)
  11. hi,

    While trying to create a mobsensor (with "hostiles" and 10 as radius)
    i get this error on the console :

    00:27:22 [GRAVE] Could not pass event org.bukkit.event.player.PlayerInteractEvent to RedstoneChips
    java.lang.NoSuchFieldError: interfaceBlocks
            at net.rarobertson.mobsensor.hostiles.init(hostiles.java:46)
            at org.tal.redstonechips.circuit.Circuit.initCircuit(Circuit.java:133)
            at org.tal.redstonechips.CircuitManager.activateCircuit(CircuitManager.java:200)
            at org.tal.redstonechips.CircuitManager.checkForCircuit(CircuitManager.java:177)
            at org.tal.redstonechips.RCPlayerListener.onPlayerInteract(RCPlayerListener.java:40)
            at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:340)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:61)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:460)
            at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:187)
            at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:283)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:609)
            at net.minecraft.server.Packet15Place.handle(SourceFile:39)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:100)
            at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:537)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:435)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    am i doing anything wrong ? (1.1R4 and 0.94 RS and i guess last mobsensor circuit ...)
  12. Offline


    Looks like MobSensor was not updated for RC .94. If the dev is still maintaining it I would contact them about updating it.
  13. yep, i've figured that, i've asked him.
    thx :)
  14. Offline


    Could you pleaes update to 1.2.3? :3 It's a plugin a use a lot, it'd be appreciated.
  15. Offline


    Many videos many how to but nothing that really helps at all wth
    plus i keep getting "If you're trying to build a redstone chip, your chip is way too big."
    If someone can help me i would appreciate.
  16. Offline


    Is the block material your sign is attached to different from the material of the ground you're building the circuit on?
  17. Offline


    I second that, this plugin rocks. Vanilla redstone is virtually useless... Thanks!
  18. please update, we can't live without our chips!
  19. Offline

    Zach Hinchy


    While there may be a few issues with this (/rcsel is broken on my end), this at least gets RedstoneChips usable on the new API platform (1.1-R5 and later). Enjoy! Also, note that the included new "etCommon" plugin is now a dependency (various text parsing and other miscellaneous functionality was moved into the plugin).

    <Edit by Moderator: Redacted mediafire url>

    Neither I, nor eisental and the RedstoneChips team (we are not affiliated!), are responsible for any problems that arise from this. It's a dev build.
    Last edited by a moderator: Dec 15, 2016
  20. Offline


    Awesome, thanks!

    Edit: The unofficial update works, but only for a little while. Eventually all of my chips just stop working. I can re-activate them by right-clicking the signs again, and they'll work perfectly for a little while, but then they'll just stop again.

    I wasn't expecting it to be perfect and I'm not complaining or anything, just letting you know! :)
  21. Offline

    Zach Hinchy

    Okay, thanks.

    Either way, eisental definitely hasn't abandoned this, so it shouldn't be too much longer. :D
  22. Offline


    [quote uid=20434 name="Zach Hinchy" post=1021419]UNOFFICIAL UPDATE TIME~

    While there may be a few issues with this (/rcsel is broken on my end), this at least gets RedstoneChips usable on the new API platform (1.1-R5 and later). Enjoy! Also, note that the included new "etCommon" plugin is now a dependency (various text parsing and other miscellaneous functionality was moved into the plugin).

    <Edit by Moderator: Redacted mediafire url>

    Neither I, nor eisental and the RedstoneChips team (we are not affiliated!), are responsible for any problems that arise from this. It's a dev build.[/quote]

    Thanks a lot!
    Last edited by a moderator: Dec 15, 2016
  23. Offline


    That's reassuring, thank you. I've been checking compulsively for days. xD I'm sure it's a lot of work.
  24. Offline


    Dear All,
    I'm sorry for missing the last few posts. I got logged out of bukkit.org for some reason and didn't get email alerts for a while.

    And now to more interesting subjects:
    RedstoneChips 0.95t1 (TEST RELEASE 1)

    -> Download

    I lost track of what's still missing/broken so please let me know about anything you can find.
    Use the issue tracker for that.

    Thanks to everyone who helped out and thanks a lot to the kind donor! Keep 'em coming if you want me to spend more time working on RedstoneChips.


    RedstoneChips 0.95
    • Updated for MC1.2.3
    • Added support for saving circuit state data on a reset.
    • Rewrote /rcsel. Added /rcsel target for selecting chips by pointing at them and /rcsel world … for selecting all chips in specified worlds.
    • Added /rctool - sets the chip probe tool material and /rctool clear for removing all tools.
    • Fixed memory file support for integers with more than 64bits.
    • Fixed bit set and big integer conversion methods.
    • Fixed redstone torch output CB1.1 bug.
    • Fixed lever update doesn't apply physics around the output block.
    • Fixes an update bug in redstone torch output devices.
    • Memory data that's no longer used by any other chip is properly released.
    • Split some functionality into etCommon library.
    • Uses new bukkit event system.
    • Player data, including the chip probe material is saved on player quit and loaded on player join.
    • /rcactivate - renamed verbose to -v. -v1 and -v2 print different amount of messages.
    • Chips can be built with one io block and a sign.
    • /rctransmit renamed to /rcsend.
    • added many command aliases.
    BasicCircuits 0.95
    • Rewrote display chip including untested direct sram access.
    • burst: Added pulse rate. Now can pulse at slower rates. It takes an additional sign argument in the same format as the frequency used for the clock chip.
    • sram: outputs are immediately updated if another sram on the same memory writes on the same address.
    • clock: Clock stops when chip is disabled.
    SensorLibrary 0.33
    • daytime: Added hour offset argument.
    • slotinput: The chip works now.
    • rangefinder: Fixed scaling bug.
    • pirsensor: Speed improvments
    • rangefinder: An output of 0 now means only "no target". When a target is detected the output value starts from 1.
    • pirsensor: Added option to track entities in a cube in addition to sphere. Tracked entity types can be specified in sign arguments. by Vecht.
  25. Offline


    Glad to see you back :)
  26. Offline


    RedstoneChips 0.95t2 (TEST RELEASE 2)

    -> Download

    • Should fix issue 59 (Chips are turning off randomly)
    • sram: Fixed init bug.
    • display: Support reading pixel data from ram.
    Please let me know if the problem is fixed!
  27. Offline


    Since the inputs[] array of the Circuit class is gone, how do I need to change my circuit plugins?

    BTW: The pixel chip does not activate for:
    green blue red
    black dist{4}

    (daytime_2bit is the name of the channel)

    This happens also without "dist{4}".
  28. Offline


    inputs[] is not gone. What is the problem exactly?

    Seems to work fine for me. How did you build the chip?
  29. Offline


    Show Spoiler
    20:09:51 [SEVERE] Could not pass event PlayerInteractEvent to RedstoneChips
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:303)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:459)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:175)
    at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:287)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:636)
    at net.minecraft.server.Packet15Place.handle(SourceFile:39)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:229)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113)
    at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:554)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:452)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    Caused by: java.lang.NoSuchFieldError: inputs
    at org.dyndns.x7eggert.rc_BCD.rc_BCD.init(rc_BCD.java:67)
    at org.tal.redstonechips.circuit.Circuit.initCircuit(Circuit.java:126)
    at org.tal.redstonechips.CircuitManager.activateCircuit(CircuitManager.java:228)
    at org.tal.redstonechips.CircuitManager.checkForCircuit(CircuitManager.java:205)
    at org.tal.redstonechips.CircuitManager.checkForCircuit(CircuitManager.java:83)
    at org.tal.redstonechips.RCBukkitEventHandler.onPlayerInteract(RCBukkitEventHandler.java:150)
    at sun.reflect.GeneratedMethodAccessor93.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:301)
    ... 12 more

    My code:
    Show Spoiler

    public class rc_BCD extends Circuit {
    protected boolean init(CommandSender sender, String[] args) {
    //next is line 67
    if(inputs.length < 3)

    (pixel chip)
    I built it without an interface block.* There seems to be a problem with the error messages.

    *) I changed it from Netherrack to Soulsand in the config, but I did not change it on this circuit.
  30. Offline


    This seems like some weird installation/compilation error. Make sure that you copied all jars from the zip file and that there are no old jars laying around in your /plugins folder. Otherwise this code should work.
  31. Offline


    I'm using the RedstoneChips 0.95t2 (TEST RELEASE 2) from above, and I think I replaced one file with each new file. I'll search for more .jars and try recompiling my .jar with the new redstone chips .jar, just in case. Give me some time.

Share This Page