[MECH] KitPlugin v6.6 - Let users simply get their Kits [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by recon88, Sep 25, 2011.

  1. Offline

    recon88 Retired Staff

    KitPlugin - Let users simply get their Kits


    Now with enchantments, one-time kits, starter kits, and more! Check out version 6.0 and the new pages!
    [​IMG]
    Overview

    Let's your users simply get predefined Kits with one command.
    Users have to pay for the kits, if the server is running with Vault and any supported economy plugin.
    Works with Minecraft 1.6+

    Plugin Setup
    Requirements for v5.x and v6.x
    • Craftbukkit between 1.4.x and 1.6.x
    • Permissions Plugin
    • Vault (for Economy support) - Optional !
    Todo
    • Nothing. Open for suggestions.
    Changelog

    v6.0:
    • Small config rework
    • Added item name and description
    • Added color support for messages/itemnames/etc
    • Added status effects which are getting applied directly to the player
    • Added deathkits! Only usable once per life
    • Items are now getting dropped if your inventory is full
    • You can now define which slot is used for items.
    • Player database is now stored in yaml files
    • It is now possible to remove armor contents before giving kits
    • Items are now using the vanilla stack sizes
    Olver versions (open)

    v5.1:
    • Separated messages are now possible
    • Player files got their own directory now ("/KitPlugin/playerdb/")
    v5.0:
    • Complete rewrite of the plugin
    • New config system for kits
    • Enchantments are now possible
    • One-time kits are now possible
    • Starter kits are now possible
    v4.2:
    • Potion Support added
    • Fixed a wrong console printout (double currency symbol/name)
    v4.1:
    • Fixed a bug where the plugin doesn't give the kit if a price is set
    • Fixed a bug where the plugin doesn't use cooldowns if a price is set
    • Added a "CurrencySymbol" entry in config to set the symbol in kit messages
    v4.0:
    • Added Vault support (set price for kits)
    • Fixed a bug where players don't receive a kit with /kit kitname playername
    • Fixed the config bug where "%" is used in front of the cooldown number instead of the "-"
    • Code cleanup
    • NOTE: YOU SHOULD REMOVE YOUR OLD KITS FILE BEFORE UPDATING (or change the values inside it)
    v3.2:
    • Added config for Prefix - Default is [Kit]
    • Added config for the Enjoy Message - Default is "Enjoy your Kit ;)"
    v3.1:
    • Updated for 1.2.x
    • Removed iConomy 5 Support
    • Removed old Permissions Support
    • Added Support for new Permission Plugins (e.g. PEX, bPermissions, BukkitPermissions, and so on)
    v3.0:
    • Releasing a remake of my KitPlugin. Works with 1.1-R4 now
    v2.1:
    • Updating to Recommended CB1240
    v2.0:
    • Releasing the remake of KitPlugin
     
    Karlkorv and Inscrutable like this.
  2. Offline

    c-eAgle

    Good job! I love this plugin! :)
     
    recon88 likes this.
  3. Offline

    Bloodknight359

    download link doesnt work. maybe u should add adf.ly

    great way to earn money... btw great plugin
     
  4. Offline

    recon88 Retired Staff

    Sorry my fault. Online again =)
     
  5. Offline

    Xemnas33

    Adf.ly links are banned.
     
    ShootToMaim and recon88 like this.
  6. Offline

    recon88 Retired Staff

    That =)
     
  7. Offline

    Bloodknight359

    oh soz i didnt know and i didnt want to let u banned cause i love ur plugins.
    By the way thx for warning.
    Keep the good work
     
  8. Offline

    MistPhizzle Retired Staff

    I have been waiting for this for a while, I was about to crack down and attempt to make something like this myself with the 1.8 stuff, you saved my life.
     
    recon88 likes this.
  9. Offline

    Stormbow

    Does this yet allow One-Time access to a specific kit? (Like a starter kit of wooden tools and leather for newcomers to a server.)
     
  10. Offline

    recon88 Retired Staff

    Nope, sorry
     
  11. Offline

    Moo Master

    You sir, get +2 internets from me. I can actually use kits now.
     
  12. Offline

    Darq

    think you might make this open source like FloydATC did? And if so, do it with GitHub? :)
     
  13. Offline

    papand13

    Could you make it possible to change the default messages. Like "Enjoy the kit :)" and changing it's tag. So i wouldn't say [Kit] in front of it's messages, but something customiseable. And maybe even changing the command so it wouldn't be /kit. :)
    I love lots and lots of customiseability. So if this is added, this plugin will be one of my most used and appreciated! :]!
     
  14. Offline

    recon88 Retired Staff

    at the moment: no sorry

    Maybe i will add a config for the [Kit] Prefix... But there will be no config for the /kit command:)
     
  15. Offline

    mrgreaper

    we have a minor issue lol

    we set the cooldown to -86400
    which is the number of seconds in 24 hours

    it tells our players to wait 9 days lol
     
  16. Offline

    recon88 Retired Staff

    Sorry didnt saw that u posted this issue... Now i updated it already to 1240.
    Will take a look on it later
     
  17. Offline

    mrgreaper

    Np I'm in no rush...though my players may Lynch me :)
     
  18. Offline

    erickingsr

    I would <3 you if you could make it so kits were a 1 time use :)
     
  19. Offline

    mrgreaper

    set the cool down to -99999999999999999999999999
    ok not one time use but at my calculaation that 306192435 years (roughly) given the formula of (99999999999999999999999999 / 60 = minutes /60 = hours /24 = days and so fourth!)
    unlike some other kit plugins this renembers between reboots how long a player has :)

    "kit needs to cooldown please wait 3 milianias "
     
    Stormbow likes this.
  20. Offline

    papand13

    The countdown won't work for me? :(
    This is my config:
    Code:
    # Name;ID Amount;ID Amount;ID amount (etc)[;-cooldown][;$price]
    p1;24 32;296 16;265 5;263 16;-86400
    p2;24 32;296 16;265 5;263 16;266 5;50 32;264 2;86 1;46 3;-86400
    p3;24 32;296 16;265 5;263 16;266 5;50 32;264 2;86 1;46 3;89 8;331 8;49 16;80 5;79 5;45 5;-86400
    p4;24 32;296 16;265 5;263 16;266 5;50 32;264 2;86 1;46 3;89 8;331 8;49 16;80 5;79 5;45 5;87 5;88 1;357 5;48 10;19 1;30 1;-86400
     
  21. Offline

    recon88 Retired Staff

    No contown or wrong contown?
    Try to set it to -86401 or -86399
     
  22. Offline

    papand13

    No countdown at all. And changing it doesn't work :(
     
  23. Offline

    recon88 Retired Staff

    wait..u can't set any countdown? Tried something like -300 ?
     
  24. Offline

    Nickexp

    awsome but it's too confusing making new kits can someone make a vid?or link 1?
     
  25. Offline

    oleerik

    How can I add wool of different color? : gives me an error
     
  26. Offline

    Moo Master

    Just by any chance, could this get updated to 1317? I have yet to test it on it, and will, but always like being up to date!

    It works on 1317
     
  27. Offline

    recon88 Retired Staff

    There will be an update to 1337 because its the newest RB ;)
     
  28. Offline

    BlancoLanda

    D:... it doesn't support iConomy 6?
     
  29. Offline

    Darq

    @BlancoLanda Correction, it doesn't support Register, which is what all major economy plugins use now for plugins that need a wallet type system to hook in to.

    On a side note, I still haven't gotten rid of FloydATC's version of this, because I've yet to see any changes in recon88's version of the plugin, nothing that he has documented anyway. I'd cross check if he released the source, but he stated that he wasn't going to do that right now.
     
  30. Offline

    BlancoLanda

    Pfft... This plugin would be very useful for my server, but I use iConomy 6
     

Share This Page