[MECH/FUN] SwordsGame v1.4 - A GunGame like gamemode for Minecraft [1185]

Discussion in 'Inactive/Unsupported Plugins' started by coolblinger, Jul 25, 2011.

  1. SwordsGame - A GunGame like gamemode for Minecraft

    I've moved the project to BukkitDev.
  2. Offline


    I found the problem thanks though, also great plugin:)
  3. Offline


    hey, um i did everything it works but when i get into the arena me and my friend cant kill eachother or hit eachother
  4. Offline


    1st have you got god mode on? if not then check to see if 'PVP' is enabled in the server properties. Or if your using multiverse is PVP enabled in the world config?
    Also if you're getting this message "You are in a no-PVP area" it could be 'world guard' region with the 'PVP' flag set to deny.
    Hope this helps you.
  5. Offline


    okay, does pvp need to be on? btw, theres no like rank system right?

    Does pvp need to be on? and btw theres no like rank systemm right

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  6. Offline


    Yes, PvP needs to be on.
    I don't understand what you mean by "like rank system".
  7. I've uploaded version 1.2.4. Players who're not killed by other players should now get teleported back to their spawn and get demoted if possible. (to prevent denying other players kills)
  8. I've uploaded version 1.2.5. (which will be the last update for a while)
    Apparently punching fire did not trigger BLOCK_BREAK, so I've fixed that.
  9. Offline


    Is it possible to get a config for players limit ?:D
  10. Offline


    iconomy please! would help so much. pay for entry and price pools

    also, sword game was working almost all day, but it stopped. /sg just says permmison denied
    edit- does it clash with any plugins.. casino?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  11. Offline


    can you possibly make a video>?
  12. It's in my todo list, I'll do it when I'm back. (I'm in Switzerland at the moment)
    Same as the above.
  13. Offline


    Oh cool have fun :)
  14. Offline


    Can you remove Permissions 2/3 support? It's not compatible with bPermissions :(
  15. Why would I? It's compatible with SuperPerms. (and thus bPermissions)
  16. Offline


    It doesn't work when a plugin supports both Superperms and Permissions 2/3.
  17. Offline


    I've got an issue when trying to go through a lobby :
    23:13:48 [SEVERE] java.lang.NullPointerException
    23:13:48 [SEVERE] at me.coolblinger.swordsgame.listeners.SwordsGamePlayerListener$1.run(SwordsGamePlayerListener.java:50)
    23:13:48 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    23:13:48 [SEVERE] at java.lang.Thread.run(Thread.java:636)

    And then I'm disconnected.
  18. Offline


    I'm loving this, and so are my players. Everything works fine on b1060, latest dev build of Spout Plugin, and the latest Spoutcraft Launcher.

    Thanks for the time and effort thrown into this. Do you have any plans for this besides your to-do list? Perhaps open to suggestions?

    Here is a little guide I wrote for you to help those who have not had much experience with WorldGuard and would like to get this working with minimal research. You can also take what you learn here and apply it anywhere :)

    How to get SwordsGame to work inside of a pre-existing WorldGuard region with a Child Region.

    Select your region. Then define it;
    • /region define <ArenaName> [Owner1 Owner2] - Set name to whatever you wish.
    I.E; /region define Swordplay Wiernusz Kurloc - Swordplay being ArenaName, Wiernusz and Kurloc being owners 1 and 2. You don't need two owners, but you do need to specify one.

    Set it's parent region.
    • /region setparent <ArenaName> <ParentName> - Parent name being the region you built your sub-region under, in my case; I used "zero" which is the main towns region on my server.
    I.E; /region setparent Swordplay zero - makes the region a child of zero. A child region basically inherits the parents flags, and will not accomplish much, until you;

    Set ArenaName's Priority.
    • /region setpriority ArenaName <number> - Each sub-region you create will allow you to over-ride the flags of your parent region. So in Zero, I cannot use PVP. But inside this subregion of Zero, with its priority set higher, you can flag pvp allow in ArenaName, and not have PVP enabled in Zero..
    IE: /region setpriority Swordplay 10 - This will inherit, then over-ride (if a flag is specified)--any flags set from any region flagged priority 1-9 that is inside of Zero.

    Set ParentName's Priority.
    • /region setpriority ArenaName <number> - Setting the parent name to 0 will basically cause it to act like a Global flag, but only for child regions of ParentName.

    Set PVP flag to Allow.
    • /region flag ArenaName pvp allow - PVP is now enabled in ArenaName, and you can now Swordplay :)
    There you go, you can now play SwordsGame inside of an existing region without having people kill each other in your town or whatever it may be. You also have to ensure that PVP is enabled in your server.properties, or MCMyAdmin if you use that (as I do).

    Hope this helped, sorry if it's a bit confusing or if I left something out; I had to go away in the middle of it, came back hours later to a half written guide >_>

    Edit: Fixed SwordsGame. Called it SwordPlay. Derp.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    coolblinger likes this.
  19. Thank you! I'm going to add economy support and make the maximum amount of players customizable once I get back from Italy. You can submit suggestions to GitHub. (the link is in the OP)

    I'll add it to the OP. Oh, and my plugin's called SwordsGame. :p
  20. Offline


    I'm sorry for the mistype, it's just what I had called it on my server, and had it drilled into my head >_>

    Glad the guide is helpful :)

    As for Github, don't know how I missed that.
  21. Offline


    Hey Coolblinger,

    thank you for your cool mod bringing my dreams into reality.

    I admit I'm a bit of a novice to Minecraft server hosting and so I would like to ask for some more guidance. In the OP when I type /sg define arenaname or /sg lobby create arenaname, nothing happens! I only get the original /sg commands screen (list, join/create or leave). I am using Minecraft 1.7.3 and host the server on the same computer. Other Bukkit plugins work fine - and this one works, also, but I cannot create any arena.

    How does it work anyway - do I need to create a lobby first to create an arena? I found no information about that in your help or on your Githut. But simple creating an arena does not work for me. Minecraft server shows no error - only that the permissions file is empty and thus it uses the pre-defined ones that you mentioned in Githut.

    Thank you very much in advance for advice from anyone.

  22. (sorry for the late response, I'm on holiday and check the forums only once a day)
    Are you sure you've set up your permissions correctly? You have give yourself 'swordsgame.define' or 'swordsgame.*' to be able to define arenas.
  23. Offline


    Can't wait to see this plugin in action :D I have some great stuff planned for it but definitely looking forward to the player count config.
  24. Offline


    Hello. I used this plugin since one week and he was good. A few day ago a friend add a plugin called "Stargate" on the server. Then when we go in a game (a swordgame) the command /sg leave don't work (permission denied). We had reboot our server in order to leave the game. When we understand that was the stargate plugin wich was the problem we deleted it. But since this problem, when we go in an arena the game never want start and in the chatbox that said "you're already in a game".

    I don't know what i can do. I try to delete swordsgame plugin and folder, reboot, then install it one more time, create new arena but it still don't work. All command work, we can use /sg ,create arena,leave arena,... but the game never start.

    Sorry for my bad english, i hope you understand me a few ^^"
  25. You could have used /swordsgame instead of /sg, but I'm not sure why the game did not start. Are there any errors in the console?
  26. Offline


    When i joined an arena that's said "You'r already in a game!" But when i tried to leave this "game" it's said "you're not in a game" so i don't know, when plugin work and you go in a arena, that all time say "you'r already in a game! " ? I can't see the console because my server was heberge by "verygames" (if i can see the console, i don't found...).
  27. Offline


    I am also using verygames, go onto your account and go into Maintenance and console log should be there.
  28. What other plugins are you using?
  29. Offline


    I used: wolrdedit,war, swordsgame, stackable,spout,noregen,nightclub,mobdisguise,mapmarker,jukebukkit,iZone,essentials,craftscripts,capturethepoint,admincmd.
  30. I have no idea what's causing this. Have you tried removing/renaming the SwordsGame folder?
  31. Offline


    Essentials likes to conflict with other plugins, get a different admin suite, like CommandBook.

Share This Page