[MECH/FUN] PVPGunPlus v1.0 - NOSPOUT - GunPack alternative [1.5.2]

Discussion in 'Archived: Plugin Releases' started by orange451, Feb 23, 2012.

  1. Offline

    toxic_london21

    orange451= BEST PLUGIN DEVELOPER EVER... I LOVE U <3 NO HOMO :3
     
  2. Offline

    caleb s

    Having this error:

    19:03:25 [SEVERE] Could not load 'plugins/pvpgun.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:154)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:223)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:199)
    at net.minecraft.server.ServerConfigurationManagerAbstract.<init>(ServerConfigurationManagerAbstract.java:50)
    at net.minecraft.server.ServerConfigurationManager.<init>(SourceFile:11)
    at net.minecraft.server.DedicatedServer.init(DedicatedServer.java:105)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:377)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
    Caused by: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:44)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:247)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:143)
    ... 9 more

    Help? I updated java.. it didnt work

    same problem... did you get it working?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  3. Offline

    Ezimox1229

    Aweosme plugin man!
    Really loving it, we have fully featured paintball with it, it's been a huge hit!

    I did find a small bug, err, a minor annoyance. the gun sounds move across worlds, so like you can hear the gun sounds in the PvP/MobArenas world in the main world at spawn. People get a little freaked out XD

    Other than that, the plugin is solid. Apreciate the dev time!
     
  4. Offline

    fussionzz97

    I was told to update java. I have not done it yet so im not sure it will fix it, worth a try.
     
  5. Offline

    Toni12051997

    I have a problem : When I made one left click with my hand that marks me " This gun needs air " and it is a problem, because we use of the pvp on the server. Thank you
     
  6. Offline

    caleb s

    I updated it, and it didnt work. I am running Mac OS X 10.7.5 and java is updated to Java 7 Update 7. Pay attention to this part of the error


    Code:
    Could not load 'plugins/pvpgun.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    I updated it, and it didnt work. I am running Mac OS X 10.7.5 and java is updated to Java 7 Update 7. Rebooted and still doesnt work

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  7. Offline

    orange451

    When I updated Java, it worked for me.
     
  8. Offline

    caleb s

    what platform are you running on java?
     
  9. Offline

    Archarin

    I have the exact same problem. I'm on a Mac. I have the latest version of Java and it still says Can not load the plugin. I don't use any permission plugin could that be it?
     
  10. Offline

    Freedom State

    You should add onto the bolt sound, so that there is a space of about 1/2 a second between the door sound. Then it would really be a bolt action sound.
     
  11. Offline

    blahblahjam

    Do you have the older versions of the plugin? Cause I want to play this on a Tekkit server, which is on Minecraft 1.2.5.
     
  12. Offline

    TikeRike

    Orange,

    could you PLEASE, I beg to you, add an "reload-multiplier" option so you can change 0.15 to 0.01 or something like that. I want fast shooting machine guns sooo bad :s
     
  13. Offline

    orange451

    to make a good machine gun:
    -enable right click firing
    -set the reloadTime to 0
    -set the rounds per burst to 1

    That's what I do on my MCwar server for Automatic machine guns :)


    I'll fix the bolting and cocking sound effects soon. I accidently broke them quite a few updates ago, and never fixed them :p
     
  14. Offline

    Macro201115

    Hey, can you please check the current availiable download. Ive tried on a few computers and extrators but all say
    "Could not open this archive, it may be corrupted, encrypted, empty or an imcompatible format"
     
  15. Offline

    TikeRike

    orange451

    Yes, but I want something similar to the M60, not an M4 :/
     
  16. Offline

    orange451

    Works fine for me.

    Then my plugin isn't for you.
     
  17. Offline

    broluigi

    Your plugin is great! its good for the VIP players on my server that always complain about things they cant do..1

    my only problem is that the second i added this plugin, there is a strange lag every time the rocketlauncher shoots, how can i fix this?
     
  18. Offline

    blahblahjam

    It doesn't work for my tekkit server :L

    18:16:38 [SEVERE] Could not load 'plugins/pvpgun.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:151)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:310)
    at forge.bukkit.ForgePluginManager.loadPlugin(ForgePluginManager.java:55)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:231)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:221)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:197)
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:59)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:177)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:247)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:140)
    ... 9 more
     
  19. Offline

    MonosityStudioz

    Is there a way I could put custom names on the weapons? Instead of it saying Iron Hoe is it possible for me to rename it to Machine Gun?
     
  20. Offline

    2006charger

    Loving this plugin. Couple suggestions though - Is it possible to add a /reload, so I don't have to restart the server when adding/editing a gun? Also, it would be cool if there was a /ammo command to show ammo in the gun at the moment.
     
  21. Offline

    joehot2000

    dont matter that its tekkit.
    get java 7

    edit:
    i do have a 1.1 java 6 version somewhere on my C drive. (it still works with 1.3.1)
     
  22. Offline

    Firesword

    Dude when will this be updated to work with the new bukkit this is my favorite bukkit plugin
    please update it! its so cool for my rpg sever works great with server textures!

    this is my error:

    [SEVERE] Could not load 'plugins/pvpgun.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:154)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:223)
    at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:572)
    at org.bukkit.Bukkit.reload(Bukkit.java:183)
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:21)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:168)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:498)
    at org.bukkit.craftbukkit.CraftServer.dispatchServerCommand(CraftServer.java:490)
    at net.minecraft.server.DedicatedServer.ai(DedicatedServer.java:249)
    at net.minecraft.server.DedicatedServer.q(DedicatedServer.java:214)
    at net.minecraft.server.MinecraftServer.p(MinecraftServer.java:473)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:405)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
    Caused by: java.lang.UnsupportedClassVersionError: com/orange451/PVPGun/main : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:44)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:264)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:143)
    ... 14 more

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  23. Offline

    orange451

    It IS updated to work with the newest bukkit.
    You are running an old version of Java on your server.

    I believe I forgot to tell people this:
    /pvpgun reload (reloads all gun configurations)

    What do you mean by the /ammo command?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 24, 2016
  24. Offline

    MisterCookiez

    If you're getting the "could not load plugin" error, you also need to change your "server launch" to
    Code:
    java -Xmx1024M -Xms1024M -jar craftbukkit.jar
    PAUSE
    That, along with an updated Java, fixed the problem for me.
     
  25. Offline

    checked01

  26. Offline

    2006charger

    It doesn't exist, but I think it'd be cool if there was one. Entering it would give you a readout of how much ammo you have for the gun in your hand. ( Maybe even the name of the gun as well?) Maybe something like "Shotgun | 345 seeds " or something to that effect.
    And thanks for adding the reload. Super useful!
     
  27. Offline

    MIXERRULES

    um quick question is there a verson of this plugins for 1.2.5?
     
  28. Offline

    Speakmore

    Cool plugin!
    I plan to use it with Ultimate Arena!
     
  29. Offline

    Firesword

    what version of java do I need i'm running debian thank you for your quick reply and help!
     
  30. Offline

    orange451

    Java7u7
     

Share This Page