Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


    @Craig1690 yes it does i use4 it
    @pelvix, i hink u have a conflicting plugins i'm not haveing that issue

  3. Offline


    When placing a bridge that crosses a WorldGuard protected region, the bridge is modifying the chunks inside the protected area. Is there a way to prevent this behavior or is it a bug in FalseBook?
  4. Offline


    @Sun-Devil i fixed it by replacing of IC signs and deleting all .db files. so all seems to work on original 0.86_02 with bukkit #953 at me.
  5. Offline


    odd, what I'm using is:
    BlastControl, to prevent creepers from blowing up my houses
    BlocksOnGlass, to be able to put stuff on glass blocks (not used anywhere near the crashing circuit)
    ChopTree, to chop down entire trees
    Helios, to control day/night cycle
    HeroicDeath, to display how someone died
    InvTools, for unbreakable tools
    LWC, to lock personal chests
    Permissions 2.8.5, i think it's this one, the latest non-v3 anyway
    PlgLogCmd, to log player commands
    Stargate, to create custom teleporters

    None of them seems to have anything to do with redstone so I'm at a loss.
    What's even more confusing is that the crashing circuit is in fact an exact replica of a working circuit build some meters away.

    With best regards,
  6. Offline


  7. Offline


    Uh, it's a private server here in our lan, plus it hasn't been running for the past weeks as the minecraft server is not the only thing running on it and I can't have the error eat up all resources.
  8. Offline


    Here's the original 0.85-file as Gemoschen uploaded it:


    Just see, that you solved the problem :)

    Found some issues between 0.85 and 0.86.x too. The Emitter for example had to be recreated ingame, because of a spelling-error (Tranmiteer in 0.85 and later Transmitter in 0.86, so they stopped working)
  9. Offline


    yeah, thx. i found out how to download old versions by editing link ;)
    yes, recreation of sensor signs solves problem by switching falsebookversions.
  10. Offline


    I am having problems with MC1511
  11. Offline


    Same issue. The IC sends a signal out when hostile mobs are near but does not turn off on its own when i kill them. MC0271 with option MOBHOSTILE area 30. same issue with 86.1, 86, 86.2, etc...
  12. Offline


    Try it your self noob stop acting so helpless!
  13. Offline


  14. Offline


    I've isolated the issue with the crashing on Bukkit #953 with the latest FalseBook. It seems to only occur, at least for me, when:

    You build a bridge using signs that are UNDER the bridge. A bridge done with signs ontop of the bridge seem to not have this issue and work 100% fine. I've also tested other things such as [gate]'s and it's also worked. This is strictly with bridges where the [bridge] signs are underneath the actual bridge.

    It seems that if you wire redstone dust to one of the signs and light it, and destroy whatever it is that's lighting it, the server will crash every single time. We tested placing a redstone torch to light the dust and activate the [bridge], then destroying the torch. Server crash. We tried placing a lever, flipping it, then abruptly breaking it while it was on. Yep. Server crashed.
  15. Offline


    I'm still wondering about my problem with WorldGuard protected areas + FalseBook bridges. Please help :/
  16. Offline


    @pelvix i must say VERY nice work. but what does it do?
    try this removeing the hole thing redstone IC's all of it and makeint it in a diffrent chunk then come back here
    @EVERYONE Gemo isnt back yeat as you may know ill ask a frend f he cant fix the IC's for everyone but plase go to and donate so i can give it to him its Diddz of logblock who may be willing to help out here.
  17. Offline


    Hi, me and a buddy are having issues getting carts to dispense, it appears to function differently from craftbook... could somebody give me a detailed guide to getting the darn things to work? Or point me to one?
  18. Offline


    Hey everyone! Sorry for not answering a long time but I've been ill the week after my vacation :-/

    Just for the info:
    I'm currently re-working the complete FalseBookIC.jar to solve most of the problems you have posted (hopefully)!

    I'm now going to answer most of the questions since I've been away. I'm reading ALL of your posts and make a todo-list for this.

    So I may not answer to every single post.

    Thanks for your patience!

    @ HPN: (According to the Deposit/Collect-Cart)
    I will look into this again. Thanks for this report!

    That is planned in a future version! (not before 0.90)

    I'm currently reworking the complete ic-section! Thanks for the reports :)

    Thanks for this suggestion! It's set on my todo-list , but not possible for now!

    Thanks for this report! I will look into it again but it seems that this error came from bukkit itself (there is nothing else stated in the error-log) :-/

    for now the only solution is to give them the following permission:

    BUT: it won't prevent blockfarming then!

    I think I will implement those ICs with the next version!

    I'll look into it again, thanks!

    I will add this as soon as possible to the first post! Thanks for this tip! :)

    set on my todo-list!

    This is not a glitch! ICs with a single input are only activated by the redstone directly in front of the sign. This is necessary!

    It's not a typo! As said in some post above: I recoded the areas a long time ago and the old filename was Areas.db. So I decided to stay compatible to the old version, which cause the filename to be Areas.db2 ;-)

    Thanks a lot man! :)

    Thanks for this suggestions! Set on my todo-list! :)
  19. Offline


    Yay I kept the faith and your back :D Hope you feel better!
  20. Offline


    It's basically a 1-input-3-output IC controlling a Goa'uld ringtransporter. When a player steps into the circle a hidden playerdetector underground sends a signal to the input in bottom left. It then generates a signal to output 1, activating the first ring (blockflip air-stone). After that it activates ring 2 and deactivates ring 1, then it deactivates ring 2 and activates ring 1 and 3. This makes it look like the rings come shooting out of the ground around you. At the end it is supposed to teleport you somewhere (not implemented yet). After the player leaves the detection-radius the whole thing resets to 0 and the rings vanish into the ground again (well it looks that way, actually they just get set back to air in a specific order).
    Anyway, as I said the thing already works perfectly but it required four identical circuits to control each side of the "ring" so I thought, why not use one circuit which outputs to a certain wireless channel, then just use wireless receivers to control the blockflips. So i created the circuit you see in my "Cloud computing center" (It's a cube flying in the clouds housing all my other circuits ^^) as an exact replica of one of the four identical circuits on the ground.
    Lo and behold, the server crashed with REDSTONE_CHANGE.

    As to moving the thing to a different chunk, I think we're on the right track with this. Perhaps the number of redstone-related things in one chunk is limited? There's quite some stuff in or around the center, one being a giant machine that plays "alle meine entchen" and some other stuff. I'll try relocating it but I sincerely hope it's not the cause as it would invalidate my idea of a centralized computing center, also the flying cube is pretty damn big and it took me a while to build it.

    EDIT: *bangs his head on the desk* After creating another copy of the circuit several hundred meters away I can confirm that the crash is NOT location specific. Why the hell does the original work then? There's four of these babies right next to each other for heaven's sake!

    EDIT2: After walking around a little and building yet another exact copy of the same thing ... this one suddenly worked. WTF? Seriously, I'm losing it man.

    EDIT3: Sorry about that. It doesn't work either, I just forgot one bit of redstone in the last one.
  21. Offline


    Keep up the good work, Ge. Your plugin has allowed me to make amazing things on my server and the players love the IC's. Still, I have to ask, did you happen to simply overlook my post? Or is it really just me that's getting it?
  22. Offline


    After crashing my server for about 200 times i finally found out what's causing the REDSTONE_CHANGE error.
    It's the way redstone wire approaches ICs from the side.

    While this one works like a charm:
    This will crash the server:

    I'm assuming it's got to do with the fact that the IC does not only output it's signal via the lever on the back as one would assume but also to the blocks on either side of it's main body, as seen here ( ).
    It probably tries to force it's signal on an already powered line or something like that.
    Well anyway, as a quick fix for all people who have this error, simply avoid approaching ICs from the side like this.

    With best regards,
  23. Offline


    I will look into this after my rework of the ICs and fix this, if I can reproduce this error! Thanks :)

    Hey Pelvix!

    Thanks for this report! The fact the the redstone gets powered is due to the physics of Minecraft (otherwith levers on walls won't work) and I cannot change that, BUT:

    I've tested the exact same constellation with my current dev-build and the server does not crash anymore (I've added a delay of 1 servertick to the execution of ICs and also a maximum execution number at each tick)

    Thanks again :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  24. Offline


    Very nice, can't wait for your next release.
    Thanks for you excellent work on what is, in my eyes, the most versatile plugin for minecraft as of now.

    EDIT: Oh, and I have a proposal for a new IC although I'm not sure if this is possible.
    It would be nice to have an IC that teleports the activating player to some predefined coordinates (maybe relative to the ICs position?). Does the redstone somehow carry the information on who activated it?

    With best regards,
  25. Offline


    welcome back Gemo! i answerd questions the best i could
  26. Offline


    Hello !
    could you add hidden switches like the ones in craftbook ? that would be amazing for my dungeon !
  27. Offline


    @GeMoschen - are fences/gates working differently? Users are reporting that the gate mechanisms arent working as they used to.
  28. Offline


    For some reason, the Lift Signs don't work for my server. They've worked perfectly before i installed permissions, but i've put every permission. Any Help?
  29. Offline


    The block detect sign [MC0263] Doesn't refresh when a block is pushed by a piston, it'll stay true even if you pull the triggering block out of the way via piston.
  30. Offline



    why i have this issue? This is only for bridge...
  31. Offline


    How does CommandSender MC1511 exactly work? Can you put {player} in it? How can you have it run a command that takes up longer than text is allowed in the sign?

Share This Page