Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


    Im making a map for a server based off of Detection areas, so in shot i want to know does
    of detection areas take up alot of resources. Like does it constantly check?
    Is a detetion area the size of 100 better than 20 areas the size of 5?
  3. Offline


    Is it just me, or 0230 is not working? 1230 is working fine, but it needs a clock, so I decided to use 0230. Placed the sign, FalseBook said that IC is successfully created, but It's not working.
  4. Offline


    anynews on bukkit 1.2 falsebook?
  5. Offline


    Well with 1.2.3 Selftriggerd Ic's wont work, only if you do a reload.
  6. Offline


    I am having a problem with this plugin. I would be grateful if anyone could help me.

    I want to use this with GroupManager - to be more exact I wanted to allow users from group "builder" to use some of the features [hidden switch, gates and lifts for now]

    I tried adding the permissions to the file manually, I also tried adding it using /mangaddp [group] [perm] comand, and it said the permission was added succesfully. It also appeared in the file.
    I used /mansave command too. And /manload later also.

    The problem is - none of those work. The permissions are there, but when I try building anything as a "Builder" group [non-op] it just says I don't have the permissions to do so.

    I have checked every possible cause I could think of, including closing the groups.yml file I had opened in Notepad++, to prevent it colliding somehow with server trying to save it to an open file [tho this should not even happen lol] , remaking groups file from scratch etc. I don't have any custom groups, it all runs like it did before [I just changed the 'builder' group name to polish, but I have also changed it everywhere I should so it should not be the cause]

    Whatever I do, the perms don't want to work. I am also using Essentials and Factions plugins and some other [that don't seem to touch the permissions in any way], if that matters.

    I would like to allow my players to be able to use some of the FalseBook features while building their fortresses, as the gameplay relies heavily on team spirit, factions and survival type group pvp.

    Here is the group.yml file of my world:
    # Group inheritance
    # any inherited groups prefixed with a g: are global groups
    # These groups are defined in the globalgroups.yml
    # and can be inherited in any worlds groups/users.yml.
    # Groups without the g: prefix are groups local to this world
    # and defined in the this groups.yml file.
        default: false
        - -bukkit.command.kill
        - g:essentials_default
          prefix: '&e'
          build: false
          suffix: ''
        default: false
        - '*'
        - admin
          prefix: '&4'
          build: true
          suffix: ''
        default: true
        - falsebook.blocks.gate
        - falsebook.blocks.hiddenswitch.create
        - falsebook.blocks.lift
        - default
        - g:essentials_builder
          prefix: '&2'
          build: true
          suffix: ''
        default: false
        permissions: []
        - obywatel
        - g:essentials_moderator
        - g:bukkit_moderator
          prefix: '&5'
          build: true
          suffix: ''
        default: false
        permissions: []
        - moderator
        - g:essentials_admin
        - g:bukkit_admin
          prefix: '&c'
          build: true
          suffix: ''
    .. Help?
  7. Offline


    When falsebook be released for Minecraft 1.2.3?
  8. Offline


    How long until this can be updated to minecraft 1.2.3?
  9. Offline


    can you add netherbrick fence to the falsebook [gate]?
  10. Offline


    I had this problem at first with 0.92.3, but it went away after a full restart or 2. hope you get it working. it wouldn't be the same without falsebook.

    not sure if it's a full release or only a dev build, but 0.92.3 is working well on my 1.2 bukkit server

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  11. Offline


    It works for me in 1.2, its just that the signs doesnt react to redstone
  12. Offline


    He said he's working on a release for 1.2 but this will take some days.

  13. Offline


  14. Offline


    I'll take a look into this, thanks :)

    Thanks for this. I think I already fixed this with the next version.
  15. Offline


  16. Offline


    It seems IC-s created before update work with redstone. But new ones dont. For example my older transmitters, receivers work, but I cant get the ones I make now to work.

    Also when I create a IC chat confirms it was created.

    I hope that helped!
  17. Offline


    Ah wonderful - I suppose it hasnt been uploaded yet then :p
  18. Yeah my MySQL part just cacked itself :p

    2012-03-05 16:10:52 [INFO] [ FalseBook IC ] ----------------------------------------
    2012-03-05 16:10:52 [INFO] [ FalseBook IC ] Error while executing SQL: addIC(int SensorID, Location location)!
    2012-03-05 16:10:52 [INFO] [ FalseBook IC ] ----------------------------------------
    2012-03-05 16:10:52 [SEVERE] com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry '1' for key 'PRIMARY'
    2012-03-05 16:10:52 [SEVERE]at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    2012-03-05 16:10:52 [SEVERE]at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    2012-03-05 16:10:52 [SEVERE]at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    2012-03-05 16:10:52 [SEVERE]at java.lang.reflect.Constructor.newInstance(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.Util.handleNewInstance(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.Util.getInstance(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.SQLError.createSQLException(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.MysqlIO.sendCommand(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.ConnectionImpl.execSQL(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.StatementImpl.executeUpdate(
    2012-03-05 16:10:52 [SEVERE]at com.mysql.jdbc.StatementImpl.executeUpdate(
    2012-03-05 16:10:52 [SEVERE]at com.bukkit.gemo.FalseBook.IC.DatabaseHandler.addIC(
    2012-03-05 16:10:52 [SEVERE]at com.bukkit.gemo.FalseBook.IC.PersistenceHandler.addSelftriggeredICToDB(
    2012-03-05 16:10:52 [SEVERE]at com.bukkit.gemo.FalseBook.IC.ICFactory.handleSignChange(
    2012-03-05 16:10:52 [SEVERE]at com.bukkit.gemo.FalseBook.IC.Listeners.FalseBookICBlockListener.onSignChange(
    2012-03-05 16:10:52 [SEVERE]at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2012-03-05 16:10:52 [SEVERE]at sun.reflect.NativeMethodAccessorImpl.invoke(
    2012-03-05 16:10:52 [SEVERE]at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    2012-03-05 16:10:52 [SEVERE]at java.lang.reflect.Method.invoke(
    2012-03-05 16:10:52 [SEVERE]at$1.execute(
    2012-03-05 16:10:52 [SEVERE]at org.bukkit.plugin.RegisteredListener.callEvent(
    2012-03-05 16:10:52 [SEVERE]at org.bukkit.plugin.SimplePluginManager.callEvent(
    2012-03-05 16:10:52 [SEVERE]at net.minecraft.server.NetServerHandler.a(
    2012-03-05 16:10:52 [SEVERE]at net.minecraft.server.Packet130UpdateSign.handle(SourceFile:41)
    2012-03-05 16:10:52 [SEVERE]at net.minecraft.server.NetworkManager.b(
    2012-03-05 16:10:52 [SEVERE]at net.minecraft.server.NetServerHandler.a(
    2012-03-05 16:10:52 [SEVERE]at net.minecraft.server.NetworkListenThread.a(
    2012-03-05 16:10:52 [SEVERE]at net.minecraft.server.MinecraftServer.w(
    2012-03-05 16:10:52 [SEVERE]at
    2012-03-05 16:10:52 [SEVERE]at
    2012-03-05 16:10:52 [INFO] [ FalseBook IC ] ----------------------------------------
  19. Offline



    When is it likely to version 0.93?
    Do the plugin much on my server.

    Sorry for my bad English
  20. Offline


    Dunno if this is just my server being insane (which it is right now due to the update), but ICs seem to be down. That's it. Lifts, Gates, Bridges, even toggleable areas are still up, but the ICs are dead. Will this be updated to 1.2.3?
  21. Offline


    FB 0.92.3 seems to take an awful long to disable on my server when I try to shut down. Anyone else?
  22. Offline




    Can you release the new Version at
    silentdojo and Nekuroi like this.
  23. Offline


    Kudos for this, i use the subscription system from dev to know about new plugin releases, and if you use it that would be awesome.
  24. Offline


    Is it possible for this plugin to hook VAULT ?
    It is the ultimate ECON/PERM Handler. It'd make a lot of server admin's lives easier!
    Tadas159, Rytharr and silentdojo like this.
  25. Offline


    FalseBookCart cart dispensers are doing a lot of nothing atm
    this is happening onCraftBukkit version git-Bukkit-1.1-R6-34-g93e135c-b2035jnks
  26. Offline


    I assume this plugin is inactive...
    How had is it to switch to craftbook? I'm not a fan of sk89q, but he's better than certain other devs who may or may not have just posted here -_-
  27. Offline


    Keep cool, guys... Like I said on the last 2 Pages 2 Times: I'm working on the next release! It does not help if you ask me 3 times the day when the next release will come.. just as a hint ;-)

    So: I'm working on it and I'm currently testing it with the latest CB-Release. If everything works fine, I will release 0.93.

    Thanks for the log! I'm looking into it!
    Avarice likes this.
  28. so perhaps today 0.93?
    coz i keep getting same kind messages in console and i started "updating" to all my plugins but i believe its this causing
  29. Offline


    I will try to release 0.93 today, yes. No promises, but I think it will be released today!
    CobbleCity, Vittek and Rytharr like this.
  30. Offline


    very nice thank you!
  31. Offline


    Ah ok sorry :p I had read a few pages ago but I think i missed a few pages when refreshing! It doesn't help that bukkit doesn't give out the "Plugin Developer" badge anymore... makes it hard to spot your posts in the rabble -_-

    Can't wait for release - if you need any help with testing I have a private testing server that I'm happy to install it on for you :)

Share This Page