Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


  3. Offline


    Actually reading back people are having issues with lifts in falsebook, I am as well.

    I have permission * (admin) i can create lifts and bridges works if i am OPPED or NOT OPPED as well with the * perm.

    A player has permission falsebook.blocks.* and falsebook.mech.* he can create bridges and USE lifts but cant create lifts? (he can create a [lift] but not a [lift up] or [lift down] it says "linked..." then "you dont have permission")

    the permission listed above must be wrong, as my * perm implies there is an undocumented lift perm that my * perm overrides, and the plugin is ignoring the falsebook.blocks.* on certain things like lifts. Specificaly using falsebook.block.lift still fails to work.

    using yeti permissions (ye mock them but they still are the best to this day.. why?)
  4. Offline


    @GeMoschen you should really test the Farea stuff, it seems to NOT like the new items
  5. Offline


    Thanks for the hint! I fixed it in the new version! :)

    I still can't see why the liftsystem is the only thing that is making problems.. I will look into this!

    Thanks for the report! I will try to fix it. (never used this feature by myself :D )

    You must do the following to make it work with the other blocktypes:
    - add the IDs to the file
    - place a sign:
    2. Line: [Gate]
    3. Line: The ID (if you want ironbars: 101)

    If there is no number entered, the first value in the properties will be used as default.

  6. It would be Nice to get an usable documentation. There are lots of features, some of them come from craftbook, but the syntax isn't equal to craftbook any more. Please Update this or add it to the wiki like the IC's :)
  7. Offline


    If you use the search, this error has been reported 6 times in this thread from different Users :D
  8. Offline


    is it not the same ?
    • falsebook.anyic
    • falsebook.ic.*

    and btw. i dont understand the lift problems
    they work fine
    maybe the is a plugin incompability or something
    with signlift or coloredsigns or this ticker thing

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  9. Offline


    It's the same I think.
    But not every permission plugin support the .*, so you could use the .anyic
    DaEgo likes this.
  10. Offline



    Is there any way to make Falsebook recognize Craftbook ICs when switching over?

    It recognises gates and all that but not the ICs, and we dont want to re-make roughly 2000 ICs :(
  11. Offline


    GeMoschen what u think about my ideas ?
    i didnt see that u say something about it ?

  12. Offline


    (falsebook) Cauldrons won't work anymore on 1.0.1 R1
  13. Offline

    Leon Philips

    Good idea!

    But, isnt it better to have this?:
    >ItemID< (or) All (to detect ANY item)

    To keep the amount of IC's down ;)!
    Again, DaEgo, Good thinking!

    (Im sorry if I am bugging you with these kind of requests! Sorry if so!)
  14. Offline


    I'm not able to reproduce the error. They work fine for me with CB #1602.

    I will add this IC!
    DaEgo likes this.
  15. Offline


    I am sorry v0.91 alpha won't even start with 1.0.1 R1
  16. Offline


    Like I said: It works fine for me here with 0.91alpha, BUT:
    I got the same error with another plugin once. (LogBlock) There seems to be an internal error with the console-logger sometimes :-/
  17. Offline


    could you please add a configuration node or something to use the old craftbook couldrines instead of the actual block ones?
  18. Offline


    The normal cauldron (as described in the video in the OP) is not removed. It still can be used. It just accepts both ways.
  19. Offline


    For some odd reason with R1 the falsebook.blocks.* or falsebook.blocks. bridge does not want to work. Seems to be a issue with lifts so I would assume that all of blocks have the issue. I am using permissionsbukkit as well.
  20. Offline


    So i can ignore that error?
  21. Offline


    I get this error that does nothing, i just want it gone. Server Version (Since 1317-[1.0.1-R1])

    14:33:43 [SEVERE] invalid stream header: 00000001
    14:33:43 [SEVERE] at java.i:confused:bjectInputStream.readStreamHeader(
    14:33:43 [SEVERE] at java.i:confused:bjectInputStream.<init>(
    14:33:43 [SEVERE] at com.bukkit.gemo.FalseBook.Block.FalseBookBlockCore.loadArea(
    14:33:43 [SEVERE] at com.bukkit.gemo.FalseBook.Block.FalseBookBlockCore.loadAreas(
    14:33:43 [SEVERE] at
    14:33:43 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    14:33:43 [SEVERE] at net.minecraft.server.MinecraftServer.w(
    14:33:43 [SEVERE] at
    14:33:43 [SEVERE] at
    14:33:43 [INFO] [ FalseBook Block ] Error while reading plugins/FalseBook/areas/.DS_Store
    14:33:43 [INFO] [ FalseBook Block ] 17 Areas loaded.
    14:33:43 [INFO] [ FalseBook Block ] 0 Bridges successfully loaded.
    14:33:43 [INFO] [ FalseBook Block ] 0 Doors successfully loaded.
    14:33:43 [INFO] [ FalseBook Block ] 0 protected gateblocks successfully loaded.
    14:33:43 [INFO] Could not call home.
    14:33:46 [INFO] [ FalseBook IC ] Loaded selftriggered ICs: 21 done
    14:33:46 [INFO] [ FalseBook IC ] Failed selftriggered ICs: 0 failed
  22. Offline


    Woooo, thanks for fixing MC0020 ^^ I just had another quick question. With command sender is there something that we can edit so that when we use it to execute a command it says a different message than the normal "[MC1511] executing command: (insert command)" and "[MC1511] Command executed!"? Thanks!
  23. Offline


  24. Offline


    server just accept .JAR files and u put the .ZIP inside plugin folder

    ähm, for me its the same,
    i only need this to get my slot machine to work
    so player drop a diamond and the machine give him a try to win 0 , 1 , 3 or (jackpot) 5 diamonds :D
    Show Spoiler
    hey GeMoschen, if u add this i invite u to my server
    to see what i build with ur plugin ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  25. Offline


    Thanks for the log! I will catch the error. Are you using areas on your server? If not, then just delete the "/areas/"-Folder. This should fix it.

    What do you mean by "not work"? You are not able to build the bridge? Did you get any response when trying to build them? Please be precise :)

    Hmm.. I'm not quite sure. Does the plugin work for you with the error? If so, then you can ignore it. But I will try to find a way to fix it.

    I'm working on it ;)
  26. When you get the time would it be possible to update the wiki with all IC's ?
  27. Offline

    Leon Philips

    The only thing I can say to that is: :D
  28. Offline


    I'm sorry but there is definitely no *.zip file in the plugin folder.
    Just tested again, still same error.
  29. Offline


    Hey there, marvellous mod.

    Sadly after we upgraded to MC 1.0 ICs have not been functioning properly. Or more they have but we've been having trouble with the permissions. When opped ICs work perfectly, however when not no-one can make them, even players with the permissions.

    This is our permissions file entry for players able to use ICs

    Show Spoiler

    default: false
    - falsebook.cart.*
    - falsebook.ic.detection
    - falsebook.ic.MC1240
    - falsebook.ic.MC1241
    - falsebook.ic.selftriggered
    - falsebook.ic.standard
    - neutral
    prefix: '&8'
    build: true
    suffix: ''

    Every other permissions command works. We're using Group Manager 1.7 with the group bridge plugin active.
  30. Offline


    and why he say it ?
  31. Offline


    but players cant fill their cauldron with water, thats why i was asking

Share This Page