[MECH] Elevators [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Cybran, Jan 27, 2011.

  1. Offline



    The plugin will be continued at dev.bukkit.org!
    Want to help? Sign up as an alpha- or beta-tester!

    What this plugin does:

    It creates vertical moving elevators, which can be controlled by redstone-powered blocks.

    Features (open)

    • Creating elevators with an individual size (square or rectangle shape).
    • Floor-management: define your own floors with their own names, being able to call an elevator on every floor by – per example – pressing a button.
    • Movement-triggers: control the elevator with redstone circuits or buttons or any other redstone-powered block!
    • Elevator movement-controls: have different buttons for moving the elevator up and down, skip floors by pressing a control button several times.
    • Command-queuing: the elevator will move to the different floors one after the other if it gets more than one command at the same time.
    • Build on the elevator whatever you want (nearly ;))
    • Use redstone outputs to link the elevator to iron doors or more complex circuits.
    • Connect the elevator to your minecart system!
    • Use the elevator as something else, like a lava door.
    • Build automtically opening/closing glass doors around or on your elevator!
    • Protect your elevator with a password or user restriction.
    • Permissions support!

    How to install (open)

    • The server mod:
      Just copy the Elevators.jar into your plugins/ folder. That's it. You can modify the config later (See section Tutorials>Configuration).
    • ???

    FAQ (open)

    • Q: I'm completely new to this plugin! What shall I do?
      A: First, install the mod (see How to install), then you can read the basic tutorials in the tutorial section below.
    • Q: I'm sick of using buttons all the time to control the elevator! I want to include my redstone circuits!
      A: You don't have to use buttons! You can right-click any type of redstone-powered block! The buttons are just the easiest way.
    • Q: I want to build several buttons or other blocks for the SAME floor! How to do it?
      A: Have a look at the "direct" command. It links other blocks to an already existing floor.
    • Q: I try to build a lava door, but the lava is transported with the elevator! How can I let displace the lava by the elevator?
      A: At first, build the elevator like it should be later. Then, use the command /elev lock. Now your elevator will not grab any blocks or fluids placed later on it.
    • Q: Is there a size limitation for the elevator's shape?
      A: Yes. Normally, there is a maximum for the area of 25 blocks. But: you can change this limitation in the config.

    Command usage & Permissions (open)

    [...] = optional parameter. ...|... = select ONE of the values, they all mean the same. <...> = put your own values here.

    /elevators|elevator|elev <command from the list below>

    The basic commands:
    • help|? - shows the commands.
    • permission|permissions - shows your current permission level.
    • create - creates a new elevator at your current position.
    • remove - removes an existing elevator from your current position.
    • call|floor <Floorname> - creates a new floor with the given Floorname.
    • up - creates a new UpBlock, right-click to select block after command.
    • down - creates a new DownBlock, right-click to select block after command.
    • go|direct [<Floorname>] - creates a new link to the given floor or the nearest. Toggled by redstone input. Right-click a block.
    • redstoneout [<Floorname>] - creates a redstoneoutput, right-click to select the output block after. Has to be a lever.
    • glassdoor [<Floorname>] - Type command and place glass blocks. A door will be created to the given floor or the nearest. Use /elev finish to finish and disable glass block listener.
    • glassremove [<Floorname>] - Removes all glass blocks linked to the given floor or from the cabin when no floor is specified.
    • finish - Finishes an action (like glassdoor placement).
    • info - creates debugging info file. CONSOLE ONLY.
    • lock - locks the cabin blocks to stop updating before every movement.
    The more advanced ones:
    • help|? - shows the commands.
    • permission|permissions - shows your current permission level.
    • create [password <Password>] [users <Username1> <Username2> <UsernameN>]- creates a new elevator at your current position, optional with password or user whitelist.
    • remove - removes an existing elevator from your current position.
    • call|floor <Floorname> [password <Password>] [users <Username1> <Username2> <UsernameN>] - creates a new floor with the given Floorname, optional with password or user whitelist.
    • up - creates a new UpBlock, right-click to select block after command.
    • down - creates a new DownBlock, right-click to select block after command.
    • go|direct [<Floorname>] - creates a new link to the given floor or the nearest. Toggled by redstone input. Right-click a block.
    • redstoneout [<Floorname>] - creates a redstoneoutput, right-click to select the output block after. Has to be a lever.
    • glassdoor [<Floorname>] [direction <DirectionIdentifier>] - Type command and place glass blocks. A door will be created to the given floor or the nearest. Use /elev finish to finish and disable glass block listener. You can use a DirectionIdentifier (left,right,up,down,splitH,splitV) to set the opening direction manually.
    • glassremove [<Floorname>] - Removes all glass blocks linked to the given floor or from the cabin when no floor is specified.
    • finish - Finishes an action (like glassdoor placement).
    • info - creates debugging info file. CONSOLE ONLY.
    • pw|password [<Floorname>] [password <Password>] - Overrides password protection for the given floor or the whole elevator.
    • user [<Floorname>] [users <Username1> <Username2> <UsernameN>] - Overrides user whitelist for the given floor or the whole elevator.
    • give [<Username>] - changes the owner of the elevator. Once changed, a reset is not possible.
    • lock - locks the cabin blocks to stop updating before every movement.
    Permission nodes:
    • elevators.builder - basic permission level, user can set up elevators.
    • elevators.advancedbuilder - advanced permission level, user can protect elevators with password / user list.
    • elevators.operator - ignores owner, passwords and user restrictions, can modify everything.

    Tutorials (open)

    Basic setup:
    • Prepare a shaft – size can be between 1x1 up to 5x5. There has to be air in the whole shaft(means also no ladders and no torches directly on the wall).
    • Build a plain of any block type in your shaft as the elevator’s ground. (I would recommend to use a block type that is not placed anywhere in the shaft again with the same shape.)
    • Stand on the ground while typing /elevator create
    • A new floor and a new “CallBlock” (to call the elevator later) are created simultaneously by first typing /elevator call <Floorname> and then right-clicking on a (already existing!!) button. The elevator will halt 2 stones below this block
    • You have to create Up- and DownBlocks (to control the elevator) on every floor OR (better) inside the elevator. Type /elevator up or /elevator down , then right-click on a button (again the buttons have to be created BEFORE).
    • Create as many floors as you want. Besides: the control-blocks can be up to 2 blocks away from the elevator
    • Now you are ready to use the elevator!
    • If you want to remove floors or control-blocks, simply destroy the blocks.
    • If you want to remove the whole elevator, stand nearby and type /elevator remove.
    • After the first server startup with the plugin v1.3+, a new file named Configuration.txt is created in plugins\Elevators\
    • Feel free to modify the values in there. But keep to the given format.
    • restart the server (or use /reload command) to apply the changes.
    Enhanced redstone:
    • If you want, you can extend your calling mechanism, per example by using stone plates connected to redstone wire.
    • To make your elevator moving to a specific floor, type /elevator direct <Floorname> and right-click any redstone wire or button or stone plate...
    • You can also use /elev direct WITHOUT the floorname. This will lead to the next floor in range.
    • If you want, you can add a redstone output to the elevator. Build a LEVER near to the elevator, then type /elev redstoneout and right-click the lever. Connect the lever to your circuit with redstone wire.
    Glass doors for your elevator:
    • Type /elev glassdoor [<Floorname>] [direction <DirectionIdentifier>] to start.
    • You can use a DirectionIdentifier (left,right,up,down,splitH,splitV) to set the opening direction manually. left and right are seen from outside the elevator. splitH and splitV will let the door split horizontally or vertically from the center.
    • Now build glass blocks around the elevator or on the elevator. Use any shape you want.
    • Type /elev finish to stop adding blocks as doors.
    • Call the elevator again to the floor where you built the door. Your created door opens.
    • The door is now activated and will open and close automatically. Have fun!
    Elevator protection (advanced builders):
    • every created elevator has an owner. Only the owner can modify the elevator. To change the owner, type "/elev give <newownername>". To enable modification for every player, type "/elev give". This will remove any owner protection.
    • use the optional parameters to create an elevator/floor with protection, p.e. "/elev floor testing floor password ultimatepassword users NTcomputer Notch" would create a new floor named "testing floor" with the password "ultimatepassword", only available for the users NTcomputer and Notch.
    • modify your protection settings with the commands /elev user and /elev password, p.e.: "/elev user testing floor users Admin" will override the previous settings to only allow user Admin the usage.
    • remove protection settings? Very easy: use /elev password or /elev user without any parameters or floorname only to reset the protection.
    • so far the whitelist, but I want to create a blacklist. How to? Like this: "/elev user testing floor users * -griefer" (no, there isn't any space between the minus and the player - damn line break). * means everybody can use it, the "-" before a name indicates you hate this player and don't want to let him destroy your secret room on the testing floor ;)
    • I have set up the protection, but I'm never asked for a password?! This can have several reasons: 1.) You are an operator. 2.) You have the permission elevators.operator 3.) You are the owner of the elevator. Just let somebody else try, he WILL get a prompt. 4.) You are standing near the elevator while another player tries to use it. He/she won't be blocked.

    Known issues (open)

    • It is difficult to move yourself or turn around while moving with an elevator.
    • Don't use doors on an elevator! They will "clone" items.
    • Pressure plates don't work as Up- /DownBlocks directly. Build at least two redstone to them, type the command and right-click the end of the wire.
    • Avoid using up/down in circuits. This will force any selected redstone-block to remain in off-state. (You can use "direct", though!)

    Future Ideas (open)

    • name elevators - v1.4.4
    • signs with current floor - v1.4.5
    • allow any block type for doors - v1.4.5
    • iConomy support - coming in v1.5

    Changelog (server mod) (open)

    • Version 1.4.3 (RB #740)
      -implementation of the secret project (not useable yet)
      -fixed the chest duplication bug
      -fixed the powered/detector rail dropping bug
      -enabled plugin usage for subfolder-worlds
      -fixed some other exceptions
    • Version 1.4.2 (RB #670)
      -elevators are now stored in the world folders (-> allow backups)
      -items will drop when moved away from a wall
      -added forbidden blocks to config
      -added command abbreviations to config
      -added glassdoor directions
      -added "lock" for cabin blocks
      -prevent block changes while elevator moves
      -added more config options and messages
    • Version 1.4.1 (RB #602)
      -cabin blocks are now searched when initiating movement
      ->WorldEdit & Co for cabin blocks supported!
      -Entities are now moved along, even if they are positioned a greater distance above the ground blocks
      -merged direct and extend commands
      -enabled relative glass doors (=doors in the cabin)
      -glass doors are now "grouped" automatically for a more real opening order
      -redstone outputs floor parameter added.
      -ground blocks pending between grass and dirt are not blocking the elevator anymore
      -wheat, cactus and sugar cane item duplication bug fixed
    • Version 1.4 (RB #556)
      -Permissions support added
      -elevator and floor protection added
      ->many new commands and command parameters
      -command to remove glass doors from a specific floor
      -owner system added
      -individual elevator size support
      -fixed some bugs (can't remember which)
    • Version 1.3.1:
      -removed TSLPC
      -added go|direct command
      -improved elevator search
      -improved elevator position search (prevention of loosing the ceiling ;-))
      -storing entity positions when initiating moving - hopefully fixes fall-through bugs
      -added info console command to create debugging info files
      -binds glass doors to a command
      -fixed button and redstone bugs
      -improved storage cleanup
    • Version 1.3:
      -added automatically closing glass doors.
      -added configuration.
      -fixed a fault timing.
      -changed the command handler to onCommand in main file.
    • Version 1.2.3:
      -fixed a block checking bug.
      -redstone on the elevator is now working.
    • Version 1.2.2:
      -chests and dispensers are now working.
      -furnaces are now working.
      -adjacent mine tracks are now working.
      -item orientation bugfix.
    • Version 1.2.1:
      -color of wool is now stored.
      -Signs are now working inside the elevator.
      -orientation of levers, buttons, torches etc. is now stored (can still be glitchy, cause multiplayer servers always have problems with that)
      -fixed many bugs for the blocks built on the elevator
      -elevator blocks can be safely removed by iStick, Superpickaxe and others now
      -improved the movement system for liquids (enables lava doors and more!)
      -improved the movement system for all entities (creatures and minecarts will also be transported now)
      -elevator movement is now much smoother
      -improved floor search for up- and down-blocks when the elevator got stuck
      -changed the entire storage system
    • Version 1.2:
      - enabled building on the elevator.
      - created redstone outputs
      - fixed server crashes
      - made compatible to CraftBukkit 289+
      - improved handling of breaked blocks
      - made plugin thread-secure
      -fixed path problems on mac + linux
      - and maybe some others...
    • Version 1.1:
      - made the creation a bit easier.
      - fixed some bugs
      - increased the maximum size to 5x5
    • Version 1.0:
      - Release
  2. Offline


    Dont work i have the last craftbukkit i follow the tutorial that say : elevator create and all but the slab dont move
  3. Offline


    I don't think it had been discussed, but the error in julllleee201's video occured because you have to make the shaft one block deeper than the floor ground is (so that floor ground and elev ground are on the same level).

    Without some info WHAT especially not works (and what you've done to get it to work) I'm unable to help! Sorry!

    I think v1.1 was compatible. But I don't want to upload it again (cause server crashes!), so can't you update to 289? (Besides: Newer is better [​IMG] and your version is VERY outdated..)
  4. Offline


    Works but throws out big errors in #298, eventually bringing down the server so for the moment I just threw it off again. Checked the server log and it said this:
    2011-02-10 19:22:44 [SEVERE] Unexpected exception
    java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.rangeCheck(ArrayList.java:571)
        at java.util.ArrayList.get(ArrayList.java:349)
        at com.bukkit.NTcomputer.Elevators.ElevatorsMoveTask.run(ElevatorsMoveTask.java:28)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:114)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:304)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:232)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
  5. Offline


    I tested it with #303, it still works fine.. I don't know what caused that error but I will prevent it soon.
  6. Offline


    Yep that was the first thing I try'd just outa curiosity and it wrk'd >.<. I will have to build more elevators to understand em fully, but yeah... great work!
    --- merged: Feb 11, 2011 4:34 PM ---
    Oooo i have a question!

    So I have a 3 level elevator. Top/Mid/Bot
    When I travel from Bot to Mid, It sends power out the lever i hook'd in with /elev redstoneout @ Mid
    When I travel from Top to Mid, It dose NOT send power out to the lever at mid
    Everything else works correctly.
    I'm a little confused about this and have been tryen to make it work right for like an hour.
    Any thoughts?

    10 minutes later i figure it out... >.< lol
  7. Offline


    Does this thing still crash servers with that block even failure?
  8. Offline


    I have some problems.
    1 - When starting my server, I get a warning: "Elevators - Store - Mainfile not found";
    2 - I don't receive either fail or success messages while creating or deleting elevators.

    Just installed as any other plugin, inside plugins directory and ran the server once before using it. Is there something I'm doing wrong?
  9. Offline


    "This thing" doesn't crash the server anymore. See changelog.

    1 - This is normal, because you don't have any saves yet when running it the first time.
    2 - This is NOT normal. Are you sure using the right syntax? Are there any errors (beside no. 1) in the console?
    --- merged: Feb 12, 2011 7:45 AM ---
    I'm just curios (and want to improve my plugin, of course ;)) - can you say what your solution was?
  10. Offline


    That's strange indeed. I followed exactly all the steps of the tutorial.

    Every time I start the server, the warning is there, and also the problem with in-game messages. Is there some known conflict with other plugin, or do I need to have installed an additional plugin, like Permissions, to get Elevators work? I have many installed, like Essentials, Movecraft, etc.

    Thanks again.
  11. Offline


    can you please make a single player version of this?
  12. Offline


    I don't know about real conflicts with other plugins. But that the warning is there everytime means that the plugin was never called ingame. I'm sorry, no idea why. Maybe just try once without the other plugins?
    --- merged: Feb 12, 2011 3:28 PM ---

    Version 1.2.1 is out!

    See the changelog for detailed information. Main changes:
    -elevators can be used for liquid doors
    -elevators can be integrated to minecart system.
    -@iSushi and @LarryDickman: use your iStick and Superpickaxe now [​IMG]
  13. Offline


    Did you fix the path for the .dat file? The last version I used creates a file called "Elevators\ElevatorsStore.dat" on Linux (and an Elevators folder that is not used). Paths need a forward slash of course.
  14. Offline


    This had been fixed by 1.2 already!
  15. Offline

    Jonathan Bloom

    If there is a torch on the elevator, it destroys them. This causes me to have extremely dark elevators.
    --- merged: Feb 12, 2011 4:23 PM ---
    Also if I put a button right in front of me on a corner and the elevator moves, it puts them on the side walls.

    Edit: And torches work fine on the front wall, just not the side walls.

    Edit: The side wall issue also affects torches, but not signs.
  16. Offline


    As I said, the orientation of torches etc. can be glitchy. My plugin restores there position EXACTLY as it had been stored on the server before.

    But that the elevator destroys torches is not usual... can you maybe post an image of your elevator and mark what doesn't work yet?
  17. Offline


    Just a quick note about mine tracks on the elevator, when elev goes down all the tracks are fine, but when the elev goes up the tracks adjacent to the elev drop. There is a work around though, if you use minecart mania, just use a stone or wood pressure plate instead of tracks as the adjacent "track".
  18. Offline


    Which are the files created by the plugin, when the server first load it?
  19. Offline


    OK here we GO!






    Hope Those pics help'd. It would be hella funny if there is/could-be some hella easy way to make one Lever detect when the elevator lift comes from top or bottom. I don't really know why this happened to me or "IF" im puting the 1 Lever in the wrong place. I made a small test elevator before this and 1 lever worked for Top to Bottom, so I went with it.



    1-When I Started makeing the Larger Elevator, I created the Main Floor "aka Mid" first. Set it up and then added buttons an set them up.

    2-I then went Up and made the Top Floor. Set it up and then added buttons an set them up. I dont know why I did the order diffrently, and I don't know if it affects the elevator. Also the creation system seem REALLY easy for adding floors in. I dont think were you start or end when building it matter's. Or dose it?:eek:

    3-Then I went Down and made the Bottom Floor "aka Storage". Set it up and then added buttons an set them up. After a quick test, ALL Buttons and Floors work Correctly! WOOT!:D

    4-After that I began to add 2 Iron Doors and the wiring for them.

    5- I made the FIRST lower LEVER at Mid, activated it with /elev redstoneout, Right-Clicked-it and it gave me a console msg saying it was active.(like it always dose);)

    6- Connected the 1 Lever I had to the wiring for the doors to test it. At this time I beleive the doors were not open because the lever was not sending out power, but all the wire's were connected to the Lever correctly and the Elevator lift was at the Mid Floor. I think?...., the lever wont put out power for the first time, untill the lift leaves from the Floor the lever is attached to is, and/or comes to it. Once it comes to the floor the lever is on, the lever will send power out, thus opening the doors for the first time and working correctly from then on.)

    7- Went down to the Bottom Floor from Mid, then back up to Mid. Poof doors open'd Once the Elevator was back to mid... YES.. SCORE!:D

    8-Went up to the Top Floor from Mid, then back down to Mid. ... ... :(!*&^$%$(*((*#!:mad:..... The doors didnt open. The Lift was at the Mid Floor thus the Lever should send POWER!

    9- Well WTF!... hmmm.... try'd a couple things and came up with what the pictures I linked show, which was the fact that I needed one more Lever, placed 1 block above the level the buttons are on, for the power to send from the Lever when it comes from the Top Floor.

    Hope what I did helps and it works for me for now!
    --- merged: Feb 13, 2011 1:26 AM ---
    Also.. I understand "why" the lift WOULD knock things off the walls of the shaft after it travels by them. Its an elevator LOL!... You probly shouldnt be able to put anything on the walls of the shaft the elevator is in.

    INSTEAD! liteing the elevator shaft example!....
    Make a 4x4 elevator shaft
    Make the outer 6x6 walls glass
    Make the outer 8x8 walls some kind of block you can attach torches to.
    Poke out holes in the 8x8 block walls so u can see the glass, and mount the torches to the sides of the holes. Light will shine thru the glass to the shaft. Do this as much as needed!!
    Lastly make the outer 10x10 blocks around the sides of this whole thing solid so you cant see the shaft at all...
    Now you have a 4x4 elev in a 10x10 shaft and it's all lit up without torches in the shaft. Puting things that may block the elevators path up and down in the shaft, sounds like a bad idea.
    Its way easy to lite the shaft without puting torches "on" its walls. :D
  20. Offline


    Hey can yu use world edit and make a tamplate thing or whatever and upload it? Thanks alot if you can
  21. Offline


  22. Offline


    Yeah I couldn't agree more. I really like this pluggin ALOT! There are still tons of things I want to try with it.
    --- merged: Feb 13, 2011 9:21 AM ---
    I'm pritty sure anyone could throw together a quick ".schematic":D But I dont think the schematic itself is going to help you because the elevators controls(that are set up manualy by the player) arn't in the .schematic( but Icould be wrong). All of the buttons and floor controls, would have to be set up manualy by you because all that info needs to be in "your" elevators folder for the thing to work right and I don't think the .schematic can put it there. You would get a shaft with no working parts.... I could be wrong so, I'll put up a .schematic soon and we shall see ? ;)
    --- merged: Feb 13, 2011 9:40 AM ---
    Ohh and also... After thinking about it at work for like 5 hours :eek:. I feel like I was just missing something with my elevator. Has anyone had the same issue I was/am haveing with redstoneout levers only sending power when the lift comes from 1 direction and not both?? I haven't even tryed building on the lift itself... OMG things to do :D
  23. Offline


    Thanks that was the name schematic =D forgot it
  24. Offline


    Thanks for your giant post! It is very comprehensible. First: You didn't do anything wrong setting up the elevator, I think. And yes, the build order is completely irrelevant.
    Now, in 6. the problems start - when you build a lever and connect it, it should provide power immediately (if the elevator is at the corresponding floor).
    I tried to copy your elevator (3 floors, levers and so on), following your steps, but - I couldn't reproduce the error :(. I tried everything, coming from the different floors, creating multiple levers - it all worked well. But somewhere has to be the issue.
    Now, I want to find a clue - I don't know how big your world is, would it be possible that you send it per e-mail together with the Elevator's storage file (plugins/Elevators/ElevatorsStore121.properties)? I will give you the adress per PM.
    --- merged: Feb 13, 2011 9:55 AM ---
    Currently - none. The first thing created is the storage file, and this only when you create your first elevator. A configuration is coming soon.
    --- merged: Feb 13, 2011 9:57 AM ---
    Right. The elevator's storage is independant from the world and won't be in that schematic (I'm pretty sure).
    --- merged: Feb 13, 2011 9:58 AM ---
    Are you using the latest version? Only v1.2.1 is designed for mine tracks. If so, could you post an image of your elevator with the mine tracks on it?
  25. Offline


    yeah.. just update'd... and just as you said 1 worked fine.. I did kill the elevator by accident tho and had to remake it real quick like. So once I got to the "put in lever's" step, I put one in and BAM! it worked[​IMG] . Tested it multiple times and it worked fine.../sigh-of-relief[​IMG]

    As i sat at work I thought to myself.. " That was a huge post.... oops.... then I was like, it will probly be no big deal at all and be fixed in 5 seconds.. bah!

    TY for the help!
  26. Offline


    And where is this storage file created? I mean where, in the directory tree of the server, it is located?
  27. Offline


    Well - ok, good that it works now! Did you create the elevator within the last version (v1.2)? Then it could be possible.. I changed also the redstone implementers in 1.2.1.

  28. Offline


    Could someone help me I'm getting this error when i try to run my server:

    2011-feb-13 19:25:07 org.bukkit.craftbukkit.CraftServer loadPlugins
    ALLVARLIG: org.bukkit.Server.getScheduler()Lorg/bukkit/scheduler/BukkitScheduler
    ; (Is it up to date?)
    java.lang.NoSuchMethodError: org.bukkit.Server.getScheduler()Lorg/bukkit/schedul
    at de.NTcomputer.Elevators.ElevatorsMoveTask.<init>(ElevatorsMoveTask.ja
    at de.NTcomputer.Elevators.ElevatorsStore.ReadStore(ElevatorsStore.java:
    at de.NTcomputer.Elevators.ElevatorsStore.<init>(ElevatorsStore.java:39)

    at de.NTcomputer.Elevators.Elevators.onEnable(Elevators.java:51)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:135)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:64)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:45)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:153)
    at net.minecraft.server.MinecraftServer.c(MinecraftServer.java:140)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:104)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:181)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
  29. Offline


    Please post you CraftBukkit version and your OS.
  30. Offline


    Yes, I'm using 1.2.1 along with 319. I was using 297, but the problem still exists in 319(only now the tracks drop when the elev goes up and down).

    I took a few screenshots:

    The whole elevator

    The elevator is going down

    Tracks dropping

    Work around

    I've also made a test elevator with nothing over top of the track that drops, and the same thing still happens.
  31. Offline


    I'm on #289 and the newest version of the plugin and have exact the same problem, but as I'm using Minecart Mania, too, I also can use pressure plates so it's no big deal for me.

Share This Page