[MECH/EDIT] SimpleSignEdit v1.7.1 - Edit signs with right-click, now on BukkitDev [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 22, 2011.

  1. Offline

    Celtic Minstrel

    Not satisfied with the mechanics of other sign edit tools, such as requiring the use of commands, I went and threw together a plugin that lets you edit signs simply by right-clicking them with another sign in hand.
    Download from the BukkitDev page. (Older versions available here.)

    When you right-click to edit a sign, you can then view and edit the text of the sign just as you would when creating it. You can only edit signs if you are the owner or if they are owned by everyone. To include colours on the sign, use the & character followed by a digit or a letter from A to F. This works both when placing and when editing. If you want to include an & character on the sign, and the plugin interprets it as a colour code, simply double it and the plugin will realize that you don't want it to be converted.

    To see who owns a sign, hold a stick in your hand (you can change this to any item in the config file), and right-click the sign. To change who owns a sign if you have permission, hold a feather in your hand (you can change this to any item in the config file), and right-click the sign. Then either type the new owner name into chat, or walk over and punch them. You can also enter the symbols @, #, and * into chat to set the owner to yourself, no-one, or everyone, respectively. You could also edit ownership by editing the config file, but since signs are stored by their location that would not be an easy task.

    To configure the items used for setting/viewing the owner of the sign, simply set the "view-owner" or "set-owner" values in the config file to the ID of the item you want to use. You can also change the "allow-stacking" and "break-protect" values if you wish. It's probably a good idea to leave the "signs" section alone since that keeps track of who owns which sign. You can also configure it so that you need to be sneaking (or not sneaking) to edit signs.

    Permissions nodes:
    • simplesignedit.edit - Allows players to edit the signs they have placed as well as public signs (owned by everyone). If Permissions is not installed, everyone gets this.
    • simplesignedit.edit.all - Allows players to edit any sign, including those with no owner and those placed by others. If Permissions is not installed, only ops get this
    • simplesignedit.colour.<code> - Allows players to use the specified colour on signs. Available colours are listed here, but leave out the underscores and use all lowercase. Or you can just give simplesignedit.colour.*; also, the U in colour is optional. Currently this is restricted to ops if Permissions is not installed
    • simplesignedit.setowner - Allows players to change the owner of a sign. If Permissions is not installed, only ops get this.

    Config options:
    • allow-stacking - Allows sign posts to be built on top of sign posts; if false, an attempt to stack sign posts will result in the edit window appearing.
    • break-protect - Protect signs from being broken by people other than their owner. Obviously signs owned by everyone can then be broken by everyone.
    • orphaned-breakable - If the above is set to true, this controls whether signs owned by no-one can be broken by anyone.
    • sneaking - One of "true", "false", or "both"; if true, you must be sneaking to edit signs, and if false, you must not be sneaking to edit signs. The default, "both", means that your sneaking status is not checked when determining if you should edit the sign.
    • view-owner - The ID of the item used to see the owner of a sign by right-clicking. Defaults to stick.
    • set-owner - The ID of the item used to set the owner of a sign by right-clicking. Defaults to feather

    Video by Warby579:


    List of things to maybe do:
    • None right now

    Changelog:

    Version 1.7
    • Now uses a database to keep track of sign ownership.
    • Added auto-save option.

    Version 1.6.2
    • Added configuration option to allow anyone to break signs that have no owner even if break protection is enabled; it has no effect if break protection is not enabled
    • Fixed a potential NullPointerException that would sometimes occur when disabling; this bug could in theory haved cause loss of owner data
    • Fixed PermissionsBukkit antibuild interfering with the operation of the plugin; now you should be able to edit signs if you have simplesignedit.edit even if you do not have permissions.build
    • Fixed duplication issue that resulted from a conflict with plugins that display an inventory window when right-clicking a sign; any other, similar duplication issues that I'm unaware of should be similarly fixed

    Version 1.6.1
    • Editing signs despite anti-build should now work with more anti-build plugins. It still might not work with some though.

    Version 1.6
    • Added an option to require that you are sneaking (or not sneaking) in order to edit signs. By default, you can edit signs regardless of whether you are sneaking.
    • Added the simplesignedit.* permission node, which somehow I managed to forget when implementing superperms support.
    • Added more API stuff. I suppose it's unlikely people will use it, but still. Also, the API is now used internally as well.
    • It should now be possible to make signs editable for users who do not have build permission. Whether it actually works may also depend on what plugin you use for anti-build. It still won't affect built-in spawn protection though.
     
    Taranis01, Pompeij and ksevelyar like this.
  2. Offline

    Joy

    I am an op, and yet still get Permission error doing anything. I loaded the plugin live, if that matters.

    Why drop Permissions support btw? SuperPerms is hardly perfect, also very new, and not yet complete Oo

    PEX has been around for ages and works smooth as butter.
     
  3. Offline

    mooman219

    I find that this plugin used to work great, now not so much
     
  4. Offline

    Joy

    Does anyone have a download of Version 1.4, before he broke support for the most widely used permission systems?
     
  5. Offline

    RobotGymnast

    Can there be an option to just right-click signs to edit, regardless of what item I have?
     
  6. Offline

    Celtic Minstrel

    It's the name of the colour, not the number. So, simplesignedit.colour.blue.

    Not sure what that means or why it would matter. And what do you mean by Permission error? That's kinda vague.

    It may not be perfect, but I'm not sure I would agree it's incomplete. Anyway, it should continue to work with things like Permissions and PEX once they upgrade to consider superperms; in fact, I think PEX has already done so. No idea if Permissions has. Nevertheless, if you absolutely rely on Permissions, you can continue to use version 1.4 until Permissions updates; the only notable change is regarding colour permissions (in 1.4 the colour permissions are like simplesignedit.colour.§d, which was not what I documented nor what I intended).

    For those asking for older versions, see the original post; there's a link to all the past versions.

    No; the only way this works is by detecting that you've placed a sign on a sign.
     
  7. Offline

    MrAbrman

    Doesn't seem to work for me :/ I don't get any errors in console its just that whenever I place a sign in the sign I want to edit, the sign I placed disappears and doesn't really do anything when I close the sign edit screen. I can see the sign owners to and can't get it even with all nodes '*'

    I have WorldGueard, WorldEdit, WorldBorder, WhoAreYou, Waypoint, VoxelSniper, VoxelAir, Tele++, Permissions, iChat-p3, Essentials and bShortcut plugins. =/
     
  8. Offline

    TheShadow777

    hey nice plugin, the color codes works, see the owner with a stick too but right click edit dont works.. whats wrong ? x.X
     
  9. Offline

    Stormbow

    This doesn't seem to work for me, aside from "right click with a sign opens a sign editing window". I don't know if it's intentional or not (the opening posts of plugins are seldom articulate), but the "sign" that pops up when I RClick a sign while holding a sign is fully blank. How is that editing a sign that's been placed? Looks like filling out a completely new sign to me.

    Worse yet, when I do enter "new" text onto the sign field that pops up, nothing is changed when I click Done.

    CB: 1000
    OS: Win7-64
    Java: 1.6
    Plugins: Administrate, BookWorm, ChestHarvester, Citizens, ColoredSigns, DailyBonus, DogWhisperer, Essentials (+chat, +spawn), FalsebookBlock (+core), FoundDiamonds, GravelClay, HeroicDeath, iConomy, Jail, Jobs, KitPlugin, Lavafurnace, LocalShops, LWC, MailBox, mcMMO, MinecartMania (+AdminCtrls, +Autocart, +ChestControl, +Core, +SignCommands, +Station), MobBounty, OtherBlocks, Permissions, Scavenger, Seasons, SimpleNews, SimpleReserve, SimpleSignEdit, SimpleTime, SimpleTips, TieDyeSheep, Tomb, Towny (+Questioner), uQuest (+AutoComplete, +ShowTracker), Vault, Whitelist, WorldEdit, WorldGuard.

    Also-

    I, too, am getting a lot of sign duplicates in inventory when I right click on signs.

    A full server restart nor reloading plugins corrects these bugs..
     
  10. Offline

    Adelion

    Exactly the same issues here. (than Stormbow)
     
  11. Offline

    Celtic Minstrel

    All four of you; are you editing signs near the spawn location and are not an op? Are you editing signs in a WorldGuard region in which you lack build rights? Do you have anything else that would cancel block placement? Cancelling the placement of the temporary sign will prevent this plugin from working. (Though I had thought the client was smart enough to not show the sign window if the placement was cancelled.)
     
  12. Offline

    Stormbow

    Posting near the spawn, about 10-15 sq away, but I have full permissions (owner). Not in a WorldGuard region. (Does a towny plot count?) I don't believe any of my other plugins prevent sign placement, at least, not to the "*" permissions group.

    And the signs I've tried to (color and/or edit) are on the ground, outside shops (which haven't been programmed yet) for what that's worth.
     
  13. Offline

    Celtic Minstrel

    If you're that close to spawn, and you're not an op, the built-in spawn protection might be blocking it. If it works a little further away, that's probably your problem. I think you can disable (or reduce) the spawn protection in bukkit.yml if you want, or if not, just make yourself an op.

    If that's not the issue, I'm not sure what would be.
     
  14. Offline

    MrAbrman

    I did some testing, ran a vanilla server with ONLY essentials plugin, and I had the same issue, without it, it works perfectly. You might want to look in that, maybe? :)
     
  15. Offline

    Celtic Minstrel

    So you're saying that if you have SimpleSignEdit only, it works, but if you add Essentials, it doesn't? That sounds like Essentials has some form of anti-build functionality which is interfering with the operation of this plugin; I guess you could ask in the Essentials thread if you can't figure out how to turn that off.
     
  16. Offline

    Lathanael

    How can i set a sign public so that anyone can edit it? (Sorry if that question is already answered somewhere in here, but i didn't find it :()
     
  17. Offline

    Celtic Minstrel

    See the opening post, third paragraph. It amounts to setting the owner to *.
     
    Lathanael likes this.
  18. Offline

    Lathanael

    OUCH, i'm stupid and/or blind :d Thank you very much for pointing me to it
     
  19. Offline

    Lathanael

    Bug/Error report:

    I've got that error while using the .hold command of the RTKwrapper:
    Code:
    2011-08-06 22:52:24 [SEVERE] Error occurred while disabling SimpleSignEdit v1.5 (Is it up to date?): null
    java.lang.NullPointerException
        at ca.celticminstrel.signedit.SignEdit.onDisable(SignEdit.java:287)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:128)
        at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:899)
        at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:288)
        at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:281)
        at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:157)
        at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:312)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:391)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
     
  20. Offline

    lipe123

    So the only permission system supported at the moment is bukkit permissions? Thats rather nasty :(

    I'm owner/admin of my server but I dont use the op system, instead i use '*' permissions and I can't set the owner or edit signs. All I get is "Sorry,you do not have permission to set the owner of signs".

    I use PermissionsEx as my permission system btw.
     
  21. Offline

    Celtic Minstrel

    @lipe123 – This should work with PermissionsEx, provided you use a version of it that incorporated support for Bukkit permissions. I'm not certain exactly when this was done, but the latest version should be fine. However, I don't know if '*' will give permissions for this plugin; try giving 'simplesignedit.*' as well as '*'.

    @Lathanael – That seems to imply that a null location has been used for recording a placed sign, which should not happen; nevertheless, it does give me something I can check up on and possibly fix. But... what is "the .hold command of the RTKwrapper"? And what's the RTKwrapper?
     
    Lathanael likes this.
  22. Offline

    lipe123

    I still had the prev ver of PEX works great with the new 1.13 version thanks. Got to say those permission 3.1.6 users must be starting to feel the hurt about now.

    Seems like all existing signs wont be editable right? I still need to do proper testing but I think I expected something else, I thought I'd get all the text on the current sign and would be able to edit single chars or fix typos etc without having to type it all over.
     
  23. Offline

    Celtic Minstrel

    Unfortunately Minecraft's text editing does not support the use of the arrow keys, preventing you from doing that. You do at least get the current text that's on the sign, so you only need to retype the lines you're changing.
     
  24. Offline

    Lathanael

    Take a look here for what RTK is and what it can do. (I'm not good at describing things in short!)
     
  25. Offline

    shadydeath999

    @Celtic Minstrel is it compatible with craftbook/falsebook? cus it has alot of sign based stuff that toggles on sign right click
     
  26. Offline

    Celtic Minstrel

    Okay, so .hold is basically stop.

    @shadydeath999 – I think it'll be compatible with falsebook/craftbook, but keep in mind that when you right-click to edit a falsebook/craftbook sign you'll also activate the sign. For the most part though, that shouldn't interfere with the editing process. I have successfully edited craftbook elevator signs, for example.

    The only thing it's not compatible with is plugins that show inventory windows when you right-click a sign.
     
  27. Offline

    shadydeath999

    well i meant it more like is there any way to make the edit key a differnt think like shift+richt click or sumthing so i dont edit sign when i wanna toggle them
     
  28. Offline

    Celtic Minstrel

    Ah. Actually, that is possible. I'll look at adding that. More specifically, an option to require that you be sneaking/not sneaking in order to edit signs, which isn't necessarily shift-right-click since it depends on your key bindings.
     
  29. Offline

    shadydeath999

    btw i tryed the plugin today couldnt edit any signs craftbukkit build: 1000
    plugins besided sign edit:
    Show Spoiler

    AntiXRay : 0.6.10
    Armor : 1.1
    ArrowTurrets : 1.2
    AutoMessage : 1.5
    AutoSave : 1.3.0
    BetterShop : 1.6.6.6
    Cleaner : 1.7
    ControllerBlock : 1.16
    DurpAntiSlime : 1.0.0
    Essentials : 2.5.6
    EssentialsChat : 2.5.6
    GroupManager : 1.0(alpha-5) [Zombie-Version, please switch to Permissions 3]
    FalseBookBlock : 0.87alpha DEV#3
    FalseBookCart : 0.87alpha DEV#3
    FalseBookChat : 0.87alpha DEV#2
    FalseBookCore : 0.87alpha DEV#3
    FalseBookExtra : 0.87alpha DEV#3
    FalseBookIC : 0.87alpha DEV#3
    FenceStack : 1.13
    godPowers : 2.0
    HealingTotem : 0.7
    HeroicDeath : 1.7.3.148
    iChat : 2.1
    iConomy : 5.01
    ItemVoid : 1.1
    LogBlockQuestioner : 0.02
    mcMMO : 1.0.50
    MinecraftViewer : 1.0c
    MultiHome : 0.9.7
    MultiVerse : 1.7.2
    MyWarp : 2.0
    NSCommand : 0.2
    PlugMan : 1.3
    PumpkinDiver : 0.16
    road : 0.1
    SecretDoors : 0.2
    SimpleAFK : 0.7
    SpawnX : 0.6
    Spout : 1.0.1
    Stats : 0.985
    StealthLogin : 1.1.0
    SupernaturalPlayers: 2.5.1
    TeslaCoil : 2.0a
    ThunderTools : 0.1
    WeatherControl : 1.0.0
    WolfPound : 0.12
    WorldEdit : 4.6
    WorldGuard : 5.2.2
    Achievements : 0.981
    Permissions : 2.7.2
    LWC : 3.3
    MobDisguise : 1.31
    PlayerEditor : 0.9.2
    dynmap : 0.19.2
    Administrate : 1.2.1
    Factions : 1.4.4
    LogBlock : 1.25
    NoCheat : 1.11b
     
  30. Offline

    Celtic Minstrel

    Well, what happened when you tried to edit a sign? I assume you followed the instructions and were holding a sign.
     
  31. Offline

    shadydeath999

    ... missed that part sry XD
     

Share This Page