Inactive [MECH/DEV] ItemCraft 1.6.6 - Support for client mods in Bukkit [1060/1000]

Discussion in 'Inactive/Unsupported Plugins' started by asdaarg, May 3, 2011.

  1. Offline




    ItemCraft is a Bukkit mod that allows adding new item and block types, crafting and furnace recipes, and custom tree generators and more. Using a Modloader and SettingsGUI interface it allows subplugins known as ICPlugins to be loaded to support client mods. ICPlugins can be created by translating a client mod using the ICTranslator ICplugin. Using a ModloaderMP interface (ported by krnlyng/liar) it allows porting multiplayer mods to bukkit.

    • Add more Block types
    • Add more Item types
    • Add more Entity types
    • Add more TileEntity types
    • Add more Crafting recipes
    • Add more Smelting recipes
    • Add more Tree generators
    • Ported ModLoader interface
    • Ported ModLoaderMP interface
    • Fake GUIAPI Settings interface
    • Startup file for configuring plugins and making simple blocks and items

    Installation & Usage:
    • Back up your world(s). Just in case.
    • ItemCraft.jar goes in same folder as craftbukkit
    • IC plugins go into ItemCraft/ICPlugins folder under craftbukkit. (folder is autocreated the first time)
    • uncomment (remove #) in front of all plugins you want to use in plugins.ics (autocreated in ItemCraft/ICScript)
    • Make sure you have the recommended version of craftbukkit in the title - since this is a mod of that version in particular.
    • Delete/rename the META-INF folder inside craftbukkit-0.0.1-SNAPSHOT.jar (Use some decent zip program (e.g. 7zip) that can do it.)
    • All players on the server needs to have the client mods installed
    • If you use the 16 bit entity id packet mod (in case you use new entites (only ICMCreatures need it)), All players need (flan's unofficial) ModLoaderMP client mod
    • All players also need the 16 bit entity id packet mod (overwrites a ModLoaderMP's class so make sure ModLoaderMP is installed first) in case you use new entites (only ICMCreatures need it) If decide not to use the packet mod, you can turn it off putting this in your startup file: false setEntityIDPacketMod
    • Sometimes you get block/item ID conflicts, between plugins. You then need to set the conflicting ids in the startup script using setID command: example. They have to be set before the plugin that uses them is loaded. Note also that there is typically a props file on the clientside you have to edit the ids on to be the same as well.
    • To start:
      • Windows:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      • Others:
        java -Xmx1024M -Xms1024M -cp ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
      IF You do not understand how to install this follow THIS link! Also Try:

      ItemCraft Forum
      ItemCraft Wiki


      Installation instructions changed since 1.5

      For Minecraft 1.7.3

      Inofficial ItemCraft update by Syrome1.6.6 (#1060)
      ItemCraft 1.6.5 (#1000)
      QwertyPower files (ICSGlass, ICFancyPack addons and more...)
      o4kapuk 16 bit packet mod Does not work without (flan's unofficial) ModLoaderMP client mod.
      ICKSlopes - support for Kaevator SuperSlopes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use Ignore ScotTools or you will have problems breaking various blocks
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.7.3 mod Details regarding use of potted plants IDs and settings
      User ported mods list maintained by icephantom

      For Minecraft 1.6.6

      ItemCraft 1.4.5
      ItemCraft 1.5.1 (for use with planes)

      ItemCraft 1.3.5 (for CB #818)
      ICSGlass - support for ChocolateySyrup's Stained Glass unofficial update for 1.6.6 mod
      ICFancyPack - support for ChocolateySyrup's FancyPack unofficial update for 1.6.6 mod Details regarding use of potted plants Also be sure to read: Release notes Does not work well and not at all with the newest FancyPack update(v6) Wait until client is stable.
      ICKSlopes - support for Kaevator SuperSlopes
      Usage notes
      ICNTrees - support for Nandonalt's Trees mod. Details regarding use
      ICMCreatures - Support for DrZhark's Mo's Creatures
      16 bit entity id packet mod
      User ported mods list maintained by Asymetrikon

      Dev tools:
      ICTranslator - How to use

      Source and old versions

      ICScript documentation

      Frequently Asked Questions

      Tutorial on how to make your own blocks also list of block and item IDs in most popular mods.

      Suggestions of mods to port
      Vote here not in this thread anymore (it gets lost in all the other stuff)

      Reporting errors:
      • Read known issues - don't report those.
      • State the version of CB, ItemCraft and ICPlugin(s) you have problems with
      • If your client crashes, start the client from command line so that you get the error report.
      • Make sure the mod(s) works in SSP First before you report any errors here.
      • You are more likely to get a response if you describe the problem in more detail and do some testing yourself first of under what circumstances it occurs
      • Do not ask for uploads of minecraft.jar.
      • Do not pm me.
      • If you have problems installing, you are likely doing something wrong. Make sure you've followed the instructions exactly, read the FAQ and Wiki. If that doesn't work you can always ask in the thread, while I will likely not reply, there are others who can help you with your problem. But at least try to get it working yourself first.

      That said, I want to thank all who have helped users with their problems. In particular special thanks to icephantom and Asymetrikon for their big efforts in this. Also a special thanks to xeronut for being generally helpful.

      Changelog: (open)

      • Inofficial update by Syrome to support CB #1060 and ModloaderMp v1.7.3v4.
      • Added changes by krnlyng/liar to support buildcraft
      • Inofficial updated by Qwertypower to support CB #1000
      • Fixed Generators not working since ModLoaderMP merged.
      • Added option to turn off packet230 being sent to clients: false setPacket230OnLogin
      • @QwertyPower's unofficial update to 1.7.2 and 1.7.3.
      • Fixed issues with ICPlugins not being able to use ModLoader methods obtained through relection.
      • Merge with @krnlyng/liar's translated vesion of SDK's ModLoaderMP
      • Added dummy method RegisterTileEntity to fake modloader.
      • Added dummy methods AddArmor and getUniqueSpriteIndex to fake modloader.
      • ItemCraft commands are now loaded automatically and can be used in init.ic
      • Fixed nonesense message when parsing a string and EOF is found after escape character.
      • Platform independent line breaks of autocreated files
      • added some stuff in the autocreated file
      • Fixed unupdated mod causing problems for other plugins accessing the enum's constants for new block ids 1.6.
      • Removed spam on use command
      • Fixed java method invocation
      • Added javamethod invocation of declared methods
      • Fixed pop removing 2 elements off stack
      • putsetting command, allowing editing settings using new script
      • putvar and getvar commands allowing use of variables in scripts
      • added if command, conditional execution of closures
      • ishidden, isCustomType and getCustomType commands
      • exec command, allowing execution of closures. Acts as function calls.
      • while command, for while-loops, execution of closures.
      • Annotation of non-standard methods allowing correction of semantics during parsing with methods that manually alter type info. (needed for for loops, and various stack commands (such as popall, push, pull,dup, casting, getvar, all that do not have a static type signature) to have any usefulness beyond execution using GUI.
      • added casts
      • Fixed setEntityIDPacketMod demanding a this pointer.
      • Fixed boolean constants missing.
      • Updated to CB #860
      • GUI is now off by default
      • Fixed illegal access of Item constructor and other methods
      • 16 bit Entity Id Packet mod can now be turned off
      • Added file loading functions that use filename rather than file class for Fileman, for use with Janino
      • Fixed intellisense being screwy, showing previous context
      • Fixed castability test of primitive types to primitive types being screwy
      • Fixed selected method in context view not being visible (scrolled down/up to).
      • Fixed array bounds error
      • added intellisense (context box showing sorted list of all applicable methods in context at cursor position, as well as selecting the one closest matching)
      • added tooltips showing documentation both in command box and in the context (list) box
      • added getmaterial method to get Minecraft's materials
      • added documentation to most methods.
      • removed some obsolete methods
      • renamed some methods
      • remove NAME: spam on classloaderlclass, 1,2,3 4.. spam and vs: spam
      • fixed classloaderlclass leaving junk on stack
      • fixed getconstructor (?)
      • fixed right square bracket without left square bracket not resulting in parse error
      • fixed parse to fail due to right bracket not yielding an array type
      • removed autocreate double spam
      • ics extension changed to ic (conflicting with korganizer and iCalendar)
      • moved plugins into plugins.ic (since it now doesn't execute "use" until it parsed the whole file, it doesn't
      • recognize ItemCraft functions in init.ic)
      • added setID
      • added back support for old file format using includeold
      • fixed execution of abstract script calling providing arguments in wrong order
      • ICScript is now completely converted into postfix
      • Completely rewritten script parsing and execution code
      • Math functions should work now
      • Scripts Are not executed until fully parsed
      • ICS now support direct invokation of java functions when no ICS function matches a call
      • ICS now support arrays
      • ICS now support closures (for later support for menus, functions, loops, conditionals)
      • Parser produces Abstract code that runs much faster, than when having to parse each time to execute code.
      • Pre 1.0-style startupfile scripts are no longer supported (for now)
      • Warning of Block loss with prompt to quit CB on any error during parsing
      • Warning of Block loss with prompt to quit CB if startup script file was not found and was autocreated. This way you can have it autocreate it safely without having to worry about loss of blocks during upgrade.
      • Detailed error reports during both parsing with line number and column and during execution.
      • added simple math functions
      • added basic string and character functions
      • fixed methods popping more than one element
      • fixed dup not duplicating
      • added primitive classes
      • added parsing of primitives as primary commands
      • added parsing of strings as primary commands
      • fixed identifier after a string being misparsed
      • fixed popup menus not working in windows
      • added methods to get icplugins and their classloaders
      • added methods to get constructors and invoke them
      • Implemented new functional script language ICScript
      • Implemented GUI
      • inclusion of files (so you can split up startupfile in smaller files)
      • loading plugins on the fly
      • executing any script commands on the fly using GUI
      • exploring variables and functions of objects in GUI
      • invoke any functions, private or public, on any class loaded in IC/ICPlugins/minecraft/CB/any bukkit plugins
      • Built in text editor (was going to be for editing java code)
      • Removal of blocks, entities and items, even on the fly
      • Adding new blocks, entities and items on the fly
      • Specify what entities spawn in what biomes and how frequently.
      • Customizable programmable menus per node type in GUI
      • IC now retrieves version number both for plugins and itself automatically and reports it when plugins are loaded
      • fixed mimic having target object mimic itself.
      • fixed invokation on wrong object when interacting with mimiced block
      • fixed setint setting a string and not an int
      • fixed case sensitivity of block parameters
      • fixed some other bugs related to block parameters
      • no more commas assigning multiple values in block parameters (because I'm lazy)
      • Mobs that are unspawnable don't crash the server anymore
      • Added new startupfile commands: blocks and entites
      • Added new startupfile commands: setbool, setint, setfloat, setdouble, that allows changing the settings of mods that use GUIAPI (nandonalt trees and mo's creatures)
      • fixed various bugs with craft command in startup script
      • removed debug spam on id command
      • fixed comments causing "unknown commands" in startup file
      • cleaned up unnecessary stuff from error report
      • fixed skip skipping over the next line too
      • Implemented modloader removespawn (could that have anything to do with the watermob problem?)
      • fixed unknown command spam on empty lines
      • fixed some bugs with craft command in startup file manager.
      • Fixed kicked when horse throws you off because of accessing protected field
      • Fixed problems adding recipes, tile entites, entites using API.
      • added items command for debug purposes
      • added a copy of spawncreatures to the mod, no idea if that will solve the issue with sharks crashing server.
      • Mimic feature of block allows block to mimic other blocks, fully or in some respect (useful to customize blocks beyond the fixed values from startup file)
      • back to start from craftbukkit folder; its no longer a plugin
      • IC plugins go into ICPlugin folder now in craftbukkit folder. These are to avoid problems caused by plugins being reloaded by CB
      • usedefaults on by default
      • fix item 0 is not valid item spam
      • implemented Modloader getUniqueEntityId,RegisterEntityID,setPrivateValue
      • implemented various SettingsGUI widgets facades, and SettingFloat, SettingsMulti
      • script pauses when error occurs to avoid startup with wrong settings
      • Items are also registered as dummy, to avoid error spam by other plugins
      • Modloader world generator interface for normal type worlds implemented
      • Barebones fake GUIAPI interface that loads default settings (might add ability to modify options through startup later)
      • Added fix for blocks not having dummy material in ICFancyPack that inherit the Block class directly
      • Dummy id changed to 255
      • Added support for Entities in API
      • Added support for adding mobs to biome spawnlist in API
      • Added support for adding tilentities in API
      • Added fake modloader for to interface with translated mod plugins
      • Added more detailed output when plugin loading fails.
      • Backward incompatible update to 766
      • Added ability to set data on input items in crafting recipe
      • Added ability to comment in startup file with #
      • Added more error handling.
      • Fixed unable to craft out of nonblocks
      • Added more error handling
      • Partial support for GUIs
      • Mod for custom tree generation
      • Custom Tree generation API
      • Custom Tree generation startup file instructions:tree,treebiome and biometreedensity
      • Added mod of org.bukkit.Material to accomodate new block types, should reduce at least some errors other plugins have.
      • Fixed Item id being offset by 256
      • Fixed startup script created Blocks not being added to item list
      • Added more error handling
      • Fixed ItemCraft not starting because of spaces in the path on windows machines
      • Fixed regexp error on windows when starting as plugin
      • More error handling added
      • Fixed freeze when adding new block properties using startup script
      • Now doubles as plugin, so you can start it as a plugin rather than a mod
      • Startup file autocreation
      • loud startup file instruction- prints out more info at startup
      • a whole lot more error handling
      • fixed bug not being able to load any other plugin that KSlopes.jar (what am I thinking)
      • Most if not all simple constant Block properties now definable from the startup file.
      • Better error handling
      • More complete Block API
      • Syntax correction
      • Initial Release
      • Made compatible with IC 1.0
      • Syntax correction
      • More information on startup
      • Fixed slopes and corners dropped having wrong data.
      • Initial Release
      • Introduced options to change settings and IDs
      • Disabled new bookshelves
      • Updated for 1.7.3
      • Fixed another NPE on startup
      • Fixed NPE on startup
      • Updated to unofficial version of 1.6.6
      • changed class path for flower, cactus and reed
      • Fixed not able to place in potted plants
      • Fixed blockcycler interaction
      • Added potted plants
      • Initial Release
      • Updated to 1.7.3
      • Fixed static construction of objects problem
      • Fixed no tree generation
      • updated to 1.6.6
      • fixed clicking on bananacake blocks, fruit leaves
      • fixed using fertilizing
      • fixed activating banana cake
      • Initial Release
      • Updated to 1.6.6
      • Made everything public and even added a public ()V constructor in water mob class (no idea if that will solve it though)
      • Says its loaded on startup when its loaded
      • Initial Release
      16 Bit Entity ID Packet Mod
      • Supports both 16 bit and 8 bit servers
      • Initial Release
      • Fixed conflict with glass bug
      • Initial Release
      • Fixed no output on windows machines.
      • More informative about files to translate not being found.
      • Made it tolerate there being no file separator at the end of retroSource.
      • Removed some spam.
      • Added checks that make sure you have all the necessary maps specified, when you translate.
      • Initial Release
      • Update to 1.7.3
      • Initial Release

      Donate (Not necessary but appreciated)
  2. Offline


    look at the init,ic and check if you have uncommented the lines needed by removing the #
  3. Offline


    IndustrialCraft doesn't work with bukkit#1000 see this page

    Have you an error with the server? If the server have no errors, do these steps
    1)Check that the blocks ID of the server math with the Block Id of the client. If they are different, change the IDs and try to connect the server. Otherwise do the two steps.
    2)Execute this command (on windows), You can create a bat file to the location of minecraft.exe:
    Minecraft.exe 2>log.txt
    And post the error.
  4. Offline


    that sets the spawn for future bunnies, i had the same issue XD after you change that need to kill off the bunnies that were already pre existent before that script. If you cant log on because its too laggy recomment mo creatures and login, save your world close it and uncomment

    also make sure to include it somewhere within your plugin.ic just type this above all the commented plugins
    "oldscript.ic" includeold
  5. Offline


    your init.ic must be uncommented go edit it with notepad
  6. Offline


    Does ICMcreatures support horse taming yet?
  7. Offline


    What do I uncomment in the init.ic?What should the file look like?


    That makes no sense....Can you edit your post with some proper English please?

    Thank You.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  8. Offline


    Self-replying here as I may have found the problem. I tried deleting the clientside config file for Nandonalt's coral mod (stored puzzlingly in the Minecraft folder instead of inside the empty Mod folder it creates, but that's beside the point entirely) and it SEEMS to be working now. I think the problem might have been a changed setting clashing with the server's default settings for the mod. A friend of mine was also having this problem, but they were also using a config file I'd copied over in the process of getting them set up with mods. Of course, now that I've said this it'll end up happening again despite this. That's just how bugs roll. But if anyone else has had this problem, try what I did, perhaps.

    Edit/Update: Nope. Looks like that was indeed not the problem after all.
  9. Offline


    I edited my post
  10. Offline


    I've been trying to get IMCreatures working for about 12 hours now with no luck. Can someone tell me what I do and don't need for the server AND clients? Also which craftbukkit build should I use?
  11. Offline


    Please help... Running the server goes fine but when im going to log into minecraft it just goes black and exits to desktop...
    and in the server console it stands : Spirit293 quitting. endofstream
  12. Offline



    Next question
    "ICNTrees - support for Nandonalt's Trees mod. Details regarding use Ignore ScotTools"
    thet mean i shoud use ShockAhPI (SAPI) ???
    but SAPI dont' work with IndastrialCraft !!!!

    help pleasea
  13. Offline


    You can use ScotTools, it's not really a problem. You will just have some difficulties to break some blocks.
  14. Offline


    Perhaps a fork of ID, the client does not know this ID, this fork lead the client to crash.
  15. is there any chance of the SP mod trains and zeplins being ported to IC as that is a plugin i so badly need for my server
  16. Offline


    Anyone know whats required for ICMCreatures? The instructions are very vague and mixed up and the only tutorial out is outdated.
  17. Offline



    next quest

    i install mod:

    and i need remove 3 block(id) and the will work. ( now new item more then 255 (258))
    i tru in confib blockid=0 blockid=-1
    dont' work!
    but how??!??!
  18. Offline


    I am trying to use the translator, but I am getting an error whenever I type something.
    This is my server log:
    Show Spoiler

    2011-08-04 20:56:01 [INFO] Starting minecraft server version Beta 1.7.3
    2011-08-04 20:56:01 [INFO] Loading properties
    2011-08-04 20:56:01 [INFO] Starting Minecraft server on *:25565
    2011-08-04 20:56:01 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-08-04 20:56:01 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-08-04 20:56:01 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-08-04 20:56:01 [INFO] This server is running Craftbukkit version null (MC: 1.7.3)
    2011-08-04 20:56:01 [FINE] ModLoader Server Beta 1.6.6v4 Initializing...
    2011-08-04 20:56:01 [INFO] ModLoader Server Beta 1.6.6v4 Initializing...
    2011-08-04 20:56:01 [INFO] ModLoader Server Beta 1.6.6v4 Initializing...
    2011-08-04 20:56:01 [FINER] Adding mods from C:\Users\Start\Desktop\1.7.3 Server\ItemCraft.jar
    2011-08-04 20:56:01 [FINER] Zip found.
    2011-08-04 20:56:01 [INFO] Done.
    2011-08-04 20:56:01 [INFO] ItemCraft 1.6.4
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/paperlantern.png,30). 87 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/bonelantern.png,54). 86 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/ironlantern.png,76). 85 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/chain.png,77). 84 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/cage.png,78). 83 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay1.png,85). 82 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay2.png,100). 81 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay3.png,101). 80 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay4.png,106). 79 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay5.png,107). 78 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay6.png,108). 77 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay7.png,109). 76 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsclay8.png,110). 75 left.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/fancypack/uncookedcrafts.png,38). 131 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone1.png,111). 74 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone2.png,125). 73 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone3.png,126). 72 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone4.png,127). 71 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone5.png,136). 70 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone6.png,137). 69 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/craftsbone7.png,138). 68 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/fancystone.png,139). 67 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/pot.png,141). 66 left.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/fancypack/uncookedpot.png,46). 130 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/fancypack/road.png,142). 65 left.
    2011-08-04 20:56:01 [INFO] ItemCraft: ICFancyPack 0.3.2 Loaded.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/mob/BabyAnimals/squegg.png,61). 129 left.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/mob/BabyAnimals/mpotion.png,62). 128 left.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/mob/BabyAnimals/shears.png,85). 127 left.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/mob/BabyAnimals/lasso.png,91). 126 left.
    2011-08-04 20:56:01 [FINER] addOverride(/gui/items.png,/mob/BabyAnimals/tameEgg.png,93). 125 left.
    2011-08-04 20:56:01 [FINER] addOverride(/terrain.png,/mob/BabyAnimals/hay.png,143). 64 left.
    2011-08-04 20:56:01 [INFO] ItemCraft: ICBabyAnimals 0.1 Loaded.
    2011-08-04 20:56:01 [INFO] ItemCraft: ICTranslator 0.1.4 Loaded.
    2011-08-04 20:56:02 [INFO] Preparing level "extra"
    2011-08-04 20:56:02 [INFO] Preparing start region for level 0 (Seed: -3152653086343913231)
    2011-08-04 20:56:03 [INFO] ModLoaderMP Beta 1.6.6v4 Initialized
    2011-08-04 20:56:03 [FINE] ModLoaderMP Beta 1.6.6v4 Initialized
    2011-08-04 20:56:03 [INFO] ModLoaderMP Beta 1.6.6v4 Initialized
    2011-08-04 20:56:03 [INFO] Preparing spawn area: 48%
    2011-08-04 20:56:04 [INFO] Preparing start region for level 1 (Seed: -8989159113414302465)
    2011-08-04 20:56:04 [INFO] Preparing spawn area: 36%
    2011-08-04 20:56:05 [INFO] ClayGen version 1.3 is enabled!
    2011-08-04 20:56:05 [INFO] FlamboyantFlock version 0.2 is enabled!
    2011-08-04 20:56:05 [INFO] Permission system not detected, defaulting to OP
    2011-08-04 20:56:05 [INFO] HomeX enabled.
    2011-08-04 20:56:05 [INFO] [MagicCarpet] MagicCarpet version 1.5.6 is enabled!
    2011-08-04 20:56:05 [INFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet or /mc.
    2011-08-04 20:56:05 [INFO] [MagicCarpet] Anyone can use the Magic Carpet.
    2011-08-04 20:56:05 [INFO] [mcMMO] Using Bukkit Permissions.
    2011-08-04 20:56:05 [INFO] Loading Config File...
    2011-08-04 20:56:06 [INFO] mcMMO version 1.0.49 is enabled!
    2011-08-04 20:56:06 [INFO] [Sortal] Permission system not detected, Open to anyone!
    2011-08-04 20:56:06 [INFO] [Sortal] version 3.6 is enabled!
    2011-08-04 20:56:06 [INFO] WorldEdit 4.6 enabled.
    2011-08-04 20:56:06 [INFO] WorldEdit: No known permissions plugin detected. Using configuration file for permissions.
    2011-08-04 20:56:06 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2011-08-04 20:56:06 [INFO] Done (0.426s)! For help, type "help" or "?"
    2011-08-04 20:56:09 [SEVERE] Exception in thread "AWT-EventQueue-0"
    2011-08-04 20:56:09 [SEVERE] java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    2011-08-04 20:56:09 [SEVERE]     at java.util.LinkedList.entry(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at java.util.LinkedList.get(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at com.asdaarg.bukkit.itemcraft.GUIFrame.tryAdd(
    2011-08-04 20:56:09 [SEVERE]     at com.asdaarg.bukkit.itemcraft.GUIFrame.RefreshContext(
    2011-08-04 20:56:09 [SEVERE]     at com.asdaarg.bukkit.itemcraft.GUIFrame$1.stateChanged(
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.DefaultCaret.fireStateChanged(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.DefaultCaret.changeCaretPosition(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.DefaultCaret.handleSetDot(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.DefaultCaret.setDot(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.DefaultCaret$Handler.insertUpdate(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.AbstractDocument.fireInsertUpdate(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.AbstractDocument.handleInsertString(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.AbstractDocument.insertString(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.PlainDocument.insertString(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.AbstractDocument.replace(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.JTextComponent.replaceSelection(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.text.DefaultEditorKit$DefaultKeyTypedAction.actionPerformed(Unknown Source)
    2011-08-04 20:56:09 [SEVERE]     at javax.swing.SwingUtilities.notifyAction(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at javax.swing.JComponent.processKeyBinding(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at javax.swing.JComponent.processKeyBindings(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at javax.swing.JComponent.processKeyEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Component.processEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Container.processEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Component.dispatchEventImpl(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Container.dispatchEventImpl(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Component.dispatchEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Component.dispatchEventImpl(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Container.dispatchEventImpl(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Window.dispatchEventImpl(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.Component.dispatchEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue.access$000(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue$ Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue$ Source)
    2011-08-04 20:56:10 [SEVERE]     at Method)
    2011-08-04 20:56:10 [SEVERE]     at$1.doIntersectionPrivilege(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at$1.doIntersectionPrivilege(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue$ Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue$ Source)
    2011-08-04 20:56:10 [SEVERE]     at Method)
    2011-08-04 20:56:10 [SEVERE]     at$1.doIntersectionPrivilege(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventQueue.dispatchEvent(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    2011-08-04 20:56:10 [SEVERE]     at Source)
    2011-08-04 20:56:14 [INFO] Stopping the server..
    2011-08-04 20:56:14 [INFO] Stopping server
    2011-08-04 20:56:14 [INFO] ClayGen is disabled!
    2011-08-04 20:56:14 [INFO] HomeX disabled.
    2011-08-04 20:56:14 [INFO] Magic Carpet disabled. Thanks for trying the plugin!
    2011-08-04 20:56:14 [INFO] mcMMO was disabled.
    2011-08-04 20:56:14 [INFO] [Sortal] Disabled!
    2011-08-04 20:56:14 [INFO] Saving chunks
    2011-08-04 20:56:14 [INFO] Stopping server
    2011-08-04 20:56:14 [INFO] Saving chunks

    I also get the message it can't find 'mcpet'.
    But that me because of this error.
    This is my plugins.ic:
    Show Spoiler

    false setPacket230OnLogin
    "itemVineBranch" 7425 setID
    "itemFertilizer" 7420 setID
    "itemBanana" 7422 setID
    "itemBananaGreen" 7423 setID
    "itemBananaCake" 7424 setID
    "blockTopiary" 153 setID
    "blockPalmLeaves" 154 setID
    "blockPalmTrunk" 155 setID
    "blockPalmSapling" 156 setID
    "blockBanana" 157 setID
    "blockBananaCake" 158 setID
    "blockLeavesGeneric" 159 setID
    "blockLogGeneric" 160 setID
    "blockLeavesFruit" 161 setID
    "blockAppleFlower" 163 setID
    "blockAppleFFlower" 164 setID
    "blockAppleSapling" 165 setID
    "blockCherrySapling" 162 setID
    "blockVines" 152 setID
    "oldscript.ic" includeold
    ## Uncomment Plugins you want to use:
    #"ICKSlopes.jar" plugin
    "ICFancyPack.jar" plugin
    #"ICMCreatures.jar" plugin
    "ICBabyAnimals.jar" plugin
    #"ICSGlass.jar" plugin
    #"ICNTrees.jar" plugin
    #"ICJanino.jar" plugin
    #"ICJode.jar" plugin
    "ICTranslator.jar" plugin
    "mcpmet" "C:\\Modtranslating\\methods.csv" putSetting
    "mcpfie" "C:\\Modtranslating\\fields.csv" putSetting
    "classmap" "C:\\Modtranslating\\classmap.csv" putSetting
    "kedamet" "C:\\Modtranslating\\kedamet.csv" putSetting
    "kedafie" "C:\\Modtranslating\\kedafie.csv" putSetting
    "retrosource" "C:\\Modtranslating\\java\\" putSetting
  19. Offline


  20. Offline


  21. Offline


    I am having issues with the installation of this plugin. My server is hosted at xenonservers, i do not have access to changing the .bat running the server. I tried deleting the Meta-inf in the craftbukkit snapshot and replacing it with the one in ItemCraft. Then i put itemcraft in the main directory, then i tried it in the plugin directory. The folder is not created and i cannot login to my server. Is there anyway for me to install this plugin?
  22. Offline


    Hey guys I'm new and clueless. I started a week ago...and made my own hamachi craftbukkit server. After countless hours or trying to get it to work I finally got itemcraft to work! So i decided to get superslopes...which works single player...but not so much in my server. 1000 bukkit, 1.7.3, and ive installed modloader, modloadermp, and the 16bit thing to my client. i correctly installed the mod as well. ive had many errors with java....but most recently i got this one:
    2011-08-04 19:38:11 [SEVERE] java.lang.RuntimeException: ModLoader has failed to initialize.
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.ThrowException(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.init(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.Init(
    2011-08-04 19:38:11 [SEVERE] at com.asdaarg.bukkit.itemcraft.ICInit.init(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    2011-08-04 19:38:11 [SEVERE] at
    2011-08-04 19:38:11 [SEVERE] at
    2011-08-04 19:38:11 [SEVERE] Caused by: java.lang.RuntimeException: Exception occured in ModLoader
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.ThrowException(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.ThrowException(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.addMod(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.readFromModFolder(
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.init(
    2011-08-04 19:38:11 [SEVERE] ... 5 more
    2011-08-04 19:38:11 [SEVERE] Caused by: java.lang.ClassNotFoundException: net.minecraft.server.mod_Kaevator_Corners
    2011-08-04 19:38:11 [SEVERE] at$ Source)
    2011-08-04 19:38:11 [SEVERE] at Method)
    2011-08-04 19:38:11 [SEVERE] at Source)
    2011-08-04 19:38:11 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-08-04 19:38:11 [SEVERE] at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    2011-08-04 19:38:11 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-08-04 19:38:11 [SEVERE] at net.minecraft.server.ModLoader.addMod(
    2011-08-04 19:38:11 [SEVERE] ... 7 more
    2011-08-04 19:38:11 [SEVERE] Unexpected exception
    java.lang.RuntimeException: ModLoader has failed to initialize.
    at net.minecraft.server.ModLoader.ThrowException(
    at net.minecraft.server.ModLoader.init(
    at net.minecraft.server.ModLoader.Init(
    at com.asdaarg.bukkit.itemcraft.ICInit.init(
    at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.RuntimeException: Exception occured in ModLoader
    at net.minecraft.server.ModLoader.ThrowException(
    at net.minecraft.server.ModLoader.ThrowException(
    at net.minecraft.server.ModLoader.addMod(
    at net.minecraft.server.ModLoader.readFromModFolder(
    at net.minecraft.server.ModLoader.init(
    ... 5 more
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.mod_Kaevator_Corners
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at net.minecraft.server.ModLoader.addMod(
    ... 7 more
    I have no idea why ModLoader isn't initializing...and it didn't before. I obviously messed something up but I have no clue what it is. Can someone please help me? Or message me your working craft bukkit server with itemcraft and superslopes working. Thanks in advance
  23. Could the minecraft forge be of any help maybe ?
  24. Offline


    please help me. i get this error java.lang.NullPointerException
    at nb.a(SourceFile:465)
    at jm.a(SourceFile:62)
    at pf.b(SourceFile:279)
    at nb.a(SourceFile:119)
    at vx.a(SourceFile:44)
    at net.minecraft.client.Minecraft.k(SourceFile:1302)
    at Source)
  25. Offline


    Will Itemcraft ever work with Bukkit 1000?
  26. Does it not ?
  27. Offline


    yes it does? im running it on bukkit 1k

    as for the modsaver crashes go into your itemcraft.jar go to net-minecraft-server and delete the world.class itll fix wrenches but disable teleporters and chest
  28. Offline


    How do you get the jumppad's to work correctly? When ever i use one the server teleports you back the the spot you were in before you got on it. It says you moved wrongly... help please XD?!?
  29. Offline


    You have to put all the line like "mcpmet" blah blah before the line "ICTranslator.jar" plugin. ;)
  30. Offline


    Are you using the newest Version? (0.3)

Share This Page