[MECH] CraftBook - Redstone bridges, gates, minecarts, ICs, more [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 27, 2011.

  1. Offline


    CraftBook adds a number of original gameplay elements to Minecraft from switchable bridges to elevators to gates (including flood gates)! It also has redstone support, allowing you to wire up pumpkins and use integrated circuits!

    Some cool stuff people made last year:

    • Mechanisms
      • Bridges
      • Doors *not yet ported*
      • Gates
      • Elevators
      • Cauldrons
      • Light switches
      • Readable bookshelves
      • Toggle areas (advanced toggle doors and bridges)
      • Hidden switches
      • Custom block drops
      • Apple tree drops
      • Bookshelf drops
      • MORE!
    • Redstone
      • Integrated circuits
      • Programmable logic chips
      • Redstone pumpkins
      • Redstone netherstone
      • Ammeter
      • MORE!
    • Minecart features
      • Booster blocks
      • Brake blocks
      • Reverse blocks
      • Ejector blocks
      • Chest-storage minecart transfer blocks
      • Station blocks
      • Sort blocks
      • Message announcer block
      • Minecart dispensers
      • Change minecart behavior
      • MORE!

    CraftBook is being developed again, although by someone else. Get the latest downloads here: http://dev.bukkit.org/server-mods/craftbook/

    [​IMG] (CraftBook is open source!)
    kazeen, dragon8510, Jaein and 45 others like this.
  2. Offline

    John Hoffmann

    hello all, i am having same exact problem chickenmove is having. I extracted all files into my plugin folder. What happens is when i go to create, lets say the mob spawner thing with the sign, i put the sign down on the face of a block and i use the default sign layout that all tutorials show which im pretty sure is *first line*= blank *second line*= [MC1200] *third line*= mob type and wire the front of the sign to a button facing the redstone wire. and nothing happens, nothing happens to the sign either (no text is automatically inserted on the first line like i thought was supposed to happen.) The thing is, i know the plugin is there and half functional because i can wire netherrak to a lever and it will trigger the netherrak on and off. I am using craftbukkit version #487. (i have the startup console as a code on this post, i do realize an error, but i also realize the error has to do with essentials, which works with or without error)

    13:10:26 [INFO] Starting minecraft server version Beta 1.3
    13:10:27 [INFO] Loading properties
    13:10:27 [INFO] Starting Minecraft server on
    13:10:27 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-487-
    g108eceb-b484jnks (MC: 1.3)
    13:10:27 [INFO] Preparing level "world"
    13:10:27 [INFO] Preparing start region
    13:10:28 [INFO] Preparing spawn area: 36%
    13:10:29 [INFO] CraftBookCommon 3.0-alpha1 enabled.
    13:10:29 [INFO] CraftBookCircuits 3.0-alpha1 enabled.
    13:10:29 [INFO] CraftBookCircuits: Default configuration file written: custom-ic
    13:10:29 [INFO] CraftBookMechanisms 3.0-alpha1 enabled.
    13:10:29 [INFO] CraftBookMechanisms: Default configuration file written: books.t
    13:10:29 [INFO] CraftBookMechanisms: Default configuration file written: cauldro
    13:10:29 [INFO] CraftBookVehicles 3.0-alpha1 enabled.
    13:10:29 [INFO] CraftBookVehicles: Default configuration file written: config.ym
    13:10:29 [SEVERE] null
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
            at com.earth2me.essentials.Essentials.loadData(Essentials.java:283)
            at com.earth2me.essentials.Essentials.reload(Essentials.java:184)
            at com.earth2me.essentials.Essentials.onEnable(Essentials.java:121)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    13:10:29 [INFO] ºeLoaded Essentials build 2.0.262 maintained by Zenexer, emental
    o, Aelux, Brettflan, KimKandor, and snowleo
    13:10:29 [INFO] Loaded EssentialsChat build 2.0.263 by Zenexer, ementalo, Aelux,
     Brettflan, KimKandor, and snowleo
    13:10:29 [INFO] Loaded EssentialsHelp build 2.0.263 by Zenexer, ementalo, Eris,
    and EggRoll
    13:10:29 [INFO] Loaded EssentialsHome build 2.0.263 by Zenexer, ementalo, Aelux,
     Brettflan, KimKandor, and snowleo
    13:10:29 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 10
    13:10:29 [INFO] GroupManager version 1.0(pre-alpha-3) is enabled!
    13:10:29 [INFO] Fake Permissions version 2.5 is enabled!
    13:10:29 [INFO] [HeroicDeath] enabled.
    13:10:29 [INFO] LoginMessage 0.5_4 enabled
    13:10:29 [INFO] PlgNoHealth version 4.0 is enabled!
    13:10:29 [INFO] PvP Control version 1.4 is enabled!
    13:10:29 [INFO] RedstoneChips: Loading  > adder, and, clock, counter, demultiple
    xer, divider, flipflop, multiplexer, multiplier, or, pisoregister, print, random
    , receiver, shiftregister, transmitter, xor, decoder, encoder, pixel, pulse, not
    , synth, srnor, terminal, router, ringcounter, iptransmitter, ipreceiver, compar
    ator, delay.
    13:10:30 [INFO] RedstoneChips: Loading  > photocell, pirsensor, rangefinder, day
    13:10:30 [INFO] RedstoneChips: 0 active circuits
    13:10:30 [INFO] RedstoneChips 0.82 enabled.
    13:10:30 [INFO] WorldEdit 4.0-beta8 enabled.
    13:10:30 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    13:10:30 [INFO] Done (0.311s)! For help, type "help" or "?"
    13:12:47 [INFO] 143 recipes
  3. Offline


    Hey, I need some help. I recently installed CraftBook to my server (I have WorldEdit as well) but I can't do anything that CraftBook is supposed to do. For example I wanted to make a netherstone incenerator with redstone, but It wouldn't work. I know that option is set to off by default, but I don't have the craftbook.properties file. I think that was removed so I have no idea how to configure anything. I have also tried the [MC1200] sign and the /bridge command but nothing happened... So how can I turn the CraftBook features on?

    P.S. I installed it correctly (I think)
  4. Offline


    it dusnt work by my server freaks out and in the server panel its saying 100 times in a second something about redstones and redstone torches ?? can someone help ???
  5. Offline


    IC's aren't ported yet.
  6. Offline

    John Hoffmann

    hahaha i was 2 seconds away from saying derp, i just read his blog and was gonna post nvm but u did it for me, thanks for the response though.
  7. Offline


    Does anyone else have a problem with the crafbook/worldedit commands not showing up when typing /help? When I do I just get the default help menu. The commands and features are working, they are just not showing up in the help menu. I'm not sure if this hasn't been ported over yet or something is up with my install, any help would be much appreciated.
  8. Offline


    I don't know if you can't read, or if you're incredibly stupid.
    You shouldn't be running the actual SERVER on your computer, Minecraft itself is fine to run, the server just kills your RAM when running with Minecraft.
  9. Offline


    @Lokiman72, I think what he's trying to say between the petty insults and smug sense of superiority is that dedicated servers (such as a paid hosting service) are preferable to home PCs-turned-into-servers. That's true, for the most part -- but it doesn't take into account every player's needs. For example, your PC makes a great test server for making plugins work together.
  10. Offline


    Neither pumpkin powering, lifts or bridges are working for me. I've tried removing them and replacing them, but still no luck.
    Haven't tried anything else than minecart boosters and they work flawlessly.
  11. Offline


    if you mean i play and run it on the same computer, i dont
    --- merged: Mar 6, 2011 10:35 PM ---
    i dont want a extremely dedicated server, i just a want a server where i can play with some friends and see how fun it can get, i am not trying to be a famous server hoster, nor do i pay money to run this server, i jusy enjoy playing as an admin, also i fixed my problem by reading a solution of getting by without worldedit in commandbook
  12. Offline

    Peter Veldman

    I don't have any problems running both on my computer... Therefore i think your statement is false. It really all depends on the ammount of ram and users.
  13. Offline


    Somehow it just started working again.

    Anyhow, I just wondered when you plan to add a config file for bridges. Would be nice to have custom material ones again.
  14. Offline


    My Mob spawners don't work [​IMG]
  15. Offline


    ...Really? He said a bunch of times that ICs havent been ported yet. Infact it says that in the title, its ignorant people like you that piss me off.
  16. Offline


    lol... while i find it kinda odd as well that people don't check the plugin details to see what really works, it's rude people like you that scare people away from posting real bugs.

    *not guna continue with this discussion here*
  17. Offline


    ima creeper [​IMG] and ima waiting for those IC ported [​IMG]
  18. Offline


    There are more [​IMG] waiting to blow up the IC's, we just have to be patient.
  19. Offline


  20. Offline


    I just want me some area toggles and I will be golden :)
  21. Offline


    Is there permissions?

    I would like users to only use a certain things ;(
  22. Offline


    Nothing about the bridge not working after unloading chunks ?
  23. Offline


    I have worldguard and worldedit
    but it not works -.-
    cant make door or signs with MC codes -.-
  24. Offline


    Hmm, boost blocks ain't working? I place gold block and create track on it, but it doesn't affect any way. Also CB aren't saying in chat that usual "Boost block created" stuff. I checked the configs and boost blocks are set to block 41, so it should be working. There isn't any errors in serverlog and craftbook seems to load perfectly without any errors.
  25. Offline


    I guys, I'm new here, I saw a lot of youtube video about craftbook, and I tried to do doors, hidding switches, light switches, cauldron, mob spawner,.. but it doesn't work ... Bridge, Gate, Lift, etc work fine.
    Can you help me ?
  26. Offline


    you guys are awesome!
    i cant wait to have the ICs working. especially the wireless ones :)

    as soon as ive got my new bank account ill give you some $$$$$$€€€€€€€

    @ Kossusukka
    ive experienced the same... but they are working as soon i /reload or restart the server, give it a try[​IMG]
  27. Offline


    Read. The. Frickin. Title.
  28. Offline


    Hiya, this mod is AWESOME. I love the gates and elevators and, though I haven't tried the other things yet, the minecarts/circuits etc sound like they'll be awesome.

    One thing though; is there a way to turn off the chat spam? I mean, when I was gleefully clicking my gate's button in a spastic spamtastic frenzy, I realized I couldn't really see the left half of my minecraft behind all that chat spam. "Gate toggled gate toggled gate toggled".

    Otherwise, sooooo cool.
  29. Offline


    They haven't been officially released yet on here. :)
  30. Offline


    Ok, if I understand good, I must wait for this functions !?
    (sry for bad english XD)
  31. Offline



    Booster blocks work flawlessly for me.
    Try /reload or something, as StUffzENra suggested.

Share This Page