Inactive [MECH] CommandSigns v1.2.0 - Issue commands using signs[1317]

Discussion in 'Inactive/Unsupported Plugins' started by HansAnderson, Aug 26, 2011.

  1. Offline

    HansAnderson

    CommandSigns:
    Version: v1.2.0

    This plugin is a complete rewrite of CommandSigns based off the original by Edward Hand. With CommandSigns, you can add invisible text or commands to signs. When the sign is right clicked, the command runs and/or the player gets a message.

    The /* feature of this plugin will not work properly with PermissionsExtended (PEX).
    There is a small issue where PEX doesn't utilize the permissions.yml from the root server folder.
    It has been tested with PermissionsBukkit and bPermissions.

    Features:
    • Run commands from signs
    • Signs can have any other text on them, the commands are linked to the sign behind the scenes
    • Uses a new permissions node so that players can use commands they wouldn't normally have access to!
    How to use:
    1. Place a sign, add any writing you want
    2. Add lines to your clipboard with /commandsigns line<number> <text>
    3. Right click a sign to make it a CommandSign
    Commands:
    Code:
    /commandsigns line<number> <text>
      - Add a line with one command (see Command Formatting). Number may be 0-9
    
    /commandsigns read
      - Read a CommandSign (the command lines associated with it)
      - Note: You need permission to create a sign in order to read
    
    /commandsigns copy
      - Copy a CommandSign to clipboard (the command lines associated with it)
      - Note: You need permission to create a sign in order to read
    
    /commandsigns clear
      - Clear your CommandSigns clipboard
    
    /commandsigns remove
      - Remove a CommandSign
    Command Formatting:
    In the place of <text> for a line, you may write a single command or sign formatting (such as @group). There are 10 total lines for separate commands or sign formatting. See Examples.
    Code:
    /command
      -  Runs a command from the player who clicked the sign
    /*command
      - Runs command with elevated permissions from the 'CommandSigns.permissions' node
      - Doesn't work for OP commands like /stop
      - (For WorldEdit //wand, use /*/wand)
    @group
      - Limits the sign use to only that group
      - **Check the permissions section below for usage!**
    \message
      - Print the message to the player's chat
    <NAME>
      - Replaced in the command by the player's name
    <X>/<Y>/<Z>
      - Replaced in the command by the player's x, y, or z coordinates
    Examples:
    examples (open)
    Code:
    /commandsigns line0 \say Hello server! <NAME> just logged on.
      - "Hello server! <playername> just logged on."
    
    /commandsigns line0 \You just clicked
    \commandsigns line1 \a sign!
      - "You just clicked
          a sign!"
      - (Message sent to the  player who clicked)
    
    /commandsigns line0 /*warp point1
      - Warps the player to point1
      - (If the /* nodes are set up correctly)
    
    /commandsigns line0 @mods
    /commandsigns line1 /*warp point1
      - Warps the player to point1 only if they have the 'CommandSigns.group.mods' permission node
      - (If the /* nodes are set up correctly)

    Permissions:
    permission nodes (open)
    Code:
    'CommandSigns.*'
      - All permissions
    
    'CommandSigns.create.*'
      - All create permissions
    
    'CommandSigns.create.regular'
      - Create signs without /* commands
    
    'CommandSigns.create.super
      - Create signs with /* commands
    
    'CommandSigns.remove'
      - Remove CommandSigns
    
    'CommandSigns.use.*'
      - Use all signs
    
    'CommandSigns.use.regular'
      - Use signs without /* commands
    
    'CommandSigns.use.super'
      - Use signs with /* commands
    
    'CommandSigns.group.<group>'
      - Replace<group> with the group name from @group
      - Allows use of signs with the matching group name
    
    'CommandSigns.group.*'
    - Allows use of all @group signs

    In your permissions.yml (in main server folder) create parent node 'CommandSigns.permissions' and attach children nodes from plugins you want to give permissions for when using the /* prefix.
    permissions.yml example (open)
    Code:
    CommandSigns.permissions:
        children:
            warp.go: true
    Now using /*warp <somewhere> on a sign will allow a player who doesn't normally have access to the /warp command to use the sign.

    Download CommandSigns
    Source

    Changelog:
    Version 1.2.0
    • Only one command per line now (commands can have many more syntax options)
    • Added ability to copy a CommandSign text to 'clipboard'
    • Fixed 'CommandSigns.group.*' permission node
    Version 1.1.0
    • Now supports all superperms permissions plugins!
    Version 1.0.1
    • Fixed a missing permissions node from the plugin.yml
    Version 1.0.0
    • Initial release

    I wanted the functionality of the old plugin, but the /* feature was broken. After becoming frustrated trying to figure out and update Fluff's version, I went back to the original and completely rewrote it. This is really my first plugin and Java experience.

    If this is not an acceptable submission, that is fine. I wrote it for my server and don't have time to go nuts adding features we don't need. However, I saw many people also wanted the /* feature, so I shared my work.

    I'm open to changing the name to something different, or withdrawing the submission. My main goal was to make this available to anyone who wants to use it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 19, 2016
  2. Offline

    HansAnderson

    @micmulca
    I tried, but PEX has it's own permissions API. CraftBukkit specifically created an API so that it wouldn't be a chaotic mess of hooking into several different permissions plugins.
     
  3. Offline

    Shalobee

    does anyone have problems running this with MCDocs commands? It used to work beautifully in the old one but now it does nothing except show in the console that i tried taht command but it looks different than when i do it by typing it:

    here is command by itself typed:
    Code:
    22:02:11 [INFO] MCDocs: Shalobee: /rules
    
    and here is from the commandsign:
    Code:
    22:03:23 [INFO] [PLAYER_COMMAND] Shalobee: /rules
    
    so it looks like its maybe the way mcdocs interrupts the command. Would there be a way to add support for MCDocs my rules and feature board rely on this pretty heavily.
     
  4. Offline

    micmulca


    @HansAnderson
    Yeah I completely understand that haha
     
  5. Offline

    Emphytos

  6. Offline

    ItsQ

    Iconomy Suport?

    So i can ask money for the use of the sign?
     
  7. Offline

    lipe123

    @Emphytos
    Dude permissions 3.1.6 is DEAD first of all and like the auth said many times now it only works with bukkits own permisisons API.
     
  8. Offline

    holst1000

    hmm, if i restart the server it dont save the signs, and i have to write commands to them. again.
     
  9. Can you make that it too work with plates and buttons ?
    And that you can make more line in one sign
     
  10. Offline

    HWDexperte

    I can't make a Signmessage with "/commandsigns line0 \&4Hallo" ...
    I use Essentials with all components or extras ...
    it dosen't work :(

    Please can you Help me (us) ?
    (sorry about my bad English, I'm German... :D)
     
  11. Offline

    Emphytos

    Ok, I've a new problem.
    I install PermissionsBukkit and I run my local server, I can create a command but when I right clic he says:
    "You don't have the permissions to do that"

    I really don't understand because if I can create a command I can use the command with the sign no ?

    My config.yml in Plugins/PermissionsBukkit
    Code:
    users:
        Emphytos:
            permissions:
                permissions.*: true
            groups:
            - admin
    groups:
        default:
            permissions:
                permissions.build: false
        admin:
            permissions:
                permissions.*: true
                CommandSigns.*: true
                CommandSigns.use.*: true
                command.*: true
                essentials.*: true
            CommandSigns.permissions:
                children:
                    jobs.*: true
            inheritance:
            - user
        user:
            permissions:
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
     
  12. Offline

    tehbeard

    @Emphytros
    CommandSigns.permissions does not go there.

    it goes in the permissions.yml, same folder as craftbukkit's jar. not your permissions plugins configs
     
  13. Offline

    HansAnderson

    @Shalobee
    I might be able to look into it... but I'd have to say that it'd be low of the priority list. That's a pretty specific issue, and I'm not sure why it would make a difference. It should run the command basically the same as if you typed it in.

    @ItsQ
    That is a definite future feature.

    @holst1000
    That's an odd issue. There might be some reason the computer isn't allowing creation of a new file/folder.

    @DarkMinecrafter
    Plates and buttons are a possibility if this goes from just signs to general blocks. Except that those wouldn't just be right click, those would be activated devices... I'll give it some thought.
     
  14. Offline

    Emphytos

    Oh thanks.
    But I've the same error

    My config.yml
    Code:
    users:
        Emphytos:
            permissions:
                permissions.*: true
            groups:
            - admin
    groups:
        default:
            permissions:
                permissions.build: false
        admin:
            permissions:
                permissions.*: true
                CommandSigns.*: true
                CommandSigns.use.*: true
                essentials.*: true
            inheritance:
            - user
        user:
            permissions:
                permissions.build: true
            worlds:
                creative:
                    coolplugin.item: true
            inheritance:
            - default
    messages:
        build: '&cYou do not have permission to build here.'
    
    My permissions.yml
    Code:
    CommandSigns.permissions:
        children:
            jobs.*: true
    
    Where is the problem ?
     
  15. When i click on a sign with the line : /*tploc 125 45 -155 than the Plugin say that i have to permissions my permission.yml is:

    Code:
    server.defaultpermissions:
        default: true
        children:
            CommandSigns.use.*: true
            CommandSigns.use.super: true
    CommandSigns.permissions:
        children:
            '*': true
            admincmd.tp.loacation: true
    
     
  16. Offline

    DZeroX

    Could it be because you typed "loacation", instead of "location"?
     
  17. @DZeroX
    I have change it but it dosent work.
    AdminCmd say that i have no permission
     
  18. The /* function not work !
    I have test it with bpermission and the DefaultPermission !

    So can you give me a permission.yml that you plugin have all rights
     
  19. Offline

    Gabriel Gortan

    how do i do to people use the command in the sign but only using the sign and not the chat .
     
  20. Offline

    wooden_dinosaur

    I too am having problems with the /*.
    my command is as follows
    /commandsigns line0 \please work this time.
    /commandsigns line1 /*permissions player setgroup <NAME> mynewgroup
    and then i right click to enable and all seems well.

    But my generic users get the "you do not have permission." I also tried with essentials time command and multiverse spawn command. All use of these signs yielded similar results with these nodes in permissions.yml in root minecraft folder. (each error was that of the individual plugins "not allowed permission" text.)
    permissions:
    CommandSigns.permissions
    children:
    permissions.*: true
    essentials.*: true
    multiverse.core.*: true

    EDIT: Got it to work! i removed the "permissions:" line above CommandSigns.permissions and it worked flawlessly for what i needed in tests!
    Thanks a ton!
    * and my permissions.yml is formatted correctly on my pc as well.
     
  21. Offline

    darker9999

    ...

    Hello. I'm using PermissionsEx. (Oh, just read it doesnt work with PEX ......)

    My permissions.yml (in main folder)
    Code:
    CommandSigns.permissions:
        children:
            permissions.*: true
            consolecommand.cmd: true
    I type :
    Code:
    /commandsigns line1 pex group Miner user add <NAME>
    And it says i havent permissions. Why ?

    Sorry for double post.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 19, 2016
  22. Really? Don't say that too loud, my server will stop working with PEX and this plugin. ;)

    Of course, I've not tried any of the permissions elevation features, but for basic stuff, it's working fine for me.
     
  23. Offline

    Flipbook

    Okay so I set up signs to have commands. They work perfectly. Then when I restart the server the commands on the signs are also resetted. Any help please?
     
  24. Offline

    Qentus

    Hi, i want to change my skin via sign (with plugin http://forums.bukkit.org/threads/fu...yerskins-change-player-appearance-1185.33445/)
    i tried to use /commandsigns line0 /set MYNAME skin http://.....png
    but the url always changes its color to blue and when i hit the sign it happens this:
    Code:
    2011-10-02 13:44:06 [SEVERE] Could not pass event PLAYER_INTERACT to CommandSigns
    org.bukkit.command.CommandException: Unhandled exception executing command 'set' in plugin SpoutPlayers v1.1
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:41)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
        at org.bukkit.craftbukkit.entity.CraftPlayer.performCommand(CraftPlayer.java:178)
        at com.hans.CommandSigns.CommandSignsSignClickEvent.onRightClick(CommandSignsSignClickEvent.java:74)
        at com.hans.CommandSigns.CommandSignsPlayerListener.onPlayerInteract(CommandSignsPlayerListener.java:23)
        at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:314)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:168)
        at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:259)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:592)
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
        at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.UnsupportedOperationException: All skins must be a PNG image
        at org.getspout.spout.player.SimpleAppearanceManager.checkUrl(SimpleAppearanceManager.java:342)
        at org.getspout.spout.player.SimpleAppearanceManager.setGlobalSkin(SimpleAppearanceManager.java:47)
        at nil0bject.spout.spoutPlayers.SpoutPlayerAppearance.refresh(SpoutPlayerAppearance.java:37)
        at nil0bject.spout.spoutPlayers.SpoutPlayerCommands.onCommand(SpoutPlayerCommands.java:80)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
        ... 19 more
    if i type /set MYNAME skin http://.....png - it works fine
    the url is really the right url to the png image

    Can anyone help me?

    Sorry for my bad English.
     
  25. Offline

    Scepheus

    PLEASE ADD SUPPORT FOR GROUPMANAGER! It works EXCELLENTLY with warps but I really need to get a manuadd sign and it wont work for me since I have groupmanager, and I definitely can't give everyone permission to that.
     
  26. Offline

    hiro24

    Was wondering if someone could help me out. I've got this up and running fine on my server, but I want to tie in a worldedit command.. a couple actually... //load and //paste. The problem, if you didn't guess it yet, are the 2 slashes. It just says command not found no matter how I seem to format the lines. No console errors, permission nodes are in there for the commands.. plus I have permissions on my player.. it just doesn't like the double slashes. Is there a certain way I can format the line so it works?
     
  27. Offline

    HansAnderson

    @hiro24
    Interesting... Did you try:
    /commandsigns line0 ///paste

    I hope that works... If not I'll come up with something.
     
  28. Offline

    hiro24

    Nope, just says unknown command, same w/ any way I try to set it up. :(
     
  29. Offline

    Qentus

    @HansAnderson What about my error?

     
  30. can you update for 1240 and add button and plate support pls

    I use bPermission 1.7.3 and my permission.yml is

    Code:
    CommandSigns.permissions:
        children:
            admincmd.*: true
    my world.yml

    Code:
    default: Default
    players:
        Florian:
        - default
        - Member
        HaltStop:
        - default
        - Member
        Maxi2:
        - default
        - Member
        Felix:
        - default
        - Member
        lopali:
        - default
        - Member
        Moritz:
        - default
        - Member
        Maxi:
        - default
        - Member
        Chris:
        - default
        - Member
        - Moderator
        Anna:
        - default
        - Member
        Domi:
        - default
        - Member
        SchaiMon:
        - default
        - Member
        Zreeper:
        - Default
        - Admins
    groups:
        Default:
        - WelcomeGift.receivegift
        Member:
        - backtobody.btb
        - CommandSigns.use.regular
        - CommandSigns.use.super
        - prefix.0.&b[Mitglied]&7
        - bPermissions.build
        - vote.voteyes.Tag
        - vote.voteno.Tag
        - vote.startvote.Tag
        - admincmd.tp.sethome
        - admincmd.tp.home
        - iConomy.access
        - iConomy.payment
        - jail.command.jailpay
        - lottery.buy
        - BetterShop.user.*
        - lwc.create
        - admincmd.tp.to
        - fight.user
        - admincmd.tp.toggle.allow
        - admincmd.server.rules
        Admins:
        - prefix.2.&2[Admin]&7
        - '*'
        - bPermissions.admin
        Moderator:
        - prefix.1.&4[Moderator]&7
        - admincmd.tp.to
        - jail.command.jail
        - jail.command.unjail
        - admincmd.player.fly
    
    An my sign:
    Code:
    /commandsigns line0 /*gm <NAME>
    But it not work :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 19, 2016
  31. Offline

    MintTheFox

    would it be possible to have this support essentials groupmanager? i have tried bPerms and its stupidly overcomplicated and i cant seem to figure a good portion of it out...
     

Share This Page