Inactive [MECH] CommandSigns v0.9 - Issue commands using signs [953]

Discussion in 'Inactive/Unsupported Plugins' started by Fluff, May 5, 2011.

  1. Offline


    CommandSigns v0.9

    Tired of having to type out the same commands again and again? Want to allow your players to use commands only at certain places? Help is at hand!

    Feature Summary
    • Allows chat commands and chat messages to be send on right-clicking a sign.
    • Allows commands to be run on signs that players wouldn't be able to use through chat.
    • Sign usage can be limited to specific players or groups.
    • Supports 'variables' for player name and x,y,z position.
    • Won't allow users to gain access to forbidden commands without permission (secure).
    • Add a cost to use a sign, or a reward for clicking the sign!
    • Limit the number of times a sign can be used.
    • Enable and disable signs without destroying them.
    • Permissions-friendly
    • Developer API available
    User's Guide

    About The Developers

    Want to ensure your bug or suggestion isn't lost in the thread? Post it on our issue tracker.

    Command Summary (open)

    • /commandsign enable - Enables the next command sign you right-click on.
    • /commandsign enable <x> <y> <z> - Enables the command sign at x,y,z in the current world.
    • /commandsign enable <x> <y> <z> [w:]<world> - Enables the command sign in world <world> at x,y,z.
    • /commandsign enable [a:]<alias> - Enables the command sign at the alias.
    • /commandsign enable <uses> - Enables the next command sign you right-click on with a number of uses.
    • /commandsign enable <uses> <x> <y> <z> - Enables the command sign at x,y,z in the current world with a number of uses.
    • /commandsign enable <uses> <x> <y> <z> [w:]<world> - Enables the command sign in world <world> at x,y,z with a number of uses.
    • /commandsign enable <uses> [a:]<alias> - Enables the command sign at the alias with a number of uses.
    • /commandsign disable - Disables the next command sign you right-click on.
    • /commandsign disable <x> <y> <z> - Disables the command sign at x,y,z in the current world.
    • /commandsign disable <x> <y> <z> [w:]<world> - Disables the command sign at x,y,z in world <world>.
    • /commandsign disable [a:]<alias> - Disables the command sign at the alias.
    • /commandsign alias - Right-click on a block to get the alias of its location.
    • /commandsign alias <x> <y> <z> - Get the alias of the location x,y,z in the current world.
    • /commandsign alias <x> <y> <z> w:<world> - Get the alias of the location x,y,z in world <world>.
    • /commandsign alias [a:]<name> - Right-click on a block to set the alias of its location.
    • /commandsign alias <x> <y> <z> [a:]<name> - Set the alias of the location x,y,z in the current world.
    • /commandsign alias <x> <y> <z> w:<world> [a:]<name> - Set the alias of the location x,y,z in world <world>.
    • /commandsign alias remove - Right-click on a block to remove the alias of its location.
    • /commandsign alias remove [a:]<name> - Removes the alias.
    • /commandsign alias remove <x> <y> <z> - Remove the alias at location x,y,z in the current world.
    • /commandsign alias remove <x> <y> <z> w:<world> - Remove the alias at location x,y,z in world <world>.
    • /commandsign alias [a:]<name> [a:]<newname> - Set the alias of the location at <name> to <newname>.
    • /commandsign config - Lists all the configuration nodes.
    • /commandsign config <node> - Lists the configuration node.
    • /commandsign config <node> <value> - Sets the configuration node to the value.
    • /commandsign exec [a:]<alias> - Executes the command sign at the location pointed to by the alias.
    • /commandsign exec <x> <y> <z> - Executes the command sign at location x,y,z in the current world.
    • /commandsign exec <x> <y> <z> [w:]<world> - Executes the command sign at location x,y,z in world <world>.
    Syntax Summary (open)

    • [command] - use on the first line of a sign to define a command sign.
    • **[title] - use on the first line in place of [command] to customise the title of the sign
    • /command - runs a command as the player using the sign
    • /*command - runs a command as the fictional user &CommandSigns
    • /@command - elevates the player's permissions (using the permissions assigned to &CommandSigns) if necessary to run the command
    • @player/group - commands following (up to the next @) are limited to that player/group.
    • \message - prints the message to chat
    • \\message - prints the message to the player
    • <NAME> / <X> / <Y> / <Z> / <I> - replaced with the using players name/x/y/z-coord/current held item id on running.
    • $;<cost1>[;<costN>] where cost is <item id>,<item number> or <item id>:<item data>,<item number> - adds a cost to the sign
    • $$ - break evaluation of a command sign
    Permission Nodes (open)

    • commandSigns.use - Use a command sign.
    • commandSigns.create - Create, enable, or disable a command sign.
    • commandSigns.super - Create, enable, or disable a command sign using /*command, /@command, @player/group, or $.
    • commandSigns.super.cost - Create, enable, or disable a command sign using $.
    • commandSigns.super.elevated - Create, enable, or disable a command sign using /@command.
    • commandSigns.super.fakeuser - Create, enable, or disable a command sign using /*command.
    • commandSigns.super.restricted - Create, enable, or disable a command sign using @player/group.
    • commandSigns.default.<default group name> - A flag stating that the group is the default group.
    • commandSigns.config - Allows a user to manage the configuration.
    • commandSigns.alias - Allows a user to manage aliases.
    • commandSigns.exec - Allows a user to remotely trigger command signs.
    Reporting a Problem (open)
    The following bits of information are helpful to include when reporting a problem:
    1. Bukkit and plugin version.
    2. Excerpt from server log of the failed command usage, preferably with the debug configuration option set to true.
    3. Complete command sign text.
    4. Command sign configuration file.
    5. Name of plugin that the failed command comes from, preferably with a link to the plugin's forum thread.

    Recommended Plugins
    • With Annotate, you can have CommandSigns on practically any block with an almost unlimited amount of room for commands! They can even activate when pressing a button or a pressure plate!
    • With ScrollingMenuSign, your signs can look even nicer while allowing your users to scroll through a menu of commands!

    Download Latest Version
    MD5: 7f4076eea7198f2c0f17cde3f62f7c1f
    Download 0.8.1i - RB 803 and previous
    MD5: 72a60e16bfd775b3d15a03aca70e86e0


    To Everyone Asking For Redstone Support (open)

    Yes, I also think redstone support would be very cool. Unfortunately, there are some major limitations on what you can do with a redstone-controlled sign. You can read about those limitations in this post, and you can read a rationale about why those limitations exist in this post. Given those two limitations, I don't think redstone support is currently a useful feature to add, especially given what Annotate can do for you. (If you disagree, please post on the issue tracker on how you would use redstone support.) In the (not too distant) future, redstone support may will be added in a separate plugin due to the different nature of redstone command signs.

    Change Log
    version 0.9 - See Post
    • If PEX permissions work, this plugin supports it.
    • Economy redone; added Essentials Economy.
    • Localization support added.
    • Added new command: /commandsign exec
    • Events properly unregistered when plugin is disabled.
    version 0.8.13
    • Default groups should work for real.
    Older Entries (open)

    version 0.8.12
    • Added handling for default groups.
    • Added support for command aliases.
    • Added /commandsign config.
    version 0.8.11
    • Fixed @ directive.
    • Fixed '/commandsign disable' bug.
    • Added aliases.
    version 0.8.10
    • Fixed /@ permissions error.
    • Added exception handling for removing permissions from users.
    version 0.8.9
    • Added PEX and Permissions 3.0 support.
    • Added new placeholders: <N> and <I>
    • Fixed bug with regular / commands.
    • Added new directives: $$ and \\
    • Added additional debug messages.
    version 0.8.8
    • Fixed /* and /@ working without permissions support.
    • Fixed Permissions creating new users with the wrong casing.
    version 0.8.7
    • Fixed command sign creation permissions.
    • Added debug configuration option.
    version 0.8.6
    • Added Permissions checks to developer API.
    • Fixed enabling bug with /* and /@.
    • Updated to work with GroupManager and fake Permission plugins.
    version 0.8.5 - See Post
    • Fixed multi-world Permissions bug.
    • Changed @ group directive
    version 0.8.4
    • Removed support for Permissions 3.x
    • Updated to 818
    version 0.8.3
    • Fixed API bug
    version 0.8.2
    • Updated for Permissions 3.x
    version 0.8.1
    • Fixed GroupManager integration
    version 0.8
    • Added /@ to temporarily elevate a user's permissions.
    • Added developer API.
    version 0.7.1
    • Fixed item data bug - for real, this time.
    version 0.7 - See Post
    • Removed SignReadMore support.
    • Added Annotate support.
    • Added more granular permissions for advanced sign creation.
    • Removed a debug message that looked like an error.
    version 0.6.2
    • Fixed enable bug on sign creation.
    • Fixed item data bug.
    version 0.6.1
    • Fixed berating of users who can't create command signs but were just innocently putting up a sign.
    version 0.6
    • Added SignReadMore support.
    version 0.5.1
    • Can no longer place blocks directly on enabled command signs.
    • Fixed @ directive.
    • Changed fake user network code.
    version 0.5 - See Post
    • Added /commandsign commands.
    • Added finite-use signs.
    version 0.4.10
    • Fixed BOSEconomy support
    version 0.4.9
    • Supports BOSEconomy
    version 0.4.8
    • Trimming commands in hopes it fixes some problems.
    version 0.4.7 - See Post
    • Added cost signs.
    version 0.4.6
    • Hackish solution to 'items not showing up in inventory' bug.
    version 0.4.5 - See Post
    • Updated support for GroupManager.
    • Added configuration option to change the display name of the fake user.
    • Added configuration option to allow command parser to understand // commands.
    version 0.4.4
    • Fixed numerous bugs when not using Permissions.
    • Beginnings of an API for other plugin devs.
    version 0.4.3
    • Added configuration file.
    • Fixed chat command bugs.
    • Rearranged code for simpler maintenance.
    version 0.4.2 - See Post
    • BREAKING CHANGE - The fake user is now named &CommandSigns.
    version 0.4.1
    • Fixed for 740
    version 0.4
    • Bukkit team trying to break everything again
    version 0.35
    • Fixed conflict when using <NAME> in commands overriding permissions.
    version 0.3
    • Added NAME, X, Y and Z variables
    • Added permission filter
    • Allowed creation of signs that call commands user would not usually have access to
    • Allowed customisation of [command] to other text.
    version 0.15
    • Bugfix ("Insufficient Permissions" annoyance bug)
    version 0.1
    • Plugin Released
    Dimochka, c_dric, Flipp and 5 others like this.
  2. Feature request:
    Could you pretty please make a config flag true/false for HandsOnly, or something like it. There is an exploit in shop plugins that allow duping food through command signs. Can only do it when you are holding the food while using the shop through a command sign.

    Thus, solution for us would be, to only allow commandsign usage with empty hands.

  3. Offline


    My took me 2 hours to figure it out how to use this. :eek:
    Very nice plugin!
  4. Offline


    Please help me. I want to do a command as the &commandsigns user. So i do [command] the next line /*
    ok now the problem is how do i use world edit with it. the command for copy and paste are // notice the two dashes.
    ive tried /*//copy /*/copy //*copy ///*copy etc. What do i do.

    i found out how to do it......I think? its /*//paste one problem though upon copying 1 block under me(gold) and using the sign to load that schematic in world edit(to try and find the position of &commandsign) i see that while clicking paste on the sign is just plain random it pastes in random direction its as if &commandsigns is moving all over the place in a circular cage. What to do.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  5. Offline


    Getting this error when typing /commandsign latest build 953 and latest build of this.

    23:04:23 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'commandsign' in plugin CommandSigns v0.9
        at org.bukkit.command.PluginCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.NetServerHandler.handleCommand(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(
        at net.minecraft.server.NetworkManager.b(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
        at com.edwardhand.commandsigns.CommandSigns.onCommand(
        at org.bukkit.command.PluginCommand.execute(
        ... 12 more
  6. Offline


    Awesome mod, I made a sign which plays Morrowind theme in my tavern.

    Would be nice if it explicitly notified player upon charging him iConomy credits for using signs.
  7. Offline


    I love the idea for this plugin. Is there a way I can make the signs say whatever I want yet STILL have them run the commands? I couldn't figure out if it was possible by reading this. I would really like to have something along the lines of being able to put a command sign under a normal sign which activates the normal sign (like SimpleSign).

    [Normal Sign]
    [Minecraft Block]
  8. Offline


    As far as I can tell, this works fine with RB 953. Let me know if you find out differently.
    The only way I can see you possibly getting that is if you disable and re-enable the plugin in a strange manner. Don't do that. The next version will guard against this.
  9. Offline


    I get that when I start the server normally and older versions work fine for me, but not newer ones.
  10. Offline


    List your plugins. Are you getting this error when you 1) use /commandsign, or 2) start the server? If #1, then as I said before, the only way you could get that error is if CommandSigns is being disabled and re-enabled in a strange manner. If #2, then you have to be running a plugin that's calling commands in a startup script, and the startup script is running before CommandSigns is enabled. Obviously, that is bad.
  11. Offline


    This error is displayed when the server starts up and /commandsign is used. I did further testing on a second server with just it loaded and it worked fine. Obviously it is conflicting plugins now. I'll give you a list of my plugins so maybe you can figure out what is causing it since I am stumped.
    ChairCraft (2)
    LWC (3)
    MagicCarpet (2)
    mcMMO (3)
    MultiVerse (3)
    NoCheat (1)
    Stargate (7)
    There is my plugin list.
  12. Offline


    is there possibly a way of making a sign do the command to the person who clicks it, not just a player put on the sign? like: [command] /slap <the-player-who-clicks-here>
  13. Offline


    As in?

    /slap <Name>
  14. Offline


    i uploaded this to my plugins directory and got a massive error in my server, causing it to crash...the log file is errored so much i cant even download it properly from my host, it fails to transfer at 10,000,000 bytes due to corruption in the file, it has not only destroyed my server while its on but completly screwed up all my plugins giving sever for everyone, i dont know why or how but this needs to be addressed, that is just a small snippet from wat bit of the log file i could get, but the entrie log file is like that
    i Finaly got the hole log to download and was going to upload it but it exceeds the size limit as you can tell this is a major issue as i deleted and recreated a fresh server log with this its erroring quite horribly
  15. Offline


    Could you possibly bind the command to a false player the game generates like an ai or maybe place a player next to it with generated player data and run commands through that and remove the player? Some complex sounding code but might be possible. I know nothing about java but that sounds like it could work.
  16. Offline


    hey fluff, i couldn't get it to work. Every time i tried to make a sign it would say u do not have permissions to enable this sign! could u plz make a tut video for me and post it?

    Or can someone else show me how plz?
  17. Offline


    the only node that wont work is - 'commandSigns.use' no matter what it wont work.

    i want to run the command //load stage1 and //paste but using the /@ i know it works because ive tried /* before that command and it worked, only prob is that the fake player never standsin one spot, he moves all over the place making for an improper paste. So what i want is to run /@/load stage1 and /@/paste -o but for some reason i put the node commandsigns.use and it just wont recognize it, no matter what. Ive done all i can but thats the only thing it wont register.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  18. Offline


    /@ should work fine. It's /* that would be a problem, since the fake player can be pretty much anywhere. When using WorldEdit pasting, I always use the -o option to paste the object right back where it was before.
  19. Offline


    well does &CommandSigns have permissions
  20. Offline


    Wow honestly I can't begin to describe how frustrated I am at this point. I spent over 1 hour re-doing and trying different options and syntax.

    I use PermissionsEX and want a sign to promote guest users to builders after they completed a test. Set everything up.
    User &CommandSigns is in the admin group with '*' permission
    guests have commandsigns.use node
    syntax I tried:
    **[promote me]
    /@pex promote <

    All I get is: [INFO] Unknown console command. Type "help" for help. in my server.log when im a guest.
    When im admin and rightclick it I get: [SEVERE] Ranking Error (Lipe123 > <): User are not in this ladder - which means the sign should work but for some reason it doesnt work for guests at all.

    Could you please do a more complex example than a "hello world" on your wiki?
  21. Offline


    Hi, sorry for stupid question but does it can handle commands on leftclick?
  22. Offline


    I'm having an issue where, with Permissions v3.1.6 and CB 953, every time I put &CommandSigns as a user into user list and start the server,
    So this:
            groups: []
            - essentials.warp
            - essentials.warp.list
            - essentials.warp.*
            - -essentials.warp.rasberry
    Is replaced with this:
        :   groups: []
            - essentials.warp
            - essentials.warp.list
            - essentials.warp.*
            - -essentials.warp.rasberry
  23. Offline


    @JesterB Try putting ' around &CommandSigns

    @Fluff Were you ever able to figure out my issue I had posted about earlier?
  24. Offline


    Kindof got it working..

    Needed to add modifyworld.interact.* to the group

    Still some issues,
    1. The @g:guest group filter does not work or I'm not sure where to put it, I tried before and after the command.
    2. Anyone with build permissions can break the signs, this is somewhat of a big downfall.
  25. Offline


    I got a little problem:
    When any of my players are using a commandsign, they get the rights defined for &CommandSigns permanently written into their PermissionsEx -permissions, making them admins.
    Anything i could have done wrong?
    Thanks in advance
  26. Offline


    CommandSigns and Annotate are insanity.

    Just did something amazing with it, it will be on youtube soon. PREPARE FOR AWESOMENESS.
  27. Offline



    Would be wonderful if you could add a config option to require an empty hand to use a command sign.
  28. Offline


    You have no idea how much AWESOME you've released into my world! At the end of my dongeons, I've added a final boss; a Giant! And now, using this pluggin along with annotations, the Giant only spawns when the player enters the room!!! Also, using citizens, I've set times for pirate attacks on my user's village. I used to only be able to use the time-command pluggin, but now with this, I can easily summon 10-20 NPCs and have them attack my town:D Many thanks, and kudos to you![zombie]
  29. Offline


    Bukkit 953 Plugin v0.9
    Console output, command appears fully formed in the console but is not executed. (If debugging output is badly needed can enable it, but on a busy server trying to get a chunk to paste with more than the lines req is a task to avodied)
    /*jail <NAME> works as intended
    /@jail <NAME> outputs to console with no reaction -no insufficient permissions text

    Trying to make a stock exchange where players who dont have acces to the commands in Stocks can use the /@ command to trade in stocks. Admins can run the stocks fine, no one clicking on the signs who isnt admin gets a response from the plugin or server.
    /@stocks buy <market name> <amount/"max">

    The fake user /CommandSigns is promoted to admin (Oldfakeuser set to true), '&CommandSigns' causes server implosion on launch due to improper formatting of essentials groupmanagers users.yml. This appears to be HeroChat and group manager duking it out over the & symbol (changes colour codes). The rest of the config is default.

    Any help appreciated, Good work on an amazing Plugin, running this in conjunction with CommandHelper makes it unstoppable.
  30. Offline



    I have been using commandsigns for a lot of things. It is fantastic. I have built rows of signs for running worldedit commands to make empty dungeons.

    I have created some signs that have stopped working. Not sure what update(s) could have caused it to stop working, but the signs are like:

    1. [command]
    2. /*addmember
    3. Battle <NAME>

    1. [command]
    2. /*delmember
    3. Battle <NAME>

    These do not work any more. I can replace the * with @ and it works for me only.

    /addmember and /delmember are MCMA commands to add/remove someone to a group.

  31. Offline



Share This Page