Inactive [MECH] bLift 1.2 - Simple elevators [1.2.5]

Discussion in 'Inactive/Unsupported Plugins' started by Brad811, Jun 15, 2011.

  1. Offline


    bLift - Simple elevators!
    Download: bLift BukkitDev
    If you like the work I've done, or would like to see more features and improvements, please consider donating!
    Version: v1.2

    If you are having issues with this plugin,

    FIRST: Read the thread to make sure your question has not been answered.
    SECOND: If you can't find an answer, file a ticket:
    If you would like to post your question instead for some reason, in your post please include:
    1. The version of this plugin you are using (the output of /version bLift, not "the latest one")
    2. The version of bukkit you are using (not "the latest one")
    3. Any error messages associated with the issue
    Otherwise I will most likely be unable to help you!

    Some simple elevator action. It's only called bLift because bElevator sounds weird.
    If y'all like it, I'll add more features like multiple floors and being able to put torches in your elevators!

    Simple 2-floor elevator:

    Multi-floor elevator:
    _____BOTTOM FLOOR________MIDDLE FLOORS_________TOP FLOOR______

    You can get fancy with it:

    Video: (NOTE: gold blocks are no longer required)

    • simple up-down elevators
    To use a simple 2 floor elevator, press the button to move between the floors.
    To make a 2 floor elevator up only, remove the button in the top floor.
    To make a 2 floor elevator down only, remove the button in the bottom floor.

    To use a multi-floor elevator, first initiate the signs by right clicking any one of them (this only needs to be done once).
    The top number is the current floor. The bottom number is the destination. You may fill in the other two lines with anything if you like.
    Right click the sign until the bottom number says the floor number you want to go to.
    Then press the button to go to that floor.

    [air] = air
    [iron] = iron block
    [glass] = glass
    [brownmushroom] = button
    [wood] = sign

    Simple 2 floor elevator format:
    [air] \
    [air] (any height)
    [air] /

    Multifloor elevator format:
    [air] \
    [air] (any height)
    [air] /
    [air] \
    [air] (any height)
    [air] /


    • Now goes up to level 256!
    • Floors can now be smaller (one floor's ceiling can be another floor's bottom)
    • Added command: /blift [floors OR ends] [material] (uses permission "blift")
    • Hopefully fixed a couple of glass disappearing problems
    • Added multi-floor elevators
    • Fixed glass disappearing
    • Removed gold block requirement
    • Initial release!
    tobmaster3000, croxis, Omen and 5 others like this.
  2. Offline


    Plugin updated to 1.2, check bukkitdev for details!
  3. Offline



    I got ur newest one in 2060. Cnat get to work.



    also no config folder generates

    Attached Files:

  4. Offline


    Please stop spamming this thread.
    1. Your elevator is not built correctly. You have an extra block of air above some of your signs. Also, to use dirt instead of glass you must make sure you have used the command "/blift floors dirt".
    2. The only permission associated with this plugin is "blift" which allows you to change the materials used for the ends and floors of the elevator (glass being the default floors, iron being the default ends).
    3. There is no config folder associated with this plugin in this release.
    4. In the future, please use the tickets system on bukkitdev.
  5. Offline


    i didnt spam i posted pics as examples to help show there just big.
    perms is what just blift or blift.*
    and i cant stand the dev site cuz i there is no alert system except for email

    ty though i will try again
  6. Offline


    It is an awesome plugin, but is it resource intensive? How do you think it will fair with ~150 online using it constantly?
  7. Offline


    Amazing Plugin, extremely useful for many different things! I have a few suggestions though; possibly make it so the floors area can be larger than just that one block, and be able to transport every person standing within that zone?
  8. Offline


    i thought you could. in demo vid i though the hole floor was specified by iron blocks and if they are all toching they all go up
  9. Offline


    Nope... :/ Tried it several times. Would be a neat feature, especially to have your entire group go up it at the same time.
    Buckethead likes this.
  10. Offline


    that would be really cool
  11. Offline


    awesome :) but one problem..:/ i build a big hotel ( max. high ) but in a certain high the elevator doesn't work..! whats the problem???!!! pls help..! :/
  12. Offline


    Please give me as much information as you can, and we'll see if we can't figure out what's wrong!
  13. Offline


    ok first here some more informations :) : I use Bukkit Sever 1.2 RO:1
    Yes my GameVersion was 1.2
    an now my hotel: high 152Block's
    and my problem on 52 Block or higher the elevator don't work..
    thats not only in my hotel thats on my complete map .... ( sry for my english im from germany :D )
  14. Offline


    I have discovered a flaw on my version where it cannot even load the map till I hide the plugin. I'm not sure the problem or why it occurs, but it seems as though having this plugin locks up the map loading process.

    Craftbukkit version: 1988
  15. Offline


    It doesnt work for me, the signs dont change when right clicked on, I am running Bukkit for 1.2.4 and doesnt work plz HELPPP
  16. Offline


    Hatte das gleiche Problem. Allerdings erst ab einer Höhe von ~130. Ich könnte in jede Beliebige höhe fahren. Aber sobald ich wieder runterfahren wollte ging nichts mehr. Das Glas wara für eine millisekunde weg und sofort wieder da bevor ich auch nur ein Stock tiefer war. Nachdem ich gestern Aber auf den neuen Bukkit Build für 1.2.4 geupdatet habe, geht es nun.

    Ich weiß nicht obs zu 100% daran liegt. Aber kannst du ja mal probieren :)

    Lilerem94 likes this.
  17. Offline


    ja danke aber mittlerweile gehts bei mir wieder weiß nicht genau warum aber ist ja auch egal :) :D
    liegt wahrscheinlich wirklich an der version ;)
  18. it actually moves you up to the next floor. :D
  19. hi so ive been using this mod over the past few versions (since beta) and on this one i noticed quite a wierd glitch

    i set up a multifloor elevator and selecting the floor goes ok the floors are marked out fine however when i click the button to go up im just bouncing around above the iron block on the bottom floor without actually going anywhere i can go down fine its just up that causes an issue

    anyone know a fix for that?
  20. Offline


    Is your head getting caught on another block above you? Is the glass block getting removed like it should? Are you using any plugins that might be interfering? Do you continue to bounce around until you log out or disable the plugin?
  21. Offline

    Dr. Dread

    Would it be possible to have a download that does not require me to have a github account?
  22. Offline


    So, I had issues with plugin, where I could not activate the signs. I re-did an elevator out in the open, and did it at minimum height, where the next floor was right after the sign. That worked. it only showed the current floor ,and teh destination floor, where the video showed the text stating which was which. I cant seem to get the higher ceiling elevators working, where there's more space between the sign and the next floor.
  23. Offline


    I am using and love this plugin as it simplifies a lot of buildings that will be built on my server. One thing i noticed is that i can't get any lift with a ceiling higher than 3 to work, i'm using CB 1.2.5 release 1.1 and i get no errors from it. Could you also add larger lift floor areas to the next version, would especially help when u want to move a whole group up/down x floors, as well as allowing torches to be placed in the lift shaft.
  24. Offline


    So the sings don't work with me if i click on it plz help and respanse
  25. Offline


    Hi i use Blift version 1.2.1 on craftbukkit 1.2.5-R3.0 and ive been kicked from the server with this massage: Lost connection flying is not allowed on this server! what should i do?

Share This Page