[MECH] Archers v1.0 - Advanced Archery [1.5R0.1]

Discussion in 'Archived: Plugin Releases' started by 1337, Apr 27, 2011.

  1. Offline


    Archers (Reborn) - Made by [1337]
    I - Introduction
    Archers, makes archery way more powerful and fun! It has a big list of special arrows who can be enabled/disabled easily with Permissions.
    Here is a quick list of its possibilities:
    • Powerful Arrows Light things up with Fire and Lighting arrows, Blow things up with TNT arrows, morph monsters, and the mighty Nuke arrow
    • Fun Arrows generate new trees, make mobs fly up and teleport
    II - Download
    III - Installation and configuration
    • Check the Permission nodes below:
      • Code:
        archers.bow.(arrow name) - Needed to fire the bow
    IV - Usage
    It is really easy. If you type /arrow a list with available arrows will pop up, if you need more information. Just type /arrow (arrow name), and you can see what ammo it uses, and what you too enable it. Also if you dont have permission for a arrow it shows up red, if you do have permission it shows up green

    V - Final note
    Suggestions, Questions or bug reports: Post them in this Thread!
    You can also post, what you want to be updated first. That would also really help me :)
  2. Offline


    Yep sounds fun,my ingame name is jack_patrick :D

    I am thinging about making a clientside addon to do that,but i will wait until the modding stuff mojang are talking about happens first

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  3. Offline


    Problem is it's tedious to have to switch between arrows with blocks. Having a whole room just for arrow types is kinda overkill. But that's just my opinion. Kitteh done the spell cycling in his AetaPriest plugin, where you leftclick to switch through spells and rightclick to use them. That's why I thought this would be a good suggestion.

    I've added you to the archer class. The IP is aeta.lolwut.net Be sure to read the rules at http://aetadomain.lolwut.net There are a bunch of them but the basic ones are - build in your own lot (lots in brill are free), kill only fox clan members (thieves, axe murderers, dark archers, the dark fox, tunnelers) and you can't enter their sanctuary (it's marked by a sign). Have fun.
  4. Offline


    :D thanks,will join later,my minecraft is playing up :(
  5. Offline


    Any insight to my problem 1337?

    Also, could anyone post the default arrow.ammo and the configuration file? The clandorge server doesn't let me delete these files in order for the plugin to remake them. :/
  6. Offline


    Could you show me the error you get with the internal error?
  7. Offline


    2011-05-21 14:41:51 [SEVERE] Could not pass event PLAYER_INTERACT to Archers
        at TechGuard.x1337x.Archers.pListener.onPlayerInteract(pListener.java:74)
        at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:280)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:289)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
        at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:207)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:526)
        at net.minecraft.server.Packet15Place.a(SourceFile:57)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    This is the error I seem to be getting all the time.
  8. Offline


    Do you have permissions? what does it say when archers is enabled?
  9. Offline


    Yes, I have permissions.
    It says this:
     [INFO] [Archers : 2.0] Found permissions
    [INFO] [Archers : 2.0] Made by TechGuard and x1337x Enabled!
  10. Offline


    That's odd...

    For all non-op people, I've tried enabling all the way up to archers.* for them, and they still cannot switch their bows.

    I've tried uninstalling and reinstalling the plugin, and it won't work either...

    Is there another step that I have to do?

    EDIT: More testing. Even admins with their '*' permissions won't let them change their bow types; it just stays on Normal, but they can do /archers and /archers info and all those commands.

    Maybe something I missed in the config file, or a bug? I'll keep looking into it


    Here are my files;

    Show Spoiler

    Normal-Arrow-Damage: 4
    Normal-Arrow-Speed: 1

    Show Spoiler

    #The right order:
    #Arrow names:
    #Lines witch start with the # symbol, will be ignored!

    #Normal Arrow

    #Ice Arrow

    #Fire Arrow

    #TNT Arrow

    #Thunder Arrow

    #Monster Arrow

    #Thrice Arrow

    #Zombie Arrow

    #Tree Arrow

    #Pig Arrow

    #Zeus Arrow

    #TP Arrow

    #Fly arrow

    #Torch arrow
    #web arrow
    #Steal arrow
    #Sniper arrow
  11. Offline


    Hmm.. I just noticed you updated your main post to say that the recommended Bukkit version is 798. How important is that?

    I'm still getting that PLAYER_INTERACT error too. :/
  12. Offline


    Seems to be probably a bug or glitch or something, since I am not the only one getting this... I am sure he'll fix it soon
  13. Offline


    Are you all using the Archers version 2.1? And have permissions and a bow in your hand when switching arrow types?
  14. Offline


    Yep. Tried redownloading Permissions, Archers, even Bukkit, it's still not working

    For me, though, it seems only OPs can change the bow type, not even Admins, if that helps any.

    And, I don't seem to be getting an error like they are, but it still doesn't seem to be working

    Edit: Also, are you using a different repository? It says on github that your last edit was on the 14th, and the last major change on the 11th, but on the forum it says on the 20th was your last update
  15. Offline


    No its updated, i just dont commit as often as i used to, since it is just me now so there is not as much need to keep github updated, the 20th was when i updated the main posts download link,which is when i got the op moved over to me. I will commit what i have done so far though on 2.2 :D
    I will see what the problem is with the arrow changing :D
  16. Offline


    Could you change the version number in the title please? It's quite confusing.
  17. Offline


  18. Offline


    Yep, I have 2.1, including the steal arrow fix. I'll try re-installing permissions though.

    Reinstalled, and still the same. Internal errors and I can't fire arrows.

    EDIT 2:
    For information's sake, I am running Craftbukkit RB 803, and have these plugins: appletree, archers, essentials, essentials chat, essentials spawn, heroic death, iobookcase, mobrider, mysql, permissions, remote bukkit, secretdoors, towny, tradecraft, iconomy.
  19. Offline


    Could you try it on 798?
  20. Offline


    I'm no expert in Java, but since I need this plugin working so desperately, I tried to look at anything that might have effected it.

    I have two theories. Permissions may have had an update that broke something, or maybe it just takes a recompile against Permissions again.

    The second theory is the last commit. I took a look at the commit on the 11th you made, it seems the only change you did was reorder the PlayerInteractEvent from the last to be loaded after PlayerItemHeldEvent and PlayerListener event in pListener.java, to the first to be loaded. Again, I only know the basics of the basics, but maybe reordering them back around might affect something? I'd recompile it myself... but I only know how to compile Hey0 plugins

    Good luck in finding the bug!
  21. Offline


    No, sadly, I don't believe Clanforge allows you to run different builds of Bukkit. All of their bukkit servers are on 803.

    Hopefully Toastman is right and you can already have a lead on what this may be...
  22. Offline


    OO OO OO! I just had an awesome idea for a new arrow: Bind Arrow.

    Shoot it. If it hits a living creature (player or monster), it encases them in glass (a 3x3x4 glass cuboid with a 2 block hollow center for the bound entity).
  23. Offline


    What if a player stands on the edge of two blocks?
  24. Offline


    Hmm. Okay, how about this?

    I don't know Java - should really learn - but here's PHP-ish-style-ish pseudocode. In English, we get the player's position, round its coordinates to their nearest integers, move the player there, then loop through the twelve blocks in the relevant cuboid around and including the player's rounded position. If any of those twelve blocks are air, we change them to glass.

        ppos = GetPlayerPosition;
        pposx = round(ppos.x);
        pposy = round(ppos.y);
        pposz = round(ppos.z);
        for (y = pposy + 2; y >= ppos - 1; y--)
            for (x = pposx - 1; x <= pposx + 1; x++)
                for (z = pposz - 1; z <= pposz + 1; z++)
                    if (GetBlockType(x,y,z) == Air)
  25. Offline


    I am also having issues with the plugin. I'm running 803 with Archers version from main post(2.1). I am admin, I have permissions set up, the /commands seem to work, but when I fire it launches only a normal arrow. It does not consume additional ammo, nor produce the effect. I'm using Archers, Permissions, WorldEdit, mobspawner, SupplySign, Zeus
  26. Offline


    When you scroll to the bow, what does it say? You need to click the rune to select an arrow:
    Type /arrow for a list, then /arrow [name] to see what a specific arrow needs. Lets take an example of TNT.
    You then equip a bow, and click a placed TNT block (or the block under it) with the bow (don't worry, it wont explode as long as you click with the bow) - check you have enough ammo, and fire!
    You can also assign multiple bows in your inventory to different arrows.

    Suggestion for an arrow type: Destruction.
    Flies like a Sniper arrow, but can destroy certain blocks (eg glass, reeds and any one-hit-break blocks)
    with certain blocks it can travel through and damage a player too. Great for two things:
    1. Shooting a player through a window, just to be awesome
    2. Harvesting reeds :D

    Also, a config for setting Sniper arrow damage? one hit kill is a little excessive, as much as I love it...
  27. Offline


    Maybe make an option that allows me to pickup all arrows from the ground, even from other players and other mobs?
  28. Offline


    Ok, thanks, I got everything working as your post states with one exception...the TNT did explode. I made a glass enclosure surrounded in obsidian and have the bottom block available to be struck, so it shouldn't be an issue again.
  29. Offline


    Is anyone else getting what these people are?
  30. Offline


    Hey 1337, to help you out, can you post an older version of Archers, maybe a version before the May 11th update? I could probably test to see if it works, if it doesn't work either, then it was probably an issue with Permissions, because one note I forgot to mention, is that it works if you are an OP (assigned by console-command), but not an admin (assigned by Permissions)
  31. Offline


    I'm still running fine with 766. The only issue I still have is the disappearing blocks with fire arrows when facing west and shooting the side of a block facing you.

Share This Page