[Mac] - Start_server.command issue

Discussion in 'Bukkit Help' started by v1films, Jan 22, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I am the administrator of my computer
    I use a mac (see bottom for specs)

    When I try to use the start_server.command it says "The file “start_server.command” could not be executed because you do not have appropriate access privileges.
    To view or change access privileges, select the file in the Finder and choose File > Get Info."

    I have Read & Write access. Still no luck.

    The start_server.command file states exactly this:

    cd "$( dirname "$0" )"
    java -server -Xmx2G -jar ./craftbukkit.jar

    However, I can start the server by opening the minecraft_server.jar file - however it does not apply my plugins.

    What am I doing wrong? Please help. Thank you.
    - Vince

    [Computer specs]
    Hardware Overview:

    Model Name:iMac
    Model Identifier:iMac10,1
    Processor Name:Intel Core 2 Duo
    Processor Speed:3.33 GHz
    Number Of Processors:1
    Total Number Of Cores:2
    L2 Cache:6 MB
    Memory:8 GB
    Bus Speed:1.33 GHz
    Boot ROM Version:IM101.00CC.B00
    SMC Version (system):1.52f9

    anyone? D:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  2. Offline


    Do you got execute privileges for your "start_server.command" file?
  3. Offline


    I am sorry, I dont think so, or I dont know how to do so. How would i go about doing that?


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  4. Offline


    Open terminal.app (Terminal)
    Type in "chmod+x "
    Then drag the "start_server.command" in.
    The hit return.
    Then let it run.
    Then type "stop" into terminal.
    Then run it.

    Why dose this happend? Because Terminal doesn't have permission to run. Not you.
  5. Offline


    1. Open up Terminal.app
    2. Type "chmod +x" into Terminal
    3. Drag the start_server.command into Terminal.app
    4. Hit "Enter/Return"
    Then you need to run the Server for it to generate needed files. If you ever want to close the server do not close the window! Instead type "Stop" in the console.

    Your welcome :D

    EDIT: WOW I didn't notice the post above me being exactly the same!
  6. Offline


    I got the same problem ass v1films !

    I can't open start_server.command cause I don't have the priviliges but I am the "Admin" of my Mac.

    I did exactly like that what wrote Topbest65. The thing is I just can't open start_server.command !!!!!

    Help me out PLS =)
  7. Offline


    I really can't help you on that I'm on windows. However I remember it has to do with dragging start_server.command into a terminal. I'm not sure.
  8. Offline


    Iv been dragging start_server.command into Terminal.. for quite some time now, followed all steps / guides to fix this "appropriate access privileges" prob. I cant find any more guides / alternatives to do this. (Been on: youtube, wiki, yahoo, google.. and so on). But I cant figure out how to fix this "tiny" little problem?! Why doesn't BUKKIT fix this soon? If I don't understand this right, the problem has been there (for a quite long time) now. tough NO upcoming fixes.

    I really need this to work soon!

    Should work!!!
    Dont forget to:
    go to activity monitor and force quit all "JAVA"s running :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  9. Offline


    I will tell you a mistake i made: it so funny.
    I have os x lion and I have both read and write privigiles to the file start_server.command.

    To get the open privigiles for terminal: I did this:
    Typed "chmod +x" and dragged the file in WITHOUT PUTTING A SPACE AFTER THE "x", so it does a different thing instead of getting terminal acces privigiles! GOD!

    If the space was there it should show nothing instead of a list of something I don't know about.

    Also if this is not helping, check if there is extra tabs, spaces and enters hit in the .command file and get info of the file-go to the bottom of the Page and see if YOU(either user,guest or admin) has read and write privigiles to the file.

    Hope this helps.

  10. Offline


    btw to all you out there reading this do NOT put spaces in the a+x, i was trying to run it as a + x and it didnt work, so... just dont do it!!!
  11. Offline


    i have been having this same problem and i have tried what tommisaperson said and i can open it up but i come up with this message in the terminal window.
    Last login: Thu Oct 25 12:18:46 on ttys001
    166440-sct00938:~ 166440$ /Users/166440/Desktop/Skyblock\ Server/start_server.command ; exit;
    -bash: /Users/166440/Desktop/Skyblock Server/start_server.command: /bin/bash^M: bad interpreter: No such file or directory

    [Process completed]
    Pugs likes this.
  12. Offline

    Barren chick

    If your jar looks something like this:
    just turn it into this:
    by deleting the other information it gives you access privilages
    Worked for me.
  13. Offline


    i get this error: /Users/(myname)/Desktop/Shadecraft/Start.command ; exit;
    -bash: /Users/(myname)/Desktop/Shadecraft/Start.command: cannot execute binary file

    [Process Complete]

    please help
  14. Offline


    Uh I hit return on accident when i wasnt supposed to...help? also, I still cant get it to work because when I try to execute it, it says no permission...please help ;_;
  15. Offline


    you have to do a space after chmod a+x
  16. Offline


    I tried everything you guys wrote here, I had the same problem. Once i sorted it i tried to open it but it said this: maryn-macbook:~ marynwilkes$ /Users/marynwilkes/Desktop/CraftBukkit/start_server.command ; exit;
    Unable to access jarfile craftbukkit.jar
    Does one of you know how to solve this? Please Reply!!![creeper]
  17. Offline

    Eamon N.

    This will answer your question.

    It says:
    Open the Terminal in the /Applications/Utilities/ folder and type in:
    chmod u+x
    followed by a space. Drag the file into the Terminal window and press Enter. This isn't an option in the Finder because anyone needing to start UNIX executables manually is presumed to know enough about the Terminal to be able to use it.

    P.S.: If you ever need help with your Mac either make a Genius Bar appointment or use the Apple Support Communities.
  18. Offline


    I don't know anything, but my situation seems like to be exactly the same with you. :( [diamond][diamond][diamond]
Thread Status:
Not open for further replies.

Share This Page