local IP works, public IP does not.

Discussion in 'Bukkit Help' started by Erythros, Feb 15, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Erythros

    When I use my local IP to enter my server, I can connect, however if I use my public IP I cannot. I have port-forwarded correctly. And I should mention that my dad got a new modem recently, and I'm not sure if that coincides with the server problem as I don't watch the server 24/7.

    Bump, if that's allowed?

    <Merged double post - Bumping is allowed only every 24 hours - Necrodoom>
     
  2. Offline

    HeadGam3z

    What does your server.properties file look like? Please post it in a pastebin.com
     
  3. Offline

    Erythros

  4. Offline

    RZeroX

  5. Offline

    AceMinister

    If you're port forwarded, (make sure you also port forwarded on the new router/modem), and you still can't connect, make sure you've added the port you forwarded to the server.propertys file. After that, you'll need to extend your IP with the port you forwarded.

    Check your public IP address: <Edit by Jade: removed url shortener-shortened link>
    Add the port you forwarded to the end of that IP in Minecraft, and you should be good to go. (Assuming you started the Minecraft server lol)
     
  6. Offline

    brandon12477

    Make sure u have that port 25565 port forwarded to the right IPv4 Address
    In the Start menu go to your search bar and type "cmd", next type in "ipconfig /all". Scroll up and find you IPv4 Address and make sure its the same with the port forwarded port. Sometimes this IP address can change on you.
     
  7. Offline

    Erythros

    I know how to portforward, no question there. However, when I teryo "canyouseeme.org" It doesn't find any ports. The connection always times out. I tried port 80, and port 25565.
     
  8. Offline

    Iroh Retired Staff

    Okay so that means the port is not open. Do you have a firewall that could be blocking it?
     
  9. Offline

    CallMeJTG

    Make sure you have a static ip address. A dynamic ip address will not correctly forward your ports.
     
  10. Offline

    Erythros

    Not to be a smartass, but I get the timeout response on port 80 as well. Which means that technically, I shouldn't be online right now.

    And no, no firewalls.


    I didn't need a static before, so I'm figuring that isn't the problem.
     
  11. Offline

    Erythros

  12. Offline

    WhoThatSword

    this happens to me sometimes just unplug you router for a few seconds and replug it (the power)
     
  13. Offline

    Erythros

    This did not solve my problem.
     
  14. Offline

    Erythros

  15. Offline

    seriosbrad

    Incorrect, this just means that you are not accepting incoming connections on port 80, just as you aren't accepting incoming connections on port 25565 because of a firewall or port forwarding problem. Even if you open port 80 manually, some ISP's will disable this port to prevent web servers from being run on residential lines.

    You said you have no Firewall, but did you account for Windows Firewall? It will block incoming connections by default unless you add an exception for Java. Disable it for testing purposes and re-try.
     
  16. Offline

    Erythros

    I'm running the server on my Macbook, and there have not messed with the firewall on that for quite some time.

    EDIT: It's turned off.
     
  17. Offline

    seriosbrad

    Is port 25565 open on canyouseeme.org? Can other players connect to your external IP?

    The reason you might not be able to connect to your own external IP is natural, it's because your router does not support NAT Loopback but this isn't really a problem. Connecting through your own external IP to a local server just causes looping issues and unnecessary network connections. It's always best to connect to your local server using localhost or your internal IP of the server.

    If you were able to connect to your external IP on your previous router, it's because of the NAT Loopback feature being supported on it :).
     
  18. Offline

    Erythros

    I used to be able to connect to my server using my public IP. No port is open according to canyouseeme.org. I've tried every number/port I could think of.

    My router did not change. My modem did.
     
  19. Offline

    seriosbrad

    Still likely that it's a NAT Loopback issue from the device that has been changed...

    Is the modem a modem/router combo? You could be behind a double NAT (laymans term: two routers) and being blocked from the modems firewall.

    You'll want to log into the modem's port forwarding page, if applicable, and forward 25565 to your routers IP (not your internal IP).

    Alternatively, and this is what I would do personally; turn your Modem into a DMZ (there should be an option in it's config, basically disables port/firewall management) and point it towards your router so that your router is doing all the port forwarding alone.
     
  20. Offline

    Erythros

    Ok, so I just checked, and I believe that it is a modem/router combo. However, I already have a router, so trying to connect to 192.168.1.1 gets me to the stand alone router. Not the modem/router.

    EDIT: It is a modem/router. And I have a router that I plug into the mode. So technically there are 2 routers.
     
  21. Offline

    seriosbrad


    You should be able to access the main modem/router in the chain in your browser if you know it's internal IP (probably on its sticker on the bottom). If not, you'll have to find a way to connect to the main modem another way, such as directly connecting to its lan port(s) or if it's broadcasting it's own wireless SSID, that.
     
Thread Status:
Not open for further replies.

Share This Page