Linux startup issue

Discussion in 'Bukkit Help' started by cronikkk, Nov 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    cronikkk

    [[email protected] minecraft]# ./start.sh
    161 recipes
    17 achievements
    13:46:20 [INFO] Starting minecraft server version Beta 1.8.1
    13:46:20 [INFO] Loading properties
    13:46:20 [INFO] Starting Minecraft server on *:25565
    13:46:20 [WARNING] **** FAILED TO BIND TO PORT!
    13:46:20 [WARNING] The exception was: java.lang.NoSuchMethodError: method java.net.ServerSocket.setPerformancePreferences with signature (III)V was not found.
    13:46:20 [WARNING] Perhaps a server is already running on that port?
    >


    Its a brand new vps, just installed bukkit, but try to run it and i can't get it to start. Any ideas?
     
  2. Offline

    c0mp

    Make sure that your server.properties 'server-ip=' line doesn't have anything after the equal sign, although it doesn't look like it does based on the startup log. I would try restarting the VPS, or making sure there are no instances of java already running. Also check to see if there's a firewall on the VPS blocking port 25565, or if some other software is already running on that port.
     
  3. Offline

    cronikkk

    Okay trying reboot now.
     
  4. Offline

    mrlwiggy

    Did you start it up then do CTRL-C to terminate it?
    If yes, just reboot the VPS and it will be back to normal. Failing that, check if any other applications are using that port.
     
  5. Offline

    cronikkk

    Fresh reboot, still doing the same thing.

    DO you have a start up script for linux

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  6. Offline

    c0mp

    I do, but it's pretty heavily weighted towards my server and how I have it set up, and it requires GNU Screen. If you have at least a basic familiarity with bash scripting (and GNU Screen), you should be able to modify it to suit your needs though. Check it out here. Just drop it into your /home/user/bin folder, make it executable, and then use the 'crontab -e' command to edit your user's crontab, adding the following line:
    But I'm not sure that the script itself is your problem, if the Minecraft server isn't already running, then there's got to be a firewall blocking it, or something else is already running on port 25565.
     
  7. Offline

    cronikkk

    [[email protected] minecraft]# sh mc.sh
    161 recipes
    17 achievements
    java.lang.OutOfMemoryError: unable to create new native thread
    at java.lang.Thread.start0(Native Method)
    at java.lang.Thread.start(Thread.java:614)
    at net.minecraft.server.ThreadSleepForever.<init>(SourceFile:53)
    at net.minecraft.server.MinecraftServer.<init>(MinecraftServer.java:68)
    at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:518)
    at org.bukkit.craftbukkit.Main.main(Main.java:127)
    OpenJDK 64-Bit Server VM warning: Attempt to allocate stack guard pages failed.

    now im getting this error :l im assigning 256mb to it and the server has 1gb. Idk whats wrong
     
  8. Offline

    c0mp

    Ewww, OpenJDK.... I'd try installing the official Sun (Or is it Oracle now?) version of Java, first of all. Second, what does your mc.sh contain, is that the script that I linked above?
     
  9. Offline

    cronikkk

    Umm, It contains:
    I just did
    to install java.
     
  10. Offline

    c0mp

    I would uninstall java using the same method, and install the latest version from java.com. OpenJDK may not support those Xms Xmx options that you're passing it, or it may handle them differently.
     
  11. Offline

    skimberk1

    Thanks, that fixed it for me.
     
Thread Status:
Not open for further replies.

Share This Page