Solved LAN Server Issues.

Discussion in 'Bukkit Help' started by Mophead64, Aug 31, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Mophead64

    Hello,

    I recently purchased a Home Server and I decided to set up a Bukkit server for me and my friends to play on Locally.

    Everything went smoothly, from the OS Installation, to the installation of Bukkit and start up.

    However, when a client goes to Connect to the server, they recieve this on their screens:

    "Internal exception: java.net.SocketException: Connection reset".

    And on the console simply the internal IP, followed by the port they are using and "lost connection".

    The server also shows as 15,000ms - 17,000ms ping on the Multi player server list on the Minecraft Client which is very peculiar.

    Uploading files via SFTP is insanely fast and pinging the IP from windows cmd replies with 1ms - 3ms so it can't be due to an old Ethernet cable/Router.

    Hardware cannot be the issue.

    OS: Ubuntu Server 12.04 with OpenSSH

    --------------------------------------------------------------------------------------
    Issue resolved.

    I'm still unsure what the issue was but this is what I did to repair the issue:
    - Reset my router to Factory settings
    - Re-configured the Port Forwarding
    - Removed Java from Ubuntu
    - Reinstalled Java
     
  2. Offline

    JamiePhonic

    depending on when you set up your ubuntu server, it may have been cause by java having an issue with the leap second glitch. not completely sure if it affected ubuntu though.
     
Thread Status:
Not open for further replies.

Share This Page