Lag Spike Every 45 Seconds

Discussion in 'Bukkit Help' started by lazertester, Aug 6, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    lazertester

    I am getting a lag spike every 45 seconds on each of our 150 slot servers. I have poured over all of our code and third party plugins and nothing has a recurring task every 45 seconds, but the timing is very precise at the 45 second mark. I poked through the Bukkit source and saw that every 900 ticks it saves the world and the chunks, is there something about that process that changes that would cause a 400-700ms halt on the server? We are running on a ramdisk so disk I/O should not be a factor. If you need anymore information/have any profiling you would like me to run please let me know.
     
  2. Offline

    Puremin0rez

    I'm getting the /exact/ same thing.
     
  3. Offline

    DrivenDemon

    what process on your server is running every 45 seconds?
     
  4. Offline

    lazertester

    No process on the box itself, and as I stated in the first post there are no plugins with sync or async 45 second tasks.
     
  5. Offline

    chaseoes

    You could try running a custom build that changes the 900 ticks to something different and then test if you still get the lag spikes at the 45 second mark.

    Here's a bug report I found on it:
    https://bukkit.atlassian.net/browse/BUKKIT-2088

    Also, MineZ!? :O
     
  6. Offline

    lazertester

    I will, I'm new to the maven stuff and had some issues getting it to build correctly and any artifacts I would produce in InteliJ would not be runnable.
     
  7. Offline

    CosmicVoyager

    I am shocked and baffled that after many days, no developer has a clue as to why this is happening. Why the server continuously gives overloaded messages with one person on who is doing nothing.

    Can't the processes be sampled to see what is happening or something?
     
  8. Offline

    Evetsi

    Is there a plugin that can force unload the chunks bukkit is keeping loaded? Can nolagg or anything similar do that?
     
  9. Offline

    uitology

    i also have the exactly same problem since the first 1.3.1 dev builds (including the RB), even with no plugins activated :(
     
  10. Offline

    Vittek

    Same problem here. Wasn't there before 1.3, so I guess it's one of the few plugins that haven't been updated yet. I'll wait and see.
     
  11. Offline

    Gyldenglad

    Bump, also getting it here, every 46 seconds the world lags for like a second, very annoying.
     
  12. Offline

    ShootToMaim

    We aren't the super-techy geniuses that you think we are. We have lives too. We don't spend every day, every hour, every second of our time at our computers, thinking about new ways to use Java. We also have plugins to take care of. Not all us developers have time for these sorts of problems that the Bukkit team should be fixing right now.
    Just report this problem on leaky.bukkit.org if it really is a big issue.
     
  13. Offline

    Mime21

    Same issue
     
  14. Offline

    strontkever

    same issue.. i am disappoint
     
  15. Offline

    uitology

    good news everyone
    i tried every new build, the problem was not solved by updating

    until now!
    i have no idea why, but when another player logged in and out again, the problem was solved

    see my log
    Code:
    17:08:36 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    17:10:06 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    17:10:51 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    ...
    ...
    ...
    17:14:37 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    17:15:14 [INFO] [mcMMO] Loading mcMMO spout.yml File...
    17:15:14 [INFO] pXXXXXXXa[/XXX.XX.XXX.XX:49735] logged in with entity id 672 at ([vlycha] -20.03162809674438, 71.0, 23.33676222431706)
    17:15:22 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    17:15:50 [INFO] pXXXXXXXa lost connection: disconnect.quitting
    17:15:50 [INFO] Connection reset
    >say no more lag spikes every 45 seconds!
    18:51:22 [INFO] [Server] no more lag spikes every 45 seconds!
    >
    so now i'm afraid to restart the server ;)

    EDIT: server rebooted, no more lag spikes -> problem solved for me
     
Thread Status:
Not open for further replies.

Share This Page