Java Heap Space crashes occur randomly

Discussion in 'Bukkit Help' started by Traq, Oct 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hello everyone,

    Since the last 2 recommended builds (1317 & 1337), my server crashes randomly (most of the time after a player joins though) with the error 'Java Heap Space'. I turned off the join logging feature of HawkEye but it still happens.

    The detailed error :
    ... and the informations you need :

    Output of uname -a && java -version :
    Command to run Craftbukkit server :
    Plugins I use :
    • PermissionsEx (& Permissions compatibility layer)
    • HawkEye
    • WorldGuard/WorldEdit
    • iConomy
    • Register (not really a plugin, but it may matter)
    • Minequery
    • ModifyWorld & ChatManager (JARs bundled with PermissionsEx)
    • PlgSetspawn
    • RegrowindSheepcoat
    • SimpleChestLock
    • SimpleRegionMarket
    • XcraftGate
    The crash can't be caused by a lack of RAM since I launch my server with 1 Go of RAM and it often occurs when there's only 1 player connected (or there's a massive memory leak somewhere).
    The first time this crash happens was when I installed build #1337, and occurs yet on both builds #1337 & #1317.

    Thanks in advance :) .

    PS : I'm not a native english speaker, so please forgive me if I made a mistake.

    No one wants to help :-/ ?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  2. Offline


    i got same error!!

  3. Offline


    I'm receiving this same error,

    can anyone help provide an answer?
  4. Offline


    2011-10-23 11:53:20 [SEVERE] java.lang.OutOfMemoryError: Java heap space

    Java is running out of memory. Means you need to allot it more memory, add more memory, or remove plugins.
  5. Offline


    Since I removed HawkEye, I don't have this error anymore :) . Seems that an active MySQL database needs a lot of memory.
    I also have another question : I launch my server with 1 Go of RAM on a server dedicated to Minecraft, and the free -m command give this result :

    Am I able to allocate more RAM to my server ?
  6. Offline


    Well, to start with - you might want use Sun's java instead of OpenJDK one. The OpenJDK, which is supposed to be better than Sun's, still has some flaws.

    Also, from your startup line, DELETE the -Xms1024M
    It just causes java to allocate 1GB at startup - totally unneeded behaviour.

    And the error says that your server is out of memory - it just exceeded the limit. 1GB of ram is not much for a Minecraft 1.8 server, unfortunately :/
  7. Offline


    Thanks for your answer.
    My server is now less laggy and more stable :) .
    Could someone please tell me, based on the results I provided, whether or not I could allocate more RAM to my server ?
  8. Offline


    I solved my problem.. I recently upgraded my ubuntu to oneric..
    there is a bug in php5 related cronjob and fuser...

    refer this documents

    so i just added #...
    sudo nano /etc/cron.d/php5

    # 09,39 * * * * root [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -minde$

Thread Status:
Not open for further replies.

Share This Page