Iridium Server Manager - |GUI|Creator|Toolkit|Port Forwarder|

Discussion in 'Bukkit Tools' started by ImminentFate, Jul 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Everytime I click the program, nothing pops up. Can you help?
  3. Offline


    I had the same I've followed all your instructions to fix errors first I had
    "Server Started at: **/**/**** **:**:**
    'java' is not recognized as an internal or external command,
    operable program or batch file."

    Then it came up with a load of script saying something about java being an invalid file or something now I'm getting
    Server Started at: 03/05/2013 14:05:03
    'java' is not recognized as an internal or external command,
    operable program or batch file.

  4. Offline


  5. Offline


    because, you have to click the "set parameters" (next to the start server button), then deselect the checkbox marked "auto detect java". then, click browse, and look for your java.exe file. once you find it, press "save", close the window, and try running the server again
  6. Offline


    This makes downloading craftbukkit so much easier I struggled without it its awsome:D
  7. Offline


    Whenever I open the manager it starts to load, but then gives an error and closes, I have uninstalled and re-installed, please help.
  8. Offline


    O nice very cool
  9. Offline


    ImminentFate I just switched computers and I got everything copied over. Changed the locations and everything and the server still runs fine. The only problem is now the console doesn't show anything other than that the server is started. Here's what it looks like: [​IMG]
  10. Offline


    I think this may be because you don't have enough RAM allocated for the server (so it's taking forever to get going).
    You can either wait for it to keep loading, and it will get there eventually, or increase the amount of RAM allocated to the server
  11. Offline


    I left it running all day and it never showed anything beyond that. Also I've allocated 2gbs of RAM and still nothing.

    Never mind I got it working. The problem was originally it was saying java not recognized command so I edited the .bat file and I made a mistake there but it's up and running now. Thanks again!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  12. Offline


    Ah, minor mistakes here and there, they mess things up don't they haha. Glad you got it working
  13. Offline


    Server Started at: 28/05/2013 17:37:16
    Usage: java [-options] class [args...]
    (to execute a class)
    or java [-options] -jar jarfile [args...]
    (to execute a jar file)
    where options include:
    -d32 use a 32-bit data model if available
    -d64 use a 64-bit data model if available
    -client to select the "client" VM
    -server to select the "server" VM
    -hotspot is a synonym for the "client" VM [deprecated]
    The default VM is client.

    -cp <class search path of directories and zip/jar files
    -classpath <class search path of directories and zip/jar files
    A ; separated list of directories, JAR archives,
    and ZIP archives to search for class files.
    set a system property
    enable verbose output
    -version print product version and exit
    require the specified version to run
    -showversion print product version and continue
    -jre-restrict-search | -no-jre-restrict-search
    include/exclude user private JREs in the version search
    -? -help print this help message
    -X print help on non-standard options
    enable assertions with specified granularity
    disable assertions with specified granularity
    -esa | -enablesystemassertions
    enable system assertions
    -dsa | -disablesystemassertions
    disable system assertions
    load native agent library <libname, e.g. -agentlib:hprof
    see also, -agentlib:jdwp=help and -agentlib:hprof=help
    load native agent library by full pathname
    load Java programming language agent, see java.lang.instrument
    show splash screen with specified image
    See for more details.
    Error: -jar requires jar file specification

    When loading I get this error which seems to be unheard of as I spent hours toiling for an answer to this error. Can you help me out?
  14. Offline


    you haven't specified a craftbukkit.jar file for the program to use.
    Click the "startup parameters" (or something like that) that is next to the start server button, and make sure the last textbox says "craftbukkit.jar" (or whatever the name of your craftbukkit file is)
  15. Offline


    OK then, this now works, however after following all of your port forwarding steps with both different ways, It is still a hamachi relied upon server. They cant join when my Hamachi is turned of and vice versa. I have a Virgin Media router and It is port forwaded to port 25565 and 25565. The IP is my IvP4 which is yet still it doesnt work. The port forward manager that you link at the beggining of this video has an identical set up to yours, yet still nothing. Any ideas?
  16. Offline


    i have found that sometimes, despite port forwarding correctly, the windows firewall is what prevents everything from working. Try turning that off, and see if the problem gets fixed. if it does get fixed, turn the firewall on again and allow java and minecraft through the firewall, and then see if it works again
  17. Offline


    That is so awesome, It worked straight away, and it never crossed my mind to turn it off, its all working now thanks so much for your help
  18. Offline


    Hey how can i update my iridium server from !.4.7 to 1.5.2[creeper]

    help me please
  19. Offline


    download the beta build of craftbukkit Mads_ALk
  20. Offline


    Am I the only one who isn't directed to the download when clicking on it?
  21. Offline


  22. Offline


  23. Offline


    Great Job! You're the B E S T !!! With help of some mods I was even able to crash my server 2 times! :p
    great thanks dude.
  24. Offline


    not sure if genuinely complimenting Iridium,
    or sarcastically saying it sucks :eek:
    hawkfalcon likes this.
  25. Offline


    I get this when I start my server can you help me fix this please

    Server Started at: 6/20/2013 9:16:48 PM
    Error occurred during initialization of VM
    java.lang.UnsatisfiedLinkError: sun.reflect.Reflection.getCallerClass()Ljava/lang/Class;
    at sun.reflect.Reflection.getCallerClass(Native Method)
    at sun.misc.Unsafe.getUnsafe(Unknown Source)
    at java.util.Hashtable.<clinit(Unknown Source)
    at java.lang.System.initializeSystemClass(Unknown Source)

    Press any key to continue . . .
  26. Offline


    unfortunately, i've never seen that error before. This is an error with bukkit, not Iridium, and therefore you should try the help section of the forums.
  27. Offline


    I just realised (if you haven't already been able to solve the problem) that the issue may be caused by Java. If you haven't tried another solution and found it to work, i suggest reinstalling Java (Update to the latest version of Java 7 while at it) and try again.
  28. Offline


  29. Offline


    I'll answer your question here, if that's okay with you.
    You simply haven't told Iridium (I assume you're using Iridium) what the name of your craftbukkit.jar file is.
    Open the startup parameters (the text next to the "Start Server" button) and in the bottom textbox, type in craftbukkit.jar.
    Then save and restart the server, and it should work.
  30. Offline


    This is a note to any who run into the issue of:

    "blah blah blah show splash screen with specified image
    See for more details.
    Error: -jar requires jar file specification"

    YOU MUST!!! - type in EXACTLY craftbukkit.jar into the jar file name section. Just to make that HIGHLY clarified.

    So after my last post and running the server for a few hours.. i set it up as a dinner for two and it starts saying my ports are not binding (possibly being used already). I tried about 10 different port "id's" and still nothing. any idea why? I have the error report in a .txt file. If you would like me to post it just let me know. Thanks!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
Thread Status:
Not open for further replies.

Share This Page