Iridium Server Manager - |GUI|Creator|Toolkit|Port Forwarder|

Discussion in 'Bukkit Tools' started by ImminentFate, Jul 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    When i open it ,it opens a window for 1 second and closes...
    Can you tell me why?
    (Sorry im noob at making servers)[fire]
  2. Offline


    Doh! I didn't even pay attention to my MC updating. Thank you!
  3. Offline


    I have got a problem with the new craftbukkit 1.8:
    2011-09-15 16:51:50 [INFO] Starting minecraft server version Beta 1.8
    2011-09-15 16:51:50 [INFO] Loading properties
    2011-09-15 16:51:50 [INFO] Starting Minecraft server on *:25565
    2011-09-15 16:51:50 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-09-15 16:51:50 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-09-15 16:51:50 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-09-15 16:51:50 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1015-g56fa8f0-b1118jnks (MC: 1.8)
    2011-09-15 16:51:51 [INFO] [Pail] Pail 0.7.1 Enabled
    2011-09-15 16:51:51 [INFO] Preparing level "World"
    2011-09-15 16:51:51 [INFO] Default game type: 0
    2011-09-15 16:51:51 [INFO] Preparing start region for level 0 (Seed: -6806695329903759695)
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntitySheep@33
    2011-09-15 16:51:52 [INFO] -400.03125,189.59375(-26,11) vs -25,11
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityChicken@38
    2011-09-15 16:51:52 [INFO] -400.0625,200.5625(-26,12) vs -24,11
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityChicken@39
    2011-09-15 16:51:52 [INFO] -400.0625,187.5625(-26,11) vs -24,11
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityWolf@3b
    2011-09-15 16:51:52 [INFO] -400.03125,233.1875(-26,14) vs -24,14
    2011-09-15 16:51:52 [INFO] Preparing spawn area: 69%
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntitySheep@fa
    2011-09-15 16:51:52 [INFO] -107.21875,416.09375(-7,26) vs -7,23
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityPig@fe
    2011-09-15 16:51:52 [INFO] -63.96875,170.0625(-4,10) vs -6,11
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityPig@10d
    2011-09-15 16:51:52 [INFO] -63.9375,190.5(-4,11) vs -5,12
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityPig@10e
    2011-09-15 16:51:52 [INFO] -63.96875,212.3125(-4,13) vs -5,12
    2011-09-15 16:51:52 [INFO] Wrong location! net.minecraft.server.EntityPig@10f
    2011-09-15 16:51:52 [INFO] -63.9375,192.5625(-4,12) vs -5,12
    2011-09-15 16:51:53 [INFO] Preparing start region for level 1 (Seed: -6806695329903759695)
    2011-09-15 16:51:53 [INFO] Preparing spawn area: 56%
    2011-09-15 16:51:54 [INFO] AdvancedPail v0.1 alpha enabled
    2011-09-15 16:51:54 [INFO] [Backup] Permission system not detected, defaulting to OP
    2011-09-15 16:51:54 [INFO] Backup v1.6 was sucessfully loaded!
    2011-09-15 16:51:54 [INFO] CraftBukkitUpToDate version 2.6.6 is enabled!
    2011-09-15 16:51:54 [INFO] CButD: Permission system not detected, defaulting to OP
    2011-09-15 16:51:54 [INFO] Preparing start region for level 2 (Seed: 6042748057614819774)
    2011-09-15 16:51:55 [INFO] CButD: CraftBukkit is up to Date
    2011-09-15 16:51:55 [INFO] Wrong location! net.minecraft.server.EntityPig@1e0
    2011-09-15 16:51:55 [INFO] 151.0,448.0(9,28) vs 9,27
    2011-09-15 16:51:55 [INFO] Preparing spawn area for World One, 65%
    2011-09-15 16:51:55 [INFO] Preparing start region for level 3 (Seed: 7443072974590138192)
    2011-09-15 16:51:56 [INFO] Preparing spawn area for World One_nether, 57%
    2011-09-15 16:51:57 [INFO] DefaultCommands 3.5.0 is enabled.
    2011-09-15 16:51:57 [INFO] [ServerLogSaver] Version 1.0 Is Enabled!
    2011-09-15 16:51:57 [INFO] Server permissions file permissions.yml is empty, ignoring it
  4. Offline


    Thank you very much. Was it a requested thing to have PailPlus?

    Though I am about to release a new version!

    That's a normal error, craftbukkit isn't used to all the changes in 1.8 yet. ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  5. Offline


    In addition to the basic "wrong location" errors, which I don't mind because they don't appear to do anything substantial , I don't appear to be able to change my server to survival. I go to my server properties files
    and change gamemode to 0 but it appears to have no effect.

    #Minecraft server properties
    #Thu Sep 15 18:50:11 EST 2011
    level-name=World One
    motd=Welcome to Minecraft!

    Any suggestions?

    No additional plugins running CB 1120 windows 7 64 bit.

    Edit: Tried on 1118 still won't work.
  6. Offline


    I just wanted to stop by and say how much I appreciate your work, and thank you for updating everything as fast as you can. The automatic installer worked fine for me, except in the Craftbukkit Starter.bat file, I had to change a small error. -d2x or something of the like in front of the java -Xincgc -Xmx1560M. Runs and works fine now though :D Anywho, thank you again for everything and hopefully you can get the 1.8.1 out soon, haha.
  7. Offline


    Had the same thing. When I started craftbukkit, it would crash after optimizing(just dissapear). I edited this line in the Craftbukkit Starter.bat file:
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" java -Xincgc -Xmx1560M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"
    originally it read :
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" java -d64 -Xincgc -Xmx2460M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"
    it started just fine after that but man do I have a long list of errors, as you said.
    Thanks for all the hard work!!!
    ImminentFate likes this.
  8. Offline


    Requested? Not really, I added it because I thought it was one of the best and most useful plugins I have seen. But I'm sure your popularity will boom now! Also, do you think you could add your plugin to CraftBukkitUpToDate? It woul make it easy for people to auto-update their versions from within the game

    try using the patch, or if that doesn't work try runnin the server from the jar directly

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  9. Offline


    ok, so the server came up and said there was an update in the bukkit_update file. I copied it into the main folder as usual. The server started fine but had severe errors from izone. Removed that, restarted. Server started fine but now I cant connect to the server, which is on my own computer. It says in the game "communication error" and the server gives me this error:
    05:22 PM [SEVERE] Bad packet id 254
    05:22 PM [SEVERE] at net.minecraft.server.Packet.a(
    05:22 PM [SEVERE] at net.minecraft.server.NetworkManager.g(
    05:22 PM [SEVERE] at net.minecraft.server.NetworkManager.c(
    05:22 PM [SEVERE] at
    05:22 PM [INFO] / lost connection
    Im sure this is probably something simple that Im just overlooking.
    nmv, my blonde hair came back. fixed it
  10. Offline


    ^ I have this same problem. Unfortunately, I don't know how to fix it. I don't normally do... java... stuff...

    03:37 PM [SEVERE] Bad packet id 254
    03:37 PM [SEVERE] at net.minecraft.server.Packet.a(
    03:37 PM [SEVERE] at net.minecraft.server.NetworkManager.g(
    03:37 PM [SEVERE] at net.minecraft.server.NetworkManager.c(
    03:37 PM [SEVERE] at

    When I try to connect despite these issues, it tells me the server is outdated. But it says in the very first post that it should work with 1.8 :/
  11. Offline


    [ya whenever i download my browsere says its not safe then norton deletes it saying its a threat so yeauhhhhhh........
  12. Offline


    Its because there was an update. Minecraft is now 1.8.1. Gotta give it a lil for bukkit to update as well.
  13. Offline


    Ah, I didn't realize it was a second update. My friend was the one who did the 1.8 update, 1.8.1 was the only one I've seen.
    Saycame likes this.
  14. Offline


    how do i find my ip?
  15. Offline


    Open command prompt, type in "ipconfig" without quotes. If you're using wireless, look under the "Wireless LAN" sections for one that has a good bit of info in it, if you're using wired internet then find the "Ethernet adapter Local Area Connection" section that has info. Your IP address is the IPv4 one.
  16. Offline


    Is pail already added? And I'll look into getting pailplus added. ^^ (Though, i'll need to update it first.)
  17. Offline


    It is added.
  18. Offline


    guess what? You're in luck. School holidays have started so i will get a chance to work on one for linux.
  19. Offline


    i think you mean your external IP

    if you want other to connect to your server, they need to know your external IP you can head here to get your external IP
  20. Offline


    New fresh Server with #1097 , now on #1124, I look @ the props and see these lines:

    What's this? Thanks.
  21. Offline


    those are new nodes for the server, i don't think you need them, not really sure what they do either :p try searching around a bit
  22. Offline


    Is this Mac compattible?
  23. Offline


    We've been running craftbukkit for a while now and have been very impressed, even with addons it runs more smothly than the official MinecraftServer.exe that is released by the makers of Minecraft.. I look forward to a suggested stable release of CraftBukkit our server will probably be down until that time because the minecraftserver.exe is having a simular issue as described above. ("But BE CAREFUL! You WILL get some erros, mainly to do with entity.[mob]. these won't harm the server though.")
    This entity.mob error in the minecraft.exe is crashing our server and causing lost items and undoing things we have built... I'm guessing CraftBucket doesn't have this issue but won't be taking any chances... thankyou for all your hard work on CraftBucket!!! Our server players and operators appreciate the stability and ability to add the addons we want easily!

    to find out your external IP; the one everyone besides you will use goto
    that will show your current external IP

    If your using a router to access the internet on multiple devices you will either have to turn off your routers firewall (dangerous and not suggested) or port forward your router on port 25565. The page I listed above can test the port to see if you have it opened properly when the server is running... If you put your external ip in the ip box and port 25565 in the port box and click the "check" button and it says port is open you are good to go, if it says port is closed it's still not quite right... port forwarding is different for every router so I won't even try to describe how to do so here as it would take pages but if you google "port forward "and the name of your router you should find several good pages on how to do it and probably some good youtube vids.

    Some routers will port forward from 1 local comp to another automatically others will not. So if all the computers you are playing the game on with your friends are in the same location connecting to the net threw the same router you may or may not have to port forward the router... To play on a server on the same machine as the server is running or on the same local network click start>run> type cmd or command depending on your version of windows, then hit enter or return. A black window will pop up that probably says c:\> and nothing else. type "ipconfig" hit enter. you'll get a readout of your local connections.

    mine looks like this.
    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    Windows IP Configuration
    Ethernet adapter Local Area Connection 2:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Ethernet adapter Local Area Connection:
    Connection-specific DNS Suffix . : Dynex
    Link-local IPv6 Address . . . . . :
    IPv4 Address. . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    Tunnel adapter isatap.{}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Tunnel adapter Local Area Connection* 9:
    Connection-specific DNS Suffix . :
    IPv6 Address. . . . . . . . . . . :
    Link-local IPv6 Address . . . . . :
    Default Gateway . . . . . . . . . : ::
    Tunnel adapter isatap.Dynex:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : Dynex

    In my case I'm using win7. What your looking for is the IPv4 Address. In my case I'm plugged into the 4'rth computer port on my router so my local ip ends in 4. ( most routers go with the order items connect to the router and not the port with which they connect but dynex wanted to be weird :p some routers reasign each comp a new ip every time they are restarted others the ip will be static or only change when the router is restarted. anyway the number you will use to connect localy will either be "localhost" if your on the same comp as the server or what ipconfig identifies as your IPv4 address if it's another computer in your home. and your friends can connect from threw the internet threw the ip address that says is your ip but only if your port is forwarded properly.

    One quick note there is a at&t router/modem that will not portforward after 6 hours on the phone with a lvl2 helpdest technition from at&t we found that the 2exteme wireless router that they are selling for around 100$ as of about a month ago (today is 09/15/2011) has portforwarding options but evin when forwarded it blocks the connection... We ended up having to bridge the connection (another book). but basically we turned a 100$ wireless router/modem into a 30$ modem...

    hopefully this answers your question.

    I just noticed 2 more posts from you "my brother is on another ip, please help" this implies that you are able to run the server and connect to it and he is not. If that's the case what I've posted above should fix the issue. Please keep us up to date. the second is, "is this mac compatible" I can't help with that one but I would assume it it because I believe the .jar version on the games download page is mac compatible as long as you have java installed. but I could be wrong there. Also if your on a mac what I posted above for finding your local ip will be useless and I'm not sure if localhost will work or if that's a windows thing. However the info for finding your internet ip and port forwarding still stands. Your computer may also have a firewall that has to be port forwarded to allow the connection. all current versions of windows have a built in firewall but it usually pops up and says "I'm blocking (program name) from connecting do you wish to keep blocking" if you choose no it will automatically forward the port for it's firewall for you. Other firewalls are not so kind and usually are bundled with anti-virus programs... I would assume Mac's have a simular firewall to windows so you may or may not have to do something to tell it it's ok for programs to connect threw port25565.....

    also some people don't want to share there ip on the net or prefer to have something cool or that discribes them for example if your interested in something like this
    offers one free dynamic name for free and for around $20.oo per year you can get several. as a note for there free one you MUST login once a month or it will stop working where the paid version you can set it and forget it. both of throws allow only minimal customization all domain names will end in something containing however it is possible to get a fully customized one but I could not tell you where to go for the cheapest dns (Domain Name Server) services but they are the only one I have found that offers a free domain name. Searching DNS will list both sites that offer DNS services and websites for sail as most people who are looking for a dns want to build a website...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  24. Offline


    Heads up. The patch works, but the server then wants you to update it from the update folder it creates. I'm not sure if it's just for me, but when I put the new craftbukkit snapshot jar file in it wont let me or anyone else connect to the server. All I have to do is not update for it to work, and it still works fine. Just thought I'd let you all know.
  25. Offline


    not yet, but i hope to make it soon

    yes the craftbukkituptodate plugin wants to update to the latest reccommended build. Unfortunately, that is 1060 which is unsupported. I should have mentioned that, so don't update. Alternatively, you can run the server and set it to update to the newest stable build.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  26. Offline


    By the way, PailPlus doesn't change the theme, that was put into Pail.
    But it's all good. ;)
  27. Offline


    the download link don't work:mad::'( so please get back to me or elce...
  28. Offline


    :mad:Can You Change The Download To Mediafire Would Be Nice i Hate fileserve it always has to wait this much time to do another download! do maybe just link it with adfly and dropbox would be SO Nice and How to use 1.8.1 Patcher?? i Click Run Then Nothing Happens????
    Im on Windows 7 Thanks xD Hope You Fix! Bye
    - Minemansam123
    P.S. I will Give you a [diamondblock] If you Complete xD plus a Friendly [creeper] To Hug You xD[tnt] Ssssss
  29. Offline


    hello, when i start my test server with 1.8 i have this error:

    2011-09-16 09:07:19 [INFO] Preparing start region for level 0 (Seed: 8229926260504005995)
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityChicken@31
    2011-09-16 09:07:19 [INFO] 135.28125,71.46875(8,4) vs 11,3
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityCow@97
    2011-09-16 09:07:19 [INFO] 204.1875,341.34375(12,21) vs 14,20
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityCow@98
    2011-09-16 09:07:19 [INFO] 198.53125,327.15625(12,20) vs 14,20
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityCow@99
    2011-09-16 09:07:19 [INFO] 233.71875,306.59375(14,19) vs 14,20
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityChicken@9f
    2011-09-16 09:07:19 [INFO] 240.4375,-32.125(15,-3) vs 15,-2
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityCow@d1
    2011-09-16 09:07:19 [INFO] 257.9375,356.53125(16,22) vs 17,19
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityCow@d2
    2011-09-16 09:07:19 [INFO] 278.0625,359.875(17,22) vs 17,19
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityCow@d3
    2011-09-16 09:07:19 [INFO] 279.75,320.0625(17,20) vs 17,19
    2011-09-16 09:07:19 [INFO] Wrong location! net.minecraft.server.EntityPig@eb
    2011-09-16 09:07:19 [INFO] 353.625,327.0625(22,20) vs 20,19
    2011-09-16 09:07:20 [INFO] Preparing spawn area: 73%
    2011-09-16 09:07:20 [INFO] Preparing start region for level 1 (Seed: 8229926260504005995)
    2011-09-16 09:07:21 [INFO] Preparing spawn area: 61%
    what is my problem?
Thread Status:
Not open for further replies.

Share This Page