Iridium Server Manager - |GUI|Creator|Toolkit|Port Forwarder|

Discussion in 'Bukkit Tools' started by ImminentFate, Jul 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Im getting this error:
    151 recipes
    16 achievements
    java.lang.UnsatisfiedLinkError: C:\Users\cyrus\AppData\Local\Temp\jline_git-Bukk
    it-0_0_0-945-g73697a4-b1000jnks.dll: Can't load IA 32-bit .dll on a AMD 64-bit p
            at java.lang.ClassLoader$NativeLibrary.load(Native Method)
            at java.lang.ClassLoader.loadLibrary0(Unknown Source)
            at java.lang.ClassLoader.loadLibrary(Unknown Source)
            at java.lang.Runtime.load0(Unknown Source)
            at java.lang.System.load(Unknown Source)
            at jline.WindowsTerminal.loadLibrary(
            at jline.WindowsTerminal.initializeTerminal(
            at jline.Terminal.setupTerminal(
            at jline.Terminal.getTerminal(
            at jline.ConsoleReader.<init>(
            at jline.ConsoleReader.<init>(
            at jline.ConsoleReader.<init>(
            at net.minecraft.server.MinecraftServer.<init>(
            at net.minecraft.server.MinecraftServer.main(
            at org.bukkit.craftbukkit.Main.main(
    Press any key to continue . . .
    How can i fix this from using a 32bit .dll? I do understand that you said you have already answered this problem but what page is it on? I cant find your reply.

    EDIT: Actually nvm. I restarted my PC and it worked!!!!
  2. Offline


    Right click on it and select edit. It will open with notepad so u can edit it
  3. Offline

    Wyatt vlach

    Some People may get an error that says "Unrecognised option d64. Press any key to continue. This means you don't have the 64 bit version of java installed.
    To fix this, go into the .bat file and remove the -d64 tag from under the architecture line

    can u explain to me how i would do that ^^^^^
  4. Offline


    So, I'm getting an error and I don't know what to do about it.
    Here's the information you requested

    1. Windows 7
    2. x86
    3. 1.7.0-ea
    4. I have the port forwarded, if that's what you're asking.
    5. Server log:
    2011-08-11 18:48:08 [INFO] Starting minecraft server version Beta 1.7.3
    2011-08-11 18:48:08 [INFO] Loading properties
    2011-08-11 18:48:08 [INFO] Starting Minecraft server on *:25565
    2011-08-11 18:48:08 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    2011-08-11 18:48:08 [INFO] Preparing level "world"
    2011-08-11 18:48:08 [SEVERE] java.lang.NullPointerException
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.WorldServer.c(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.a(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.Chunk.addEntities(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.ChunkProviderServer.getChunkAt(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.getChunkAt(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.getTypeId(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.isEmpty(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.a(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.canSpawn(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.c(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.World.<init>(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.WorldServer.<init>(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.SecondaryWorldServer.<init>(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    2011-08-11 18:48:08 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    2011-08-11 18:48:08 [SEVERE] at
    2011-08-11 18:48:08 [SEVERE] at
    2011-08-11 18:48:08 [SEVERE] Unexpected exception
    at net.minecraft.server.WorldServer.c(
    at net.minecraft.server.World.a(
    at net.minecraft.server.Chunk.addEntities(
    at net.minecraft.server.ChunkProviderServer.getChunkAt(
    at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(
    at net.minecraft.server.World.getChunkAt(
    at net.minecraft.server.World.getTypeId(
    at net.minecraft.server.World.isEmpty(
    at net.minecraft.server.World.a(
    at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    at net.minecraft.server.World.canSpawn(
    at net.minecraft.server.World.c(
    at net.minecraft.server.World.<init>(
    at net.minecraft.server.WorldServer.<init>(
    at net.minecraft.server.SecondaryWorldServer.<init>(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(

    Server Properties:
    #Minecraft server properties
    #Sat Jul 16 14:02:15 EST 2011

    6. I have not tried anything.
  5. Offline


    i'm new to Bukkit, and, well, I came across your post. So I installed it, but i came across a few problems. I have Windows XP, x32 bits, and I don't know my Java version, but it's pretty new. I use Hamachi, because I have another server (no loss in deleting). So i tried downloading this, but when I ran it, it said it couldn't access the SNAPSHOT file, but that was only when I clicked on the Starter JRE7 file. Then I found out about the desktop icon, and it said it couldn't access the port (after about 30 seconds of a blue screen loading things). Hamachi was running, so I don't know what happened. Any help?
  6. Offline


    Seriously, if you can't get that under your belt, then you're in for a roughy time maintaining a server. But here's the steps:
    Open C:/Users/username/AppData/Roaming/.craftbukkit
    Locate Craftbukkit Starter Jre.bat
    Right click on it and select edit
    Scroll down to the second last paragraph
    Locate -d64
    Backspace it
    save and quit
    Run the server

    Thine world is corrupted.

    Luckily for you, the starter for jre7 also works with java 6. As for the error about port, you should read m other post which I have linked at the start of this thread

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  7. Offline


    All that you have posted has helped greatly and helped me overcome many problems, but I've come to a halt here and I can't seem to find a solution.
    If you may help I would gladly appreciate it. My problem is this, or rather, question: I can't seem to log on into my own server. I am using Hamachi, so I am thinking I don't connect to my own server. If I can, which I am not able to, then what is the problem? Below are what I believe to be the problems.

    Optimizing PC... PLease wait
    Removing Temporary Files...
    C:\Users\raikum\AppData\Local\Temp\FXSAPIDebugLogFile.txt - The process cannot a
    ccess the file because it is being used by another process.
    Access is denied.
    Also, it displays that the permission is not detected, defaulting to OP, then going to permissions.yml, but that it is empty and is ignoring it.
    Again I will gladly appreciate any help.
  8. Offline


    None of those are problems. The access denied means the file is needed by another program. It says that so your pc won't screw up. And the permissions one means you haven't put anything in the permissions.yml
    Did you read my other post on setting up a server?
  9. Offline


    Hi im new to bukkit and im trying to make a server for me and my friends and while i can make a vanilla one very easily im having trouble getting bukkit to load, everytime i select the craftbukkit starter it gives me the error message that windiows cannot find 'java.exe' even though ive just downloaded it and installed again to make surei have it

    Thank you

    Os:windows 7 64 bit
    Java 1.6_026

    scratch what i said, i re read ur page an realised i needed to install the 64 bit version on java :D thank you

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  10. Offline

    Thomas Downs

    I have 64 bit java installed, however bukkit gave me that -d64 error, i took that line out of the .bat but will that effect the performance of the server or not?
  11. Offline


    Hi, I'm trying to get this to work on my computer, but am running into problems:
    1. What OS are you using (Brand and version)? Windows 7 64bit, Fully Updated afaik
    2. What architecture is the OS you are running (x64 or x86)? x86, I think? It's what's next to my program files folder...
    3. What version and architecture is your java install? Java 1.6_026
    4. Are you trying to portforward, or use Hamachi? Hamachi. Although at the moment it's just for me and the people on my LAN.
    5. What error are you getting (post your server.log and files)? The server log shows nothing, but what I'm getting in the window is:
      'java' is not recognised as an internal or external command,
       operable program or batch file.
      The server window is cleared at this point.
       Optimizing PC... Please wait
       Removing Temporary Files...
       [Various messages of processes I have open for some programs not being able to have their temporary files deleted]
       Prioritizing Java.exe...
      At this point I get an error message saying "Windows cannot find Java.exe. Make sure you typed in the name correctly, and then please try again." Then in the server window I get:
       The system cannot find the file Java.exe.
       Optimization Completed Successfully!
      Then the window is cleared again, and I get:
      'java' is not recognised as an internal or external command,
        operable program or batch file.
       Press any key to continue...

    6. What have you tried already? Reinstalling Java, reinstalling the Craft Bukkit.
    Should probably add that I've managed to have a craftbukkit server work fine with McMyAdmin running, but not on its own.

    Any help would be appreciated. :)
  12. Offline


    I have, but I will read it again. What I want is to test if the server is working by logging on to it and playing around in it. Perhaps I just need someone else to log in?
  13. Offline

    Wyatt vlach

    oh sorry, i shoulda told u, i did it without this help ^^^^ thanks anyway
  14. Offline


    Yes, it will mean you can't use more than 1gb ram for your server. If you need more, try upgrading to java 1.7

    Ok, you actually have a windows 7 x64 Pc. The x86 next to One of your program files folders is for backwards compatibility for other programs. To fix your error, go into the starter.bat file for craftbukkit and remove the. -d64 tag from it

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  15. Offline


    Still doing the exact same errors. The file Craftbukkit Starter JRE6.bat was the one you wanted me to edit, I'm assuming? The code it's using is:

    Show Spoiler
    title CraftBukkit Server JRE6        
    Color 17                 
    java -version             
    timeout/nobreak 3 >NUL
    echo Optimizing PC... PLease wait
    timeout/nobreak 1 >NUL
    echo Removing Temporary Files...
    rmdir "%TEMP%" /s /q >NUL        
    rd "%WINDIR%\Temp" /s /q >NUL        
    timeout/nobreak 1 >NUL
    echo Complete!
    timeout/nobreak 1 >NUL
    echo Prioritizing Java.exe...
    cmd /c start /AboveNormal Java.exe >NUL    
    timeout/nobreak 4 >NUL
    echo Complete!
    timeout/nobreak 1 >NUL
    echo Optimization Completed Sucessfully!
    timeout/nobreak 3 >NUL
    timeout/nobreak 1 >NUL
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64"  java -Xincgc -Xmx1560M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86"  java -Xincgc -Xmx1024M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"

    I can't see any other -d64 in the file, any ideas? :s
  16. Offline


    Ok, I just downloaded and installed this server. I'm running Windows 7 with 64-bit and Java 1.7. I am a complete noob to this so I am really confused. Can I use this server to play Minecraft with my friend who's on another I.P. Address? Or does he have to be on my LAN? I honestly don't even understand how to get onto this server.
  17. Offline


    Check out my other post which I linked under the download section
  18. Offline


    you mean the port forwarding thing? i did that but it's still not working! typing localhost doesnt work
  19. Offline


    Norton says it's a threat and deletes it. :(
  20. Offline


    Thank you so much for this. It is the easiest and cleanest install of CB i have ever done.
    I highly recommend this to any and everyone!
    Thanks again!!!
  21. Offline


    i have confiremed norton and two ohter antivirus software do find a problem with it. Try turning norton off while you install it.
  22. Offline


    mine keeps saying 'java' is not recognised as an internal or external command,
    operable program or batch file.
  23. Offline


    In case you missed it, last post on the page and all that. :) Can get it to run on my Linux OS, but not on my Windows 7 OS, which is where I need it to be.
  24. Offline


    I wonder why that is... Sorry you'll have to wait until tomorrow for an answer, I need to do a bit of tinkering and research
  25. Offline


    No worries, isn't urgent. Thanks very much for looking into it! ^.^

    Edit: Just attempted to get Craftbukkit installed manually on my Windows machine - it looks to be a problem at my end, because I've had the same error using the various .bat files from the tutorial. Guessing it may be a java problem. I'll report back if I find a solution, but don't need to worry about it, it looks like it's not a problem with the installer. :)
  26. Offline


    Ok i installed it, ran it, and ran Craftbukit start or whatever.
    1. How can I tell If my server Is online?
    2. How do I make myself an OP?

    Also one more thing after that, How do I temporarily shut down the server so someone else can use my computer?
    Sorry for so many questions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  27. Offline


    When i start the launcher, after going through lots of stuff
    it says...
    151 recipes
    16 achievements
    18:11:52 [INFO] Starting minecraft server version Beta 1.7.3
    18:11:52 [INFO] Loading properties
    18:11:52 [INFO] Starting Minecraft server on *:25565
    18:11:52 [WARNING] **** FAILED TO BIND TO PORT!
    18:11:52 [WARNING] The exception was: Unrecognized Win
    dows Sockets error: 87: create
    18:11:52 [WARNING] Perhaps a server is already running on that port?
    What does this mean and why wont it let me on my server?

  28. Please join my cracked server iv'e port forworded and used hamachi
    hamachi:id. minecraft111222333haha. password 123. hamachi ip
    portforward ip EDIT: (i havent been able to test my portforward so if you cant use that try hamachi

    Thats happend to me, do you have multiple users on your computer? If you do log in to one of those accounts and check if a server is already running. If so close it. If you dont have multiple accounts check and make sure that 1 isint already running on your account, also check and make sure you have it connected to the right version of java, and the newest version of minecraft. Im sorry if none of this helps but this is what i did and i got it working.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  29. Offline


    Man, if you can't do those things you shouldn't have started with craftbukkit. Op yourself by adding your username to the ops.txt file
    Go into and edit. Online-mode to say true

    No, it means that he hasn't set up a server port or ip to use the game

    Did you not read my other post? You can't give someone your internal up for portforwarding. For someone to connec to your portforwarded server, give them the ip from

    is your server up? If not, please tell me when it will be and I can test it for you

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  30. Offline


    i have an error *windows cannot find java.exe make sure you typed name correctly and then try again
Thread Status:
Not open for further replies.

Share This Page