[INFO/WEB] Landmarks v0.2 - with DynMap addon [953]

Discussion in 'Inactive/Unsupported Plugins' started by DFYX, Apr 7, 2011.

  1. Offline


    Version: v0.2
    Tested with Craftbukkit 953/Dynmap 0.19.1


    This plugin lets you define landmarks that will be saved into a JSON file, similar to the old MapMarkers for hMod. I have included a DynMap component that shows those landmarks as little icons on the map.

    If you like this, why not donate a few bucks? But don't worry, this plugin will always be free.​

    • Set and delete landmarks
    • Display them on a DynMap
    • Full support for multiple worlds
    Download Landmarks 0.2 (Jar only, dynmap component only)
    Source Code
    Older versions: 0.1.1, 0.1

    /landmark add <name>
    Set a new landmark to your current position. Name may contain spaces.
    /landmark modify <name>
    Set update an existing landmark to your current position. Name may contain spaces.
    /landmark set <name>
    Shortcut for add or modify depending if there already is a landmark with this name. Name may contain spaces.
    /landmark delete|del|remove <name>
    Remove an existing landmark. Name may contain spaces.

    (All permissions include the rights to use the matching aliases and shortcuts such as /landmark set)
    The player may use /landmark add
    The player may use /landmark modify on his own markers
    The player may use /landmark modify on all markers
    The player may use /landmark remove on his own markers
    The player may use /landmark remove on all markers

    • List existing landmarks
    • Show information like creator and time (already included in JSON file)
    • Think about priorities or grouping
    • Different icons? Probably larger icons for higher zoom levels.
    • Save display settings in cookies
    1. Just unpack the contents of the zip file into your bukkit folder.
    2. If you want to use the DynMap component:
      1. Go to plugins/Landmarks/config.yml and set markersfile to ../dynmap/web/markers.json
      2. If you have copied your dynmap/web folder to your Apache folder (as described in DynMap's setup instructions), use that path instead or use a symlink
      3. Go to plugins/dynmap/configuration.txt, find "components:" and add the following below it:
          - class: org.dynmap.ClientComponent
            type: landmarks
      4. Optional: to display the settings panel, add the following just above what you added in the last step:
          - class: org.dynmap.ClientComponent
            type: settings
    There's also a more detailed howto for Linux users below. Thanks, paccer!

    Version 0.2
    • Permissions support
    • New settings panel where people can select if they want to see the markers and marker texts (optional). See setup instructions step 2.4
    • Markers are now automatically removed from dynmap without reloading the page
    • New commands add and modify (they do basically the same as set, but you won't accidentally update an existing marker when you want to add a new one or the other way round)
    • The default config now contains the correct markersfile path for dynmap
    Version 0.1.1
    • Included config.yml and removed markers.json (will be created automatically)
    • Added a 2 pixel semi-transparent white border around the landmark icons
    • No changes to the jar file itself!
  2. Same like that :( I dont see any Landmarks tag in the DynMap, maybe i should wait :)
  3. Offline


    landmarks.js doesn't get loaded. You probably made a mistake when you edited your dynmap/configuration.txt
  4. Offline


    I made a list of all available icons that u can use.
    Credits for making the icons goes to: @Toothless

    Usage: /landmark type <icon_name> (this only desides which your active icon is, this does not create a new landmark for you)

    Icon List: (41 icons)
    *Plz note that even though the imagenames doesnt have a capital first letter, they do have it in minecraft. i.e. "airport" would be "Airport" in minecraft.
    (last updated 6/5/11)
    kyle921, ledhead900 and crckdns like this.
  5. Offline


  6. I haven't edited it, but after i edited it, it still not worked :(
    Its's probably my fault. Can you send me your configurations.txt ?

    Thanks :D
  7. Offline


    Please read the instructions again. The config format for DynMap has changed in 0.16 and you are mixing the old and the new format.

    There you go
  8. Thank you :D now testing again
  9. Offline


    Can you make a .zip file version. rar files don't work for me because I have a mac :(
    Toothless likes this.
  10. Offline


    41 icons to add to your dynmap:
    Download (css and images included)

    kyle921 likes this.
  11. Offline


    Hey thanks! You deserve [cake] and [diamond][diamond][diamond].

    Oh and one more question:
    How did you make the map so you are in 3d mode by default rather than in flat view? Is it something that you have to change in the dynmap config txt file?
  12. Offline


    Yes you have to change teh order in the config, replace your config with the file i embeeded.
    if you want the order to be: 3d, 2d, cave

    Attached Files:

  13. Offline


    I deleted the 2d mode.

    Im adding more icons (around 500)
  14. Offline


    Never mind, I found it.
    I guess this is why github has pull requests and why some plug-in devs do not like people posting modded mods in their original thread...
    For completeness sake: here is the post of the custom icon modded dynmap:
  15. Offline


    Aight, I love this so far, but there's still room for improvement ;). Do you think it's possible to make the landmark types non-case sensitive by making duplicates within the css file that are lower case? I'm going to try it out and tell you what I find :)

    P.S. CSS is so useful because I'm a web designer so I know how to use it :D (unlike java :()
  16. Offline


    Hard to say. Could you please use [code]-Tags instead of [quote]? In YAML files, the spaces are important.
  17. Offline


    I can help you out if you start up something like teamviewer :)
  18. Offline


    Working great with DM v0.18 #208 and CB #839. ;)

    Edit: Toothless' .css isn't though. Nothing at all shows up using it. :oops:

    Edit2: I went to Toothless' map and the icons show up and most disappear. When I copied this all to the correct folders, I used the commands /landmark type and various attempts at the last part, like Spawn, icon_Spawn, iconSpawn, and other variations with no luck. It doesn't seem to be a command and pick up any changes made.

    Would there be a way to easily integrate an icon command and a folder to use icons of any type as landmarkers? If so, I'd like to request this feature be added to Landmarks. Thank you. :)
  19. Offline


    The icons on my map are corrupt because i changed the worldname.

    To add an icon simply typ /landmark type Radiation (or whatever)
    Then /landmark set powerplant

    Done :)

    Version 0.2.1
    73 icons to add to your dynmap:
    Download (css and images included)

    New Icons V0.2.1 Preview
    All Icons Preview

    If you miss some icons, please contact me with your ideas and I will add them.

    css file bugfix (Icons didnt show up correctly)

    32 Icons added.
    icon Radiation changed. (Using a capital wont let you place an icon)

    Project started.
    41 Icons added.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
    MacG32 likes this.
  20. Offline

    Marco Moreira

    Ive added the new icons but some of them a cant seem to get work they wont show up (Apartments, Realestate etc..)

  21. Offline


    I found the error.
    There was a typo in the css, please redownload 0.2.1 (its fixed there)
  22. Offline


    WOW i was just on the site and server these look really cool but the link is broke can you fix it please i would love to use this on my server its soo cool Herp Derp is scroll up....

    hope you fix the link but if not....

    if any one else has this can they please share a link i would love this on my server thank you

    Herp Derp I scroll up...
  23. Offline


    Looks pretty awesome. I managed to set up my dynmap up and it's been working great for the past few days. It's set up in the plugins folder and set up with the apache alias rewrite (you can see the map at http://coyote-den.dyndns.org/minecraft/map)
    It was working fine, and I could see my avatar on the map when I moved around. However when I added this Landmarks to the plugins and set it up, the map's functionality like the avatar and world time stopped working. I then went and downloaded the landmarks package that Zaph34r provided and set that one up instead. My map still has missing functionality, I changed the config.txt file with the one provided here and it's still not working :/
    I'm thinking about redoing the whole Dynmap and Landmarks plugins unless someone could help me figure this out? It'd also be really great instead if someone packaged the Dynmap and Landmarks together already configured, it might take out the headache for me to figure the whole thing out.

    Update: Got it fixed! I went ahead and just reinstalled both plugins since I figured that was the quicker way to do it rather than spend hours trying to figure out where I went wrong on the initial install.

    I had alias rewrite and I had moved the dynmap web folder under /var/www and forgot about that. So I copied over the web files from Landmarks into that, symlinked the markers.json file and it was all good after that!
  24. Offline


    Hi Toothless, I have install Dynmap 0.18 and Landmarks. After I installed the 0.2.1 pack, the icons are not displayed. If I landmark.css back into the original file, hte icons are displayed. Do you have an idea? I have installed the latest 0.2.1.
  25. Offline


    U got it fixed ;)
  26. Offline


    I installed Dynmap v0.18 and set up my maps, etc... and it works.

    Then I tried to install Landmarks v0.2. I am running my CraftBukkit860 on Ubuntu, and followed the linked ubuntu instructions. After I installed Landmarks and ran the server, i get this:

    21:45:04 [SEVERE] [dynmap] Error loading maptype
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:186)
        at org.dynmap.ConfigurationNode.createInstance(ConfigurationNode.java:188)
        at org.dynmap.ConfigurationNode.createInstances(ConfigurationNode.java:213)
        at org.dynmap.DynmapPlugin.onEnable(DynmapPlugin.java:101)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    21:45:04 [SEVERE] java.lang.NullPointerException
    21:45:04 [SEVERE]     at java.lang.Class.forName0(Native Method)
    21:45:04 [SEVERE]     at java.lang.Class.forName(Class.java:186)
    21:45:04 [SEVERE]     at org.dynmap.ConfigurationNode.createInstance(ConfigurationNode.java:188)
    21:45:04 [SEVERE]     at org.dynmap.ConfigurationNode.createInstances(ConfigurationNode.java:213)
    21:45:04 [SEVERE]     at org.dynmap.DynmapPlugin.onEnable(DynmapPlugin.java:101)
    21:45:04 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    21:45:04 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
    21:45:04 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
    21:45:04 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
    21:45:04 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
    21:45:04 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    21:45:04 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    21:45:04 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    21:45:04 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    21:45:04 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    any ideas?
  27. Offline


  28. Offline


    Hello I have read through a bunch of posts but cant figure this out

    I want to go to the plugins/Landmarks to get to the configs but even after I run the server and Landmarks loads, I have no Landmarks folder :\. The server even states something about a file its loading in the Landmarks folder that doesnt exist ><
  29. Offline


    Plugins does not work any times, very bad plugin fix it pls !
  30. Offline


    I guess you only downloaded the jar file. When installing the plugin for the first time, use the zip file with everything included.

    Have you read this?

    On a side note: I've returned from Switzerland, so I might soon have time to release the next version of dynmap.

    Oh, forgot to answer that. Sorry for my double post.

    I just looked at your dynmap and landmarks.js doesn't get loaded, so it might be a configuration error. In dynmap 0.16 or 0.17, the configuration format has changed. Please read the opening post for updated instructions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  31. Offline


    oh ok i have edit it wrong

Share This Page