Inactive [INFO] MCDocs v14.3 ~ Documentation Plugin || MOTD, Local or Online Files, Your Commands [1.3.1]

Discussion in 'Inactive/Unsupported Plugins' started by Tazzernator, Jan 17, 2011.

  1. Offline



    [​IMG] [​IMG] [​IMG] [​IMG]
    NEWS (open)

    Version 11.2 released (22nd October 2011)

    Version 11.2
    • Added permissions wildcard support (mcdocs.*) works for all commands.
      • Note: this only allows all commands. mcdocs.reload does not fall under this wildcard. This needs to be set separately.
    • Added some try catch around the motd: configs.
    • Fixed motd-enabled
    Version 11.1
    • Removed the spacing that occurs when you only have 1 page.
    • New variable: %time (Shows what time it is in the player's world in 12 hour format.
      • Sun rises @ 5am, Sets @ 7pm
    Version 11
    • Updated to work with PermissionsBukkit (Tested, nodes work)
    • Updated to work with Register for %balance, you will need to download the Register plugin for this to work with iConomy and various other economy plugins.
    • Optimised much of the code.
    • Updated the commands config structure, much simpler now than before. :)
    • You can now use %name, %size, %world, %group, %ip, %world, %prefix, %suffix in your file paths in the config.yml
    • Redefined the MOTD process.
      • Is now all defined within configuration
      • You can now use online files
    • Changed how logging occurs, you can toggle if you want to be informed about errors or not in the config now.
    • Group support now uses an in house permission system, where you define the groups players are in manually.
    • New permissions-enabled variable, Do you have any permissions system installed? Yes: true | No: false
    DoomLord, Camberme, efstajas and 18 others like this.
  2. Offline


    Any issues in the console?
  3. Offline


    For me, if another plugin uses the command, change it slightly. So yeah, if you want a short command, just do /rul or something.

    I changed /help to /cmd.
  4. Offline

    Don Redhorse

    don't you need to still edit the plugin.yml inside the essentials plugin jar to correct this issue?

    the essentials thread is full of this.
  5. Offline


    What other method is there?
  6. Offline


    For anyone having issues with MCDocs and Essentials, read how Essentials now works... if you want to have MCDocs handle a /help command, I believe you must remove EssentialsHelp.jar from your plugins directory completely.

    If you want MCDocs to handle /motd and /rules, DO NOT add - motd and - rule to the disabled-commands configuration in your Essentials\config.yml as this will block the command altogether no matter what plugin uses it... instead, remove the motd: and rules: lines from the Essentials\config.yml altogether.

    I haven't tested this theory yet (I will later this evening) - If someone else does before I do please post results and as always, remember to test on a development server FIRST before putting on your live/production server.
    Bloq likes this.
  7. Offline


    Doesn't work. It just returns null unfortunately.
  8. Offline


    Working great with bukkit build 325.
    I've used the permissions command structure to create a make-shift help menu for each user group.

    Thanks for the plugin!
    Tazzernator likes this.
  9. Offline


    I posted earlier for a Balance request (Iconomy) for the motd.
    Would that be a possibility?
    Would passing /commands of any kind be possible?
    I mean for it to be able to display "/bount list" as an example in the motd.

    Thank you for the great plugin.
  10. Offline


    For those of you wanting to get MCDocs & Essentials co-habitating successfully, I've got great news - it CAN be done. I had exactly the same problems at the start of the week.

    Here is a link to my post on the Essentials thread which describes what you have to do. I'll also repost it here at the bottom in a spoiler.

    tremor, you're right - don't install EssentialsHelp if you want to use MCDocs for a /help system. The only upside to Essentials help is that it will get the commands for ALL plugins and display them. Downside is it doesn't distinguish permissions, so will just display them all, no exceptions.

    Arilsilde, the post I linked was a direct reply to your query.

    Anyways, on with the show...
    MCDocs/Essentials Help (open)
    @Arilsilde, yes there is. It's a pain in the arse, but this is what you have to do and it works PERFECTLY. I had the same problems about 4 days ago.

    This is what I had to do:
    - Ensure 'motd' and 'rules' is in the list of DISABLED commands.
    - Using 7Zip, WinRAR or an appropriate program for your Operating System, open Essentials.jar, and find 'plugin.yml'. - In that file, you must delete the entries for 'motd' and 'rules' (including the description & syntax, NOT JUST THE COMMAND ITSELF).
    - Save the file plugin.yml back to Essentials.jar (if you have something like WinRAR, drag the plugin.yml file out of the .JAR, edit it, save it and drag it back in).
    - Restart the server or type /essentials (if you have OP priveleges or the correct permissions) to reload it all up.

    By disabling the commands in the config (especially 'motd'), Essentials won't try to use it's own MOTD when you join the server, won't display '[null]' and will use MCDocs instead for the motd. If you have a plugin that you use for kits instead of Essentials, you will need to do the same for 'kit' as well. Although the commands are on the disabled list, because they're not in the plugin.yml it won't take effect and you can still the use the commands from other plugins.

    After this is all done, you can configure MCDocs with /rules, /help, /motd, etc. and you shouldn't have a problem.

    And now I've done my civic duty, I'm off to do something I've been unable to do for the last week and a half... PLAY MINECRAFT.

    Edit: Running Craftbukkit build #320, MCDocs v5.1, Essentials b191 & Permissions v2.0.

    Tazzernator likes this.
  11. Offline


    Really!? Since when? This was the reason I got MCDocs :p But it didn't do that for me, and as far as I know it hasn't been updated? I might have both since I just put in all that effort making my files, lol.
  12. Offline


    sadly they should have thought to package a /help command with the permissions plugin... that's ultimately where it would have worked best.. and create a hook for all the plugin developers to hook their help files into permissions.. this way it would have only displayed help files for commands for each rank. I like the control of MCDocs, and present help is a more player friendly way.. plugin devs tend to either not put enough time into their help files or they overestimate the intelligence of us players and admins.
  13. Offline


    Fresh install, and /rules comes up three times when typed once. Anyone got an idea why, because i have no addons that would affect it.

    Edit: Resolved, just filled in fresh files again.
  14. Offline


    It's only what I read somewhere. I don't use EssentialsHelp so I don't know if that's the case! I use MCDocs w/ Permissions and create my own help files based on the permissions list, just like was mentioned elsewhere in this thread (can't remember who, sorry!)
  15. Offline


    Slimey, your fix worked perfectly. Thanks again man.
  16. Offline



    Added the fix to the OP - I'd never gone into the later builds of Essentials. Thanks for the update mate :)
    --- merged: Feb 18, 2011 3:46 AM ---
    Is my use/installation user friendly? -- I know the plugin is pretty complicated.. :/
  17. Offline


    Tazz, is no problems. Glad to be able to help. I *painfully* started off with a vanilla craftbukkit.jar and added one plugin at a time, let the plugin generate it's necessary config files THEN modify the config file(s) to my taste, test in the client, and bang, on to the next one. 23 times. Yes - I run 23 plugins on my server and NOT ONE conflicts with the other. I think where people go wrong is they copy their old config stuff over before they do an upgrade instead of copying/moving things AFTER the config has been generated and tested as working. Apart from the hiccup with Essentials/MCDocs, the only other problem I had was having to restart the server a few too many times to get Stats & Achievements going, but I got there - as stated, no conflicts :) (I may have an upper leg though... I work as a SysAdmin for Government so doing that sort of stuff is 2nd nature ;-))

    With regards to your use/installation, it's perfectly set out, only have to go to one spot for permissions, one spot for commands, one spot for set up, one spot for colours... you get my drift :) I for one, am SO glad you added the Permissions support in, especially after you said earlier you weren't going to. It's making my life so much easier already.
  18. Offline


    MCDocs is a dream IMHO. But its not the installation docs I was talking about.. it's in-game help files for the players for /commands. Sometimes it seems those are one of two extremes. 1- an afterthought (most of essentials) or 2- filled with too much technical jargon (worldedit, worldguard). This is exactly why I love MCDocs, I've re-written basically every piece of information for in game commands using MCDocs in ways the my users understand it.

    For example, help for /give written by a developer looks like: /give <name> <item> <amount>

    Re-written for my players to understand it better... help for /give now looks like this: /give mean u r can has diamond w00t w00t, I R want has tp now?


    Just trying to get a laugh... thats funny nah come on admit it.
  19. Offline


    When I run the server everything works fine, but when someone logs in I get this error:

    [SEVERE] Could not pass event PLAYER_JOIN to MCDocs
    at com.bukkit.tazzernator.mcdocs.MCDocsListesner.groupMotd<MCDocsListener
    at org.bukkit.plugin.RegesteredListener.callEvent<RegesteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent<SimplePluginManager.j
    at net.minecraft.server.ServerConfigurationManager.a<ServerConfiguration>
    at net.minecraft.server.NetLoginHandler.b<>
    at net.minecraft.server.NetLoginHandler.a<>
    at net.minecraft.server.PacketLogin.a<SourceFile:46>
    at net.minecraft.server.NetworkManager.a<SourceFile:232>
    at net.minecraft.server.NetLoginHandler.a<>
    at net.minecraft.server.NetworkListenThread.a<SourceFile:91>
    at net.minecraft.server.MinecraftServer.h<>

    Help please....
  20. Offline


    This is really weird.

    On a server running an older CB (302 or so, bamboo numbering) McDocs works like a charm.

    On a server running CB 328 (roughly), with a more or less same setup, noone except Admins can read the files. Now, this would seem like a permissions issue, but my lowest group does have mcdocs.* and I never had troubles with permissions setups, it works for every other plugin. For testing I also added the actualy mcdocs./blah nodes and added mcdocs.* to all groups, but all that doesnt work.

    Any idea where I could start troubleshooting?
  21. Offline


    Updated my server today to b405-jnks and this message popped up, just thought you'd like to know.

    2011-02-21 12:37:24 [WARNING] Using the stupidly long constructor com.bukkit.tazzernator.mcdocs.MCDocs(PluginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is no longer recommended. Go nag the plugin author of MCDocs to remove it! (Nothing is broken, we just like to keep code clean.)
  22. Offline


    Lol - Okay - I'll have a squiz later today :)
  23. Offline

    Kevin Forte


    I thought I would show you this: Happens with the motd. I'm not really sure why, and it surely isn't hurting anything, it's just annoying :p
  24. Offline


    Open your txt files with notepad ++ and check if it's there.

    EDIT: I've been able to replicate the error - Standby. :/
    --- merged: Feb 22, 2011 10:05 AM ---
    MCDocs V5.2 Is available

    See OP.

    • Fixed up the constructor warning.
    • Changed the namespace.
    Notes regarding the strange "y" symbol:

    This seems to be appearing when the file is saved as a UTF-8 -- I originally used these files before I implemented the & for colour coding.

    To Rid the funny "y" symbol -- Open you file and copy what's inside. Then delete the file - Create a new text document, and name it what the file was named before - Paste what you originally had in the file.

  25. Offline


    ok, thanks ill try it out...
    --- merged: Feb 22, 2011 12:27 PM ---
  26. Offline


    Is it possible to use spaces in the commands? For instance, "/cmd cmd".
    If so, how would I do this?
    So far i have set up MCDocs to use as a help menu like others, and have set the commands as "/help-topic". While I would like to use a space instead of a "-"
  27. Offline


    Seems like a feature many wish to use -- I'll see what I can do.
    --- merged: Feb 23, 2011 7:30 AM ---
    Update: Looked into it -- It's very difficult to do - Considering the user can use page numbers. - I've decided against supporting this as a result.
  28. Offline

    Cosmic Break

    im getting the same error with version 5.2
  29. Offline


    Stop posting without further information - Bukkit Build - Permissions build # etc. How do you expect me to help when I don't know your scenario?

    MCDocs 5.2 was build for CB409 confirmed working on 423 and Permissions 2.0.
  30. Offline

    Cosmic Break

    im using CB 409 and permissions 2.1
  31. Offline


    First off I can't see mcdocs in the permissions at all... Can you even use any of the commands? See my original post for permissions support...

Share This Page