Inactive [INFO] MCDocs v14.3 ~ Documentation Plugin || MOTD, Local or Online Files, Your Commands [1.3.1]

Discussion in 'Inactive/Unsupported Plugins' started by Tazzernator, Jan 17, 2011.

  1. Offline



    [​IMG] [​IMG] [​IMG] [​IMG]
    NEWS (open)

    Version 11.2 released (22nd October 2011)

    Version 11.2
    • Added permissions wildcard support (mcdocs.*) works for all commands.
      • Note: this only allows all commands. mcdocs.reload does not fall under this wildcard. This needs to be set separately.
    • Added some try catch around the motd: configs.
    • Fixed motd-enabled
    Version 11.1
    • Removed the spacing that occurs when you only have 1 page.
    • New variable: %time (Shows what time it is in the player's world in 12 hour format.
      • Sun rises @ 5am, Sets @ 7pm
    Version 11
    • Updated to work with PermissionsBukkit (Tested, nodes work)
    • Updated to work with Register for %balance, you will need to download the Register plugin for this to work with iConomy and various other economy plugins.
    • Optimised much of the code.
    • Updated the commands config structure, much simpler now than before. :)
    • You can now use %name, %size, %world, %group, %ip, %world, %prefix, %suffix in your file paths in the config.yml
    • Redefined the MOTD process.
      • Is now all defined within configuration
      • You can now use online files
    • Changed how logging occurs, you can toggle if you want to be informed about errors or not in the config now.
    • Group support now uses an in house permission system, where you define the groups players are in manually.
    • New permissions-enabled variable, Do you have any permissions system installed? Yes: true | No: false
    DoomLord, Camberme, efstajas and 18 others like this.
  2. Offline


    :eek: I was just using Notepad, but I'll try that now.

    EDIT: Nope, doesn't change anything. I even disabled the Essentials plugin which uses /help, but it still doesn't do anything.
  3. Offline


    I can recommend TextPad, or probably Notepad++ as well. I just tested it out here, the regular Notepad indeed eats all the newlines. TextPad worked fine. Any text editor meant for programming or coding will probably work fine.
    When you fix this, it'll probably work all fine then. ;)
  4. Offline


    Just to get you a notification of my edit >.>
  5. Offline


    I'm running out of ideas then. [​IMG]
    Let's sum up...
    1. MCDocs is indeed running?
    2. There is a MCDocs folder in your plugins folder?
    3. The MCDocs folder contains commands.txt?
    4. The commands.txt contains the relevant lines including '/help:help.txt'?
    5. There is indeed a help.txt file with contents in that same folder?
    6. Just to make sure: MCDocs is indeed running? Essentials also had /rules, maybe you got that instead? You need to see something like 'MCDocs version 4.3 is enabled!' when you start up your server.
    I can't think of much more else I'm afraid.
  6. Offline


    1. Yep
    2. Yes
    3. Affirmative
    4. Indeed
    5. There is
    6. Go back to 1. :p It said the message (I was blind before) and I also tried /registration, and every other file.
  7. Offline


    For me, I had the same issue as Bloq, the commands.txt only works if they're all on one line with some odd unicode character between each entry. I'll upload my commands.txt so that you can see.

    EDIT: I'm using craftbukkit #137 and MCDocs 4.3

    Attached Files:

  8. Offline


    That makes me think of linux versus windows newline issues. Save the commands.txt in the UNIX file format? (TextPad has that option, other advanced editors probably as well)
  9. Offline


    The default commands (not the ones I added) did work when they were all on one line. I didn't try the presets after putting them on separate lines.

    Also, does the type of .txt matter? Like Unicode or UTF (I'm using UTF, but I didn't set it)?
  10. Offline


    Hey, just wondering if anyone might be able to tell me why my motd doesn't post when you join the server? Once I'm in the server, if I type /motd, all i get is error:null. I've tried setting my commands.txt so it's all on one line, and also to where it's on individual lines, and neither seem to take care of the issue.

    edit: here's the error in console
    Player count: 1
    2011-01-30 15:14:39 [INFO] [PLAYER_COMMAND] kyanther: /motd
    at org.bukkit.earth2me.essentials.Essentials.getLines(
    at org.bukkit.earth2me.essentials.Essentials.getMotd(
    at org.bukkit.earth2me.essentials.EssentialsListener.onPlayerCommand(Ess
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.NetServerHandler.c(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(

    edit 2:
    After looking at the error, i wanted to assume it had something to do with the essentials plugin. So, i removed that. Still isn't working. :/ My new error says "Unknown console command".
  11. Offline


    • MCDocs will automatically make page numbers for you
    • Please make sure each of your /command:filename.txt is on a new line in the commands.txt
    • Please make sure that in you help.txt, your lines are no longer than those in minecraft, or my built in pagination will not work. TO fix this, simply wrap the text yourself.
    • Remove the trailing / in your commands.txt
    • I have provided you a command.txt -- Copy and paste it.

    Yes it was conflicting with essentials, although it should still be working on login.

    Now it is crashing because the plugin you're using earthtome depends on motd in essentials.

    Read the console error, and you'll see it blatantly infront of you.
  12. Offline


    Thanks for that info, but how am I sure how long a line in Minecraft is? Most of the descriptions were from the Essentials' command list, and none of those were over one line, so hopefully I should be okay. I'll try that out now and inform you :)

    Also, is there a way to remove the commands from Essentials? The config file says commands that will be unable to be used on the server - is this universal or just for that plugin?
    --- merged: Jan 31, 2011 4:09 PM ---
    2011-01-31 16:07:51 [INFO] Unknown console command. Type "help" for help.[/FONT][/SIZE][SIZE=3][FONT=verdana]31-Jan-2011 16:07:54 org.bukkit.plugin.SimplePluginManager callEvent[/FONT][/SIZE]
    [SIZE=3][FONT=verdana][/FONT][/SIZE][SIZE=3][FONT=verdana]SEVERE: Could not pass event PLAYER_COMMAND to MCDocs[/FONT][/SIZE]
    [SIZE=3][FONT=verdana]java.lang.ArrayIndexOutOfBoundsException: 1[/FONT][/SIZE][SIZE=3][FONT=verdana]        at com.bukkit.tazzernator.mcdocs.MCDocsListener.onPlayerCommand(MCD[/FONT][/SIZE][SIZE=3][FONT=verdana][/FONT][/SIZE]
    [SIZE=3][FONT=verdana]at [/FONT][/SIZE][SIZE=3][FONT=verdana]va:138)[/FONT][/SIZE][SIZE=3][FONT=verdana]        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginMana[/FONT][/SIZE][SIZE=3][FONT=verdana]ava:216)[/FONT][/SIZE]
    [SIZE=3][FONT=verdana]      at net.minecraft.server.NetServerHandler.c([/FONT][/SIZE][SIZE=3][FONT=verdana]at net.minecraft.server.NetServerHandler.a([/FONT][/SIZE]
    [SIZE=3][FONT=verdana] [/FONT][/SIZE][SIZE=3][FONT=verdana]      at net.minecraft.server.NetworkManager.a(SourceFile:232)[/FONT][/SIZE][SIZE=3][FONT=verdana]      at net.minecraft.server.NetServerHandler.a([/FONT][/SIZE][SIZE=3][FONT=verdana]     at net.minecraft.server.NetworkListenThread.a(SourceFile:104)[/FONT][/SIZE][SIZE=3][FONT=verdana]   at net.minecraft.server.MinecraftServer.h([/FONT][/SIZE]
    [SIZE=3][FONT=verdana]   at[/FONT][/SIZE]
    [SIZE=3][FONT=verdana]    at[/FONT][/SIZE]
    [SIZE=3][FONT=verdana]2011-01-31 16:07:54 [INFO] [PLAYER_COMMAND] Bloq: /help 2[/FONT][/SIZE]
    [SIZE=3][FONT=verdana]2011-01-31 16:07:54 [INFO] Bloq issued server command: help [/FONT][/SIZE]
    [SIZE=3][FONT=verdana][/FONT][/SIZE][SIZE=3][FONT=verdana]2011-01-31 16:07:54 [INFO] Unknown console command. Type "help" for help.[/FONT][/SIZE][SIZE=3][FONT=verdana]
  13. Offline


    Just that plugin.
  14. Offline


    Oh, then I cannot understand the problem. Ignore the failed BBcode, but can you understand what has happened from the console message?
  15. Offline


    Is this working on b186?
  16. Offline


    Works nice with #188
  17. Offline


    I know this has been asked before, but it still would be very nice if this supported permissions, as bukkit may not be finished for a while or add its own permissions support for a while either. It doesn't seem to difficult to add permissions on and it would be a very nice function to have.
  18. Offline


    It's very easy to make it so you can set groups to use MCDocs -- But I want to make it so you can set which user commands can only be used by your defined groups -- And ontop of that -- vary the motd based on groups.

    This complexity means I really don't wish to do it twice. Although, I shall read up on the progress of the core permissions in bukkit -- and if they're still a distant feature, i'll add support for the current Permissions Plugin.
  19. Offline


    Not sure as of what build, but running #231 MCDocs doesn't even load up anymore.
  20. Offline


    --- merged: Feb 3, 2011 6:23 PM ---
    Please update for 232 :) Only addon left before I can switch.
  21. Offline



    No issues for me.
  22. Offline


    The issue is with /help. It just echoes "/help"
    --- merged: Feb 4, 2011 7:48 AM ---
    same with /motd, temp server on port 33333 is up
  23. Offline


    Updated OP.
  24. Offline


    Great Plugin!
    I have a request.
    I am using this and prefer it over essentials motd because it updates realtime.
    Is there anyway to include the /money variable in iconomy?

    Thank you for one of the most helpful plugins!
  25. Offline


    i got a little nice feature to add:

    if i try /rules shops and /rules are already assigned to it. Only the /rules will show up. This is okay, since if you accidently add a space or something behind /rules it will still show the rules. However, if I got another text file under the same command, like /rules shops it will still show the output of /rules not /rules shops like I already said.

    Sorry about the repeating :) And it didn't work for me when I first tried and according to the changelog nothing have happened since. So thanks if you add it ^^
    --- merged: Feb 5, 2011 9:59 PM ---
    Oh... I lol'd.

    "Okay let's try this awesome plugin!! *enables* ... okay, lemme try a command here now! *tries a command* ... *waits some seconds* ... *INTERNAL SERVER ERROR*"

    Relax. It was on a old version :)
  26. Offline


    This plugin is the most awesome thing ever. I have one request that shouldn't be hard to do at all, and maybe there is a solution to it without even having to update the plugin...

    My request is being able to read text files from another location besides the MCDocs folder.

    The reason is that since I run a private server, I wanted all of the users to have their own /<username> text file.
    So I did that, however they can't change it because they can't access the server files. I thought then, how great it would be to be able to access text files in different locations so I could just use our community dropbox account and put our messages on there. That way I, as the server admin, could also update the news via my android phone with dropbox!!!!

    So, that is my request, is it possible?? And once again thank you for this AWESOME plugin!
  27. Offline


    I just want to say that this plugin is, by far, my favorite. The on-the-fly edit capability is REALLY nice, not to mention how easy to make and limitless, but without sacrificing detail the actual documents can be. The multi-page functionality is beautiful, too. I'm not only extremely grateful to be able to use this, but am borderline proud of being able to run a server with such an awesome plugin. (Okay, that sounded WAY too kiss-ass.)
    Keep up the good work.
    Tazzernator likes this.
  28. Offline


    No - That's is functionaility that is obviously very unique. Sorry

    A work around would be to setup a cron job, maybe hourly or every minute - , to copy the files from the dropbox dir to your MCDocs dir.
    --- merged: Feb 7, 2011 1:29 AM ---
    Cheers mate :)
  29. Offline


    I still can't get this plugin to work. I've tried it with every new CraftBukkit release starting from 246. Every /command I do returns an error to the server log. I've tried everything previously mentioned in the thread but nothing's worked.

    EDIT: Scratch that, I got it working. I had previously checked the commands.txt to see if the formatting was incorrect (spaces, each file on a new line, ect.) and it SEEMED to be fine. I just happened to open it in Notepad++ and saw that some of my lines had 2-3 extra lines between them when it looked perfectly fine in regular Notepad!

    Guess this goes to show, never ever use default Notepad.
  30. Offline


    The joys that Microsoft put the common folk through. :p
    Asara likes this.
  31. Offline


    Sorry, I didn't think it would be that hard to make the plugin read a text file from another directory on your computer. Goes to show how much I know about programming.
    I did think of this, looks like this is the route I will probably have to go.

    Thanks for the response though, that is great. Keep up the fantastic plugin making work!!!! Plugins like this make hosting a server a joy!

Share This Page