Inactive [INFO] MCDocs v14.3 ~ Documentation Plugin || MOTD, Local or Online Files, Your Commands [1.3.1]

Discussion in 'Inactive/Unsupported Plugins' started by Tazzernator, Jan 17, 2011.

  1. Offline



    [​IMG] [​IMG] [​IMG] [​IMG]
    NEWS (open)

    Version 11.2 released (22nd October 2011)

    Version 11.2
    • Added permissions wildcard support (mcdocs.*) works for all commands.
      • Note: this only allows all commands. mcdocs.reload does not fall under this wildcard. This needs to be set separately.
    • Added some try catch around the motd: configs.
    • Fixed motd-enabled
    Version 11.1
    • Removed the spacing that occurs when you only have 1 page.
    • New variable: %time (Shows what time it is in the player's world in 12 hour format.
      • Sun rises @ 5am, Sets @ 7pm
    Version 11
    • Updated to work with PermissionsBukkit (Tested, nodes work)
    • Updated to work with Register for %balance, you will need to download the Register plugin for this to work with iConomy and various other economy plugins.
    • Optimised much of the code.
    • Updated the commands config structure, much simpler now than before. :)
    • You can now use %name, %size, %world, %group, %ip, %world, %prefix, %suffix in your file paths in the config.yml
    • Redefined the MOTD process.
      • Is now all defined within configuration
      • You can now use online files
    • Changed how logging occurs, you can toggle if you want to be informed about errors or not in the config now.
    • Group support now uses an in house permission system, where you define the groups players are in manually.
    • New permissions-enabled variable, Do you have any permissions system installed? Yes: true | No: false
    DoomLord, Camberme, efstajas and 18 others like this.
  2. Offline


    yeh like thrain said it certainly doesnt require rewriting the whole plugin
  3. Offline


    Can you add color to the txt. If so how do you add the color?
  4. Offline


    Indeed. I'll have to code in support for the main permission plugins. I havn't checked to see if their API holds such needs. i'll do that first.

    You missunderstand. %group is not the only use for group...

    Same commands for different groups, %online_group, motd, etc... all rely on the knowledge of the player's group

    it /is/ possible to make this work with just super perms, but it lacks simplicity and the usability for first timers is low.

    At the moment, I'm going to look into which permission plugins have their own API, and support them.

    This exists in my current version, which is yet to be released.

    &0 thorugh to &9 --- &a through to &f
    Don Redhorse likes this.
  5. Offline


    PermissionsBukkit support please!​
  6. Offline


    You sir, are an ass.
  7. Offline



    I didn't realize that there was another post about it... Sorry :(
  8. Offline



    Works 100% with all new builds and PEX. (Now on #1139)
  9. Offline


    for some reason it doesnt work for me with 1.8

    when i type /motd or any command nothing is printed, i do see : MCDocs: strontkever: /motd in console..
  10. Offline


    Having the same issue -- MOTD displays on join but no commands work after join. Used the .jar, when that had this issue, I then used the .zip and modified nothing and had the same problem (have changed the amount of news lines since then, below). Bukkit build is #1149. Didn't check with #1139, so I couldn't tell you if it's a problem of mine or a problem that's emerging with MCDocs.

    * Bukkit #1149
    * MCDocs 10
    * Console errors: None (except for the 'Can't find %group %prefix %suffix%' spam), but it does report that a user attempted to use the command, as expected
    config.yml (open)
    #MCDocs 10 by Tazzernator / Andrew Tajsic
    #Configuration File.
    #For detailed assistance please visit:
    #Here we determine which command will show which file.
    - /motd:motd.txt
    - /rules:rules.txt
    - /news:news.txt
    - /register:register.txt
    - /about:
    #This changes the pagination header that is added to MCDocs automatically when there is > 10 lines of text.
    header-format: '&c%commandname - Page %current of %count &f| &7%command <page>'
    #Format to use when using %online or %online_group.
    online-players-format: '%prefix%name'
    #The file to displayed when using %news.
    news-file: news.txt
    #How many lines to show when using %news.
    news-lines: 3
    #How long, in minutes, do you want online files to be cached locally? 0 = disable
    cache-time: 5
    #Show a MOTD at login? Yes: true | No: false
    motd-enabled: true
    #Inform the console when a player uses a command from the commands-list.
    command-log-enabled: true

    I'll probably also poke at the code to see if anything jumps out at me.

    Edit: Solution for me was
  11. Offline


    I'm pretty sure this has to do with a small change in the bukkit api for 1.8.
  12. Offline


    MCDocs fails to read my online file. For example, here is a part of my config.yml:
    - /motd:
    If I go to the url in my browser it works just fine, but if I try to use a command on the server it gives me this error:
    <!DOCTYPE html>
    <title>Not Found -</title>
        <meta name="Slurp" content="NOYDIR">
        <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">
        <link rel="icon" href="/favicon.ico" type="image/x-icon">
    <link rel="stylesheet" type="text/css" media="all" href="">
    Any help would be appreciated.
  13. Offline


    Works 100% with #1049 and PEX.

    My guests and members has their own motd with online-list, all commands working for the groups (different docs for the groups with same command, etc... ä ü ö works too with UTF-8)

    Online-Docs not testet.
  14. Offline


    darn, i use bpermissions
  15. Offline


    #1152 - no issues
  16. Offline

    Daniel Heppner

    Why not support SuperPerms?
  17. Offline


    I'm running MCDocs on Bukkit #1136 with CommandBook. The /motd command works, but on connect I see the MOTD from CommandBook, and I can't get MCDocs to take precedence. I'm not sure whether this is a Commandbook-specific issue or something in Build 1136... has anyone else had the same problem?
  18. Offline


    Does anyone have this working on 1185, PermissionsBukkit, and group-specific help files? I can't seem to figure it out.
  19. Offline


    Working for me! ;)
  20. Offline


    Hmm. Let's say I have a text document called:


    The config.yml has a commands-list entry called:

    - /help:help-default.txt:default

    And let's say my default group in PermissionsBukkit has a permission called:

    mcdocs./help: true

    That should work, should it not? I see nothing, even printed in the console. When I leave it as the default /help entry for everyone, it works just fine.
  21. Offline


    Wierd. It works for me... :/
  22. Offline


    Using PermissionsBukkit, I had to add superpermbridge.mcdocs.*: true
  23. Offline


    Tried it, no dice. I assume the problem is because MCDocs doesn't support bukkitperms yet.
  24. Offline


    Thats's true. Since Tazz hasent updated it in a while I've started working on a continuation of the plugin. :)
  25. Offline


    what does the Register.txt do?
  26. Offline


    it is just another sample text -- a suggestion for what your /register document might look like.
  27. Offline


    Does anyone know how I can get MCDocs to not override the /list and /online commands from essentials? I put them in the essentials override section of their config but its still looking to MCDocs for both the commands.
  28. Offline


    Could you add %size_group ? For showing how many players conected in a group?
    Could you also add %time for show the time on the server?

    Thanks for the work, awesome plugin ;)
  29. Offline


    I think you would all be happy to know that I have been working on version 11.

    This new version holds true support for PermissionBukkit, though it does require a new rework of the backend.

    I've optimised most of my code, and am pretty eager to release it.

    I've also added some new variables discussed :)

    Version 11 will be released on the 15th/16th of October. Look forward to it! :)
  30. Offline


    I thought mcdocs+ was a official continuation of mcdocs? guess I read wrong.

  31. Offline


    I love this plug-in so much, but I am having issues and I read all 35 pages and tried all of the suggestions, but nothing.

    as a preface to this problem I use PEX, Superpermbridge

    The problem is pretty simple (common):
    11:38 PM [INFO] [MCDocs] Warning, Group not found for Otterpawps
    11:38 PM [INFO] [MCDocs] Warning, One of the following is not found: %group %prefix %suffix for player Otterpawps
    And of course it spams when I use any command and causes quite a bit of lag for the user. Along with that, the neat little group commands do not work, whatsoever.

    for example:
    /rules doesn't work whatsoever. Infact, unless the command has no permissions, it won't work. So the only way I can get /rules to work is for it to be:
    On top of that, it won't display with a '*' or 'mcdocs.*', it has to be specific to the command; ie. 'mcdocs./rules'

    When it does work it spams about 20 lines of warnings/errors about not having a group/suffix/prefix. And I've troubleshot the hell out of it. Adding prefix/suffix to ever group, including mine [admin], and even adding all of that to my actual user portion of my perms.

            suffix: '&f'
            prefix: '&e'
            - Admin
            default: false
            prefix: '&c[Admin]&b'
            suffix: '&b'
            - mcdocs./motd
            - mcdocs./rules
            - '*'
    I'm not sure what the deal is. Would the PEX config have a large impact on this issue? Any direction would be awesome. Thanks!

Share This Page