Inactive [INFO/ADMIN] LogBlock v1.54 - Enderdragon Logging! Tree Grow Logging! [1.4.5]

Discussion in 'Inactive/Unsupported Plugins' started by DiddiZ, Feb 15, 2011.

  1. Offline


    Version: 1.50​
    Find and Backroll those Damn Griefers
    LogBlock release are on DevBukkit:

    LogBlock dev builds:

    Please read the installation guide

    I won't port LogBlock myself to mcAPI. Source code is available, so it shouldn't be to difficult for someone else to do it, also I'm still here. so I can answer questions. If there is more than one willing, that's up to you to handle that.

    The reasons I take this step, are the usual: I quit playing Minecraft about 5 months ago and lastly I was struggling to keep up with updates. The developement of Guardian made slow progress, so I fear it won't be ready to fully replace LB in time.

    Download latest dev build: Jenkins
    View the source code: GitHub
    Table of contents:
    1. Description
    2. Features
    3. Why to use LogBlock
    4. Example command
    5. Older versions
    6. Change log
    7. Todo list / feature requests
    8. Permission nodes
    9. Plugins supporting this
    10. Support the dev
    11. How to post error messages
    12. Advertizing

    LogBlock logs block changes into a MySQL database. Block changes can be placed or destroyed block, explosions, burned blocks, sign text changes, chest access, leaves decay etc.
    It can be used as griefer identification tool, to find out who build a particular building, or even roll back changes by certain players. Other purposes can be e.g: Undoing of forest fires
    All additional features are optional, to keep the database as short as possible. All database actions run in their own threads to avoid server lags.
    The use of permissions plugin (or any clone) is possible, but not necessary.
    Uses Spout for chest logging (but it's fully optional, and there is no need for the client mod at all).

    • Logging for block placing, block braking, fire, explosions, leaves decay, signtexts, lava flow and chest content
    • Very mighty commands system, not only allowing to rollback and redo, but also to tp to blockchanges, delete log ingame etc. Full list of commands.
    • Many parameters for lookup/rollback/redo/tp/clearlog commands: Block changes of one ore more player, in a specific area, in a world edit selection, specific block types only, block changes older or newer that a specific date, destroyed/created block only, in a different world and combinations of all these parameters. Full list of parameters.
    • Rebuilding map after importing a backup (/lb redo)
    • Last parameter to use the parameters of the last command
    • Quick ingame lookup of block history a wood pickaxe or a bedrock block.
    • All commands accessible from console (exept tools :D)
    • Custom queries for tools.
    • Different tool modes (lookup, rollback, redo, writelogfile and clearlog)
    • Saves block data like wool color, log type, torch adjustment, etc
    • Multiworld and multiserver support (some servers sharing the same database)
    • BigBrother log import
    • Loggable super pickaxe plugin (not to confuse with WorldEdit's super pickaxe)
    • API
    • Webstats
    Why to use LogBlock:

    Example commands: (thanks to tha d0ctor, read more about commands here)

    /lb rollback player fire since 1d3h – rolls back fire 1 day 3 hours
    /lb rollback player fire since 1d3h area 15 – rolls back fire 1 day 3 hours within a radius of 15 blocks

    /lb rollback player thad0ctor since 1h - rolls back thad0ctor 1 hour
    /lb rollback player thad0ctor since 1d area 5 – rolls back thad0ctor actions for the last day within 5 blocks
    /lb rollback area 10 since 1h30m - rolls back all modifications within 10 blocks since the list 1 hours and 30 mins
    /lb rollback area 10 before 06.11.2011 - roll back all changes in an area of 1o before June 11th, 2011
    /lb rollback player thad0ctor since 05:36:00 - roll back all changes of thad0ctor since 05:36 (server time)

    Download, Command, Configuration and Details:

    -> Full changelog
    • LogBlock v1.50 # 81 (Dez. 13, 2011)
      Works with CraftBukkit 1.0.1-R1
      • Feature: /lb me shows the total block count
      • Feature: Chest logging without spout
      • Feature: Enderdragon logging
      • Feature: Logging for tree and mushroom grow (thanks to MD5 for the api)
      • Fix: Area param works again with default radius
      • Fix: Rollbacks got slowed down a bit to avoid rare server crashes
      • Fix: If mysql username, password or database only consist of unquoted numbers, LB will read them now
      • Config: World configs changed totally, some names changed and all logging options are now in an own section
    • LogBlock v1.41 #63 (Nov. 15, 2011)
      Works with CraftBukkit recommended build #1337
      • Fix: Players with spawnTools permission are no longer allowed to spawn all tools.
      • Fix: Added a check to avoid "The permission xy is already defined!" errors
    • LogBlock v1.40 #60 (Nov. 09, 2011)
      Works with CraftBukkit recommended build #1337
      • Feature: Custom auto ClearLog
      • Feature: Reduced error spam. Instead of like 40 line of error code, there is now just a warning stating the MySQL con
      • Feature: The queue will now be dumped after 10 tries even when the MySQL server is connected
      • Feature: Custom material names, allows naming custom blocks
      • Feature: LogBlock will now respond to messages when started without MySQL connection
      • Fix: Log import runs now async
      • Fix: Log import errors won't crash the server
      • Fix: Console commands work again
      • Fix: You can now use upper case letter in tool names (I don't know why you even should, but ...)
      • Config: Added, clearlog.enableAutoClearlog in main config. Added materials.yml. Removed clearlog.keepLogDays
      • Permissions: Added 'logblock.spawnTools'
    • LogBlock v1.32 (Oct. 04, 2011)
      Works with CraftBukkit recommended build #1240
      • Feature: Player info logging: firstLogin, lastLogin, onlinetime, ip. No ingame lookup yet.
      • Feature: /lb queuesize to see the current queue size
      • Fix: Door logging logs now also fence gates
      • Fix: Bukkit api break in CB #1191
      • Fix: time restriction works now as intended. Thanks to xrobau
      • Fix: Players with insufficient permissions can't smuggle bedrock from one world to another
      • Config: Added logPlayerInfo
    • LogBlock v1.30 (Sep. 22, 2011)
      Works with CraftBukkit recommended build #1185
      • Feature: Chat lookup /lb chat player diddiz search +admin +sucks +dicks (more info)
      • Feature: Door logging
      • Feature: Dynamic tools, define your own tools
      • Feature: Use since and before to define a timespan
      • Feature: Enderman logging
      • Feature: cake logging (who ate it)
      • Config: Added logEndermen, logCakes and logDoors to world config and moved the tool section in main config.
      • Permissions: logblock.tool changed to and
        logblock.toolblock to
    Todo List:

    Permission Nodes:

    Plugins supporting Logblock:
    List (open)

    When you want to appear your plugin here, tell me about

    Support the developer (that's me :D):
    If you want to support me writing plugins or want to thank me for the plugin/support, you can: Suggest features I missed, report bugs (best with fix :D), donate via PayPal, flattr my plugins, gift me The Witcher 2 (thanks to newyoukdaily), 2x 1GB DDR1 modules (thanks to HonestFlames), or send me the inner life of a laptop or netbook with a broken display (need it to build a model aircraft, so there is no need for parts like display and keyboard).


    How to post error messages:

    I won't aswer questions to general MySQL setup/installation/what is MySQL (there are lots of good tutorials out there, use google)
    Please read the installation guide before asking a question about installation problems.
    Please read the FAQ before posting a error report. It may be solved there.
    In case of rollback or lookup problems: Type /lb savequeue and try again (when it's fixed then, it was a consumer problem, see FAQ)
    When you post error messages, it's important to paste the whole stack trace!

    Newyorkdailys Plugin Support Buisness (open)
    Still can't get LogBlock working, or any other plugin? Are you getting errors in your console and cant figure out why? Newyorkdaily offers Basic/Advanced Plugin support.
    • General/Advanced troubleshooting: FREE!
    • Plugin Installations: 1-2 Plugins - FREE!
    • 3 or More Plugins - $2
    Click on the link below to connect to him now!

    There is a LogBlock irc channel: #logblock at
    You can ask me on skype. My name is 'hawky.diddiz'.
  2. Offline


    the place where he griefed, did it looked something like randomly ~50% of the blocks where destroyed?
    thinking about it, even if the last action (destroying blocks) weren't logged, you should still be able to rollback (a little bit tricky, but....) the blocks because the action from the player which placed the block were logged! (if not to many days ago and deleted)
  3. Offline


    Yes we could manage to fix 50% of what he destroyed. A complete medium size (BBQ) house was burned down to the ground wasn't restored after the rollback. I still have the damaged world backup, but I guess with the SQL, we can't not reproduce the issue or test . We just went for a daily back up of the day before and went from there. The (3)Griefer(s) admitted he did it and was removed from the white-list. Ps: We haven't tried the "//chunk" and restoring an area, as we are still learning :)
  4. Offline


    Released v1.23

    Two bugfixes and per world config
    Taranis01 likes this.
  5. Offline


    Nice, will test it soon.
    I guess is that we rename the world/world nether as the world we are running? Plus make more copies of the yml's and name them to the other world(s) ?
  6. Offline


     21.07 23:40:36 [Server] INFO [Permissions] version [3.1.6] (Yeti)  loaded
    21.07 23:40:36 [Server] INFO 	at
    21.07 23:40:36 [Server] INFO 	at
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.MinecraftServer.h(
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.NetServerHandler.a(
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.NetworkManager.b(
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.Packet3Chat.a(
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.NetServerHandler.a(
    21.07 23:40:36 [Server] INFO 	at
    21.07 23:40:36 [Server] INFO 	at net.minecraft.server.NetServerHandler.handleCommand(
    21.07 23:40:36 [Server] INFO 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    21.07 23:40:36 [Server] INFO 	at org.bukkit.command.SimpleCommandMap.dispatch(
    21.07 23:40:36 [Server] INFO 	at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(
    21.07 23:40:36 [Server] INFO 	at org.bukkit.craftbukkit.CraftServer.reload(
    21.07 23:40:36 [Server] INFO 	at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    21.07 23:40:36 [Server] INFO 	at de.diddiz.LogBlock.LogBlock.onLoad(
    21.07 23:40:36 [Server] INFO 	at de.diddiz.LogBlock.Updater.checkTables(
    21.07 23:40:36 [Server] INFO 	at de.diddiz.LogBlock.Updater.createTable(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.StatementImpl.execute(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.StatementImpl.execute(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.ConnectionImpl.execSQL(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.ConnectionImpl.execSQL(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.MysqlIO.sendCommand(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.SQLError.createSQLException(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.Util.getInstance(
    21.07 23:40:36 [Server] INFO 	at com.mysql.jdbc.Util.handleNewInstance(
    21.07 23:40:36 [Server] INFO 	at java.lang.reflect.Constructor.newInstance(
    IDK what the problem is now.
  7. Offline


    Config is autoupdated. Should mention that :D
    You cut off the interesting part
  8. Offline


    Oh ya oops here is the whole thing as far as I can see that matters.
     21.07 23:59:23 [Server] INFO 	at
    21.07 23:59:23 [Server] INFO 	at
    21.07 23:59:23 [Server] INFO 	at net.minecraft.server.MinecraftServer.h(
    21.07 23:59:23 [Server] INFO 	at net.minecraft.server.MinecraftServer.b(
    21.07 23:59:23 [Server] INFO 	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    21.07 23:59:23 [Server] INFO 	at org.bukkit.command.SimpleCommandMap.dispatch(
    21.07 23:59:23 [Server] INFO 	at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(
    21.07 23:59:23 [Server] INFO 	at org.bukkit.craftbukkit.CraftServer.reload(
    21.07 23:59:23 [Server] INFO 	at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    21.07 23:59:23 [Server] INFO 	at de.diddiz.LogBlock.LogBlock.onLoad(
    21.07 23:59:23 [Server] INFO 	at de.diddiz.LogBlock.Updater.checkTables(
    21.07 23:59:23 [Server] INFO 	at de.diddiz.LogBlock.Updater.createTable(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.StatementImpl.execute(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.StatementImpl.execute(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.ConnectionImpl.execSQL(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.ConnectionImpl.execSQL(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.MysqlIO.sendCommand(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.SQLError.createSQLException(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.Util.getInstance(
    21.07 23:59:23 [Server] INFO 	at com.mysql.jdbc.Util.handleNewInstance(
    21.07 23:59:23 [Server] INFO 	at java.lang.reflect.Constructor.newInstance(
    21.07 23:59:23 [Server] INFO 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    21.07 23:59:23 [Server] INFO 	at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    21.07 23:59:23 [Server] INFO 	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    21.07 23:59:23 [Server] INFO com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: CREATE command denied to user 'mcpoliceuser'@'localhost' for table 'lb-players'
    21.07 23:59:23 [Server] SEVERE [LogBlock] Error while loading:
    21.07 23:59:23 [Server] INFO [LogBlock] Creating table lb-players.
    21.07 23:59:23 [Server] INFO [LogBlock] Connecting to mcpoliceuser@jdbc:mysql://
    21.07 23:59:23 [Server] INFO [LogBlock] Version check: There is a newer version: v1.23 
  9. Offline


    You forgot to give your mysql user sufficient rights:
    GRANT ALL PRIVILEGES ON mcpolice TO 'mcpoliceuser'@'localhost';
  10. Offline


    Offtopic: Edit, doesn't belong here and google helps.
  11. Offline


    I'm still seeing that error on the latest 1.23 - thoughts?

    Strange btw, I never wanted to store anything flatfile or queue up a storage... not sure why this msg is even appearing.
  12. Offline


    Only fixed generation, you can delete all lines with "null". Or the whole file.
    It's because LB couldn't save the queue at last stop/reload and so wrote it to a file instad of dropping it.
  13. Offline


    Not sure if I missed something, but I had to do a minor rollback today and right when it asked me to confirm I typed in /yes and it told me unknown command, any ideas.

    Maybe it's the DefualtCommands plugin.
  14. Offline


    Hello again, users on my server are having an issue with LogBlock, specifically the tool command which allows them to right click with a wooden pick (default) and look at the block history. Well, nothing is showing up when they do this! I've checked the database is synched up still, and it's logging the blocks and players there just fine... it's just the tool command. I have turned it off and on using /lb tool [off/on] as well.

    Here is my LogBlock Config:
    - lb-main6
    - lb-nether6
    - world6
    - world_nether6
        port: 3306
        password: [password]*
        user: [username]*
        database: [database]*
        logBlockCreations: true
        logBlockDestroyings: true
        logKills: false
        logFire: false
        logChestAccess: true
        logSignTexts: true
        - 0
        hiddenPlayers: []
        logButtonsAndLevers: true
        logLeavesDecay: false
        logCreeperExplosionsAsPlayerWhoTriggeredThese: true
        logLavaFlow: true
        logKillsLevel: PLAYERS
        logExplosions: false
        logChat: false
        dumpDeletedLog: false
        keepLogDays: -1
        askRedos: true
        askClearLogs: true
        askRollbacks: true
        - 8
        - 9
        - 10
        - 11
        - 51
        maxArea: 50
        - 10
        - 11
        - 46
        - 51
        maxTime: 2 days
        delayBetweenRuns: 6
        forceToProcessAtLeast: 0
        timePerRun: 100
        useBukkitScheduler: true
        toolID: 270
        toolQuery: area 0 all sum none limit 15 desc silent
        toolblockID: 7
        toolBlockQuery: area 0 all sum none limit 15 desc silent
        defaultDist: 20
        defaultTime: 30 minutes
        linesPerPage: 15
        linesLimit: 100
    version: '1.22'
    *login details removed, brackets and * not in actual file!

            system: default
            default: true
                prefix: ''
                suffix: ''
                build: true
                - ''
                - 'essentials.home'
                - 'essentials.motd'
                - 'essentials.rules'
                - 'essentials.sethome'
                - 'essentials.warp'
                - 'logblock.tool'
                - 'essentials.suicide'
                - 'essentials.who'
                - 'essentials.afk'
                - 'essentials.list'
                - ''
                - 'essentials.msg'
            default: false
                prefix: '&d'
                suffix: ''
                build: true
                - Default
                - ''
                - 'essentials.tphere'
                - 'essentials.invsee'
                - 'essentials.kick'
                - 'essentials.ban'
                - 'essentials.unban'
                - 'essentials.home.others'
                - 'logblock.*'
            default: false
                prefix: '&c'
                suffix: ''
                build: true
                - '*'
            group: Admins
            group: Admins
            group: Moderator
    To recap:
    - Using Multiplay's Clan Forge
    - Database is set up at db4free and logs blocks (checked manually)
    - Tool command doesn't show any changes to blocks (except chests sometimes?)
    - Have restarted to rollback Essentials (as it was conflicting with permissions apparently)
    - ?????????????
    - halp

    Thanks again DiddiZ for all the time and effort you put into this plugin, and especially for keeping it up to date, and us informed about the latest bugs/fixes.
  15. Offline


    Look i have a error, i connected mysql bla bla bla and its okay, when i put a commands show this
    But says the destructions but no the people when destroyed that :(
    and i cant put bed rock
  16. Offline


    on cb 1000 and lb 1.23 i dried some rollbacks and got an error on the second rollback

    2011-07-22 13:06:32 [SEVERE] [LogBlock] Error while fetching connection
    java.sql.SQLException: Access denied for user 'ni3980_1_DB'@'' (using password: YES)
        at com.mysql.jdbc.SQLError.createSQLException(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(
        at com.mysql.jdbc.MysqlIO.secureAuth411(
        at com.mysql.jdbc.MysqlIO.doHandshake(
        at com.mysql.jdbc.ConnectionImpl.coreConnect(
        at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(
        at com.mysql.jdbc.ConnectionImpl.createNewIO(
        at com.mysql.jdbc.ConnectionImpl.<init>(
        at com.mysql.jdbc.JDBC4Connection.<init>(
        at sun.reflect.GeneratedConstructorAccessor22.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at com.mysql.jdbc.Util.handleNewInstance(
        at com.mysql.jdbc.ConnectionImpl.getInstance(
        at com.mysql.jdbc.NonRegisteringDriver.connect(
        at java.sql.DriverManager.getConnection(Unknown Source)
        at java.sql.DriverManager.getConnection(Unknown Source)
        at de.diddiz.util.MySQLConnectionPool.getConnection(
        at de.diddiz.LogBlock.LogBlock.getConnection(
        at de.diddiz.LogBlock.CommandsHandler$
        at de.diddiz.LogBlock.CommandsHandler$AbstractCommand.<init>(
        at de.diddiz.LogBlock.CommandsHandler$CommandSaveQueue.<init>(
        at de.diddiz.LogBlock.CommandsHandler$
        at Source)

    nothing worked wit lb i tried a reload but stopped my server because of extrem cpu usage (its from the provider a autostop script)

    edit: i think something with my provider is happend, all my mysql datas arent working now...

    edit2: ok its my provider hardware is crashed and i got new on.
  17. Offline


    @Porydan2 @Byktor
    To tell wether it's a logging or a lookup problem:
    Place some block, wait 10s (important!), click it with tool, type "/lb savequeue", click it with tool again, keep the coordinates in mind and go to phpMyAdmin and execute: "SELECT * FROM `lb-main` WHERE x = '0' AND z = '0' AND y = '0';" (replace lb-main with your actual table and add the coordinates from the block.
    There are 4 three options:
    1. It shows up at first click: Everythink ok.
    2. It shows up after savequeue: You have to adjust your consumer settings (FAQ).
    3. It shows up in the db but not ingame: REALLY strange and fairly impossible.
    4. It nowhere shows up: Check console for errors and whether you've enabled block logging

    A short look at the commands reference would have shown "/lb toolblock off" ...
    Yes, your MySQL server stopped to work and/or changed passwords/usernames
  18. Offline


    This process just for a block?
  19. Offline


    I get this alot in my logs...What can I do to change this? I am logging one world and it happens after about 10 min with only 6 users on this morning

    04:06:30 [INFO] [LogBlock Consumer] Queue overloaded. Size: 2726
    04:06:36 [INFO] [LogBlock Consumer] Queue overloaded. Size: 2724
    04:06:42 [INFO] [LogBlock Consumer] Queue overloaded. Size: 2721

  20. Offline


    Yes ...
    O wait, that's only to test where the problem is.
    Hm, the consumer processes too less blocks.
    Set forceToProcess to 20 or something
  21. Offline


    I'm suddenly getting this error message appear every two seconds:

    16:42:20 [SEVERE] [LogBlock Consumer] SQL exception
    com.mysql.jdbc.MysqlDataTruncation: Data truncation: Out of range value for column 'z' at row 1
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(
            at com.mysql.jdbc.MysqlIO.sendCommand(
            at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
            at com.mysql.jdbc.ConnectionImpl.execSQL(
            at com.mysql.jdbc.ConnectionImpl.execSQL(
            at com.mysql.jdbc.StatementImpl.execute(
            at com.mysql.jdbc.StatementImpl.execute(
            at java.util.TimerThread.mainLoop(
  22. Offline


  23. Offline


    Okay I think I ran the query correctly....


    Currently scanning logs

    lots of these: 2011-07-22 16:57:01 [INFO] [LogBlock Consumer] Queue overloaded. Size: 13372

    Going to change the consumer settings to:

    delayBetweenRuns: 5
    forceToProcessAtLeast: 0
    timePerRun: 200
    useBukkitScheduler: true

    Still returning no results :/
  24. Offline


    Never mind I just turned off all the questions in the config. Might wanna update it for CB#1000, I'm gonna delete and reload later to see if it fixes the problem.
  25. Offline


    set forceToProcessAtLeast: 50
    did you use "/lb savequeue" ?
  26. Offline


    I used /lb savequeue ingame, but I'm not sure what that did? It did flash up with something to do with the current queue size (1021).

    I will set ToProcessAtLeast: 50 now.
  27. Offline


    Should save the queue instantly instead of over time
  28. Offline


    How can i disable BukkitContrib?
  29. Offline


    Well, increasing the ToProcessAtLeast: 50 has made things work! Everyone's reporting full function with the tool command now \o/ thanks again for all the help DiddiZ.
    DiddiZ likes this.
  30. Offline


    Does the rollback Function work for anyone else? I am getting the 0 blocks found message. Yes I did test the section I wanted to roll back, it is returning data indicating a change. Yes I am using the commands suggested in the FAQ /lb rollback player erdrickk since 5 minutes

    My WebStats are even showing up properly with all the correct data.....

    I don't get this
  31. Offline


    Disable chest logging
    Maybe you should search in a larger timespan?
    like "since 99 days"

Share This Page