[INACTIVE][WEB/ADMN] milkAdmin - Free Web Administrator Tool v0.0.55- Backups, Starting and Stopping

Discussion in 'Inactive/Unsupported Plugins' started by Snowl, Feb 12, 2011.

  1. Offline


    [​IMG]MilkAdmin [ALPHA]

    Liked MilkAdmin? Well, good news!

    It's out again: http://forums.bukkit.org/threads/ad...0-05-14-full-webserver-in-a-plugin-766.17249/

    A free, open-source admin tool thats compatible with every OS.
    Designed to be simple, easy and functional.
    How to use? (open)

    1. Download milkAdmin.zip
    2. Extract into the directory craftBukkit is in.
    3. Go into your web browser and go to http://<server ip address here>:64712
    4. Login (username is admin password is admin)
    5. Create a new administrative user (username CANNOT be admin)

    Restarting/Starting/Stopping/Restoring not working?!? (open)
    This requires the wrapper made by drdanick: http://forums.bukkit.org/threads/ad...view-full-remote-console-access-r10-a6-2.674/
    Use this server wrapper to launch your server and restarting will work.

    Editing strings (open)
    Go into milkAdmin/strings.txt and edit the strings in there.
    Editing strings (open)

    Current strings available to edit:
    • banned
    • giveitem
    • takeawayitem
    • port

    Features currently implemented:
    • SHA-512 authentication
    • Restarting/Reloading/Killing server
    • Users online
    • Free/Total Memory
    • Server Version
    • Broadcasting messages.
    • Chat (type in the console, dont use /say)
    • Performing Server Commands (start commands with a /)
    • Backups
    • Starting and Stopping Server
    Features in next version:

    • Finish off web interface (players)
    Features coded but not in interface yet (should be in in a version or two):

    • Kicking User
    • Banning User/IP
    • Giving/Removing item from player
    • Getting and setting health of player
    • Changing display name of players
    • Teleport players to x, y, z/another player
    • Get IP: Port of player
    • Saving server
    • Editing/viewing inventory
    Features planned:

    • Fixing up web interface
    • Adding in all the features
    • Plugins
    • Mobile Theme
    • Fixing of properties
    • milkAdmin Account Management
    • View of logs
    • Dynamic Signatures
    • Scheduling
    • multiWorld Backups


    Why use MilkAdmin?

    There are a lot of alternatives out there that seem to have more features.
    Well for a start, MilkAdmin is very easy to install and requires almost no technical knowledge whatsoever to install and run. Not to mention that the server uses only java so configuring a complex webserver is not required as most gamers that play minecraft are gamers and not professional server administrators.

    A list of reasons why to use MilkAdmin;

    -Very easy to install and use
    -Does not require technical server knowledge
    -Does not use an external webserver
    -Does not require configuration
    -It's free and open source, I like to be forked on github :p
    -It uses a relatively small amount of memory
    -It's cross platform (will work like a charm on Linux, OS X and Windows)

    And I hope you enjoy my program we put time and effort into it, we appreciate your donations it encourages us and helps every step of the way!

    Thanks to
    • drdanick
    • cayde Dixon
    • d3x
    • RandomSRVApps (for testing and more ;) )

    • Fixed major bug.

    • Backups /Restoring
    • Fixes
    • Starting and stopping server
    • Edits to the Web Server
    • More

    • Added console in server

    • Fixed Firefox
    • Added save-all option
    • Fixed restarting server
    • Fixed RTK errors
    • Added focusing Broadcast Message clears the box

    • Added port changing
    • Added customizable strings

    • Initial commit. Nothing really special here.
    Source code available at https://github.com/Snowl/milkAdmin

    Want to support me? Like this plugin? [​IMG]
  2. Offline


    What about default login/password???
  3. Offline



    or edit the admin.ini with this user/pass "admin/admin"
  4. Offline


    Any chance you can add non administration accounts like that don't have access to restart and stop and manage plugins but have access to banning and viewing ips.. this would be a big help
  5. Offline


    The default login/password doesn't work on my server, and the files like properties.txt, etc reappears after all restart / reload or plugin reload... i try with
    admin=c7ad44cbad762a5da0a452f9e854fdc1e0e7a52a38015f23f3eab1d80b931dd472634dfac71cd34ebc35d16ab7fb8a90c81f975113d6c7538dc69dd8de9077ec but no result...

    version git-Bukkit-0.0.0-544-g6c6c30a-b556jnks (MC: 1.3)
  6. Offline


    it still doesnt work. i tried it with CB 559, 556, and 588. i tried it with all the other plugins out. what is wrong now. it still comes up with this error:
    2011-03-26 22:07:34 [INFO] Starting Minecraft server on *:25565
    2011-03-26 22:07:34 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-593-g90614b9-b588jnks (MC: 1.3)
    2011-03-26 22:07:34 [INFO] Preparing level "world"
    2011-03-26 22:07:34 [INFO] Preparing start region
    2011-03-26 22:07:35 [SEVERE] Could not load plugins\milkAdmin.jar in plugins: null
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:102)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:158)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:106)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:202)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:189)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:129)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:244)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoSuchMethodException: com.Snowl.org.milkBukkit.milkBukkit.<init>()
    at java.lang.Class.getConstructor0(Unknown Source)
    at java.lang.Class.getConstructor(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:97)
    ... 8 more
    2011-03-26 22:07:35 [INFO] Done (0.063s)! For help, type "help" or "?"
  7. Offline


    Hmmmm I am wondering what OS are you running on ? I am going to make an assumption that all other plugins load up with no issues ? You are running the updated code which is here ( Sharkale's Code found here ) ?
    What Version of Java are you running to find this out:
    1 if you are the Windows OS go to the control panel and click on the java app and then on the first tab click on About.

    2 If you are on a linux OS drop to a terminal window and type java -version it should kick back something to this:
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.7) (suse-1.2.1-x86_64)
    OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

    I look forward to helping you solve your issue. Sharkale you did not program in the back rub button on the interface I mean really how dare you forget such a thing :):):)

    I suggest you send to your trash the admin.ini file and use the default one from the zip and then reset the password on that one .

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  8. Offline


    i dont understand what the "updated code" is.
    my OS is windows and my java version is version 6 update 24.
  9. Offline


    I added the link to Sharkales updated code in my post it is in blue click on the link it will download to you the updated code.

    <Edit by Moderator: Redacted mediafire url>

    I hope this fixes the issue I am here to help
    Last edited by a moderator: Dec 15, 2016
  10. Offline


    For some reason the admin page never loads, it's just stuck in an infinite loop. Does not display any information about the server I'm afraid =(
  11. Offline


    Hmm is there a chance you could grab a screen cap to show us what is going on ?
  12. Offline


    ok now it works but when i try logging in it wont let me.
    i tried
    username: admin
    password: admin
    and i tried
    username: user
    password: pass
    what is the username and password?
    Last edited by a moderator: Dec 15, 2016
  13. Offline


  14. Offline


    it should be admin / admin but if that does not work try putting in this line in your admins.ini file and make sure you change the password shortly there after.

    make sure you clear out any other items in the file.

    Hmmm So you are seeing no errors in your console at all correct ?
    What time zone are you in maybe we work together to get it fixed? I am in the UTAH (gmt -7 )

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  15. Offline


    I'm in Sweden so it's GMT +1

    I'm getting no errors in my console so it's very strange.

    Could it be a port issue? Other router issues?
    I'm going to reinstall the mod and see if it fixes the issue.


    I found out what was causing the issue now. One of the other sysadmins of my server had opened up a dynmap on the same port as the "remote" port. The strange thing is however that it didn't show up in the console. But nevermind, it's fixed now and I'm happy happy :)


    However it loads information very slow. Could the problem be that I'm still on 516?
  16. Offline


    I can log in, admin/admin, user/pass, and I tried all the things that TheTalles says.
  17. Offline


    That is great to hear that it is working for you now.

    It could be I would update to at least 556 since that is the RB for CB. I am on 559 and cannot progress any further due to plugin breakage until they push the RB higher.

    Your post confuses me. Are you saying you can login or it was a brain slip and you ment to say cannot log on using admin/admin or user/pass ?

    Okay I hope helps solve the issue. I created a dummy account on my milkadmin to see if this resolves the issue
    open your admin.ini file clear out all your text in this file paste this into that file


    now save the file.
    The credentials are
    username is u53r
    password is password

    after you are in make another user for you with your password and then go back into the admin.ini file and remove if it is still there the pasted line from above.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  18. Offline


    I updated to CB 556 and It's still loading awfully slow and it's not displaying the most recent information about the server. I.E. milkAdmin is displaying 3 players online when there's actually 4 players online on the server. I can't reinstall the mod right now since the server is quite active at the moment but will give it a shot when there's time.

    Any ideas why this might be occuring? I'm running the server on Ubuntu Server 10.10, could it be a permission issue?
  19. Offline


    It "should" not be. If you did not have alter the perms when you created all the correct directories then that "should" not play into the issue at all.
    A. Are you noticing any lag in the server with milkadmin running?
    B. Is it showing the correct amount of memory being used.
    1. Are you running X ? if you are running X can you bring up your session manager and find out how much memory is being consumed by the Java process if not running X bring up top in another shell and see what the mem usage for the java process is.
    2. Are you local to the box that milkadmin is running on or is it remote?
    3. are you running on the default port ?
    4. Is there a websever running on the box ?

    lets see I could ask one more question but i think that is enough for now
  20. Offline


    I run Command Line... http://www.nyskaparna.nu/images/htop.png I took a screenshot of cpu and memory usage. Is it normal to have that many instances of rtoolkit.sh? Seems weird.

    Yes. Running Apache.

    I believe this might be the issue. I just gave another admin access to milkadmin and he could see the information perfectly. I run the server from my home and when I access it I do so locally.

    Hope I've been thorough.


    Not noticing any lag btw :)

    It's displaying the correct amount of memory usage.
  21. Offline


    I am not running the remote toolkit so I am not sure drdanick would have to answer that one. I did notice that you seem to have more than one craftbukit server running ? am I seeing that right. If you are local to the box then you should be seeing the update the fastest. If you have another admin who is logging on and he is seeing all the numbers and all is correct I am not sure what is going on on your local loop. ...
  22. Offline


    I disabled the remote toolkit now but the issue persists. Everyone outside of the network can access milkadmin and progress the information, for me (locally) I just loads and loads :(

    I'm only running one server, the remote tookit messed something up
  23. Offline


    THANK YOU! it works now.
    (i created a different account)
    thanks for helping me through everything.
  24. Offline


    Hmmm that is just strange that is not working locally but everyone else is okay .... I am not sure if you are running X on the server box or not if you are try to bring it up in a local webpage on there and see what happens...

    You are most welcome I am very glad I could help.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  25. Offline


    I'm not running any gfx interface on the server box I'm afraid. I tried to connect to milkadmin on the local adress also, but with the same result. I guess I'll just wait for a new release or something. Thanks for your advices and help ! :)
  26. Offline


    Wow you have strange one that is for sure. Try this for a trick it might work it night now. Change the Port it is calling to in the configuration file and then connect to it. If you get different results then something be not right
  27. Offline


    Try running the toolkit without using the .sh, then tell me if it's still spawning multiple processes. This is quite a serious bug if it is, and may well be that the blocking method that holds the wrapper until the child process dies is failing, which may indicate that something is wrong with your JVM. On that note, what is the output of java -version?

    Edit: ah, try using top rather than htop. It seems to display more than just the currently active processes.
    ps -u yourusername will also tell you how many JVMs are running.
  28. Offline


    602? Ehhhhh??

    I absolutely love this plugin, tank you for keeping it alive :)
  29. Offline


    I'll try that when I get a chance to restart the server.

    Yes I ran top instead and it only displayed one process. And ps -u only displayed one process also.
    I'm using OpenJDK 1.6.0_20
  30. Offline


  31. Offline


    Last edited by a moderator: Dec 15, 2016

Share This Page