[INACTIVE][TP] MyWarp v2.0.1 - native PermissionsEx support - no superperms yet [1337]

Discussion in 'Inactive/Unsupported Plugins' started by flames, Apr 15, 2011.

  1. Offline


    Version: 2.0dev
    Download (JAR / ZIP)
    Source code

    MyWarp is now in development by SpathiZilla, please see here

    MyWarp was made by Taylor Kelly (tkelly), all credits go to him! I forked MyWarp and will provide updates in future, or until tkelly is back. There are no changes in usage or functionality. Just the same commands, same permission nodes and same features. Original description:

    ...is Basic
    Many server admins only want the very basics. MyWarp delivers on that, and still gives the speed and reliability of using a SQLite database.

    By only giving your users permission to mywarp.warp.basic.*, they will only be able to use the very basic commands.

    ...is Social
    However, sometimes your users will demand more. They'll want to make their warps private, invite only specific people to their warps, even give their warp to someone else. MyWarp can do that too.

    Give your users mywarp.warp.soc.*, and they'll be able to do all of that.

    ...is Intelligent
    Sometimes, warps can be long and hard to remember. This is where MyWarp's auto-complete abilities come into play. It tries to find the most applicable match, and sends you there. It only considers warps you have access to, and will not send you somewhere unless it knows it's correct.

    A few examples:
    There are warps: {"Mob Spawner", "Farm", "farm", "tkelly's house", "joe's house"}
    tkelly has access to: {"Mob Spawner", "Farm" "tkelly's house"}
    joe has access to: {"Mob Spawner", "Farm", "farm", "joe's house"}

    No matter who uses /warp spawn, they will be sent to "Mob Spawner"
    If tkelly uses /warp house, he'll be sent to "tkelly's house"
    If joe uses /warp house, he'll be sent to "joe's house"
    If tkelly uses /warp farm or /warp arm, he'll be sent to "Farm"
    If joe uses /warp farm, he'll be sent to "farm"
    But if joe uses /warp arm, it equally matches both "Farm" and "farm", so will send him to neither.

    ...is Sign-full
    Physical interactions with the world is what Minecraft is all about. That's why signs can be used to replace many of the basic commands. For now, you can have a sign warp you to one of your current warps (using the auto-complete). Feel free to suggest more things, and I'll build that in.

    In order to build a warping sign, create a sign with two lines of text (it doesn't matter what specific lines).

    If you don't use the basic permission-set, give your players following nodes:

    ...is Guiding
    Want to make your users work to get to their points of interest? Rather than giving them /warp permission, just give them (mywarp.warp.basic.compass) permission. This will let them /warp point <name> to a given warp, and that'll orient their compass to that warp, allowing them to use their own two legs to get there.

    ...is Restricting
    In addition to the compass restrictions, you can also limit the number of public and private warps users can make. You can find and change these settings in MyWarp.settings.

    Until Bukkit's permissions and groups get fleshed out, this is a global number. However, with another setting in MyWarp.settings, you can allow admins to go around this limit.

    ...is Helpful
    As an server administrator, warps can easily be abused. MyWarp gives you access to be able to visit and modify all the warps.

    Version 2.0dev
    • MySQL support
    • importing warps from warps.db to mysql
    • permissions 3.x
    • removed extremely old artifacts (import of hmod warps)
    • tested and works on CB928
    Version 1.10.7
    • added native support for PermissionsEx
    • fixed namespace
    Version 1.10.6
    • updated for CB786-793
    • updated to Help 3.0 ( not interesting for you until you compile from Lycano's fork on github :p )
    Version 1.10.5c
    • fixed the "Could not pass event PLAYER_INTERACT to MyWarp" error
    Version 1.10.5b
    • updated for CraftBukkit RB #677 (also tested with CB #678)
    • Permissions 2.5.5 or higher (tested with 2.6 and 2.7)
    • added GroupManager support
    • changed update URL where MyWarp downloads sqlite libraries
    kahlilnc, Mtihc, Charant and 5 others like this.
  2. Offline


    Well I've currently got it set to false, but clearly since everything is slowly switching to it and a few packages are now switching to only MySQL, it's kind of a pressing matter that isn't going to go away.
  3. Offline


    nothing special...
    install mysql server.
    dont forget to set a secure password to the user "root" of mysql server.
    login as root and create another, less priveleged user "mcserver" with a good password.
    create a database "minecraft"
    (how to do the steps above google for your operating system)

    change MyWarp.settings:

    usemySQL = true
    mySQLconn = jdbc:mysql://localhost:3306/minecraft
    mySQLuname = mcserver
    mySQLpass = mysqlpassword

    mywarp will create the table in the database by it self, and if it finds plugins/MyWarp/warps.db (the sqlite database of mywarp) it will convert all of the existing warps to mysql automatically.

    btw. the same works for myhome 2.0rc1 ^^
  4. Offline



    Thanks for the reply, that helps, though sadly like all the other posts I've seen regarding MySQL, this is directed to people hosting locally. I don't, we use a game server host so I don't have access to set up a MySQL database in that manner. Thanks anyway, looks like we'll have to make do without plugins requiring MySQL support.
  5. Offline



    mySQLconn = jdbc:mysql://localhost:3306/minecraft

    change "localhost" to domain or ip of the server where your mysql database is hosted. allow external access to the database (if your minecraft server has a static ip, so for sake of security allow to access the database only this ip externally)

    while external access to the database is a lot slower than local! (depending on the connection between those servers)
    khamseen_air likes this.
  6. Offline



    Ah ha, thank you for the input. I shall look into that then and see if I can gain remote access to the MySQL databases on my webhost. Not sure how reliable it'd be but I can try it out if nothing else. Thanks.
  7. Offline


    Does this support economy yet? like price for warping and creating a warp? possibly using register?
  8. Offline


    I keep getting this error

    08:04:20 [INFO] Need to download 3 object(s)
    08:04:20 [INFO] - Downloading file : http://procrafter.de/downloads/lib/sqlite.
    08:04:26 [INFO] + Download complete
    08:04:26 [INFO] - Downloading file : http://procrafter.de/downloads/lib/win-x86
    08:04:27 [INFO] + Download complete
    08:04:27 [INFO] - Downloading file : http://procrafter.de/downloads/lib/mysql-c
    08:04:28 [INFO] + Download complete
    08:04:31 [SEVERE] [MYWARP] SQL exception on initialize
    com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link fai

    The last packet sent successfully to the server was 0 milliseconds ago. The driv
    er has not received any packets from the server.
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
    at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:343)
    at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2334)
    at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2
    at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2163)
    at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:794)
    at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection.java:47)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
    at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:378)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java
    at java.sql.DriverManager.getConnection(Unknown Source)
    at java.sql.DriverManager.getConnection(Unknown Source)
    at me.taylorkelly.mywarp.ConnectionManager.initialize(ConnectionManager.
    at me.taylorkelly.mywarp.MyWarp.sqlCheck(MyWarp.java:84)
    at me.taylorkelly.mywarp.MyWarp.onEnable(MyWarp.java:46)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:134)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:112)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.net.ConnectException: Connection refused: connect
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(Unknown Source)
    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.<init>(Unknown Source)
    at java.net.Socket.<init>(Unknown Source)
    at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.ja
    at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:292)
    ... 27 more
    08:04:31 [SEVERE] [MYWARP] Could not establish SQL connection. Disabling MyWarp
  9. Offline


    same error here
    maybe you should use persistent connection zu database if that is possible?
  10. Offline


    yep, soon
  11. Offline


    Hey there, i'm having a little problem over here... i've put all the nodes in the permissions folder but when i try to create a sign warp I have the following message:

    "You do not have permission to create a SignWarp"

    I tried as a Default and as a Admin, but this really doesn't work.

    Would you please help me?
  12. Offline


    Thanks a lot. This plugin is excellent. It's full featured, well documented, and has good in-game notifications. I really appreciate it!
  13. Offline

    The Wizard

    How can i change the name of the table (warptable)?
    I want to put a prefix mc_. Can you add this to your plugin?
  14. Offline

    Robert McKay

    MyWarp isn't working with 1.7_1 Bukkit.
  15. Offline


    It's usually considered more helpful to provide some sort of explanation, other than "not working". Does it give an error in the log, does it load but mess up when trying to use it etc.
  16. Offline

    Robert McKay

    Sorry! It seemed to be conflicting with mcMMO. It would not do anything, except when you type a command, it would show "/warp help"
  17. Offline


    I can confirm that MyWarp works with 1.7.2, RB 953.
  18. Offline


    regardless what you type in e.g. /warp list it says a warp with that name does not exist. even existing warps do not work.

    CB 953
  19. Offline


    This would be the perfect mod for me if only for one thing. In one of the mods I use (mcMMO) they have a feature called Chimaera Wing. With this, you can warp directly to the last bed you slept in using some feathers as a catalyst. The thing I like about this feature though is that you can only do it if the sky is exposed directly above you. If any single block is above you outside of air to the top of the world, you can't warp.

    Would it be possible to get a feature similar to that as an option in the config file? The main thing I am trying to avoid on my server is people looting underground, then warping back to the safety of their house without even leaving bedrock. Let me know if this is possible, and great mod :D
  20. Offline


    Could you possibly allow us to define a cooldown time for certain warps? Thanks for the great plugin so far, I'm in love with it so far.
  21. Offline


    I'm trying to import warp locations from my warps.txt file. I get the message that there is no warp called convert.
    I'm using the command '/warp convert' like it says in the description.
    What do I have to do to import the warps?
    Using latest Permissions plugin.
  22. Offline


    Maybe you do not have the mywarp.admin permission.
  23. Offline


    still one who needs to import warps.txt from hmod? wow. changelog says, i removed the old hmod artifacts, there is no warps.txt anymore, sorry. if you need to import download old craftbukkit build, get old mywarp from tkellys topic, and import, after that you can upload the warps.db to the productive server with new craftbukkit and new mywarp (oh sorry, i see i forgot to remove the info from topic, but still changelog tells you the import is gone)
  24. Offline



    may it possible to use mywarp at the console?
    An Example to teleport a player mywarp player user city? "mywarp player mediamemphis city" when i try this, i become a massage like this: /warp help - Displays the help for MyWarp

    Have a nice day
  25. Offline


    02:28:30 [INFO] Starting minecraft server version Beta 1.7.2
    02:28:30 [INFO] Loading properties
    02:28:30 [INFO] Starting Minecraft server on
    02:28:30 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-
    g9277096-b953jnks (MC: 1.7.2)
    02:28:30 [INFO] [Permissions] (Phoenix) was Initialized.
    02:28:30 [INFO] Preparing level "synopsize server"
    02:28:30 [INFO] Preparing start region for level 0 (Seed: -3696127726980915356)
    02:28:31 [INFO] Preparing spawn area: 61%
    02:28:32 [INFO] Preparing start region for level 1 (Seed: -3696127726980915356)
    02:28:32 [INFO] Preparing spawn area: 36%
    02:28:34 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    02:28:34 [INFO] [iConomy] Developed by: [Nijikokun]
    02:28:35 [INFO] [MYWARP] [MyWarp] Creating Database...
    02:28:35 [INFO] [MYWARP] [MYWARP]: 0 warps loaded
    02:28:35 [INFO] [MYWARP] Permissions enabled using: Permissions v2.7.4
    02:28:35 [WARNING] [MYWARP] Help plugin not detected. Only providing help via /w
    arp help.
    02:28:35 [INFO] [MYWARP] MyWarp 2.0 enabled
    02:28:35 [INFO] [Permissions] version [2.7.4] (Phoenix)  loaded
    02:28:35 [INFO] [iConomy] hooked into Permissions.
    02:28:35 [INFO] Done (0.437s)! For help, type "help" or "?"
    Can someone help? It's not doing like anything? :(
  26. Offline


    you mean this happens on every restart of the server? mywarp tells it created the database but it is not there? check filepermissions (if the server can write to the folder).
  27. Offline


    Has anyone else had an issue with this plugin causing you to take damage and/or getting stuck and dying? I've had to turn it off on my server for now.
  28. Offline


    you can go get the Help plugin
    but if you don't want another plugin, you can safely ignore that warning.
  29. Offline


    I'm getting the /warp help thing where I only am allowed to do that one command. I have the help plugin. I believe my permissions are setup right. Help?
  30. Offline


    Since the upgrade to 1.7.2 my players have been getting a problem happening very regularly where by when they use warps they get warped over the top of the void and die. I suspect this is just a problem with Minecraft itself but given I have googled it and can't find any info I was wondering if yourself or anyone else on this thread might be able to point in the right direction for how I might be able to fix this (if at all possible). Like I said I don't expect miracles but its worth a last ditch effort because I am getting a lot of QQ.

    In other news I have been using MyWarp for about a month or so now and freaking love it dude and so do my players. Thanks for putting the time in to make such a great plugin.

  31. I'm getting the same thing. Search results yield nothing for this problem and it's terribly frustrating for my players.

Share This Page