[INACTIVE][TP] MyWarp v2.0.1 - native PermissionsEx support - no superperms yet [1337]

Discussion in 'Inactive/Unsupported Plugins' started by flames, Apr 15, 2011.

  1. Offline


    Version: 2.0dev
    Download (JAR / ZIP)
    Source code

    MyWarp is now in development by SpathiZilla, please see here

    MyWarp was made by Taylor Kelly (tkelly), all credits go to him! I forked MyWarp and will provide updates in future, or until tkelly is back. There are no changes in usage or functionality. Just the same commands, same permission nodes and same features. Original description:

    ...is Basic
    Many server admins only want the very basics. MyWarp delivers on that, and still gives the speed and reliability of using a SQLite database.

    By only giving your users permission to mywarp.warp.basic.*, they will only be able to use the very basic commands.

    ...is Social
    However, sometimes your users will demand more. They'll want to make their warps private, invite only specific people to their warps, even give their warp to someone else. MyWarp can do that too.

    Give your users mywarp.warp.soc.*, and they'll be able to do all of that.

    ...is Intelligent
    Sometimes, warps can be long and hard to remember. This is where MyWarp's auto-complete abilities come into play. It tries to find the most applicable match, and sends you there. It only considers warps you have access to, and will not send you somewhere unless it knows it's correct.

    A few examples:
    There are warps: {"Mob Spawner", "Farm", "farm", "tkelly's house", "joe's house"}
    tkelly has access to: {"Mob Spawner", "Farm" "tkelly's house"}
    joe has access to: {"Mob Spawner", "Farm", "farm", "joe's house"}

    No matter who uses /warp spawn, they will be sent to "Mob Spawner"
    If tkelly uses /warp house, he'll be sent to "tkelly's house"
    If joe uses /warp house, he'll be sent to "joe's house"
    If tkelly uses /warp farm or /warp arm, he'll be sent to "Farm"
    If joe uses /warp farm, he'll be sent to "farm"
    But if joe uses /warp arm, it equally matches both "Farm" and "farm", so will send him to neither.

    ...is Sign-full
    Physical interactions with the world is what Minecraft is all about. That's why signs can be used to replace many of the basic commands. For now, you can have a sign warp you to one of your current warps (using the auto-complete). Feel free to suggest more things, and I'll build that in.

    In order to build a warping sign, create a sign with two lines of text (it doesn't matter what specific lines).

    If you don't use the basic permission-set, give your players following nodes:

    ...is Guiding
    Want to make your users work to get to their points of interest? Rather than giving them /warp permission, just give them (mywarp.warp.basic.compass) permission. This will let them /warp point <name> to a given warp, and that'll orient their compass to that warp, allowing them to use their own two legs to get there.

    ...is Restricting
    In addition to the compass restrictions, you can also limit the number of public and private warps users can make. You can find and change these settings in MyWarp.settings.

    Until Bukkit's permissions and groups get fleshed out, this is a global number. However, with another setting in MyWarp.settings, you can allow admins to go around this limit.

    ...is Helpful
    As an server administrator, warps can easily be abused. MyWarp gives you access to be able to visit and modify all the warps.

    Version 2.0dev
    • MySQL support
    • importing warps from warps.db to mysql
    • permissions 3.x
    • removed extremely old artifacts (import of hmod warps)
    • tested and works on CB928
    Version 1.10.7
    • added native support for PermissionsEx
    • fixed namespace
    Version 1.10.6
    • updated for CB786-793
    • updated to Help 3.0 ( not interesting for you until you compile from Lycano's fork on github :p )
    Version 1.10.5c
    • fixed the "Could not pass event PLAYER_INTERACT to MyWarp" error
    Version 1.10.5b
    • updated for CraftBukkit RB #677 (also tested with CB #678)
    • Permissions 2.5.5 or higher (tested with 2.6 and 2.7)
    • added GroupManager support
    • changed update URL where MyWarp downloads sqlite libraries
    kahlilnc, Mtihc, Charant and 5 others like this.
  2. Offline


    Permissions 3 works, I think also PermissionsEX, Superpermbridge does also work.

    With superpermbridge you can give your users any of the following;
    superpermbridge.myhome.home.basic: true
    superpermbridge.myhome.home.social: true
    or superpermbridge.myhome.home.*: true

    Then give your admins;
    superpermbridge.myhome.*: true

    Hopefully he will respond to this thread soon and let us know if he intends to ever update it for PermissionsBukkit. :)
  3. Offline


    Im using Superpermbridge.. this is my config:
                permissions.example: true
            - admin
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.example: true
            - user
                permissions.build: false
                permissions.*: true
                superpermbridge.stargate.destroy: true
                superpermbridge.stargate.admin: true
            - user
                superpermbridge.stargate.use: true
                superpermbridge.stargate.option: true
                superpermbridge.mywarp.warp.soc.public: true
                superpermbridge.mywarp.warp.soc.private: true
                superpermbridge.mywarp.warp.sign.warp: true
                superpermbridge.mywarp.warp.basic.*: true
                superpermbridge.essentials.sethome: true
                    permissions.build: true
                    superpermbridge.stargate.create: true
                    permissions.build: true
                    permissions.build: true
                    permissions.build: false
            - default
        build: '&cYou do not have permission to build here.'
    But it doesnt work, Stargate and essentials doesnt either, just nothing works oO
  4. Offline


    Can we get support for PermissionsBukkit, please?
  5. Offline


    Sorry, I just noticed I posted the MyHome permissions instead of the MyWarp ones, my brain was failing me haha. For my members I have given them 'superpermbridge.mywarp.warp.*: true' and for my admins 'superpermbridge.mywarp.*: true' that seems to be working ok.
  6. Offline


    Why is it not for me? oO
    Are you using Essentials?
    Which version do you have?
  7. Offline


    ok, im having a problem. i dont know if its perms or mywarp, but im guessing mywarp. when i try to use any warps it just does that /warp help thingy. im using bPermissions for perms, and i have given my group, Admins, mywarp.warp.basic.* as well as the Default group. it is exactly the same for both groups, i have checked, and i have checked that i am a member of both groups and that the capitalization is correct. i have also tried with myself in just one group, and reloaded permissions after every change, but i cant get it to work.

    EDIT: nvm, i fixed it, it turns out that i still have the permissionsex jar from when i tried it. im using bpermissions, it was trying to use permissionsex.
  8. Offline


    is there a permissions node for bypass private warps ?
  9. Offline


    My moderators have a 30+ page full of warps (alot of them are private). Is there a possibility to make a command to temporarly disable the private warps of showing up? Or the use of a filter?
  10. Offline


    I'm using MyWarp on a 1.7.3 server without issues - now we are trying to upgrade to 1.8.1 experimental and about half of the time the warps end up in an unloaded/unrendered chunk.

    I raised this on the craftbukkit bug tracker, but the suggestion I received back is such:

    Are you by any means able to verify if this is the case? I like MyWarp a lot and would like to keep it available on the updated server but with the issue count on 1.8.1 going down by the hour it's one of the few remaining open items really.

    Sample image of issue attached.

    Thanks a lot,

  11. Offline


    Do you have the option 'loadChunks = true' in the wywarp.settings file?
  12. Offline


    No I didn't - good thing we talked about it, I was not even aware of this setting. Resolved.

    Thanks again for the cool plugin!
  13. Offline


    few ideas ;]

    -"search by user"
    as a server op i cant look up my warps because i see only the whole list :/ and it would be nice to look up other people's warps, not to mention the public ones /warp show chlitto and /warp show public

    -a permission to give groups individual number of public and private warps would be very nice ;] and i think the problem with permissions is now over? at least in SignColours i can use "signColours.e - Allow user to use the colour yellow (e)" to assign individual colors with permissions...

    -/warp invite group:NAME and /warp group NAME

    -mysql support so we could show warps on my webpage and map
  14. Offline


    2.0 already has MySQL support. :)

    The search by user function would be very handy. I'm not to sure if @flames is still maintaining this or not though.
  15. Offline


    heh, i had another proposition but deleted it... adding dates to the changelog so more people would read them and know if the plugin is still maintained (or moving to dev.bukkit) - with dates i would now about mysql and flames :p

    btw do you know any good alternatives ?
  16. Offline


    You could perhaps look at the Essentials Warp, though this one is still working. I'm going to have to start looking for a replacement myself though as I want to switch to PermissionsBukkit and this doesn't support it yet without SuperpermBridge.
  17. Offline


    essentials sucks ;] its for ops and public warps only...

    first kiwiadmin now this :( so i hope your suppositions are incorrect - however with an opensource i think someone would pick up the project ;] will see after the new version of bukkit...

    <end of off-topic>

    PS im switching to PermissionsEx ;]
  18. When using ANY MyWarp command - nothing happens. It'll just throw back the "/warp help - Displays the help for MyWarp." message. No console errors, and I have permission to use it (PermissionsBukkit). Help?
  19. Offline


    Are you using the superpermbridge? Just MyWarp doesn't officially support the PermissionsBukkit.
    TheDeclonedCrafter likes this.

  20. I am using the bridge yes. Using the normal nodes didn't work, nor did superpermbridge.mywarp.warp.* or superpermbridge.mywarp.*.
  21. Offline


    Our members have;
    superpermbridge.mywarp.warp.*: true
    And our admins have;
    superpermbridge.mywarp.*: true
    Try those and see how you get on. :)
  22. That is what they have.
  23. Offline


    That's rather unusual then. Can you post your permissions config file please?
  24. Offline

    The Wizard

    It doesn't work on 1152.
  25. Offline


    Any sort of error log to show?
  26. Offline

    The Wizard

    Yeah, forgot to show the error :)
    2011-09-20 02:56:43 [SEVERE] Error occurred while enabling MyWarp v2.0 (Is it up to date?): null
        at me.taylorkelly.mywarp.Warp.processList(Warp.java:93)
        at me.taylorkelly.mywarp.Warp.<init>(Warp.java:36)
        at me.taylorkelly.mywarp.WarpDataSource.getMap(WarpDataSource.java:61)
        at me.taylorkelly.mywarp.WarpList.<init>(WarpList.java:21)
        at me.taylorkelly.mywarp.MyWarp.onEnable(MyWarp.java:55)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:892)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  27. Offline


    Before 1.8.1 with CB1060 Mywarp run with Essentials warp, but with last CB1153, I have error in consol and command return IG return "an internal error occurred while attempting to perform this command"

    2011-09-20 19:04:26 [INFO] [MYWARP] MyWarp 2.0 enabled
    here, error in console http://paste2.org/p/1661477

    Do you have same error ?
  28. Offline


    I get the below on build 1157:

    16:37:22 [INFO] pythros tried to use command /warp create test
    16:37:22 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin MyWarp v2.0
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:41)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:755)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:720)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:713)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:91)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.IncompatibleClassChangeError: Expecting non-static method org.anjocaido.groupmanager.GroupManager.getWorldsHolder()Lorg/anjocaido/groupmanager/dataholder/worlds/WorldsHolder;
            at me.taylorkelly.mywarp.WarpPermissions.permission(WarpPermissions.java:60)
            at me.taylorkelly.mywarp.WarpPermissions.warp(WarpPermissions.java:74)
            at me.taylorkelly.mywarp.MyWarp.onCommand(MyWarp.java:425)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
            ... 12 more
  29. Offline


    @Pythros I have same problems, if you find solution tell me it ;)
  30. Offline


    On shutdown (no one is logged on):
    12:44:12 [SEVERE] [MYWARP] Error on Connection close
    com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Communications link failure during rollback(). Transaction resolution unknown.
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
            at java.lang.reflect.Constructor.newInstance(Unknown Source)
            at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)
            at com.mysql.jdbc.Util.getInstance(Util.java:382)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1013)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:987)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:982)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:927)
            at com.mysql.jdbc.ConnectionImpl.rollback(ConnectionImpl.java:4751)
            at com.mysql.jdbc.ConnectionImpl.realClose(ConnectionImpl.java:4345)
            at com.mysql.jdbc.ConnectionImpl.close(ConnectionImpl.java:1564)
            at me.taylorkelly.mywarp.ConnectionManager.closeConnection(ConnectionManager.java:47)
            at me.taylorkelly.mywarp.MyWarp.onDisable(MyWarp.java:35)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:128)
            at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:913)
            at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:294)
            at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:287)
            at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:168)
            at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  31. Offline


    people seems to get stucked when warping eather they die or only get stucked is it gonna be a uppdate for 1.8? or is it the build that is making the problem?

Share This Page