[INACTIVE][TP/FUN] NetherGate v0.56 - Just Like Single Player! [803]

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Feb 4, 2011.

  1. Offline


    NetherGate - A plugin that uses multi-world to create a completely automatic Nether experience.

    If you're using Essnetials, go no further.

    Essentials breaks NetherGate in strange and frustrating ways, I'm not going to support it anymore. I'll try and get this resolved by NG beta, at which point I'll remove this message.


    To use NetherGate, drop the required jars in your plugins folder.

    Then you can create and light a portal to travel to the nether!

    Grab elBukkit.zip to get all of my plugins- take out the ones you don't want.

    For more details on NetherGate, or for individual jar downloads, see the NetherGate entry on bukkit's wiki.

    Tip Jar
    If you really love my stuff, and you're feeling generous, I'd more than appreciate a donation.

    Go here if you're interested!

    View changelog on github
  2. Offline


    Well, it should/will be in terms of your world data- but I doubt that any other plugin is going to re-pair any portals you've set up.
    --- merged: Mar 2, 2011 1:30 AM ---
    0.50 adds a 10-second window of temporary invincibility during/after portalling.

    This is mainly so you don't get "splinched" by the surroundings before I get a chance to clean it up- but it also might give you enough time to run back through a portal, if one is available, and the place is swarming with ghasts or something :)

    If you're a Wand/Spells pro, you could probably even construct and light a portal in that amount of time...
  3. Offline


    I had this in my plugins folder for a few versions and I just tried it (0.50). I'm sorry to report that it was a horrible mess.

    First, my server log
    Show Spoiler

    2011-03-02 02:59:08 [INFO] Starting minecraft server version Beta 1.3
    2011-03-02 02:59:08 [INFO] Loading properties
    2011-03-02 02:59:08 [INFO] Starting Minecraft server on *:25565
    2011-03-02 02:59:08 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-487-g108eceb-b484jnks (MC: 1.3)
    2011-03-02 02:59:08 [INFO] Preparing level "world"
    2011-03-02 02:59:08 [INFO] Preparing start region
    2011-03-02 02:59:09 [INFO] Big Catch version 0.3_1 is enabled!
    2011-03-02 02:59:09 [INFO] BlockBonus has been enabled.
    2011-03-02 02:59:09 [INFO] ControllerBlock: 1.13 by Hell_Fire
    2011-03-02 02:59:09 [INFO] ControllerBlock: Using IRON_BLOCK (42) as ControllerBlock, loaded 0 disallowed types from config
    2011-03-02 02:59:09 [INFO] ControllerBlock: Loaded v3 data - 3 ControllerBlocks loaded
    2011-03-02 02:59:09 [INFO] ControllerBlock: Enabling quick redstone check
    2011-03-02 02:59:09 [INFO] ControllerBlock: Events registered
    2011-03-02 02:59:09 [INFO] CraftBukkitUpToDate version 1.9.2 is enabled!
    2011-03-02 02:59:09 [INFO] CButD: Permission system not detected, defaulting to OP
    2011-03-02 02:59:09 [INFO] CButD: CraftBukkit is up to Date
    2011-03-02 02:59:09 [INFO] CrowdControl version 0.17 is enabled
    2011-03-02 02:59:09 [INFO] [DeathChest] version [1.33b] loaded.
    2011-03-02 02:59:09 [INFO] [DeathChest] Enabled permission system: LOCAL
    2011-03-02 02:59:09 [INFO] [DeathChest] Loaded expiration time: 0
    2011-03-02 02:59:09 [INFO] Growbie version 1.2.1 enabled.
    2011-03-02 02:59:09 [INFO] [HeroicDeath] enabled.
    2011-03-02 02:59:09 [INFO] HigherExplosives 1.2 enabled
    2011-03-02 02:59:09 [INFO] Minecart Mania Admin Controls version 1.0 is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Autocart version 1.01 is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Automations version 1.0 is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Chest Control version 1.01 is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Core version 1.01a is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Sign Commands version 1.01 is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Spawner version 0.8 is enabled!
    2011-03-02 02:59:09 [INFO] Minecart Mania Station version 1.01a is enabled!
    2011-03-02 02:59:09 [INFO] [MYHOME]: 1 homes loaded
    2011-03-02 02:59:09 [SEVERE] [MYHOME] Permissions isn't loaded, there are no restrictions.
    2011-03-02 02:59:09 [WARNING] [MYHOME] 'Help' isn't detected. No /help support.
    2011-03-02 02:59:09 [INFO] MyHome 1.9.2 enabled
    2011-03-02 02:59:09 [INFO] [MYWARP]: 5 warps loaded
    2011-03-02 02:59:09 [SEVERE] [MYWARP] Permissions isn't loaded, there are no restrictions.
    2011-03-02 02:59:09 [WARNING] [MYWARP] 'Help' isn't detected. No /help support.
    2011-03-02 02:59:09 [INFO] MyWarp 1.10.3 enabled
    2011-03-02 02:59:09 [INFO] NetherGate version 0.5 is enabled
    2011-03-02 02:59:09 [INFO] [OddGive] 0.3 enabled
    2011-03-02 02:59:09 [INFO] [OddItem] 0.3 enabled
    2011-03-02 02:59:09 [INFO] [OddItem] Parsed 0 entries.
    2011-03-02 02:59:09 [INFO] Persistence version 0.53 is enabled
    2011-03-02 02:59:09 [INFO] [PlugMan] Starting Up! - Version: 1.2.2 by bekvon
    2011-03-02 02:59:09 [INFO] [PlugMan] Permissions Plugin NOT Found, using OP!
    2011-03-02 02:59:09 [INFO] Snowballz has been enabled with the following options:
    2011-03-02 02:59:10 [INFO] Snow damage: 0
    2011-03-02 02:59:10 [INFO] Snow range: 10
    2011-03-02 02:59:10 [INFO] Snow douses fire: true
    2011-03-02 02:59:10 [INFO] Snow makes ice: true
    2011-03-02 02:59:10 [SEVERE] [TELEPLUS] Permissions isn't loaded, there are no restrictions.
    2011-03-02 02:59:10 [INFO] TelePlus 1.5.5 enabled
    2011-03-02 02:59:10 [INFO] Varietree version 0.1 is enabled!
    2011-03-02 02:59:10 [INFO] WorldEdit 4.0-beta8 enabled.
    2011-03-02 02:59:10 [INFO] WorldEdit: No known permissions plugin detected. Using configuration file for permissions.
    2011-03-02 02:59:10 [INFO] Done (0,169s)! For help, type "help" or "?"
    2011-03-02 03:01:29 [INFO] 143 recipes
    2011-03-02 03:01:29 [INFO] XYZ [/] logged in with entity id 49
    2011-03-02 03:01:37 [INFO] Preparing spawn area for nether, 4%
    2011-03-02 03:01:38 [INFO] Preparing spawn area for nether, 8%
    2011-03-02 03:01:39 [INFO] Preparing spawn area for nether, 8%
    2011-03-02 03:01:40 [INFO] Preparing spawn area for nether, 16%
    2011-03-02 03:01:42 [INFO] Preparing spawn area for nether, 16%
    2011-03-02 03:01:43 [INFO] Preparing spawn area for nether, 20%
    2011-03-02 03:01:44 [INFO] Preparing spawn area for nether, 24%
    2011-03-02 03:01:45 [INFO] Preparing spawn area for nether, 24%
    2011-03-02 03:01:46 [INFO] Preparing spawn area for nether, 28%
    2011-03-02 03:01:47 [INFO] Preparing spawn area for nether, 32%
    2011-03-02 03:01:48 [INFO] Preparing spawn area for nether, 36%
    2011-03-02 03:01:49 [INFO] Preparing spawn area for nether, 40%
    2011-03-02 03:01:51 [INFO] Preparing spawn area for nether, 40%
    2011-03-02 03:01:52 [INFO] Preparing spawn area for nether, 44%
    2011-03-02 03:01:53 [INFO] Preparing spawn area for nether, 48%
    2011-03-02 03:01:54 [INFO] Preparing spawn area for nether, 52%
    2011-03-02 03:01:55 [INFO] Preparing spawn area for nether, 60%
    2011-03-02 03:01:56 [INFO] Preparing spawn area for nether, 69%
    2011-03-02 03:01:57 [INFO] Preparing spawn area for nether, 73%
    2011-03-02 03:01:58 [INFO] Preparing spawn area for nether, 77%
    2011-03-02 03:01:59 [INFO] Preparing spawn area for nether, 81%
    2011-03-02 03:02:00 [INFO] Preparing spawn area for nether, 89%
    2011-03-02 03:02:01 [INFO] Preparing spawn area for nether, 93%
    2011-03-02 03:02:02 [INFO] Preparing spawn area for nether, 97%
    2011-03-02 03:02:02 [INFO] NG: TP'ing Player XYZ from (258, 21, -733) to (11, 22, -88)
    2011-03-02 03:02:02 [INFO] NG: Building a full portal at 11, 22, -88 and filling with air
    2011-03-02 03:02:02 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-03-02 03:02:04 [WARNING] XYZ moved wrongly!
    2011-03-02 03:02:04 [INFO] Got position 11.0, 23.0, -88.0
    2011-03-02 03:02:04 [INFO] Expected 11.0, 23.0, -176.30000001192093
    2011-03-02 03:02:09 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-03-02 03:03:48 [INFO] 0, 1
    2011-03-02 03:04:01 [INFO] NG: TP'ing Player XYZ from (11, 23, -89) to (584, 65, -969)
    2011-03-02 03:04:01 [INFO] NG: Building a full portal at 584, 65, -969 and filling with air
    2011-03-02 03:04:03 [WARNING] XYZ moved wrongly!
    2011-03-02 03:04:03 [INFO] Got position 584.0, 66.0, -969.0
    2011-03-02 03:04:03 [INFO] Expected 11.699999988079071, 23.200000047683716, -89.69999998807907
    2011-03-02 03:04:17 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-03-02 03:06:40 [INFO] NG: TP'ing Player XYZ from (258, 21, -732) to (-61, 23, 21)
    2011-03-02 03:06:42 [WARNING] XYZ moved wrongly!
    2011-03-02 03:06:42 [INFO] Got position 11.0, 23.0, -88.0
    2011-03-02 03:06:42 [INFO] Expected 11.0, 23.0, -144.30000001192093
    2011-03-02 03:06:46 [INFO] XYZ died from unknown causes
    2011-03-02 03:12:14 [INFO] NG: TP'ing Player XYZ from (258, 21, -733) to (-61, 23, 21)
    2011-03-02 03:12:15 [WARNING] XYZ moved wrongly!
    2011-03-02 03:12:15 [INFO] Got position 11.0, 23.0, -88.0
    2011-03-02 03:12:15 [INFO] Expected 11.0, 23.0, -144.30000001192093
    2011-03-02 03:12:20 [INFO] XYZ died from unknown causes
    2011-03-02 03:13:05 [INFO] NG: TP'ing Player XYZ from (258, 21, -733) to (-61, 23, 21)
    2011-03-02 03:13:07 [WARNING] XYZ moved wrongly!
    2011-03-02 03:13:07 [INFO] Got position 11.0, 23.0, -88.0
    2011-03-02 03:13:07 [INFO] Expected 11.0, 23.0, -144.30000001192093
    2011-03-02 03:13:11 [INFO] XYZ was killed by Herobrine
    2011-03-02 03:13:52 [INFO] NG: TP'ing Player XYZ from (258, 21, -732) to (-61, 23, 21)
    2011-03-02 03:13:53 [WARNING] XYZ moved wrongly!
    2011-03-02 03:13:53 [INFO] Got position 11.0, 23.0, -88.0
    2011-03-02 03:13:53 [INFO] Expected 11.0, 23.0, -144.30000001192093
    2011-03-02 03:13:58 [INFO] XYZ was killed by Herobrine
    2011-03-02 03:16:31 [INFO] XYZ issued server command: op XYZ
    2011-03-02 03:16:31 [INFO] XYZ: Opping XYZ
    2011-03-02 03:17:06 [INFO] XYZ lost connection: disconnect.quitting
    2011-03-02 03:17:08 [INFO] XYZ [/] logged in with entity id 12925
    2011-03-02 03:17:45 [INFO] NG: TP'ing Player XYZ from (258, 21, -733) to (-61, 23, 21)
    2011-03-02 03:17:47 [WARNING] XYZ moved wrongly!
    2011-03-02 03:17:47 [INFO] Got position 11.0, 23.0, -88.0
    2011-03-02 03:17:47 [INFO] Expected 11.0, 23.0, -144.30000001192093
    2011-03-02 03:17:51 [INFO] XYZ was killed by Herobrine
    2011-03-02 03:18:06 [INFO] XYZ lost connection: disconnect.quitting

    What Happened:
    I built a portal and stepped in it. At first, nothing happened, no console output in the server, nothing. Then eventually (maybe after restarting the server, I don't remember), the world started changing and I ended up in a 5x5x5 cube of air, encased in netherrack. I heard Ghasts close by.
    Eager to test the return to the real world, I immediately built a portal there using some obsidian I had brought. It worked, but teleported me somewhere seemingly random, or at least very far from where I started from. My starting portal was underground and I came back on the surface, as well.

    Then I used the MyWarp plugin to return to a warp point near my starting portal, to try again and see what happened. This time I just saw myself falling in void (the usual visuals when you teleport or respawn), heard Ghasts again, but died before I could see where I had ended up. I respawned and repeated, and the same thing happened over and over (as you can see in my log file). I probably wasn't killed by Ghasts, since the HeroicDeath plugin message would've mentioned them I think. If I had to make a guess it would be suffocation from being encased in rock.

    After respawning there were some extra-weird consequences: it was night but no monsters were appearing near my spawn point, instead there was a single immobile Ghast stuck above the forest doing its usual sounds. A disconnect/reconnect fixed that. The other, worse problem is that all pressure pads stopped working (they wouldn't power redstone wires like before). I haven't tried restarting the server yet to see if it fixes the problem (which may be due to mod interactions I guess, though all my mods played mostly fine together so far).

    Thankfully I backed up my world before trying this :p. I hope you can get it working since the concept is great.

    Edit: forgot to mention that right at the same time as I got that stuck Ghast, I wasn't able to mine blocks anymore.
  4. Offline


    I think I'm having a similar issue as Metatoaster. I went ahead and tried NetherGate again, but even with scaling turned off I can't simply walk through a portal, build a gate in the nether, then come back through and be even remotely close to the original location.

    The locations seem to be repeatable though, so maybe this is something to do with centering? I really wish this forum had intrathread searching. :(

    [Edit] Okay, strangely if I walk into the left side of my World portal, then turn around and walk into the right side of my Nether portal I get back at the right place. Same if I use right side World and left side Nether. Left-Left and Right-Right put me in two different spots. Right-Right I have to be ready to swim. :D
  5. Offline


    Hmm, very interesting. Going to test this when I get home tonight. Maybe it'll enlighten us as to why the coordinates are off!
  6. Offline


    I'm fairly sure that none of this is my fault- there are lots of multi-world bugs right now. However, if MyWarp is working ok, then I guess they are still my bugs :p

    I know the ghasts-crossing-over thing is a multi-world bug, there is currently a very annoying bug that makes blocks "invisible" to plugins randomly- this breaks all my stuff, and frankly I'm considering pulling my plugin til it's fixed, because it makes them look completely broken and I'm sick of taking crap for it, honestly. :p

    Now, that being said, portal pairing is still broken, as is the fast travel algorithm. Use "/nether scale world nether 0" to turn that off, I'll turn it off forcibly in te next release.
    --- merged: Mar 2, 2011 3:43 PM ---
    Uhhhhhh.... weird!! Thanks for doing a bit of science on this- but that's freakin' bizarre, to be honest. I'm only looking for you hitting a portal block- it shouldn't matter which side you hit it on- I use the block position (or, I should be) to map your location, so it ought to be the same either way... in theory.

    Bah- portal tracking is the right solution for this anyway, once that portal's bound, it should always take you back/forth. I really need to get that working.
    --- merged: Mar 2, 2011 3:57 PM ---

    I've been getting a lot of complaints lately. I think there are two things going on:

    • I turned lots of things on before they were ready because I was goaded into doing it. For all of you who were fairly happy with NetherGate and got boned by this, I apologize- won't do it again. The main problem was fast-travel, which I am now disabling on start-up- please update to 0.51.
    • There is a really nasty bukkit bug right now that I'm hoping gets fixed soon. The apparent result for NG is that portals just stop working. The real issue seems to be that calls to getBlock() fail to "notice" world modifications at some very fundamental level. Switching worlds or logging out and back in again seems to fix this, but it's super frustrating when it happens.
    So, please update to 0.51- and that other thing, I can do nothing about.

    With fast travel back off, portalling is symmetrical again, which seems to be the major complaint I'm getting that I can actually do something about.

    Thanks for your attention :)
  7. Offline


    Hey Nathan, I've been using your plugin for a couple weeks and it's been awesome. One of the guys on my server found a bug I believe. Not sure if it's the plugins' fault, persistence, or just regular minecraft. They broke a single block to break the portal and it was gone but apparently when they stood in it they still got warped to the Nether. Even a few minutes later and breaking a second block we could still get through. Later on though it stopped warping us through. I guess it's just a heavy delay for the portal to "disappear"?

    Running NetherGate V. 47 and Persistence 53 on CB 440 if that helps any.
  8. Offline


    Hmm.... that's weird!

    First off, please grab NG 0.51- just updated, and it makes portaling a lot more reliable- though honestly it probably just puts things back to how they are in 0.47- so you may have skipped all the right upgrades :)

    Secondly, that shouldn't happen of course :)

    I disable portal block physics (globally) for a few seconds when a portal is created- eventually this will be more specific (to the portal that was just created).

    So, maybe someone else created a portal as you tried to destroy that one?

    The idea is that portal block physics takes care of all this for me- I don't do anything special to disable or break portals. If you break a single portal block (or part of the frame), MC should break the whole portal. And since you have to touch an actual portal block for it to work, that effectively "turns off" the portal- at least by making it invisible to NetherGate.

    I'll play around with this a bit more- I usually "cheat" and use disintegrate to disable a portal- but it seems to work every time. I aim at the portal itself, which destroys the whole thing with one click (since breaking a single portal block will trigger physics and break the whole thing). I'll try manually breaking a frame block the old-fashioned (minute-long!!) way and make sure it breaks my portal.

    Failing that, I suppose I could try to blame lag :) It's two server round-trips before you'd see that portal break.... but I'm assuming your connection is better than that.

    I'll let you know what I find in testing- thanks for bringing this up! I do like to hear about bugs, I really do- I just wish there was a better way for you all to sort out what is actually an NG bug versus a Bukkit bug :(
  9. Offline


    Hey :)

    Just updated craftbukkit to 491 and all my plugins to current versions, I'm now getting this exception:

    16:50:37 [WARNING] Persistence error getting field x for vector
    16:50:37 [SEVERE] java.lang.IllegalArgumentException
    16:50:37 [SEVERE]       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    16:50:37 [SEVERE]       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    16:50:37 [SEVERE]       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    16:50:37 [SEVERE]       at java.lang.reflect.Method.invoke(Method.java:616)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedField.set(PersistedField.java:100)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedField.load(PersistedField.java:234)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.load(PersistedClass.java:754)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.createInstance(PersistedClass.java:772)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedObject.load(PersistedObject.java:155)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.load(PersistedClass.java:754)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.createInstance(PersistedClass.java:772)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.loadCache(PersistedClass.java:692)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.loadCache(PersistedClass.java:675)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.checkLoadCache(PersistedClass.java:608)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.checkLoadCache(PersistedClass.java:595)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.core.PersistedClass.getAll(PersistedClass.java:382)
    16:50:37 [SEVERE]       at com.elmakers.mine.craftbukkit.persistence.Persistence.getAll(Persistence.java:100)
    16:50:37 [SEVERE]       at com.elmakers.mine.bukkit.plugins.nether.NetherManager.loadWorlds(NetherManager.java:911)
    16:50:37 [SEVERE]       at com.elmakers.mine.bukkit.plugins.nether.NetherManager.initialize(NetherManager.java:229)
    16:50:37 [SEVERE]       at com.elmakers.mine.bukkit.plugins.nether.NetherGatePlugin.initialize(NetherGatePlugin.java:97)
    16:50:37 [SEVERE]       at com.elmakers.mine.bukkit.plugins.nether.NetherGatePlugin.onEnable(NetherGatePlugin.java:56)
    16:50:37 [SEVERE]       at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    16:50:37 [SEVERE]       at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:414)
    16:50:37 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:187)
    16:50:37 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
    16:50:37 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    16:50:37 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    16:50:37 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    16:50:37 [SEVERE]       at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    16:50:37 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    16:50:37 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    This repeats for y and z fields. Any pointers as to what's going wrong?
  10. Offline


    Im getting it too.
  11. Offline


    me too
  12. Offline


    Uh... me too :(

    I'll try to get this fixed ASAP... things still seem to work, but this is probably why paired portals are not persisting- and, generally speaking, my plugins should never stack trace- that always represents a failure on my side, if it comes from one of my plugins.

    Anyway, I've not been able to get this to happen on my dev machine- I noticed it last night in my logs while playing on my public server.

    It may be a data migration failure- I'm going to pull down the data from my server and test with that, see if I can reproduce.
  13. Offline


    I keep getting teleported to a box room and i have to kill my self to respawn and then there's no portal inside the spawn area of the nether.
  14. Offline


    I know how you must feel Nathan,

    I stopped development on my multi portal travel plugin until bukkits support is a bit more stable. There are just new issues introduced each release that make the functionality a pain. But, Its expected with the development status of bukkit.
  15. Offline


    I'll be happy to supply you with my Persistence db files if you need them, too. Also migrated from an earlier version of the plugin, so that might indeed be the cause?
  16. Offline


    I always try to start off fresh by removing the db files before testing a new NG world. There are too many variables already -- better to start off clean. Once things get stable with both bukkit and NG, then the files should be able to stay. Just my opinion! [​IMG]
  17. Offline


    Nope, I had it, then deleted all of my persistence files, then I got it again.
  18. Offline


    Might be- but I'm starting to think not. I can repro it now, on my dev machine- bringing in my public server data worked.

    So, it may be a migration thing - I try not to wipe my public server data, if I can avoid it- so it's pretty "old".

    But, the thing is, when I look at the data- it looks good! Like, really good. So, I'm thinking it's a core Persistence issue loading data.... as usual, I'm testing the edge cases with how I use Persistence in NG :)

    But, look at this!


    Not only do all the worlds have data- so do the players who have either created a portal themselves, or have set a home. Basically, if they're referenced by something in NetherGate, they show up in nether.player.

    Anyway, the really cool thing is my portal table! It really looks good- all the portals with an empty "targetId" row also have "updatePending" set- which is a flag I'm using to know that that portal will need some love when the auto-pairing code is ready.

    So, anyway- it's all getting close, and (in fact) the current version of NG may be silently creating a useful portal network for you, in the background- and it will auto-build portal structures as necessary, when it's ready, using this pre-built portal network! (Uh, assuming I don't do something between now and then that breaks all this data, since I reserve that right, it's not really working yet! :D)
    --- merged: Mar 2, 2011 9:08 PM ---
    Not a bad approach for now :)

    FWIW, Persistence now does this for you, automatically- at least, in theory. If it detects that something has changed (for now) it just auto-drops the table. Eventually, it will try to save your data....

    Still, there may be issues there, and if you don't care about your data (not much there yet, really)- it's not a bad approach to just wipe every upgrade :D

    That's certainly what I do on my dev machine- I wipe my data there constantly. Then, I try to keep things more "production" on my public server, to make sure migration works.
    --- merged: Mar 2, 2011 9:11 PM ---
    Yeah- I don't think it's a simple migration issue, honestly. I think the data just "breaks", in terms of loading, eventually.

    I'm tracking it down- I at least know where it's happening- basically I have a BlockVector whose x y or z is "null" in the data, for some reason- I think it's not supposed to be, it looks good in the DB itself.

    So, the main problem is that I then try to assign "null" blindly to the x, y z of BlockVector, which explodes because those are ints and not Integers, and hence can't be null.

    So, first step, I'm adding a check within Persistence for this, it will throw a useful exception explaining the problem when it finds a null value for a primitive type.

    Secondarily, I need to find out why the position component of LocationData is not getting loaded right- the values are good in the db, but null by the time they make it to the object. Going to track that down once I've put the check/exception in place.
  19. In regards to the weird chunk-loading, it doesn't seem to load farthest-first (as you were saying) when I first enter the world, nor when I go into the Nether. Only going back from the Nether to the normal world causes the weird loading issue. Though I have noticed in the newer versions I'm not "falling" and hurting myself anymore, so that's good.

    One other issue, though, is that now, even using the same portals as before, I am spawning in the Nether in a tiny room underneath the original Nether portal. Not a big deal, but kind of odd.
  20. Offline


    I turned off scaling in the latest release, so make sure to upgrade- should put you closer to where you were before.

    Also, if you upgrade to CB 478 (or higher), the whole loading thing is no longer an issue- Dinnerbone changed it to a spiral algorithm it works much better now.
  21. Offline


    So I'm mildly confused as to how this plugin worked. We have a nether portal on our server, but for some reason this plugin is not allowing us to go through to the other side. Is there something that needs to be done before this works? The OP is vague.

    Call me stupid, but I'm just trying to figure this all out.
  22. You need to call this (both ways):
    /nether target world [name] [to] : Re-target a world to point to another world
  23. Offline


    That shouldn't really be necessary on a clean install- it's supposed to be "drop in".

    This may either be a permissions issue, or a bukkit bug. There's a bug that can occasionally prevent NG from 'seeing' portals (or any other world mods). Login/logout can sometimes fix this.

    Try "/nether go" to make sure that's the problem.

    It may also be a Permissions/permissions issue....

    I'm hoping to get this straightened out soon- I'm going to kill Groups, and provide direct Permissions support again- and I'll test it, make sure it's working, etc. Hopefully by this weekend.
  24. I saw that the world is loading in spiral but it starts from spawnpoint, not where player actually is. So world starts loading from far away from player who is jumping in the void for some time.

    When i command /nether spawn set , and then come to that world through the portal it will not go to that spawn, but other uncontrollable location other side of a large lake. I have not used world scaling. If i call /nether spawn it does take me to correct spawn location.
  25. Offline


    I'm not sure I understand- seems like there are two issues here, maybe.

    Spiral loading is an internal bukkit thing- from what I've seen, it always starts from wherever NG has TP'd me to. This is with CB478 or higher.

    As for spawn- portals aren't supposed to take you to spawn, necessarily. In fact, with location mapping off, a portal at spawn in one world won't necessarily go to spawn in another- they'd all have to be at the same location, and I don't think spawn defaults to something constant like (0,0,0).

    The idea with location mapping is to "overlay" worlds in a consistent manner, for one thing centering them around spawn. But, if you're turned off scaling, you've turned off mapping entirely.

    You can try setting scales for both worlds to 1, if you want. This will turn on location mapping, but it should effectively disable fast travel and scaling.
  26. Offline


    The portal still working after being destroyed actually seems to be a server bug that appeared since 1.3, and is affecting this other nether portal plugin as well: http://forums.bukkit.org/threads/tp...ple-nether-portals-450.4447/page-5#post-96488
  27. Offline


    How do we make the portal connect?
  28. Offline


    Hm- maybe a variant of the issue where NG can't see the portals at all? Maybe they're also "invisible" to block physics? I have no idea how far-reaching that bug is, to be honest. :(
  29. Offline


    Logging in and out doesn't do anything. This portal has been here for a long time now and it has done nothing regardless. It seems the commands themselves are registering in the console, but '/nether go' doesn't really do anything. I mean it gives me the text like its going to teleport me there and stuff, the plugin responds, but it doesn't actually warp me there. Is that command necessary to use once you stand in a portal?

    If it's a permission issue idk what i need to do.
  30. Offline


    Unfortunately, neither do I. Hoping to have a permissions fix soon- are you using Permissions? Because it's most certainly the problem, if you are.
  31. Offline


    Is there a way to make it so they can only use portals to get to the nether?

Share This Page