[INACTIVE][RPG/FUN/MECH] Dungeon v0.6 - Creates a World of Dungeons [953]

Discussion in 'Inactive/Unsupported Plugins' started by Thomas Bucher, Jun 6, 2011.

  1. Offline

    Thomas Bucher

    Dungeon - Creates a World of Dungeons:
    Version: v0.6

    It creates a new World, called "dungeon". After First load a OP has to run the command
    After that everyone can can join the Meetingarea of the Dungeons by type
    There are 3 Mazes / Dungeons waiting for the Player
    - Iron (easy) 200x200 Blocks
    - Gold (normal) 500x500 Blocks
    - Diamond (hard) 1000x1000 Blocks
    If you join the Maze via the Platforms in the Meetingroom, your compass will show to the Exit
    The Exit is a Square on the Ground made with Obsidian.

    - Only OP can place/destroy Blocks in this world
    - There should be no Creepers / Explosions
    - Spawnpoints are located in Rooms, if you reach a Room, there will be some Spawn
    - There are Chests. They are Filled with Loot.
    - Mobs / Chests have a Cooldowntimer in Spawning.
    - For normal / hard, you should get some Torches with you.

    • 3 Different Maze (Seed)
    • Complete separate Spawn / World Rules
    • Lot of Fun

    Pictures (open)




    Download The Plugin
    Source Code on Github

    Config (open)

    gensmall: 200
    respawntime: 600000
    exitz: 0
    exity: 70
    torchchance: 50
    chestchance: 5
    exitx: 0
    exitworld: world
    lootablecount: 5
    rarechance: 70
    lootstacksize: 10
    genlarge: 1000
    maxroomsize: 20
    gennormal: 500
    removedeads: 5
    roomchance: 80
    autosavechunklist: true
    autosaveinterval: 30
    worldseed: 12345
    world: dungeon
    gensmall -> Small Maze Size
    gennormal -> Normal Maze Size
    genlarge -> Large Maze Size
    respawntime -> Respawn Time of Monsters per Room / Chests (in miliseconds)
    exitx, exity,exitz -> Coordinates on the Normal world to Port players to, if the stay on the Stone Platform
    torchchance -> Chance to place a random torch in the maze (in per mille)
    chestchance -> Change to place a chest (Room edges only in %)
    exitworld -> Name of the World the exitx/y/z points too
    lootablecount -> Times it roles per Chest for some Loot
    rarechance -> Chance to get a Rareloot
    maxroomsize -> Maximal size of Rooms
    removedeads -> Times recurring to remove Deadends from the Maze -> 0 is most Difficult after
    roomcahance -> Chance to get a Room in a Position
    worldseed -> seed of the World
    world -> name of the new World

    Check it at our Server: MC.KTN.CH
    Version 0.6
    • Fixed for Version 1.7.2
    Version 0.5b
    • Added Teleport from Roof to Startarea
    • Fixed some Problem
    • Removed Torches on the Dungeons.
    • Fixed Worldname to match dungeon not sphere.
    Version 0.4
    • First Public release
    • Disable /dungeon while in Dungeonwolrd (Configurable)
    • Permissions for build etc..
    • No Spawn at entrance room
  2. Offline


    When are you going to update this Plugin? For me it's not working,...but i would really like to use it.

    I have the chunk 0,0 problem and have a huge building at this chunk,...so,..no way to use it @ the moment..

    Thanks and greetings.

  3. Offline


    slight huge bug on my server, it does not give any error for this but if i go to the stone dungeon it transports me to where i first spawned the first time i loaded my server main world "world" and er punches a huge hole in the ground see pic:
    any ideas? ive never even seen the inside of a stone dungeon jsut this
  4. Offline


    The "stone" dungeon is not a dungeon... it teleports you out of the dungeon world.
  5. Offline


    hey, erm. when i just installed the plugin, the iron, gold, and diamond dungeons are working. but the exit which is the stone platform isn't working, can i fix this? thank you in advance :)
  6. Offline


    okiedokie that makes sence lol my bad, what about the whopping hole though?
  7. Offline


    go to your main world, go to your spawn area, hit F3, write down the X, Y, Z, just the numbers before the decimal point.
    Go into your dungeon config file and set the exitx, y, z with the matching X Y Z you got from spawn. Save, restart/reload the server. try again.
  8. Offline


    For my server, I forgot to set the exitworld to my world name so it wasn't working. You might give that a try.
    Get a plugin called BananaChunk. That fixed all of the holes in our world.
  9. Offline


    think ive worked out the hole issue, (already had banana chunk btw)
    i moved my first spawn point using a plugin so im going to try setting that new point as the point for the stone slab to send to

    edit: it works fine now though i still get an error message:
    10:17:14 [SEVERE] java.lang.NullPointerException
    10:17:14 [SEVERE]       at sun.misc.FloatingDecimal.readJavaFormatString(Unknown
    10:17:14 [SEVERE]       at java.lang.Double.parseDouble(Unknown Source)
    10:17:14 [SEVERE]       at com.carbunkulous.firstSpawn.FirstSpawnWorld.<init>(Fi
    10:17:14 [SEVERE]       at com.carbunkulous.firstSpawn.FirstSpawnWorld$1.run(Fir
    10:17:14 [SEVERE]       at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainT
    10:17:14 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServe
    10:17:14 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftSer
    10:17:14 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(Sour
    10:17:14 [INFO] [FirstSpawn] I had issues reading the firstspawnloc-dungeon.txt
    file! (Common on first run)
    i know it says common on first run, but it aint my first run, and that lot might at well be in an anien language for all my understanding >.>
  10. Offline

    Thomas Bucher

    This is a FirstSpawn issue ;-P
    Cant help with that. Sorry

    Added on my Todo-List

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  11. Offline


    do you need mutliverse
  12. Offline

    Thomas Bucher

    I dont use mv
    I only use Stargate, but not even Stargate is needed for this plugin, you can enter the dungeon and leave with /dungeon
  13. Offline


    so the plugin works fine alone
  14. Offline


    I just addded the plugin to my server. When I try to teleport to the dungeon, it never puts me in a correct place.
    So far I teleported 3 times inside stone. One time on the dungeon. The last time under the dungeon.

    I'll try and delete the world and see if it does it again.

    edit: k Now it works. But ... The first time I do /dungeon it puts me near the first time I used the command. The second time I do /dungeon it puts me in the starting area.

    When I die, I return to the normal world. Not in the starting area. Is that normal behaviour ?
    Also when I return to the normal world, it's not in the exact same spot I went to the dungeon.
  15. Offline


    For some reason, the iron teleport pad is sending me outside the dungeon. Why is that? :eek:

    Great plugin by the way :)
  16. Offline


    can u make is so the dungeon resets every time everyone leaves, so this way everyone can place blocks (not destroy, cause they can cheat) hope u do that THX!:cool:
    Awesome plugin!!! [diamondblock][diamondblock][diamondblock][diamondblock][diamondblock][cake][diamondblock][diamondblock][diamondblock][cake][cake][cake][chest]
  17. Offline


    This would be perfect on my server if it used permissions, no offense to the creator, its cause i use multiple worlds though and dont want everyone to be able to get into it unless they are on a certain map.
  18. Offline


    ^ Agreed, I will add to this list.

    • Some form of interact for porting to dungeon maybe a command for OP's to spawn a Pre made tower or some form of enterence in the world so that players can use that instead of a command.
    • Water Sewer like dungeon type ?
    • Messages for when you enter the dungeon and Exit! <Customizable ofc"
    ^ What he said but I use anyway to test it out a bit but likewise id prefer it only work if on the default world.

    @Thomas Bucher
    Major BUG Found!

    CB 935
    The World holes everyone is speaking off appear to be linked to the Dungeon Exits.

    For example
    Walking over the stone square in the meeting room teleports to to the exact coords of the Hole in the world that I found recently after installing this plugin. I would assume it there would be a hole in the world for each of the 3 exits for the dungeons as well.

    Also at times I found I was not being teleported to meeting room when using /dungeon but rather teleported to the coords that the meeting room should be, should it have changed worlds from the default of world sending me to dungeon map.

    I am able to replicate the /dungeon issue every single time on my server it appears to send to me too X:421.0 Y:65.0 Z:-1851.0

    That is where I end up everytime I use command /dungeon and I have to use it again to once I am there for it to actually tp me to the correct world.

    Those are the two BIG ones that need fixing asap I confirmed that the VOID spots do generate from this plugin.

    Your welcome to login to my server to see for yourself. Info on that is at http://mindcalf.net/forum/showthread.php?tid=18

    Some interesting info you may wish to have regarding my server to debug this!
    2011-06-30 06:07:16 [INFO] Plugins: AfkBooter, AngryWolves, Annotate, Appleseed, BorderGuard, ChairCraft, ChopTree, CommandSigns, Dungeon, EasyRPG, EasyRules, FalseBookBlock, FalseBookCore, FalseBookExtra, FalseBookIC, FlamboyantFlock, HeavenlyMob, iChat, iConomy, Jobs, Landmarks, Lockette, LogBlockQuestioner, mcbans, MinecartManiaCore, MinecartManiaSignCommands, MinecartManiaStation, MinecraftViewer, MobRider, NaturalGiants, NextStation, Permissions, PhatLoots, ScheduledAnnouncer, Seasons, Showcase, SignColours, SkylandsPlugin, Tables, TimeRank, WorldEdit, Citizens, dynmap, Essentials, EssentialsProtect, EssentialsSpawn, MinecartManiaAdminControls, MinecartManiaAutomations, MinecartManiaChestControl, Factions, LogBlock

    Worlds currently running

    world - Default - pre generated to a size of 7000: map is over 1gb large!

    world_nether - Not pre generated but capped to border of ^

    world_skylands - Generated by Skylands Plugin ^^

    dungeons - Generated by this plugin

    Java command line args
    java -Djline.terminal=jline.UnsupportedTerminal -server -Xmn250M -Xmx3G -Xincgc -Xss15m -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:ParallelGCThreads=-XX:+DisableExplicitGC -XX:MaxGCPauseMillis=400 -XX:SurvivorRatio=16 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=15 -cp BiomeTerrain.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main nogui -"yyyy-MM-dd HH:mm:ss" 
    Used in McServerGui


    I see the exit issue was sorted by another poster by manually setting the exit point in config :p will give that a try but I think it will generate a whopping void hole at exit there instead tho.

    Okay I manged to solve the exit issue but now the /dungeon command takes me to my new exit location instead of teleporting me to dungeon world on first use.

    I also managed to really confirm that this plugin creates voids in your world as after I removed it to test if my hole existed with out it I't did exist and I had to do a rollback of the map the a backup I had done 3 hours before installing this plugin to fix it.

    Edit AGAIN
    It appears what ever is making the void is gone at least it did not make it on exit this time.
    so it must be during the /initdun that does it as after putting this plugin back in after fixing void the void was still gone and the exit that is now the proper spawn is intact.

    I uninstalled this again anyway as currently its a little unstable not only did a void appear from installing this at least once that I could I FIND! it has a host of issues to do with teleporting as this time when I used /dungeon it teleported me inside a Dungeon and not at the meeting room and if I did /dungeon while in the spot I end up I get TP to where the Void used to be!.

    I think you have some debuging and code work to do ;) Im willing ot test future versions but you deff need to work on your teleporation and really look into the void issue.
  19. Offline


    Could you make a permission where non-ops can build in the Dungeon world? I would certainly appreciate it!

    Oh, and for some reason, the iron and stone teleport pad aren't working. The stone one doesn't do anything, while the iron one transports us outside the dungeon. I've deleted the Dungeon file and tried it again but it's still the same thing. Could you help?


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  20. Offline

    Thomas Bucher

    Stone needs config in the Configfile -> exitworld etc

    Dont Delete the Dungeonfile. Do the following:
    1.) Stop the Server
    2.) delete chunklist.data
    3.) Start the Server

    This will fix the iron problem i guess..

    Sincerely Thomas

    1.) /dungeon ports you in and out.
    Means it trys to port you to start area first time typed in.
    Second time it ports you to the location you typed it the first time.

    2.) The Chunkhole is at 0,0. This Bastard gets Lost while the World is created. I dindt find out why.
    The only way to avoid get the chunk 0,0 lost, is to create the world manualy before you install the plugin

    Sincerely Thomas

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  21. Offline


    Thanks! I appreciate it :D
    Oh, and how about that other thing I asked? Can it be done? :)
  22. Offline

    Thomas Bucher

    Sure, it can be done ;-P
    I Add it to my Todo list..
  23. Offline


    Yayz, thanks :D
  24. Offline


    1.This needs to be worked on as during my testing it was never accuratelty teleporting me around as required I expected to end up at one of two place: Exit defined in config or the MeetingRoom, Instead somtimes I would end up at a certain coord in my exit world where the dungeon meeting room should be, and the other time I was teleported to the start room of the dungeon I just exited using /dungeon.

    I't just seems all little rushed in the teleportation area, My advice would be to set a static entry point in dungeon world at the meeting room so that you are guranteed to end up there every time with out fail and also do more checks to make sure the world does indeed actually change to dungeon world.

    I might also go as far as to advise looking into making it compatible with "Essentials Spawn" that does multiworld spawn areas. This method would then require me to input the name of the spawn in your config and essentials will just Teleport via spawn location.

    Also I am able to teleport back to the default world assigned as the exit point in config, using /spawn and /tp while this is not an issue but it is something that I would consider maybe trying a way to make a spawn on that world In fact I may try this with essentials as it seems to pick up world fine, so I may just do a /setspawn there at meeting room so that is where u end up could be usefull for ppl who wanted to meet again and join more people.

    I'm just trying to give some helpfull advice as currently the teleportation does not function to a degree I could not baby sit my server as people will always be bitching as to why it not working and ill have to keep telling them to type it twice. As I said currently if I type it once It just takes me to the exit coords "being my worldspawn" and then typing near there takes me to meetingroom. But I found that if I was no where near the exit area then I could endup being sent inside a dungeon maze and not the meeting room. Maybe I will try deleting the chunkdat file let that re generate. I just hope that it wont make blackhole "void" while doing so.

    2.I see you narrowed down the chunkhole so it appears only be an issue while the world is generating on first load, But if I was to backup the region data of the main world like I DO, then install plugin let it generate then run the initdun command. Stop server and replace the region file for the world to fix the chunkhole.

    This would explain why after I installed it again when the world was pre generated from before after replacing the brokenworld with my backup the chunkhole was gone.
  25. Offline


    hmm thats not working sorry ... when i got to "dungeon" im at an bedrock area where im dieing
  26. Offline


    2011-07-01 17:45:01 [SEVERE] Error occurred while enabling Dungeon v0.5b (Is it up to date?): net.minecraft.server.Chunk.b()V
    java.lang.NoSuchMethodError: net.minecraft.server.Chunk.b()V
        at com.bukkit.toasterktn.Dungeon.Chunk.DungeonChunkProvider.getOrCreateChunk(DungeonChunkProvider.java:318)
        at org.bukkit.craftbukkit.CraftWorld.regenerateChunk(CraftWorld.java:172)
        at com.bukkit.toasterktn.Dungeon.Chunk.ChunkListener.<init>(ChunkListener.java:42)
        at com.bukkit.toasterktn.Dungeon.Dungeon.onEnable(Dungeon.java:69)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:857)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Bukkit 953
  27. Offline

    Thomas Bucher

    Yes its broken... ;-(

    Updated for 1.7.2
    Tested and Working. Just Download the new Version

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  28. Offline


    2011-07-02 12:24:48 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'initdun' in plugin Dungeon v0.5b
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:298)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:711)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:676)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:669)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoSuchMethodError: net.minecraft.server.Chunk.b()V
        at com.bukkit.toasterktn.Dungeon.Chunk.DungeonChunkProvider.getOrCreateChunk(DungeonChunkProvider.java:318)
        at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:70)
        at org.bukkit.craftbukkit.CraftWorld.getChunkAt(CraftWorld.java:92)
        at org.bukkit.craftbukkit.CraftWorld.getBlockAt(CraftWorld.java:60)
        at com.bukkit.toasterktn.Dungeon.Block.DungeonBlockModifier.CreateLounge(DungeonBlockModifier.java:99)
        at com.bukkit.toasterktn.Dungeon.Dungeon.onCommand(Dungeon.java:160)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
  29. Offline

    Thomas Bucher

    Will Check that out.

    Sorry for the Troubles..

    EDIT: You need the new Version.
    You have 0.5b, 0.6 is the newest Version.. Redownload..
  30. Offline


    the jar is still 0.5b? :)
  31. Offline

    Thomas Bucher

    Where you Download it ?
    I just doenloaded and tested it.. i am confused..

Share This Page