[INACTIVE][MISC] HeroLock 0.0.4 - Password Protected Chests [670]

Discussion in 'Inactive/Unsupported Plugins' started by RightLegRed, Apr 3, 2011.

  1. Offline


    0.0.4 | 0.0.3 | 0.0.2 | 0.0.1 | source
    What is it?
    HeroLock is a plugin by the Herocraft Development Team. It uses the functionality of the new built-in persistence system that is provided by Bukkit to ensure that the locked chest stay locked. It allows users to quickly lock and unlock chests.
    How do I install it?
    To install HeroLock all you need to do is drop the jar file into your plugins folder. Then start up your server. HeroLock creates a folder entitled "HeroLock" inside your plugins folder. Inside this folder, is the database file. Which is a SQLite3 database file. This file is vital to the plugin. This is where the chest locations and passwords are stored. Deleting this file would mean that all of your chest that have been locked will be lost.
    How do I use it?
    Using HeroLock is simple. It consists of three commands currently. The first of which is lock. This command locks a chest with the password specified after the command. To use this, you activate the command and then right click on a chest. This will lock the chest if the chest isn't already locked. All of HeroLock's commands have 1 argument. Which is simply the password you wish to assign to the chest.
    The second command that HeroLock showcases is the unlock. Unlock is locks sister command. After you have locked a chest you simply need to use this command to use this as your unlock key. After saying this command, you can unlock any chest with the same password. Simply use the command unlock and then attempt to open a chest. If you get it right, the inventory window for that chest will open. If you get it wrong, then the window won't open and you'll be given a message saying that the password is incorrect.
    The final command that HeroLock has is change. This command is quite simple. It allows you to change the password of a chest. This is basically lock, but allows you to change the password. Only the owner can change the password. Please note, it doesn't require you to use the current password to change it. To use this command, do the command change followed by the new password. After doing this, right click on a chest. It'll give you a message if it was successful.
    What will it be able to do?

    In the future I plan to add more functionality. I plan to add change in a way that lets anyone who has the password change it. My next plan would be to add modes. Much like an IRC channel, you could set a mode of a chest to react in a certain way to a player. Like if you were to set it to -p, it wouldn't be private and anyone could see inside, reguardless of using unlock or not.
    Does it have permissions support?
    Yes, HeroLock does. The permissions nodes are:
    herolock.chest.lock - to allow the user to lock chests
    herolock.chest.unlock - allow the user to unlock chests
    herolock.chest.change - allow the user to change a chests password.
    Whats been changed?

    0.0.1 - I've just finished the basic features of the plugin. This is the initial release and feedback period.
    0.0.2 - Bug fix for the database system.
    0.0.3 - Implemented permissions support and new recommended build [670]
    0.0.4 - Fixed the above permissions support.
    Other staff members - I do not expect for this plugin to be brought into releases or I would've done it myself. I am simply posting to showcase the plugin and gather feedback. The plugin builds against a non-rb build which means it cannot be released.

  2. Offline


    Sorry, it was my fault, there were some conflict with another mod I forgot to remove.
    it's okay now, and I apologize for my messsage.
  3. Offline


    I have the latest release (670) and I have Herolock 0.0.4 and I get the error:

    2011-04-10 00:20:50 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'lock' in plugin HeroLock v0.0.3
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:254)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:596)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:559)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Caused by: java.lang.NullPointerException
        at com.herocraftonline.rightlegred.herolock.commands.CommandChestLock.onCommand(CommandChestLock.java:30)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
    when I try to enter the lock command. I'm having a lot of trouble with the Permissions plugin recently.
  4. Offline


    Unfortunately, this doesn't work. I've tried it on my server with multiple people, and there's a few problems. For one thing, chests randomly unlock themselves - and as mentioned before double chests sometimes one side is locked and the other isn't, but the biggest problem is chests not staying locked.

    I'm running CraftBukkit 670 with HeroLock 0.0.4 on Debian Lenny 5 64-bit. Here's my server logs: https://pastee.org/exa9z


    EDIT: Oh, and it seems any password works sometimes...
  5. Offline


    There is no way any password can work or that chests can unlock themselves. It's either another plugin you're using or you're manually unlocking them. I have tested this with friends for a day straight (in-game time). We never experienced this problem and were using the plugin frequently. Double chests don't work because of a mistake I made.

    All problems could be caused by a slow server though. Causing the plugin to miss the chest opening.

    I'd also appreciate if you didn't claim it didn't work, as other people have said it did. It's rude because you're saying it doesn't work without any other sources. Just you say it doesn't work with those problems. I also find it offensive.

    Weird, does this happen with all commands? It does seem like a permissions error, but it could be the way I'm checking for permissions.
  6. Offline


    Yes. It comes up for all commands. Permissions is causing me a lot of trouble. InstaBreak no longer works either. I've added the command nodes in the permissions.yml, and I have also tinkered with the group settings.
  7. Offline


    I apologize if you find it offensive, that's just the way I talk. I didn't mean to bash your plugin, or offend anybody.
    I think the server slowness is correct - that certainly describes us.
    Sorry for the trouble.
  8. Offline


    Is this something to replace LWC?
    Interesting, I will test it.
  9. Offline


    It is. You might not like it if you like LWC though.
  10. Offline


    I get a "Internal Error Message"

    When I do /lock <password>

  11. Offline


  12. Offline




    Says in the paste bin :)

    1. This server is running Craftbukkit version git-Bukkit-0.0.0-646-
    2. gb61ef8c-b670jnks
  13. Offline


    2011-04-12 14:47:02 [SEVERE] Could not pass event PLAYER_INTERACT to HeroLock
        at com.herocraftonline.rightlegred.herolock.HLPlayerListener.onPlayerInteract(HLPlayerListener.java:31)
        at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:252)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:133)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:663)
        at net.minecraft.server.Packet18ArmAnimation.a(SourceFile:35)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  14. Offline


    My players quickly discovered that anyone can lock any unlocked chest, regardless of who placed it. This is a new kind of griefing, since people can lock up your chests if they get to them before you do.

    Players only be able to lock chests placed by them, shouldn't they?
  15. Offline


  16. Offline


    What are the commands? to lock and etc
  17. Offline


    My full server.log is:

    Starting minecraft server version Beta 1.4
    2011-04-13 21:28:56 [INFO] Loading properties
    2011-04-13 21:28:56 [INFO] Starting Minecraft server on x.xxx.xxx.xxx:xxxxx
    2011-04-13 21:28:56 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-04-13 21:28:56 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-04-13 21:28:56 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-04-13 21:28:56 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-646-gb61ef8c-b670jnks (MC: 1.4)
    2011-04-13 21:28:57 [INFO] Preparing level "XXXXXXXXX"
    2011-04-13 21:28:57 [INFO] Preparing start region
    2011-04-13 21:28:57 [INFO] 144 recipes
    2011-04-13 21:28:58 [INFO] Preparing spawn area: 32%
    2011-04-13 21:28:59 [SEVERE] ebean.properties not found
    2011-04-13 21:28:59 [INFO] DataSourcePool [HeroLock] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2011-04-13 21:28:59 [INFO] SubClassFactory parent ClassLoader [org.bukkit.plugin.java.PluginClassLoader]
    2011-04-13 21:28:59 [INFO] Entities enhanced[0] subclassed[1]
    2011-04-13 21:29:00 [INFO] [Permissions] version [2.1] (Handler) was Initialized.
    2011-04-13 21:29:00 [INFO] [CookieMonster]  v1.2.1 loaded successfully.
    2011-04-13 21:29:00 [INFO] [CookieMonster]  Developed by: [jascotty2, Coelho]
    2011-04-13 21:29:00 [INFO] [iConomy] Logging is currently disabled.
    2011-04-13 21:29:01 [INFO] [iConomy] v4.65 (Kenzi) loaded.
    2011-04-13 21:29:01 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    2011-04-13 21:29:01 [INFO] InstaBreak version 1.4 is enabled!
    2011-04-13 21:29:01 [SEVERE] PLAYER_COMMAND loading Permissions v1.0 (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_COMMAND
        at com.nijikokun.bukkit.Permissions.Permissions.registerEvents(Permissions.java:118)
        at com.nijikokun.bukkit.Permissions.Permissions.onEnable(Permissions.java:111)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:578)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:216)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:115)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:93)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    2011-04-13 21:29:01 [INFO] PP STARTED
    2011-04-13 21:29:01 [INFO] [iConomy] hooked into Permissions.
    2011-04-13 21:29:01 [INFO] [RemoteChests] Permissions enabled
    2011-04-13 21:29:01 [INFO] [RemoteChests] iConomy enabled
    2011-04-13 21:29:01 [INFO] [RemoteChests] Loaded 0 chests.
    2011-04-13 21:29:01 [INFO] [RemoteChests] Remote Chests version 1.3 is enabled!
    2011-04-13 21:29:01 [INFO] SecretDoors v0.1 by MrChick enabled
    2011-04-13 21:29:01 [INFO] WorldEdit 4.3 enabled.
    2011-04-13 21:29:01 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-04-13 21:29:01 [INFO] Done (0.444s)! For help, type "help" or "?"
    2011-04-13 21:29:01 [INFO] Stopping the server..
    2011-04-13 21:29:01 [INFO] CONSOLE: Stopping the server..
    2011-04-13 21:29:01 [INFO] Stopping server
    2011-04-13 21:29:01 [INFO] [iConomy] Plugin disabled.
    2011-04-13 21:29:01 [INFO] InstaBreak version 1.4 is stopping...
    2011-04-13 21:29:01 [INFO] [Permissions] version [2.1] (Handler) Disabled.
    2011-04-13 21:29:01 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-04-13 21:29:01 [INFO] PP DISABLED
    2011-04-13 21:29:01 [INFO] [RemoteChests] Remote Chests version 1.3 is disabled!
    2011-04-13 21:29:01 [INFO] SecretDoors v0.1 by MrChick disabled
    2011-04-13 21:29:01 [INFO] Saving chunks
    2011-04-13 21:29:02 [INFO] Stopping server
    2011-04-13 21:29:02 [INFO] Saving chunks
    Everyone is running 1.4_01 and I'm using CB670

    Same here. I get that with any HeroLock command.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  18. Offline


    I know what the problem is now. Will fix it now.
  19. Offline


    atleast tell me how to use this.. you didnt say what commands there are
  20. Offline


    Hi, this plugin doesn't work at all for me
  21. Offline


    Hello, RightLegRed. :D
    I've been using this plugin for a good while now. I love it, thanks!
    However, our server crashed a little while back. Since then, HeroLock hasn't worked. I've tried to re-install it from scratch, and nothing. No other plugins have been affected by this.
    http://pastebin.com/AA2dzxPW -- Here is a paste of the error I get when I open the server.
    It's not a conflict with another plugin, that I know for sure. In-game, it's like the plugin isn't even installed. I go to use /lock or /unlock, and it says it's an unknown command. Any help?
  22. Offline


    Awesome plugin, but I have a question.
    Is it too much to ask for password protected doors? :p
  23. Offline


    Learn to read.

    More information please.

    Might do. Big project atm, support for this plugin is limited.

    I know what the error is, I will get it to work soon. Apologies.
  24. Offline


    Hi, ok this is the error I receive when the plugin is initialized and it basically does not work in the game. It is an unknown command.

  25. Offline


    I know how to get it now :) I got craft bukkit and ready to intall 0.0.3 :D
  26. Offline


    Which cb are you running?
  27. Offline


    Ya I did upgrade but for some reason I guess it never applied. Thanks to redoing the server I have been able to test your plugin and it is simply perfect!
  28. Offline


    I had the same problem, I didn't have to use the correct password to access the chest. Note there was no errors in the log.
  29. Offline


    Hi, love the plugin but for some reason after being unlocked the chests refuse to be locked. This may be an issue with the plugin or maybe because I'm using craftbukkit #677. Just thought you should know.
  30. Offline


    I think what's happening is that when you are the person who locked the chest, any password will unlock it, similar to how /change doesn't need the original password. I've been testing this on my server and so far no one has been able to open a chest they themselves didn't lock without the proper password.

    edit: Er, to Phatality's post.
  31. Offline


    On Bukkit Build 726, any password will open any chest. I'm trying to see how long I can go before members figure this out...

Share This Page