[INACTIVE][MECH] Wool Color Spawner 0.2 [CB241+]

Discussion in 'Inactive/Unsupported Plugins' started by Firestar, Jan 19, 2011.

  1. Offline


    Wool Color Spawner
    Version 0.2 [241+]

    Spawns 64 stacks of wool of your choice, great for creative and build servers.

    Spawn color wool by typing
    /gw <color> <number of stacks>
    Color can be a string or integer

    List color names
    /gw list

    Permissions Plugin Support, Permissions permission

    version 0.2 2/4/2011 (RELEASED)
    • fixed to work with 241+
    Download Now!
    Source Code
    M1sT3rM4n likes this.
  2. Offline


    Any chance you can make this work with GroupUsers so not everyone can use it? :D
  3. Offline


    only Ops can use this.
  4. Offline


    Where do you define "Ops" ? And at the moment I kicked out of my server using the command this provides.
    I use the command and I get;
    "Disconnected by Server

    Internal server error"

  5. Offline


    ops from vanilla
  6. Offline


    IT BROKE!! *insert random complaining*

    You don't have any user error checking for your nice little plug in. If you type in the wool color wrong it still trys to spawn it and you get kicked off the server.

    In the code, the if statement nest starting on line 45 needs a check for a valid color on line 47 once, or individually on lines 56 and 59. On line 45 your could do something like if(commandName.equalsIgnoreCase("gw") and is a valid color) or even check in the give_wool function on line 34, something like if not valid color give white wool or give an error.

    Just my two cents, hope it helps. And sorry if I messed something up on the post, I am quite tired.
  7. Offline


    Doesn't work. It says it loaded 0.1 version successfully but then it just don't want to work... /give works fine which means im an op, but /gw does nothing

    EDIT: it seems to be fine now with version 115 !

    Edit: it doesn't work it just kicks me out of the server, and when i do a right command it doesnt do anythign

    Edit3: fixed
  8. Offline


    the github works fine, i just need to push the compiled version into the direct download.

    working version is now downloadable.
  9. Offline


    I still get the "Internal server error" got build 118 here :)?

    EDIT: Works Now Thx! :D
  10. Offline

    Gene Myers

    Found a bug.. When ever i type a type using a command i get internal server error..

    Build 118

    e.g. /gw light blue instead of /gw light_blue causes it.. Just to let u know! until u fix it ill just be extra careful not to typo!
  11. Offline


    That's what I was talking about with my post.

    A nice fix could be:

    public int color_to_num(String s){
    return colors.get(s);
    return -1;// So you know its not on the list
    public void give_wool(Player player, String color, Integer amount){
    Byte data = null;
    String s= String.valueOf(color_to_num(color));
    data = Byte.valueOf(s);
    if(s==-1)// If error returned by color to num, send error
       player.sendMessage("Not a valid color");
         //The rest of the function code here
  12. Offline


    the problem has been fixed in the github version
  13. Offline


    I'm able to give myself wool blocks and when I receive them they are the color specified in both the player hand and inventory. When I place them, though, they appear as the color for a split second, then revert to plain white wool.

    I just downloaded the version you have linked in OP.

    Edit: Huh, seems to be a server error. Gonna have to see if it's plugin related.
  14. Offline


    It happens to me to dude..
  15. Offline


    how do i keep them from turning white when i place them? I'm running craftbukkit-0.0.1-SNAPSHOT.jar and client 1.2_02
  16. Offline


    Starblazer all the build files are called "craftbukkit-0.0.1-SNAPSHOT.jar" :p
  17. Offline


    Boo. Make it Do.
  18. Offline


    How do you keep the wool from turning white once u place?
  19. Offline


    Running CraftBukkit build 87, can't get the /gw list command to work. If I type /gw and then anything, all I get is 64 white wool regardless of how much I specified or what type I specified.
  20. Offline

    Gene Myers

    @Bazzam He needs to update, it was working until beta 1.2_02
  21. Offline


    the white when placed cloth is a bukkit error, and the command system was changed after 9x forget which, but that means this only works on the latest build.
  22. Offline


    not works with #66
  23. Offline


    Someone needs to make the Bukkit devs aware of this error. This means no one on the server can place any kind of wool. :I
  24. Offline


    I pulled the latest version of craftbukkit and wool_color from their git servers and still no dice on actually laying the colored wool.

    I have it on good authority, a friend told me, that colored wool is inherently foobar in CraftBukkit. And how!
  25. Offline


    update plz... not works
  26. Offline


    bukkit has been updated, it is fixed in the latest build.
  27. Offline

    Voxel Box


    Very cool plugin. We've added it to the list of "Similar Plugins" on the post for our item duplication / wool dye-ing plugin called VoxelMore.
  28. Offline


    updated with permissions support.
  29. Offline


    Neat. I'd only want Admins to have access to this though. Good to have the options though.
  30. Offline


    Great plugin, easy for me to make murals!

    But would you mind cleaning up the list of blocks and/or color them :eek:?

Share This Page