[INACTIVE][MECH] SignEdit v1.4.8 - Remote-edit signs (with Colors!) [617]

Discussion in 'Inactive/Unsupported Plugins' started by .$pIrit, Jan 22, 2011.

  1. Offline

    .$pIrit

    SignEdit v1.4.8 (LWC, GroupManager & Permissions support)

    Built against:
    Latest recommended CraftBukkit #617
    LWC 2.1
    GroupManager 1.0 alpha 5
    Permissions 2.5.4

    Description:
    With SignEdit you can edit the text of a sign without having to re-place it.
    You can register names for the signs to edit them whithout seeing them.
    This is very useful for sign-plugins like CraftBook!

    [​IMG]

    Features:
    • Use colors on signs!
    • Edit whole signs you´re looking at.
    • Edit only some lines of signs.
    • Edit signs out of range with a self-set name.
    • Clear signs with ease.
    • Add/Edit/Remove names for signs to edit them from everywhere.
    • Full LWC & GroupManager support
    • Much more planned...
    ToDo:
    • Switch between texts by clicking the sign. (if wanted)
    • Switch between texts of another sign by clicking the control sign.
    • Redstone-Wire the control sign.
    • Save texts & sign-names per player.
    • Allow multiple signs per name.
    Using it:
    The main command is /signedit or /se
    ( <> = needed; [ ] = optional )
    Add an ID to the sign you´re looking at:
    /se add <name/id>
    Edit the ID of the sign you´re looking at or by ID:
    /se edit [Name/ID] <newName/newId>
    Remove the ID of the sign you´re looking at or by ID:
    /se remove [Name/ID]
    Clear the text of the sign you´re looking at or by ID:
    /se clear [Name/ID]
    Set the text of the sign you´re looking at:
    /se set <text>
    Set the text of the sign matched by it´s ID:
    /se setid <name/id> <text>
    Save the text of a sign.
    /se save [Name/ID] <SaveName>
    Load a text on the sign.
    /se load [Name/ID] <SaveName>
    Remove a saved text.
    /se rsave <SaveName>

    Syntax of <text>:
    "first line" "second line" "third line" "fourth line"
    - Two quotes mark one line.
    - You dont need to put a space between the quotes.
    - A line can contain any character except for a quote.
    - A line can be empty
    - You dont have to set all lines.
    Setting specific lines:
    2"second line" 4"fourth line"
    - The number before a quote is the line-number. (1-4)[/size]
    - None-set lines will keep the text they have.

    Permissions:
    Code:
    signedit.add - Add Sign-IDs
    signedit.edit - Edit Sign-IDs
    signedit.remove - Remove Sign-ID´s
    signedit.edittext - Clear/Set/Edit signs
    signedit.savetext - Save sign-texts
    signedit.loadtext - Load sign-texts
    signedit.removetext - Remove saved texts
    Colors:
    See http://wom.thatgamer.com/colorguide.php for Color-Codes.

    Example commands:
    /se add MyPluginName
    /se edit MyPluginName MyNewPluginName
    /se remove MyPluginName
    /se set "First line" "" "Third line"
    /se set 2"Second line" 4"Fourth line"
    /se setid MyPluginName "First line" "" "Third line"
    /se setid MyPluginName 2"Second line" 4"Fourth line"
    Change Color of a line:
    /se set "[ColorCode]"

    Download v1.4.8 #617:
    http://software.sp1rit.de/Minecraft/SignEdit.jar

    Download v1.4.7 #602:
    http://software.sp1rit.de/Minecraft/600/SignEdit.jar

    Download v1.4.6 #556:
    http://software.sp1rit.de/Minecraft/556LWC2/SignEdit.jar

    Changelog (open)
    V 1.4.8
    - again
    V1.4.7
    - Latest Bukkit and LWC 2.1
    V1.4.6
    - Compiled with LWC 2
    V1.4.5
    - And again
    V1.4.4
    - Built with latest Bukkit, GroupManager, Permissions & LWC.
    V1.4.3
    - Built with latest Bukkit, GroupManager, Permissions & LWC.
    V1.4.2
    - various bugfixes
    V1.4.1
    - Added Multiworld support for name-based sign editing.
    - Updated to b493jnks
    - Update to GroupManager 1.0 pre alpha 3
    - Update to Permissions 2.5.2
    - Changed to new save-format for sign-names
    V1.4
    - Added Permissions 2.5.1 support
    - Added Save/load/remove of sign-texts (atm only one savefile for all users)
    V1.3
    - Added GroupManager support
    V1.2.1
    - Recompiled with new bukkit
    - Fixed TSLPC
    - Temorary disabled permissions (LWC still active)
    V1.2
    - Added LWC-Protection support
    - Added Permissions support
    V1.1.1
    - Rebuild with new bukkit rev.
    V1.1
    - Colors now usable without the command (Right-click sign after placing)
    - Registered ID´s will be removed if the signs get destroyed.
    V1.0
    - First release


    Reuploaded... sry 4 missrelease ^^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 6, 2016
    Jucko13, Kainzo, PoPsou and 1 other person like this.
  2. Offline

    Soul Reaper

  3. Offline

    fugue2005

    1.2.1 still giving constructor message
     
  4. Offline

    .$pIrit

    Next version with groupmanager is up in some minutes.
    i´ll look for CraftBukkitUpToDay then.

    @fugue2005 which bukkit version do you use?
    I dont get the message and i dont have any constructor in this version ^^

    V1.3
    - added GroupManager support

    CraftBukkitUpToDate should be rdy soon. Have to be integrated by the plugin author.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 6, 2016
  5. Offline

    fugue2005

    running 437
    any chance you can put the build# that this is made against in the op?
    tried 452 but this does not load in 452

    just so we are both clear, what constructor name are you using

    in the Jar i have it's
    com.bukkit.sp1rit.signedit.SignEdit
     
  6. Offline

    .$pIrit

    I use (as every plugin developer should do) the recommend build. Thats #440 at the moment.
    You should use that for your server as well.
    Here is the link to the always latest recommend build: http://ci.bukkit.org/job/dev-CraftBukkit/promotion/latest/Recommended/

    The next "crazy" thing is that the namespace isnt com.bukkit.sp1rit.signedit.SignEdit ^^
    Since 1.2 its de.sp1rit.signedit.SignEdit so something went wrong with your download.
    I tested the download link and it´s the newest version for me.
     
  7. Offline

    Kainzo

    Does this have support ofr Permissions 2.4 ? our server wont be using GroupManager nor will our coding team.
     
  8. Offline

    .$pIrit

    I cant implement Permissions 2.4 right now. Their API reference is incorrect.

    The problem with the cut text seems to be a problem from bukkit.
     
  9. Offline

    Kainzo

    And so the chasm begins. We're not moving from Permissions 2.4+ and all of our development teams code is staying with Permissions. We'll swap when bukkit brings out their own system.
    --- merged: Feb 28, 2011 5:15 AM ---
    I'll also comment that right now it is working fine - just the permissions for anyone that doesnt have * is wrong.
     
  10. Offline

    rlagur55

    bukkit 460 plugin error ....
     
  11. Offline

    DThielke

    What is incorrect about it? The API works fine.
     
  12. Offline

    wolf hatake

    Any update for 460 + ?
     
  13. Offline

    .$pIrit

    No. Use recomment CraftBukkit builds. In this way you dont have the problems.
    Latest recommended is #440.

    http://ci.bukkit.org/job/dev-CraftBukkit/promotion/latest/Recommended/

    I said the API reference seems to be wrong. I cant use it without getting errors for the used namespace. Maybe because the reference is for v2.5?
    Or my eclipse just dont work the way it should.
     
  14. Offline

    shadrxninga

    Could you make remotely editable signs with Id's. So you set a sign ID when you make it like you can already do ( Signs can have the same id) then you could be 300 blocks for example away from the sign and still be able to edit it.

    /sign edit <id> <message>

    If signs had the same ID's you could have server notice boards all around the server that could be updated with one command.
     
  15. Offline

    .$pIrit

    Remote edit is already working with /se setid "text""text2""text3"
    For multiple signs with one id i have to change my saving system. Ill look what i can do.
    Atm im implementing save/load sign texts and enable rightclick to change between saved texts.
     
  16. Offline

    Kainzo

    The thing is - we're on 1.3 - on build 440 (also tried 448) and the ADMINS can use /se and actual set signs - however the basic users cannot - it gives the permission error "you dont have the permission to do this despite them being able to do /se"
     
  17. Offline

    .$pIrit

    V1.4
    - Added Permissions 2.5.1 support
    - Added Save/load/remove of sign-texts (atm only one savefile for all users)

    EDIT: Found some small bugs. Nothing serious so ill wait till next release to post a fix ;)
     
  18. Offline

    Kainzo

    sweet - thanks for the fixes.
    --- merged: Mar 2, 2011 5:17 PM ---
    http://pastie.org/1625301
    Getting that on reload
    1) Perms 2.5.1
    2) bukkit 440/448/490
    3) Dunno!
     
  19. Offline

    Pawned

    Needs updating for the removal of PLAYER_COMMAND :).
     
  20. Offline

    .$pIrit

    As i wrote one or two times i use the recommend build.
    With the new version (this week i gues) i´ll try to build it always with the recommended AND the newest built. But i dont think that this will work so lets wait ^^

    I cant rebuilt the newest version because i changed many things which dont work right now.

    @Kainzo ok shit maybe i missed something xD sry for that. wait a mom ill see.

    Regards
    --- merged: Mar 2, 2011 6:14 PM ---
    I cant find any error. It works fine for me on 440 with Permissions 2.5.1 hm
     
  21. Offline

    Jobsti

  22. Offline

    Kainzo

    in the fury that is my server - I may have been on 448 or something similar - thanks for the hardwork ;) We wont be able to go back to 440 due to the lag
     
  23. Offline

    .$pIrit

    Ill update soon. Little bit busy the last weeks ^^
     
  24. Offline

    Kainzo

    Much appreciated - hoping the new recommended build will be 493 - its been very stable lately.
     
  25. Offline

    wolf hatake

    I look forward to finding this plugin up to date for 493! Good work!!
     
  26. Offline

    Kainzo

    Havent tested it - but im guessing it works (though not with permissions)
     
  27. Offline

    Acru

    By the way, I'd like to suggest that you support Lockette too. ;3

    Specifically by not allowing altering of [Private] or [More Users] signs.

    Perhaps there will be an event for editing signs in the future, that can be canceled, but this should do for now.
     
  28. Offline

    .$pIrit

    I never heard from lockette by ill see what i can do. ;)
    The integration of such new permissions plugins is (mostly) easy if they have a good api.
    The only problem for updates are the changes in craftbukkit which arent explained centralized. For example i tried to find out why my onCommand didnt work until i found out that i have to edit the plugin.yml ^^

    Update for #493 (and with Lockette support i guess) is coming today.

    EDIT:
    Okay lets say tomorrow. Just saw that there are some multi-world problems i have to fix. Also there are problems with the permissions if the commands are sent by IRC for example.
     
  29. Offline

    Kainzo

    Very nice. I'll be testing this as soon as you have a fix up.
     
  30. Offline

    Afforess

    Code:
    15:10:05 [SEVERE] PLAYER_COMMAND loading SignEdit v1.4 (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_COMMAND
            at de.sp1rit.signedit.SignEdit.onEnable(SignEdit.java:29)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    .java:414)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    r.java:187)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
            at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:205)
            at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleComma
    ndMap.java:195)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:79
    )
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:1
    83)
            at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:381)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:366)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    
    None of the commands work either, might want to update and use onCommand.
     
  31. Offline

    .$pIrit

    Read 3 posts above this ;)
     

Share This Page