[INACTIVE][MECH/FIX] QuickBelt 0.1.8 - Auto-reloading for your inventory slots! [670]

Discussion in 'Inactive/Unsupported Plugins' started by cyklo, Mar 5, 2011.

  1. Offline


    QuickBelt - Auto-reloading for your inventory slots!
    Version: 0.1.8
    Download: Jar File | Source Code
    Like this plugin? Donate a buck!

    QuickBelt provides rapid auto-reloading for broken tools and used-up stacks of blocks!

    Have you ever had that sword with about three hits left in it, and never used it
    for fear of it breaking mid-battle and not reloading quickly enough? What about large
    building projects where you keep having to swap stacks in as they get used up? QuickBelt
    is just what you want!

    Any time an empty slot appears in your toolbar, QuickBelt auto-reloads it by moving
    items in your inventory vertically downwards. So if you had a sword in slot 1 and
    another sword above it, as soon as the sword breaks your new sword is
    instantly activated.

    QuickBelt has a simple basic set of commands:
    • /qb - QuickBelt status
    • /qb on - Turn your QuickBelt on
    • /qb off - Turn your QuickBelt off
    QuickBelts are off by default, and are enabled by players as they want them. Settings
    are persistent and are remembered even if you reboot the server.

    There are also some slightly more advanced commands:
    • /qb slots shows which slots (1-9) of your toolbar will auto-reload
    • /qb slots 123456789 sets which slots will auto-reload (e.g. /qb slots 345)
    • /qb slots all resets your inventory to all slots active at once.
    You can also force QuickBelts on for all players. Download it, run it, then check your plugins/quickbelt/config.yml file. You will see two new parameters: force and silent. "Force" makes it unresponsive to /qb commands and simply has the plugin enabled for everybody. "Silent" means it doesn't even bring up the "replenished slot ..." message, making it truly invisible to players.

    Nothing to install, just copy the quickblocks.jar file to your plugins directory.

    Changelog (open)

    Version 0.1
    • Compatibility patch (0.1.8)
    • Compatibility patch (0.1.7)
    • Fixed: crashy NullPointerException horribleness, finally (0.1.6)
    • Fixed: big crashy null pointer horribleness (hopefully?) (0.1.5)
    • Fixed: logging out lost your settings until next server reboot (0.1.4)
    • Fixed: "silent" didn't work. (0.1.3)
    • Can now specify only certain slots to auto-reload (0.1.3)
    • Fixed everything that was broken. Which was everything. (0.1.2)
    • Added "force" and "silent" parameters (0.1.1)
    • First release (0.1)
    Mitsugaru and Steve Cole like this.
  2. Offline


    Excellent. We appreciate you taking the time out to work on it. :)
  3. Offline


    Same here :)
  4. Offline


    0.1.7 is now uploaded. No new features, but now targets CraftBukkit build 602.
  5. Offline


    Hurrah, cheers cyklo!
  6. Offline


    Working great with 602 so far.
  7. Offline


    Ok, so maybe I'm a little slow, so forgive me please, but how do I install this? I clicked on the link to download the jar file, and it takes me to another page. So I click on the link to download the jar file on that page, and it gives me a tar.gz file. I open the tar.gz file and there is another tar file inside. Inside the tar file is a bunch of other files. I tried renaming the tar file to a jar file but that didn't work.
    I'm stuck.
  8. Offline

    Kevin Forte

    Yeah I have the same issue, pardon my noob but where is the actual .jar?
  9. Offline


    I assume everyone having trouble is using Windows. You need to use a file archiver which is less rubbish than the built-in one. I recommend 7zip. The jar file is wrapped into a tar file, which is then compressed.

    From wikipedia (the jar file is one of the light blue blobs):
  10. Offline


    Working on 617 with no issues

    Depending on your decompiler you may inadvertently be decompiling the jar along with the tar.

    I had this problem on my Mac.

    Change to another program and you should see the .jar

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
    bk1138 likes this.
  11. Offline

    Kevin Forte

    That was exactly it, I figured it out a few hours after this after trying to download something else.
  12. Offline


    I do use 7zip, never used the crappy built in archiver, and it still doesn't give a jar file. I open the tar file and it just lists all the contents that should be, I assume, in the jar file. Why even wrap it in a tar file, why not just zip up the jar and post it?
    Edit: Downloaded the latest version of 7zip and re-installing seems to fix it and give me a jar file now. Thanks!
  13. Offline


    Could we possibly get an update to Bukkit 670? Ever since installing the latest update, my players have been complaining about not having QuickBelt anymore. It's a lifesaver!
  14. Offline


    0.1.8 should do the job.
  15. Offline


    You're amazing! Thanks. :)
  16. Offline


    I'm not getting any errors, I can enable/disable quickbelt, but it isn't working. My slots aren't being replenished. I downloaded newest versions of this and bukkit. Any ideas?

    EDIT: OK nevermind..I restarted a few times and it seems to be working again. Odd.
  17. Offline

    Kevin Forte

    Is it possible for you to have a Straight .jar only download? I keep running into extraction issues.
  18. Offline

    City Builder

    Working great, thanks
  19. Offline

    Alex H

    670 is is giving bugs even with 0.1.8
  20. Offline

    Kevin Forte

    I'm having bugs as well, /qb on/off is functioning but the plugin seems to be doing nothing.
  21. Offline


    Server says it could not pass "player_drop_item" to QuickBelt. Any suggestions? using CB 677
  22. Offline


    Working good on CB 684
    Anyone test with 733 ? :)
  23. Offline


    No, command not found.
  24. Offline


    works fine on 733 here
  25. Offline


    Same here... Love this plugin!
  26. Offline


    Working in 733 here also, too usefull :)
  27. Offline


    Not working here, I see no errors in CB console, in-game I enable the plugin but it doesn't load the next stack once stack in hand is empty.

    Maybe one of my other plugins are conflicting with it.
    CB 733
    MC 1.5_01
  28. Offline


    Odd what else are you running?
  29. Offline


    Very strange. I am running the same and have no problem. Are you sure that somehow qb did not get turned off? As a sanity check, can you try '/qb slots' and verify you have that slot selected?
  30. Offline


    This works fine on 740 aswell :)
  31. Offline


    Is it official? Is this updated for 740?

Share This Page