[INACTIVE][MECH] EekRunes v1.4.0.19 - Runecraft Port (Now reads magic.dat!)

Discussion in 'Inactive/Unsupported Plugins' started by Eeketh, Jan 23, 2011.

  1. Offline


    The latest version can always be downloaded from here:

    Code can be obtained from https://github.com/Eeketh/EekRunes

    I am attempting to port the below to Bukkit, because there's a lot of functionality I've been missing.
    (Note: the original Runecraft mod is by Superllama. He doesn't intend to port anything until Notch releases the API, so it looks like this will be the only Runecraft for Bukkit)

    So far, only the 7 below runes have been ported:
    • Secret Passages
    • Waypoints/Teleporters
    • Compass
    • Oracle
    • Freezer Rune
    • Chrono Trigger
    • Power Tool (power pick/shovel)
    Runes can also be loaded/unloaded using the following commands:
    • /eekRuneAdd <name>
    • /eekRuneDel <name>
    • /eekRuneReload <name>
    • /eekRuneList will list all the loaded runes
    Please note that the rune name when loading is case sensitive.

    Runes can be switched on/off by editing the settings.ini file created when you first run the plugin.
    If more runes are added after you have run the program, they will be added to your settings.ini file as disabled.

    Note: There are some slight differences with the way my hidden passages work:

    1) The keystone is always used as the "ink". Whatever the keystone is made of, the entire door will be made of.
    (note: I believe the previous system either used it as ink, or a key you needed to use, depending on how rare the block was. Nobody I know uses keys, so I didn't think it important)
    2) The door activation can now be triggered by redstone.
    3) If you right-click the keystone while holding a redstone torch, you will ONLY be able to open the door with redstone - right-clicking will not work.
    (this is to keep secret doors harder to find)

    Superllama - Original Runecraft creator.
    @MRH - code to read from Runecraft's data file.
    @Herr Riz - NotRunecraft code
  2. Offline


    Ahh thank you, I didn't enable it. Good tip :)
    --- merged: Feb 2, 2011 1:47 PM ---

    After I enabled it and tried it, here is what happened.

    1. I dropped redstone down, right-clicked center block and the redstone disappeared.

    The java console showed this stack trace:

    Checking number of redstone things... 0
    Checking number of redstone things... 0
    Checking number of redstone things... 0
    Checking number of redstone things... 1
    can chrono
    Feb 2, 2011 8:46:10 AM org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event BLOCK_RIGHTCLICKED to EekRunes
    java.lang.NoSuchMethodError: org.bukkit.Server.setTime(J)V
    at com.bukkit.Eek.ChronoTriggerRune.runRuneRightClick(ChronoTriggerRune.
    at com.bukkit.Eek.RuneRunner.onBlockRightClick(RuneRunner.java:44)
    at org.bukkit.plugin.java.JavaPluginLoader$16.execute(JavaPluginLoader.j
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:470)
    at net.minecraft.server.Packet15Place.a(SourceFile:57)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:71)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:283)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:209)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    Checking number of redstone things... 0

    I am running the latest snapshot of craftbukkit as of last night
  3. Offline


    @Deklin : Ok, craftbukkit's been updated and the server.setTime method deprecated :) I have to change code to make it work with latest version, probably tomorrow lunch...
  4. Offline


    No rush :) Again all your effort is much appreciated
  5. Offline


    Chrono trigger updated with latest version.
  6. Offline


    Works great! Thanks!
  7. Offline



    Magic.dat conversion now works.
    Power tool (power pick/shovel) released after testing.
    Teleports now work if you click the block underneath, if there's no block in the center. (this was added a while ago, but I forgot to update)
  8. Offline

    Herr Riz

    All right! My server is going to be so excited to have their power picks back. And I'll make a fortune selling bookcases again.
  9. Offline


    Any chance of the Recall Rune and Zeerix Chest Rune being implemented soon?
  10. Offline


    How would I get it to convert my magic.dat file?
  11. Offline


    hmm I can't get the powerpick rune to work? all the others seem to work fine.
  12. Offline


    after running the first time, the subfolder EekRunes is created.
    If you delete the teleports.ini and waypoints.ini (or back them up) and put the magic.dat in this location, it'll convert the file for you.

    Are you using the latest CraftBukkit? - it's using one of the new methods
    Also, as it's a new rune, have you enabled it in the settings.ini?

    Not sure about Zeerix - last I checked there were some issues with chest inventories that needs fixing.
    Recall rune would be pretty easy though, so I'll put that at the top of the list.
  13. Offline


    Cheers! Thanks for the power tools and all the great work. Haven't played Minecraft in a while, and now the server went down yesterday lol.

    But thank you very much for your work, and sadly I wasn't able to help you out much.

  14. Offline


    Oh snap didn't realize new runes were disabled by default. Thanks!
    Keep up the good work btw, my people are loving it :)
  15. Offline


    Thanks a lot!
  16. Offline


    How easy is it to update this file? It seems like you are still working on bringing over more of the runes, and I am wondering if I should just wait until you finish. You already brought over the only two I use though (tp and power tools), so I'm tempted to make the switch to bukkit right now.
  17. Offline


    Hrm...is it supposed to insert some data into teleports.ini and waypoints.ini? It doesn't seem like it worked.
  18. Offline


    Did you get any messages about the magic.dat file when it loaded? like saying it couldn't find the file or any other errors?
    If not, it's not even trying to convert it, so you need to delete the teleports.ini and the waypoints.ini, it will not overwrite them.
  19. Offline


    Hrm I got it to at least display this error now:
    magic.dat is not in the correct format, it may be corrupt!
    I just copied the magic.dat in my world folder and put it in the Eekrunes folder. Is this the correct process?
  20. Offline


    Yup, that's correct.
    @MRH any ideas? That's the error from your code that was in German.
  21. Offline


    I deleted teleports and waypoints files... put magic.dat in the EekRunes folder... started the plugin... and it created an empty teleports/waypoints file

    Is that whats supposed to happen?
  22. Offline


    This part of Code only checks if the first int in your file is -2.
    This value was in everyversion of Runecraft i used a constant so i used it as a check value.
    This message comes, when the first int is not -2.

    I don't know of this is a different Version, wich has a different Number on the first position or a wrong file.


    Could you upload your magic.dat?
    --- merged: Feb 5, 2011 8:00 PM ---
    Just tested the Conversion with my file.
    Works fine.
  23. Offline


    I am running into the same issue as Grandcruiser when I attempt to import an existing magic.dat. I've tried copies of the files from backups spanning the last 4 months with the same result each time.

    "magic.dat is not in the correct format, it may be corrupt!"

    Copy of the magic.dat file is attached (in zip format).. If anyone gets a different result let me know. :)

    Running Craftbukkit version git-Bukkit-0.0.0-332-gf165ec6-b254 (MC: 1.2_01)

    Attached Files:

  24. Offline


    Here you go. Thanks for your help!

    Attached Files:

  25. Offline


    Hmm your File is correct.
    I can read your File without any Problems.
    You have 30 Waypoints and 67 Teleporter :)

    Same with your File: 15 Waypoints and 45 Teleporter

    On my End, everything works.
    --- merged: Feb 6, 2011 2:10 PM ---
    When you open your magic.dat with any Hex Editor there has to be following Data:
    FFFF FFFE this is the Value that my Code Validates.
    ( FFFF FFFE [16] = -2 [10] )
    --- merged: Feb 6, 2011 2:21 PM ---
    Ok, i just saw, that some Waypoints and maybe Teleporters are like 2 are 3 times in the List ...
    I don't know how this is possible ...


    Just found a possible Error reason.
  26. Offline


    Interesting. I tried it on 3 different computers (Linux 64 bit (java 1.6.0_22), Windows 7 64 bit (32 bit java 1.6.0_23), and Windows Vista 32 bit (1.6.0_23) and I get the same result on each machine.

    Any idea what the difference could be? Could the craftbukkit build have anything to do with it?

    PS. I did check that the first 4 bytes are FFFF FFFE last night before posting and they definitely are. Something is causing that check for -2 to fail on my end though.
  27. Offline


    I've uploaded a new version, small change, but should hopefully be slightly better at reading magic.dat files...
  28. Offline


    To test this, i have used my .NET Libary.
    Lets see, if this works with this new Version.
  29. Offline


    I just tried again and got the same error, but it looks like the download link is still pointing to for me.. I'll give it a few minutes and try again.

    Nope, still getting the same result.

    Could not load door state - starting new door list
    magic.dat is not in the correct format, it may be corrupt!
    Could not load waypoint state - starting new waypoint list
    Could not load teleport state into converter - starting new teleport list
    freezer enabled? false
    EekRunes loaded!
  30. Offline


    I've just used your magic.dat on my Server ... with the old Version of this Plugin.
    Magic.dat conversion complete.

    2145620854392730912 97 63 199=73,56,73,56
    2145620854392730912 48 103 562=17,17,17,17
    2145620854392730912 17 61 41=57,49,41,80
    2145620854392730912 48 66 562=42,42,42,42
    2145620854392730912 -183 79 71=20,20,20,20
    2145620854392730912 -183 107 71=14,80,48,49
    2145620854392730912 102 104 -56=57,42,57,42
    2145620854392730912 14 83 38=14,14,14,14
    2145620854392730912 -190 101 88=45,45,45,45
    2145620854392730912 -223 108 127=5,5,5,5
    2145620854392730912 -220 70 -75=73,73,73,73
    2145620854392730912 -181 5 11=12,12,12,12
    2145620854392730912 -5 49 -40=57,57,57,57
    2145620854392730912 -216 21 65=15,15,15,15
    2145620854392730912 373 60 9=5,13,5,13
    2145620854392730912 163 107 -647=5,5,5,5
    2145620854392730912 48 104 562=42,42,42,42
    2145620854392730912 -220 71 -75=73,56,74,56
    2145620854392730912 -223 109 127=14,14,14,14
    2145620854392730912 49 81 47=41,41,41,41
    2145620854392730912 -195 5 11=20,20,20,20
    2145620854392730912 -220 69 -82=73,56,73,56
    2145620854392730912 -190 102 88=15,15,15,15
    2145620854392730912 -195 28 94=5,5,5,5
    2145620854392730912 13 67 580=17,17,17,17
    2145620854392730912 -183 79 71=42,42,42,42
    2145620854392730912 -5 50 -40=41,41,41,41
    2145620854392730912 48 67 562=5,5,5,5
    2145620854392730912 97 64 199=73,73,73,73
    2145620854392730912 93 84 11=48,0,48,0
    2145620854392730912 -211 66 102=5,13,5,13
    2145620854392730912 48 79 45=57,57,41,57
    2145620854392730912 -174 75 110=57,41,57,57
    2145620854392730912 -204 122 110=42,42,42,42
    2145620854392730912 100 63 -55=41,41,41,41
    2145620854392730912 -216 22 65=5,5,5,5
    2145620854392730912 104 64 -34=41,41,41,41
    2145620854392730912 48 80 45=57,41,57,57
    2145620854392730912 -188 5 3=20,20,20,20
    2145620854392730912 104 64 199=73,73,73,73
    2145620854392730912 122 73 -24=41,41,41,41
    2145620854392730912 71 64 91=45,45,45,45
    2145620854392730912 14 84 38=57,42,57,42
    2145620854392730912 -166 70 98=45,45,45,45
    2145620854392730912 -182 109 71=5,45,5,45
    2145620854392730912 -193 75 82=12,12,12,12
    2145620854392730912 85 64 233=73,73,74,73
    2145620854392730912 48 81 51=57,57,41,57
    2145620854392730912 -183 108 71=57,49,41,80
    2145620854392730912 107 104 -48=57,57,57,57
    2145620854392730912 82 74 35=41,57,57,57
    2145620854392730912 373 61 9=5,5,5,5
    2145620854392730912 -5 64 47=5,5,5,5
    2145620854392730912 93 83 11=41,41,41,41
    2145620854392730912 -220 70 -81=73,56,73,56
    2145620854392730912 -262 58 39=5,5,5,5
    2145620854392730912 17 62 41=14,80,48,49
    2145620854392730912 93 104 -48=14,14,14,14
    2145620854392730912 -174 106 82=41,41,41,41
    2145620854392730912 106 70 -57=57,42,57,42
    It seems that this is a Problem that occurs on your End.
    --- merged: Feb 6, 2011 6:26 PM ---
    Also works with the newest Version.
  31. Offline


    Out of curiosity, what build of craftbukkit and java are you testing it with?

    I'll see if I can do some further debugging on it later this afternoon and find out exactly what the code thinks the first 4 bytes of that file is. There must be something in our environments that is causing it to fail.

    Thanks for taking a look at it.. I'll post back if I find out whats going on.

    P.S. I just tried Grandcruiser's magic.dat file.. It works fine.

Share This Page